Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libprojectm: ld: cannot find -lCg
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
aminalshmu
Tux's lil' helper
Tux's lil' helper


Joined: 13 Sep 2004
Posts: 78
Location: Tallahassee, Florida, USA

PostPosted: Mon Dec 06, 2010 5:49 pm    Post subject: libprojectm: ld: cannot find -lCg Reply with quote

Code:
[ 83%] Building CXX object CMakeFiles/projectM.dir/KeyHandler.cpp.o
/usr/include/FTGL/FTFont.h(29): warning #1224: #warning directive: This header is deprecated. Please use <FTGL/ftgl.h> from now.                                                             
  #   warning This header is deprecated. Please use <FTGL/ftgl.h> from now.
      ^

[ 85%] Building CXX object CMakeFiles/projectM.dir/timer.cpp.o
[ 87%] Building CXX object CMakeFiles/projectM.dir/wipemalloc.cpp.o                                                                                                                           
[ 88%] Building CXX object CMakeFiles/projectM.dir/PresetLoader.cpp.o                                                                                                                         
[ 90%] Building CXX object CMakeFiles/projectM.dir/PresetChooser.cpp.o                                                                                                                       
[ 92%] Building CXX object CMakeFiles/projectM.dir/PipelineMerger.cpp.o                                                                                                                       
[ 94%] Building CXX object CMakeFiles/projectM.dir/ConfigFile.cpp.o                                                                                                                           
[ 96%] Building CXX object CMakeFiles/projectM.dir/TimeKeeper.cpp.o                                                                                                                           
[ 98%] Building CXX object CMakeFiles/projectM.dir/PresetFactory.cpp.o                                                                                                                       
[100%] Building CXX object CMakeFiles/projectM.dir/PresetFactoryManager.cpp.o                                                                                                                 
Linking CXX shared library libprojectM.so                                                                                                                                                     
ld: cannot find -lCg                                                                                                                                                                         
make[2]: *** [libprojectM.so.2.00] Error 1
make[1]: *** [CMakeFiles/projectM.dir/all] Error 2
make: *** [all] Error 2
emake failed
 * ERROR: media-libs/libprojectm-2.0.1-r1 failed:
 *   Make failed!
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 3008:  Called cmake-utils_src_compile
 *   environment, line  779:  Called _execute_optionaly 'src_compile'
 *   environment, line  245:  Called enable_cmake-utils_src_compile
 *   environment, line 1142:  Called cmake-utils_src_make
 *   environment, line  798:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "Make failed!";
 *
 * If you need support, post the output of 'emerge --info =media-libs/libprojectm-2.0.1-r1',
 * the complete build log and the output of 'emerge -pqv =media-libs/libprojectm-2.0.1-r1'.
 * The complete build log is located at '/var/tmp/portage/media-libs/libprojectm-2.0.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-libs/libprojectm-2.0.1-r1/temp/environment'.
 * S: '/var/tmp/portage/media-libs/libprojectm-2.0.1-r1/work/projectM-2.0.1-Source'

>>> Failed to emerge media-libs/libprojectm-2.0.1-r1

 * Messages for package media-libs/libprojectm-2.0.1-r1:

 * ERROR: media-libs/libprojectm-2.0.1-r1 failed:
 *   Make failed!
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 3008:  Called cmake-utils_src_compile
 *   environment, line  779:  Called _execute_optionaly 'src_compile'
 *   environment, line  245:  Called enable_cmake-utils_src_compile
 *   environment, line 1142:  Called cmake-utils_src_make
 *   environment, line  798:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "Make failed!";
 *
 * If you need support, post the output of 'emerge --info =media-libs/libprojectm-2.0.1-r1',
 * the complete build log and the output of 'emerge -pqv =media-libs/libprojectm-2.0.1-r1'.
 * The complete build log is located at '/var/tmp/portage/media-libs/libprojectm-2.0.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-libs/libprojectm-2.0.1-r1/temp/environment'.
 * S: '/var/tmp/portage/media-libs/libprojectm-2.0.1-r1/work/projectM-2.0.1-Source'
 * Build finished correctly. Removing temporary files...
 * You can re-run revdep-rebuild to verify that all libraries and binaries
 * are fixed. Possible reasons for remaining inconsistencies include:
 *   orphaned files
 *   deep dependencies
 *   packages installed outside of portage's control
 *   specially-evaluated libraries


anyone know what this means? dynamic linker issue? i'm trying to run revdep-rebuild which only wants to rebuild libprojectm, which is needed for vlc visualization plugin.
Back to top
View user's profile Send private message
wcg
Guru
Guru


Joined: 06 Jan 2009
Posts: 588

PostPosted: Mon Dec 06, 2010 7:09 pm    Post subject: Reply with quote

Quote:
ld: cannot find -lCg


Linker cannot find libCg.so (or libCg.a).

From package media-gfx/nvidia-cg-toolkit ?

http://developer.nvidia.com/object/cg_toolkit.html
_________________
TIA
Back to top
View user's profile Send private message
wyvern5
Apprentice
Apprentice


Joined: 11 Nov 2006
Posts: 161

PostPosted: Sat Jan 26, 2013 4:50 pm    Post subject: Reply with quote

I'm seeing this issue as well, but I do have nvidia-cg-toolkit installed and its libraries are known to ldconfig:

# ldconfig -p | grep -i cg
Code:

        libcupscgi.so.1 (libc6,x86-64) => /usr/lib64/libcupscgi.so.1
        libcupscgi.so.1 (libc6) => /usr/lib32/libcupscgi.so.1
        libcupscgi.so (libc6,x86-64) => /usr/lib64/libcupscgi.so
        libcupscgi.so (libc6) => /usr/lib32/libcupscgi.so
        libcgraph.so.5 (libc6,x86-64) => /usr/lib64/libcgraph.so.5
        libcgraph.so (libc6,x86-64) => /usr/lib64/libcgraph.so
        libCgGL.so (libc6,x86-64) => /opt/nvidia-cg-toolkit/lib/libCgGL.so
        libCg.so (libc6,x86-64) => /opt/nvidia-cg-toolkit/lib/libCg.so



Code:

[100%] Building CXX object CMakeFiles/projectM.dir/PresetFactoryManager.cpp.o
/usr/bin/x86_64-pc-linux-gnu-g++  -DprojectM_EXPORTS -DCMAKE_INSTALL_PREFIX=\"/usr\" -DUSE_CG -DUSE_FBO -DUSE_FTGL -DUSE_THREADS -DLINUX -DSTBI_NO_DDS -DUSE_FTGL -DprojectM_FONT_MENU="\"\\\"/usr/share/fonts/dejavu/DejaVuSans.ttf\\\"\"" -DprojectM_FONT_TITLE="\"\\\"/usr/share/fonts/dejavu/DejaVuSansMono.ttf\\\"\""  -I/opt/nvidia-cg-toolkit/include -DNDEBUG -O -pipe -march=core2  -fopenmp  -fPIC -I/usr/include/freetype2 -I/var/tmp/portage/media-libs/libprojectm-2.1.0-r1/work/projectM-complete-2.1.0-Source/src/libprojectM -I/usr/include/FTGL -I/var/tmp/portage/media-libs/libprojectm-2.1.0-r1/work/projectM-complete-2.1.0-Source/src/libprojectM/Renderer -I/var/tmp/portage/media-libs/libprojectm-2.1.0-r1/work/projectM-complete-2.1.0-Source/src/libprojectM/NativePresetFactory -I/var/tmp/portage/media-libs/libprojectm-2.1.0-r1/work/projectM-complete-2.1.0-Source/src/libprojectM/MilkdropPresetFactory    -o CMakeFiles/projectM.dir/PresetFactoryManager.cpp.o -c /var/tmp/portage/media-libs/libprojectm-2.1.0-r1/work/projectM-complete-2.1.0-Source/src/libprojectM/PresetFactoryManager.cpp
Linking CXX shared library libprojectM.so
/usr/bin/cmake -E cmake_link_script CMakeFiles/projectM.dir/link.txt --verbose=1
/usr/bin/x86_64-pc-linux-gnu-g++  -fPIC -O -pipe -march=core2  -fopenmp   -Wl,-O1 -Wl,--as-needed -L/opt/nvidia-cg-toolkit/lib64 -shared -Wl,-soname,libprojectM.so.2 -o libprojectM.so.2.1.0 CMakeFiles/projectM.dir/projectM.cpp.o CMakeFiles/projectM.dir/PCM.cpp.o CMakeFiles/projectM.dir/Preset.cpp.o CMakeFiles/projectM.dir/fftsg.cpp.o CMakeFiles/projectM.dir/KeyHandler.cpp.o CMakeFiles/projectM.dir/timer.cpp.o CMakeFiles/projectM.dir/wipemalloc.cpp.o CMakeFiles/projectM.dir/PresetLoader.cpp.o CMakeFiles/projectM.dir/PresetChooser.cpp.o CMakeFiles/projectM.dir/PipelineMerger.cpp.o CMakeFiles/projectM.dir/ConfigFile.cpp.o CMakeFiles/projectM.dir/TimeKeeper.cpp.o CMakeFiles/projectM.dir/PresetFactory.cpp.o CMakeFiles/projectM.dir/PresetFactoryManager.cpp.o Renderer/libRenderer.a -lCg -lCgGL NativePresetFactory/libNativePresetFactory.a MilkdropPresetFactory/libMilkdropPresetFactory.a -lGLEW -lftgl -lfreetype -lm -ldl -lGLU -lGL -lSM -lICE -lX11 -lXext -ldl Renderer/libRenderer.a -lCg -lCgGL -lm
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.4/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lCg
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.4/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lCgGL
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.4/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lCg
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.4/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lCgGL
collect2: ld returned 1 exit status
make[2]: *** [libprojectM.so.2.1.0] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-libs/libprojectm-2.1.0-r1/work/libprojectm-2.1.0_build'
make[1]: *** [CMakeFiles/projectM.dir/all] Error 2
make[1]: Leaving directory `/var/tmp/portage/media-libs/libprojectm-2.1.0-r1/work/libprojectm-2.1.0_build'
make: *** [all] Error 2
 * ERROR: media-libs/libprojectm-2.1.0-r1 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=media-libs/libprojectm-2.1.0-r1'`,
 * the complete build log and the output of `emerge -pqv '=media-libs/libprojectm-2.1.0-r1'`.
 * The complete build log is located at '/var/tmp/portage/media-libs/libprojectm-2.1.0-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-libs/libprojectm-2.1.0-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/media-libs/libprojectm-2.1.0-r1/work/libprojectm-2.1.0_build'
 * S: '/var/tmp/portage/media-libs/libprojectm-2.1.0-r1/work/projectM-complete-2.1.0-Source/src/libprojectM'


One thing to note is that the g++ line has -L/opt/nvidia-cg-toolkit/lib64, but that directory does not exist:

Code:

tree /opt/nvidia-cg-toolkit
/opt/nvidia-cg-toolkit
├── bin
│   └── cgc
├── include
│   └── Cg
│       ├── cg_bindlocations.h
│       ├── cg_datatypes.h
│       ├── cg_enums.h
│       ├── cg_errors.h
│       ├── cgGL.h
│       ├── cgGL_profiles.h
│       ├── cg.h
│       └── cg_profiles.h
└── lib
    ├── libCgGL.so
    └── libCg.so


I have stable nvidia-cg-toolkit (2.1.0017-r1).
Back to top
View user's profile Send private message
aarond80
n00b
n00b


Joined: 27 Jan 2013
Posts: 1

PostPosted: Sun Jan 27, 2013 2:38 am    Post subject: Reply with quote

By unmasking media-gfx/nvidia-cg-toolkit-3.1.0013-r2 (~) and emerging this first, I was able to succesfully emerge libprojectm-2.1.0-r1. It appears to be a dependancy issue.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum