Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Current Status of Gallium on Intel?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
SDNick484
Tux's lil' helper
Tux's lil' helper


Joined: 05 Dec 2005
Posts: 144

PostPosted: Sun Nov 14, 2010 5:38 am    Post subject: Current Status of Gallium on Intel? Reply with quote

Anyone using Gallium3D with an Intel card? I see the "gallium" use flag is currently masked, so I assume stability is a bit questionable. I believe my laptop (Lenovo T400) has an Intel 945GM, so I'm thinking of giving it a go.
Back to top
View user's profile Send private message
cynapsis
n00b
n00b


Joined: 14 Nov 2010
Posts: 35

PostPosted: Sun Nov 14, 2010 6:14 am    Post subject: Reply with quote

There's an ebuild for the new dev version in x11 overlay. The gallium useflag isn't masked there, at least not on my ~amd64 arch.
The new dev version was released last month, maybe give it a try?

Here are the release notes of it: http://mesa3d.sourceforge.net/relnotes-7.9.html
Back to top
View user's profile Send private message
SDNick484
Tux's lil' helper
Tux's lil' helper


Joined: 05 Dec 2005
Posts: 144

PostPosted: Sun Nov 14, 2010 8:45 am    Post subject: Reply with quote

Thanks, I'll give that a look I unmasked the gallium use flag and re-emerged both mesa and cairo with it (both in ~amd64), and X didn't function properly (gdm started, but half the screen was black, etc.). I've since reverted back to no gallium, but may try again with the new version later.

I haven't played around much with the X11 overlay; how stable is it? I run ~amd64 with the gnome overlay on this machine so I'm not super concerned about stability, but I remember when xorg in Gentoo unstable went from 6.8 to 6.9/7.0 (and I'd rather avoid getting into a similar situation again).
Back to top
View user's profile Send private message
cynapsis
n00b
n00b


Joined: 14 Nov 2010
Posts: 35

PostPosted: Sun Nov 14, 2010 9:45 am    Post subject: Reply with quote

Almost all ebuilds in x11 overlay are live ebuilds and hardmasked as 9999 version. You won't have any updates but mesa. Mesa itself is running fine here and I don't have any problems with it.

Edit:
Oh another thing.. you can switch the renderer even with build in Gallium.
Have a look at "eselect mesa list".
Back to top
View user's profile Send private message
ToeiRei
Veteran
Veteran


Joined: 03 Jan 2005
Posts: 1156
Location: Austria

PostPosted: Sun Nov 14, 2010 10:15 am    Post subject: Reply with quote

Due to my intel card I am working with the X11 overlay to finally get my desktop effects working - gallium enabled + live-ebuilds.
Must have been my lucky day that the state from the git worked :)

But one thing to mention about kernels: 2.6.37-rc1 causes problems. 2.6.36 works.
_________________
Blog | btrfs | Please stand by - The mailer daemon is busy burning your messages in hell...
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1678
Location: Berlin, Germany

PostPosted: Sun Nov 14, 2010 11:07 am    Post subject: Reply with quote

The i915g and i965g drivers can hardly do more than draw triangles.
Back to top
View user's profile Send private message
jbouzan
Tux's lil' helper
Tux's lil' helper


Joined: 23 Nov 2007
Posts: 138

PostPosted: Tue Nov 23, 2010 6:35 am    Post subject: Reply with quote

Maybe a lot has changed in week, I found this thread googling for how to get my laptop back to opengl, after I changed KDE to use xrender. The gallium i915 driver is working fine so far (5 minutes in, no invisible menus or anything).
Back to top
View user's profile Send private message
SDNick484
Tux's lil' helper
Tux's lil' helper


Joined: 05 Dec 2005
Posts: 144

PostPosted: Wed Nov 24, 2010 12:42 am    Post subject: Reply with quote

What's your underlying hardware? Also for the record, I was having issues with GDM/Gnome.
Back to top
View user's profile Send private message
jbouzan
Tux's lil' helper
Tux's lil' helper


Joined: 23 Nov 2007
Posts: 138

PostPosted: Wed Nov 24, 2010 6:21 am    Post subject: Reply with quote

KInfo says the renderer is "Gallium 0.4 on i915 (chipset: 945GM)." Compositing doesn't work because I can't make KDE switch to OpenGL rendering, but performance is acceptable. Really not much different than before, other than now I don't have the invisible menus problem.

Now that I look at it, I didn't emerge Cairo with USE gallium. Don't know what that'll change when I do.
Code:
[ebuild   R   ] x11-libs/cairo-1.10.0-r3  USE="X opengl svg xcb (-aqua) -debug -directfb -doc (-drm) (-gallium) (-openvg) -qt4 -static-libs"

Using X11 overlay mesa
Code:
[ebuild   R   ] media-libs/mesa-7.9  USE="classic gallium nptl -debug -gles -llvm -motif -pic (-selinux)" VIDEO_CARDS="i915 intel -i810 -i965 -mach64 -mga -nouveau -r100 -r128 -r200 -r300 -r600 -radeon -savage -sis -tdfx -via -vmware"


Doubt it's relevent, but emerge --info for compiler and such
Code:
Portage 2.2.0_alpha4 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.1, glibc-2.12.1-r3, 2.6.35-zen2 x86_64)
=================================================================
System uname: Linux-2.6.35-zen2-x86_64-Intel-R-_Core-TM-2_CPU_U7600_@_1.20GHz-with-gentoo-2.0.1
Timestamp of tree: Tue, 23 Nov 2010 19:15:02 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r2
dev-lang/python:     2.6.6-r1
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.6.5
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.68
sys-devel/automake:  1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5, 4.5.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4
sys-devel/make:      3.82
virtual/os-headers:  2.6.36 (sys-kernel/linux-headers)
Repositories: gentoo mozilla sunrise kde x11
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going"
FEATURES="assume-digests binpkg-logs candy distlocks fail-clean fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.netnitco.net http://gentoo.wetzlmayr.com/ http://www.cyberuse.com/gentoo/ http://osmirrors.cerias.purdue.edu/pub/gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/mnt/portdir"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/mozilla /var/lib/layman/sunrise /var/lib/layman/kde /var/lib/layman/x11"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 aspell avahi bash-completion branding bzip2 cairo cdr cli consolekit cracklib crypt cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gnutls gpm hal htmlhandbook hunspell iconv ipv6 jpeg kde laptop lcms libnotify lm_sensors lzma mad mikmod mmx modules mp3 mp4 mpeg mudflap multilib ncurses networkmanager nls nptl nptlonly ogg opengl openmp pam pango pch pcre pdf phonon png policykit ppds pppd qt3support qt4 readline sdl semantic-desktop session spell sse sse2 ssl ssse3 startup-notification svg synaptics sysfs tcpd tordns truetype unicode usb virtuoso vorbis wicd x264 xcb xcomposite xml xorg xulrunner xv xvid zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" PHP_TARGETS="php5-2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel i915" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1402
Location: Bardowick, Germany

PostPosted: Wed Nov 24, 2010 10:33 am    Post subject: Reply with quote

To change back to use opengl, just edit your ~/.kde4/share/config/kwinrc while KDE is not running:
Code:
[Compositing]
Backend=OpenGL
CheckIsSafe=true
DisableChecks=false
Enabled=false
GLDirect=true
GLMode=TFP
GLTextureFilter=1
GLVSync=false
OpenGLIsUnsafe=false
The "enabled=false" is in there, because if something goes wrong, you won't fall back to your login manager. KDE is started with desktop-effects disabled with this setting, so you can play around with the system-settings.

If you do use XRender, it doesn't change anything whether mesa uses classic or gallium. However, with the OpenGL backend gallium won't function properly on my laptop with kwin crashing and restarting every few seconds. With "classic" most effects work fine.

@cynapsis: It might be impossible to switch to classic with "gallium" USE-Flag enabled, depending on the chipset:
Code:
 # eselect mesa list
i915 (Intel 915, 945)
  gallium *
i965 (Intel 965, G/Q3x, G/Q4x)
  classic *
  gallium
r300 (Radeon R300-R500)
r600 (Radeon R600-R700)
sw (Software renderer)
  classic *
  gallium                   
i915 and i945 have no classic variant.
_________________
systemd - The biggest fallacies
Back to top
View user's profile Send private message
jbouzan
Tux's lil' helper
Tux's lil' helper


Joined: 23 Nov 2007
Posts: 138

PostPosted: Wed Nov 24, 2010 6:58 pm    Post subject: Reply with quote

My output is different.
Code:
eselect mesa list
i915 (Intel 915, 945)
  classic                   
  gallium *                 
i965 (Intel 965, G/Q3x, G/Q4x)
  gallium                   
r300 (Radeon R300-R500)
r600 (Radeon R600-R700)
sw (Software renderer)
  classic                   
  gallium *
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1402
Location: Bardowick, Germany

PostPosted: Thu Nov 25, 2010 10:36 am    Post subject: Reply with quote

Ah. Okay that means, that mesa does not install classic drivers for i915 because I have set i965 and for you it's the other way round. Quite nifty, eh? ;)
_________________
systemd - The biggest fallacies
Back to top
View user's profile Send private message
jbouzan
Tux's lil' helper
Tux's lil' helper


Joined: 23 Nov 2007
Posts: 138

PostPosted: Thu Nov 25, 2010 9:29 pm    Post subject: Reply with quote

If I've understood the ebuild correctly, this section only builds the Intel driver you specify if you've given it in your VIDEO_CARDS variable, or all of them if you haven't.
Code:
# Intel code
   driver_enable video_cards_i810 i810
   driver_enable video_cards_i915 i915
   driver_enable video_cards_i965 i965
      if ! use video_cards_i810 && \
         ! use video_cards_i915 && \
         ! use video_cards_i965; then
      driver_enable video_cards_intel i810 i915 i965
   fi

So yeah, pretty neat.
Back to top
View user's profile Send private message
SDNick484
Tux's lil' helper
Tux's lil' helper


Joined: 05 Dec 2005
Posts: 144

PostPosted: Tue Nov 22, 2011 5:54 am    Post subject: Reply with quote

chithanh wrote:
The i915g and i965g drivers can hardly do more than draw triangles.


Any idea whether there's been updates to the i965 driver? I checked the status page, and it's still listed as WIP, but I don't believe that page is being updated.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1678
Location: Berlin, Germany

PostPosted: Tue Nov 22, 2011 1:32 pm    Post subject: Reply with quote

The i915g driver has seen a significant amount of work. In current mesa git, it is now comparable to the classic driver.
For the i965g driver, the situation is unchanged.
Back to top
View user's profile Send private message
SDNick484
Tux's lil' helper
Tux's lil' helper


Joined: 05 Dec 2005
Posts: 144

PostPosted: Tue Nov 22, 2011 8:54 pm    Post subject: Reply with quote

chithanh wrote:
The i915g driver has seen a significant amount of work. In current mesa git, it is now comparable to the classic driver.
For the i965g driver, the situation is unchanged.


Interesting, thanks for the update.
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1402
Location: Bardowick, Germany

PostPosted: Wed Jan 11, 2012 10:23 am    Post subject: Reply with quote

Just a little update: The i965g gallium drivers got removed - broken and unmaintained: http://phoronix.com/forums/showthread.php?65304-The-Gallium3D-Intel-965-Driver-Gets-Dropped
_________________
systemd - The biggest fallacies
Back to top
View user's profile Send private message
defer-
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2007
Posts: 140
Location: Finland

PostPosted: Tue Jul 30, 2013 1:34 pm    Post subject: Reply with quote

What is the current state of gallium on intel? I have intel MHD4500 with i965 driver. Is the gallium3D driver stable and well supported? Is there any performance benefits over mesa?
_________________
https://github.com/defer-
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2109
Location: Near Toronto

PostPosted: Tue Jul 30, 2013 2:11 pm    Post subject: Reply with quote

Quote:
Is the gallium3D driver stable and well supported? Is there any performance benefits over mesa?


I do not understand this question. Gallium is part of mesa SFAIK.
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
defer-
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jun 2007
Posts: 140
Location: Finland

PostPosted: Tue Jul 30, 2013 2:16 pm    Post subject: Reply with quote

With mesa i meant mesa classic driver.
_________________
https://github.com/defer-
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2413
Location: UK

PostPosted: Wed Jul 31, 2013 3:18 am    Post subject: Reply with quote

Intel developers dropped the Gallium branches from their code years ago and the current driver does not use it at all.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2643
Location: Slovenia

PostPosted: Wed Jul 31, 2013 9:46 am    Post subject: Reply with quote

There is a fully working i915g driver for gen3 (GMA950, GMA3150) graphics. Google has been working on it. It's considered complete, there's nothing more to be done for the old gen3 graphics. I'll give it a go on my netbook once mesa 9.2 is released, see if anything works better with it than with the classic i915 driver.

Then there's a i965g driver for Sandy Bridge and Ivy Bridge. It's more or less a hobby project of a single developer. He's regularly working on it, but it's not complete yet, and right now slower than the classic i965 driver.

defer- wrote:
I have intel MHD4500 with i965 driver.

There is no Gallium driver for the 4500MHD (gen4) and probably never will be. The hobby project I mentioned above is only for Sandy/Ivy Bridge (gen6 and gen7).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum