Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HowTo Gnash, Lightspark, Html5
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
EvaSjo
n00b
n00b


Joined: 01 Jun 2006
Posts: 4

PostPosted: Thu Nov 11, 2010 8:30 pm    Post subject: HowTo Gnash, Lightspark, Html5 Reply with quote

Hardware:
AMD Duron 800 MHz
ATI Technologies Inc Rage 128 RF/SG AGP
Crt 21 inches, resolution 1600 x 1200, depth 24
# glxinfo | grep rendering
direct rendering: Yes

Software:
Portage 2.1.8.3 (default/linux/x86/10.0, gcc-4.4.4, glibc-2.11.2-r0, 2.6.34-gentoo-r6 i686)
x11-libs/qt-core-4.6.3
kde-base/kde-meta-4.4.5


1) Gnash
# emerge -av www-plugins/gnash
[ebuild R ] www-plugins/gnash-0.8.8 USE="agg dbus ffmpeg kde mysql nls opengl sdl ssl xv (-aqua) -cairo -cygnal -doc -fbcon -gnome -gstreamer -gtk (-kdeenablefinal) (-lirc) -nsplugin -python -sdl-sound -ssh -test -vaapi" VIDEO_CARDS="-intel" 0 kB [?=>1]
=> Error (Bug 339610)

1.1 Overlay (Bug 339610, https://bugs.gentoo.org/show_bug.cgi?id=339610)
# nano -w /etc/make.conf
PORTDIR_OVERLAY="/usr/local/portage"
# mkdir /usr/local/portage
# mkdir /usr/local/portage/www-plugins
# mkdir /usr/local/portage/www-plugins/gnash
# mkdir /usr/local/portage/www-plugins/gnash/files
# cp /usr/portage/www-plugins/gnash/gnash-0.8.8.ebuild /usr/local/portage/www-plugins/gnash/gnash-0.8.8.ebuild
# cp /usr/portage/www-plugins/gnash/files/* /usr/local/portage/www-plugins/gnash/files/.
# cd /usr/local/portage/www-plugins/gnash/files
# wget -O gnash-0.8.8-klash.patch https://bugs.gentoo.org/attachment.cgi?id=249444
# wget -O gnash-0.8.8.ebuild.patch https://bugs.gentoo.org/attachment.cgi?id=249446
# less /usr/local/portage/www-plugins/gnash/gnash-0.8.8.ebuild
# Adapted from Alt Linux to fix klash support properly // This row already in the file
epatch "${FILESDIR}"/${PN}-0.8.8-klash.patch // This row already in the file
# patch -p1 -g0 -E --no-backup-if-mismatch '/usr/local/portage/www-plugins/gnash/gnash-0.8.8.ebuild' < '/usr/local/portage/www-plugins/gnash/files/gnash-0.8.8.ebuild.patch'
# ebuild /usr/local/portage/www-plugins/gnash/gnash-0.8.8.ebuild digest
# emerge -av www-plugins/gnash

1.2 Check

Should show the following:
Configure Konqueror, File Management, File Accociations, Textbox: swf <enter> shows:
application Show file in embedded viewer
x-shockwave-flash
General:
*.spl // Unsure if this row came after Lightspark installation
*.swf
Embedding:
Show file in embedded viewer
Ask whether to save to disk instead (only for Konqueror browser)
Services Preferences Order:
Klash, embedded Gnash plager for KDE (klash_part)

Test:
http://www.skierpage.com/olpc/flash_tests/car_smash.swf // Test Gnash Ok!
http://www.skierpage.com/olpc/flash_tests/embed_car_smash.html // Test Gnash Ok!
http://www.youtube.com/watch?v=YR4ezMgRlWo // Test Gnash not Ok!
Only a black box and no arrow to click on.
Right click in the box, File, Properties: SWF 10 // Flash 10; substitute url "watch?v=" to "v/"
http://www.youtube.com/v/YR4ezMgRlWo // Test Gnash Ok!
It shows a big arrow.
Right click in the box, File, Properties: SWF 8 // Flash 8

Gnash result: Gnash works!


2) Lightspark

# nano -w /var/lib/portage/world
www-plugins/lightspark

# emerge -av www-plugins/lightspark
[ebuild R ] www-plugins/lightspark-0.4.4.3 USE="-nsplugin -pulseaudio" 0 kB

2.1 Check

Should show the following:
Configure Konqueror, File Management, File Accociations
Textbox: swf <enter>, General, Application Preference Order,
Lightspark

Test:
http://www.youtube.com/watch?v=YR4ezMgRlWo // Test Lightspark not Ok!
Only a black box and no arrow to click on.
Right click in the box, File, Properties: SWF 10

Analyze, why is it not working:
http://en.wikipedia.org/wiki/Rage_128
Rage 128 was compliant to Direct3D 6 and OpenGL 1.2.
http://en.wikipedia.org/wiki/Lightspark
It uses OpenGL shaders (GLSL).
http://en.wikipedia.org/wiki/GLSL
Included into the OpenGL 2.0
# glxinfo | grep -i "opengl version"
OpenGL version string: 1.2 Mesa 7.8.2

Lightspark result: My software and hardware are speaking OpneGL 1.2. Lightspark speaks 2.0 or above. I will mot get Lightspark to work with my hardware!


3) Html5

Test:
http://punky030.com/test/test.html // Test Html5 Ok!

Test Youtube:
http://www.youtube.com/html5 // http://googlesystem.blogspot.com/2010/08/watch-video-in-youtubes-html5-player.html
Click on "Join the HTML5 Trial"
http://www.youtube.com/watch?v=YR4ezMgRlWo&html5=True
Only a black box and no arrow to click on
http://www.youtube.com/v/YR4ezMgRlWo&html5=True // Starts Gnash instead of Html5
It shows a big arrow.
Right click in the box, File, Properties: SWF 8
http://www.youtube.com/html5
Click on "Leave the HTML5 Trial"

Html5 result: Html5 works! Youtube (opt-in trial) demands browsers plus versions plus codecs which I do not have at home or at job.
_________________
// Evald
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1674
Location: Berlin, Germany

PostPosted: Fri Nov 12, 2010 9:02 pm    Post subject: Reply with quote

For Youtube, you may also want to mention the Youtube without flash greasemonkey script, which leverages mplayer/totem/vlc browser plugins for displaying videos.
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4672
Location: Theux (Belgium)

PostPosted: Fri Mar 25, 2011 9:49 pm    Post subject: Reply with quote

Well, no, Gnash doesn't work, evevn with the URL hack. It's been a couple of ebuilds it has never worked for me. Curiously enough, when I enable HTML5 on youtube, I can see the circling ring (as if it were a YouTube video) and I'm immediately prompted with a message there's no HTML5 support. The only thing I'm able to get is a black square without any content.

Note I must enable nsplugin otherwise I get a «Download» dialog instead. When I go to Dailymotion, it says the content for the plugin has been deactivated (wtf?). But in Firefox modules & plugins, I can see «Shockwave flash Shockwave Flash 10.1 r999. Gnash 0.8.8, the GNU bla bla bla...» and it's enabled!

Been stuck for years in fact. Never been able to make Gnash work properly on Gentoo. Any hint?
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1674
Location: Berlin, Germany

PostPosted: Fri Mar 25, 2011 10:15 pm    Post subject: Reply with quote

Gnash works fine here with Youtube. Of course you need USE="nsplugin" enabled to get the gnash browser plugin.

With gnash-0.8.8 you had to block Youtube cookies in some cases, or else you would only see an error message. This issue has been fixed in gnash-0.8.9.
Back to top
View user's profile Send private message
Raptor85
Apprentice
Apprentice


Joined: 29 Dec 2007
Posts: 208

PostPosted: Fri Mar 25, 2011 11:33 pm    Post subject: Reply with quote

VinzC wrote:
Curiously enough, when I enable HTML5 on youtube, I can see the circling ring (as if it were a YouTube video) and I'm immediately prompted with a message there's no HTML5 support. The only thing I'm able to get is a black square without any content.

you need firefox 4 and not all videos are compatible yet. add &webm=1 to the end of your youtube search to see ones available
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4672
Location: Theux (Belgium)

PostPosted: Sat Mar 26, 2011 10:44 am    Post subject: Reply with quote

Raptor85 wrote:
you need firefox 4 and not all videos are compatible yet. add &webm=1 to the end of your youtube search to see ones available

Yeah, I know. You can also enable HTML5 on Youtube as they have a page where they allow you to enable that feature and avoid changing the URLs by hand.


chithanh wrote:
Gnash works fine here with Youtube. Of course you need USE="nsplugin" enabled to get the gnash browser plugin.

With gnash-0.8.8 you had to block Youtube cookies in some cases, or else you would only see an error message. This issue has been fixed in gnash-0.8.9.

I don't see anything, just a black rectangle. That's been like this for (no lie) years. No error message, nothing more than just a black rectangle.

BTW how can you tell from Firefox that you have Gnash? I have downloaded Adobe Flash player 10-... (64-bit) from their web site and it's working pretty well. Except I sometimes get "crashed" error messages and Firefox becomes unresponsive at times. In the list of plugins, this is what I have:
Code:
gxine starter plugin (disabled)
Shockwave Flash 9.0 r999 (disabled)
Shockwave Flash 10.1 r999. Gnash 0.8.8, the GNU swf player [...] (enabled)
Shockwave Flash 10.3 d162 (disabled)

But where could the second shockwave flash come from? I also read that Gnash supports Flash up to version 9 so the third item in the list is a little bit surprising to me.

ll .mozilla{,/firefox}/plugins:
.mozilla/firefox/plugins:
total 0
lrwxrwxrwx 1 vinz users 31  3 sep  2010 gxineplugin.so -> /usr/lib64/gxine/gxineplugin.so

.mozilla/plugins:
total 19560
lrwxrwxrwx 1 vinz users       31  3 sep  2010 gxineplugin.so -> /usr/lib64/gxine/gxineplugin.so
-rwxr-xr-x 1 vinz users  1208323 24 oct  2006 libcrypto.so.0.9.7
-rw-r--r-- 1 vinz users 10606256 17 nov 01:10 libflashplayer.so
-rwxr-xr-x 1 vinz users   215537 24 oct  2006 libssl.so.0.9.7
-rwxr-xr-x 1 vinz users  7985509 24 oct  2006 viewer
-rw-r--r-- 1 vinz users     1788 24 oct  2006 xpcomIVMControl.xpt

ll /usr/lib/nsbrowser/plugins/:
total 76
lrwxrwxrwx 1 root root    31  5 jan 15:11 gxineplugin.so -> /usr/lib64/gxine/gxineplugin.so
lrwxrwxrwx 1 root root    40 25 mar 22:33 libgnashplugin.so -> /usr/lib64/gnash/npapi/libgnashplugin.so
-rw-r--r-- 1 root root  1492 25 déc 10:39 libswfdecmozilla.la
-rwxr-xr-x 1 root root 69752 25 déc 10:39 libswfdecmozilla.so

Any idea?
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2374
Location: UK

PostPosted: Sat Mar 26, 2011 3:48 pm    Post subject: Reply with quote

VinzC wrote:
BTW how can you tell from Firefox that you have Gnash?

about:plugins
_________________
runit-init howto | Overlay
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4672
Location: Theux (Belgium)

PostPosted: Sat Mar 26, 2011 9:24 pm    Post subject: Reply with quote

Ok, Shockwave Flash 9.0 r999 was in fact swfdec plugin. But I've disabled it and still I get only a black rectangle...





**sigh**
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1674
Location: Berlin, Germany

PostPosted: Sat Mar 26, 2011 11:34 pm    Post subject: Reply with quote

Having several plugins for the same MIME type installed will cause problems. Disabling them is not enough, you need to unmerge the ones you don't want.
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4672
Location: Theux (Belgium)

PostPosted: Mon Mar 28, 2011 9:42 am    Post subject: Reply with quote

Removing all plugins SO but gnash seemed to do the trick. Now one of my CPU cores gets eaten 8O. Is there any acceleration setting I could use?
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1674
Location: Berlin, Germany

PostPosted: Mon Mar 28, 2011 9:57 am    Post subject: Reply with quote

In 0.8.9 there are some features and performance optimizations like threading, but they require firefox-4.0.
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4672
Location: Theux (Belgium)

PostPosted: Mon Mar 28, 2011 10:07 am    Post subject: Reply with quote

Nice to know indeed. So far gnash seems to work but it's a PIA to always clean Youtube cookies before watching any video. Note now those videos don't play and give me an error message permanently instead («An error occurred, please try again later»), even after clearing Youtube cookies.

BTW I think I was confused with the CPU activity. It was my screensaver that actually left remnant applets which were consuming the CPU. I've killed and wiped them now. Not sure it was Gnash in the end.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
e3k
Apprentice
Apprentice


Joined: 01 Oct 2007
Posts: 187
Location: Slovakia

PostPosted: Sun Oct 06, 2013 8:20 pm    Post subject: Reply with quote

oldie but goldie...
now with firefox(google)Shumway coming i remembered i had once Gnash or Silverlight installed.
how do those 2 work with youtube and southparkstudios.com?
currently a flashless system at home.
_________________
---__o__---
Back to top
View user's profile Send private message
e3k
Apprentice
Apprentice


Joined: 01 Oct 2007
Posts: 187
Location: Slovakia

PostPosted: Mon Oct 07, 2013 2:30 pm    Post subject: Reply with quote

lightspark-0.7.2-r1
plays: youtube (sometimes) and (soundcloud)
does not play: southparkstudios, fb videos, bandcamp, vimeo, ektoplazm

gnash-0.8.10_p20130822
plays: youtube and ektoplazm
does not play: southparkstudios, fb videos, bandcamp, vimeo, soundcloud
----
2013-11-02 i noticed soundcloud stoped working.
_________________
---__o__---
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum