Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Akonadi kann nicht starten; dadurch geht kein kmail
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum
View previous topic :: View next topic  
Author Message
Max Steel
Veteran
Veteran


Joined: 12 Feb 2007
Posts: 1951
Location: My own world! I and Gentoo!

PostPosted: Fri Nov 05, 2010 1:19 pm    Post subject: Akonadi kann nicht starten; dadurch geht kein kmail Reply with quote

Hmpf... fehlenbei euch auch die kdepim Pakete (also meta, akonadi, und der ganze Glumbsatsch) auf Version 4.5.3... seit 4.4.7 gab es hier kein Update mehr.

Was eigentlich seltsam ist.
Jedenfalls hat mein Vater an seinem PC das Problem das sich akonadi nicht starten kann, wodurch kontakt, kaddessbook und kmail nicht funktionieren.

Die Fehlermeldung die der Akonadi ausspuckt:
Code:
[akonadiserver] search paths:  ("/usr/local/bin", "/usr/bin", "/bin", "/opt/bin", "/usr/x86_64-pc-linux-gnu/gcc-bin/4.4.5", "/usr/qt/3/bin", "/usr/games/bin", "/var/spool/fax/bin", "/home/achim/bin", "/usr/sbin", "/usr/local/sbin", "/usr/local/libexec", "/usr/libexec", "/opt/mysql/libexec", "/opt/local/lib/mysql5/bin", "/opt/mysql/sbin")
[akonadiserver] Found mysql_install_db:  "/usr/bin/mysql_install_db"
[akonadiserver] Found mysqlcheck:  "/usr/bin/mysqlcheck"
[akonadiserver] QSqlDatabase: QMYSQL driver not loaded
[akonadiserver] QSqlDatabase: available drivers: QSQLITE QSQLITE3 QMYSQL3 QMYSQL
[akonadiserver] ASSERT: "database.driver()->hasFeature( QSqlDriver::LastInsertId )" in file /var/tmp/portage/app-office/akonadi-server-1.4.1/work/akonadi-1.4.1/server/src/storage/dbconfigmysql.cpp, line 154
[akonadiserver] "[
[akonadiserver] 0: akonadiserver(_Z11akBacktracev+0x39) [0x40ba79]
[akonadiserver] 1: akonadiserver() [0x40bfb2]
[akonadiserver] 2: /lib/libc.so.6(+0x33ba0) [0x7fd6ef7a7ba0]
[akonadiserver] 3: /lib/libc.so.6(gsignal+0x35) [0x7fd6ef7a7b25]
[akonadiserver] 4: /lib/libc.so.6(abort+0x180) [0x7fd6ef7a9330]
[akonadiserver] 5: /usr/lib64/qt4/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0x64) [0x7fd6f09a7384]
[akonadiserver] 6: /usr/lib64/qt4/libQtCore.so.4(+0x6e584) [0x7fd6f09a7584]
[akonadiserver] 7: /usr/lib64/qt4/libQtCore.so.4(_Z6qFatalPKcz+0x96) [0x7fd6f09a7716]
[akonadiserver] 8: /usr/lib/libakonadiprivate.so.1(_ZN13DbConfigMysql19startInternalServerEv+0x14df) [0x7fd6f0f0483f]
[akonadiserver] 9: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer20startDatabaseProcessEv+0xe6) [0x7fd6f0e64ae6]
[akonadiserver] 10: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServerC1EP7QObject+0xd5) [0x7fd6f0e686b5]
[akonadiserver] 11: /usr/lib/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer8instanceEv+0x2f) [0x7fd6f0e69dcf]
[akonadiserver] 12: akonadiserver(main+0x3cd) [0x406a0d]
[akonadiserver] 13: /lib/libc.so.6(__libc_start_main+0xfd) [0x7fd6ef792d2d]
[akonadiserver] 14: akonadiserver() [0x405b09]
[akonadiserver] ]
[akonadiserver] "
ProcessControl: Application 'akonadiserver' returned with exit code 255 (Unknown error)
"akonadiserver" crashed too often and will not be restarted!


Jedenfalls sind folgende Versionen installiert:
Code:
$ eix akonadi
[I] app-office/akonadi-server
     Available versions:  1.3.1 (~)1.4.1 {(+)mysql postgres +server (+)sqlite}
     Installed versions:  1.4.1(06:32:34 27.10.2010)(server sqlite -mysql -postgres)
     Homepage:            http://pim.kde.org/akonadi
     Description:         The server part of Akonadi

[I] kde-base/akonadi
     Available versions:  (4.4) 4.4.5 (~)4.4.6 4.4.7
        {aqua debug kdeenablefinal kdeprefix}
     Installed versions:  4.4.7(4.4)(04:16:15 05.11.2010)(-aqua -debug -kdeenablefinal -kdeprefix)
     Homepage:            http://www.kde.org/
     Description:         An extensible cross-desktop storage service for PIM data and meta data

$ eix kdepim
[I] kde-base/kdepimlibs
     Available versions: 
        (4.4)   4.4.5!t
        (4.5)   (~)4.5.2!t (~)4.5.3!t
        {aqua debug +handbook kdeenablefinal kdeprefix ldap (+)semantic-desktop test}
     Installed versions:  4.5.3(4.5)!t(22:52:45 03.11.2010)(handbook ldap semantic-desktop -aqua -debug -kdeenablefinal -kdeprefix -test)
     Homepage:            http://www.kde.org/
     Description:         Common library for KDE PIM apps.

[I] kde-base/kdepim-runtime
     Available versions:  (4.4) 4.4.5 (~)4.4.6!t 4.4.7!t
        {aqua debug kdeenablefinal kdeprefix}
     Installed versions:  4.4.7(4.4)!t(08:29:53 30.10.2010)(-aqua -debug -kdeenablefinal -kdeprefix)
     Homepage:            http://www.kde.org/
     Description:         KDE PIM runtime plugin collection

$ eix kde-meta
[I] kde-base/kde-meta
     Available versions: 
        (4.4)   4.4.5
        (4.5)   (~)4.5.2 (~)4.5.3
        {accessibility aqua kdeprefix nls sdk semantic-desktop}
     Installed versions:  4.5.3(4.5)(22:09:24 04.11.2010)(accessibility nls semantic-desktop -aqua -kdeprefix -sdk)
     Homepage:            http://www.kde.org/
     Description:         KDE - merge this to pull in all split kde-base/* packages


Was läuft da falsch?... ICh bin echt ratlos.

Edith:
Ach sorry, ich seh gerade im falschen Unterforum. Mag sich ein lieber Mod erbarmen dieses rüberzuschieben?
Dankeschön =)
_________________
mfg
Steel
___________________
Big sorry for my bad English.

Heim-PC: AMD Phenom II X4 3,2GHz, 16GB RAM, gentoo-sources-3.10.7, NV GTX 780
Laptop: Intel Celeron 1,7GHz, 512MB Ram, tuxonice-sources-3.7.1, SIS Graphic

Version 0.4
Back to top
View user's profile Send private message
gandalf_hak
n00b
n00b


Joined: 10 Jun 2013
Posts: 2

PostPosted: Mon Jun 10, 2013 12:24 pm    Post subject: Reply with quote

Hallo!

Dein Thread ist zwar nicht aktuell, hatte nach einem Akonadi Update allerdings mal wieder das Vergnügen :)
QSQLITE wird von akonadi entweder nicht mehr richtig unterstützt oder dein qtbuild wurde mit anderen libs gebacken.

Lösungsmöglichkeit:

Du benutzt einfach QMYSQL oder QMYSQL3 statt QSQLITE:

kannst du in
Code:
~/.config/akonadi/akonadiserverrc

setzen
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1240
Location: Bardowick, Germany

PostPosted: Wed Jun 12, 2013 12:58 pm    Post subject: Reply with quote

dazu passt die Ausgabe von portage wenn man kmail installiert:
Code:
 * We strongly recommend you set your Akonadi database backend to QMYSQL in your
 * user configuration. This is the backend recommended by KDE upstream.
 * Reports indicate that kde-base/kmail-4.10 does not work properly with the sqlite
 * backend anymore.
 * You can select the backend in your ~/.config/akonadi/akonadiserverrc.

_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum