Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]xorg 1.9, keyboard layouts missing/conf file moved?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
KrossFIN
n00b
n00b


Joined: 08 May 2010
Posts: 63
Location: Finland, Oulu

PostPosted: Wed Oct 13, 2010 11:35 am    Post subject: [SOLVED]xorg 1.9, keyboard layouts missing/conf file moved? Reply with quote

So, I cant use AltGr, and keyboard layouts don\t work any more (only US)
Running xorg-server 1.9.0.901.
And xorg-x11 7.4-r1

/etc/make.conf

Code:
# Welcome to /etc/make.conf!
# WARNING: DO NOT change your chost unless it is really required and you know what you're doing!
#
# [ System specific ]
CFLAGS="-O2 -pipe -march=k8"
CXXFLAGS="-O2 -pipe -march=k8"
MAKEOPTS="-j5"
CHOST="x86_64-pc-linux-gnu"
USE="mmx sse sse2 3dnow multilib alsa bluetooth bzip2 cdda cddb cdr cups dri dvb dvd dvdr dbus encode emerald extras ffmpeg flac ftp gif gzip gtk gconf gnome gnome-keyring gnutls java jpeg javascript kvm lm-sensors lzma mysql matroska mpeg mp3 mp4 nsplugin nls ogg opengl png pulseaudio raw rss smp svg taglib tiff theora udev unicode vorbis x264 xvid X -minimal -debug -thunar -kde -hal -qt4"
LINGUAS="fi en"
ACCEPT_KEYWORDS="~amd64"

# [ Download settings ]
GENTOO_MIRRORS="ftp://trumpetti.atm.tut.fi/gentoo/"
SYNC="rsync://rsync.fi.gentoo.org/gentoo-portage"

# [ Application specific ]
VIDEO_CARDS="radeon"
INPUT_DEVICES="evdev"


USE flags that I think are important, -hal udev.

I have done
Code:
emerge -DuvaN world
and
Code:
revdep-rebuild

Any ideas?
_________________
Gentoo Linux user
~amd64 user
no-multilib user
KDE user


Last edited by KrossFIN on Fri Oct 15, 2010 1:02 pm; edited 2 times in total
Back to top
View user's profile Send private message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1437
Location: Oranienburg/Germany

PostPosted: Wed Oct 13, 2010 6:02 pm    Post subject: Reply with quote

Hi,

i had a similiar problem with my german keyboard. I recognized in the logfile of xorg, they use a special config dir. I found a config for a keyboard there but incomplete. So I added my german config there. Maybe this helps you a bit. Since im not in Linux Im not able to check for correct path.

bb

EDIT: I booted into my gentoo install and checked the conf dir: /usr/share/X11/xorg.conf.d

check this directory for an additional config for your keyboard :)
_________________
1st: C2D 3GHz, 8GB, 2.25TB, HD4850
2nd: Celeron 2.6GHz, 2GB, 500GB, HD4350
3rd: TP X220, 2,5GHz, 8GB, 320GB, HD3000
4th: Athlon X2 BE-2300, 4GB, 64GB SSD + 3TB RAID5 GF7025
5th: Samung N350, 2GB, 250GB, HD3150
6th: Rasperry Pi, 512MB, 32GB SD
Back to top
View user's profile Send private message
KrossFIN
n00b
n00b


Joined: 08 May 2010
Posts: 63
Location: Finland, Oulu

PostPosted: Wed Oct 13, 2010 8:09 pm    Post subject: Reply with quote

Does your keymap conf file have a name_ (I hate when my keyboard doesn\type right)

/usr/share/X11/xorg.conf.d/ has only one file, 10-evdev.conf

By intensively looking at xorg log, I only noticed that it loaded us keymap(no dirs shown)
_________________
Gentoo Linux user
~amd64 user
no-multilib user
KDE user
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2633
Location: Slovenia

PostPosted: Wed Oct 13, 2010 8:21 pm    Post subject: Reply with quote

http://fedoraproject.org/wiki/Input_device_configuration

Why doesn't Gentoo have a similar document yet? xorg-server-1.8 has been in the tree for quite some time now, there should be a document explaining the new post-hal method of configuring input devices.
Back to top
View user's profile Send private message
KrossFIN
n00b
n00b


Joined: 08 May 2010
Posts: 63
Location: Finland, Oulu

PostPosted: Thu Oct 14, 2010 3:35 pm    Post subject: Reply with quote

Gentoo don\t do documents on unstable stuff for some reason. (has caused some problems that I have to bloat this forum with)
Sadly that document didn\t help much.
/etc/X11/ doesn\t have a xorg.conf.d file. (nor did it have xorg.conf or anything like that..)
_________________
Gentoo Linux user
~amd64 user
no-multilib user
KDE user
Back to top
View user's profile Send private message
TequilaTR
n00b
n00b


Joined: 01 Feb 2005
Posts: 58

PostPosted: Thu Oct 14, 2010 5:38 pm    Post subject: Reply with quote

Hi,

you do not search for that file, but for that directory.

in /usr/share/X11/xorg.conf.d/10-evdev.conf

I changed:

Section "InputClass"
Identifier "evdev keyboard catchall"
MatchIsKeyboard "on"
MatchDevicePath "/dev/input/event*"
Driver "evdev"
+ Option "xkb_layout" "de"
EndSection

Hope that helps. However i also wonder if one could plug the thing to xorg.conf or equal... did not try yet.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2633
Location: Slovenia

PostPosted: Thu Oct 14, 2010 5:48 pm    Post subject: Reply with quote

KrossFIN wrote:
Gentoo don\t do documents on unstable stuff for some reason. (has caused some problems that I have to bloat this forum with)
Yeah, it seems that's a policy of Gentoo. But in certain cases (like this one) it brings problems.

KrossFIN wrote:
/etc/X11/ doesn\t have a xorg.conf.d file. (nor did it have xorg.conf or anything like that..)
One of the first rules I learned when starting with Linux is this: If a configuration file a piece of documentation mentions doesn't exist, create it.
You can create /etc/X11/xorg.conf and write stuff in there. Or you create a random .conf file (or more of them) in the /etc/X11/xorg.conf.d/ dir. There you write an InputClass section with MatchIsKeyboard and settings in that section will apply to all keyboards.
Same for any other type of input device, you create a section, determine a match, and the settings will apply to everything that matches.
Back to top
View user's profile Send private message
KrossFIN
n00b
n00b


Joined: 08 May 2010
Posts: 63
Location: Finland, Oulu

PostPosted: Fri Oct 15, 2010 1:01 pm    Post subject: Reply with quote

I've noticed that it I'm not missing a conf file, it's GNOME that fails.
I changed to KDE and keyboard works perfectly.
For some odd reason GNOME implements it's own keyboard technology on top of xorg's. And it fails.
Yes, I do create conf files if one doesn't exist, but it's quite complicated file. (for me at least)
Solved, but still not solved..

Thank you for your help.
_________________
Gentoo Linux user
~amd64 user
no-multilib user
KDE user
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 336
Location: Stockholm, Sweden

PostPosted: Fri Oct 15, 2010 8:28 pm    Post subject: Reply with quote

I have the same issue, will try to add the extra evdev settings and see if it helps. I did think that Gnome would handle the keyboard layouts though, since that is where I do the settings (I run dvorak for me and qwerty for my girlfriend).
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
Mikkl
n00b
n00b


Joined: 12 Jan 2006
Posts: 60

PostPosted: Sat Oct 16, 2010 2:02 pm    Post subject: Reply with quote

me, too. and the keys in gnome-keyboard-properties -> Layouts -> Options (e.g. kill x-server by ctrl-alt-backspace or change layout) don't do anything, too. This has happened since the xorg-server-1.9.0.901 came up and now in .902, too. My xorg logfile doesn't show any differences between the working xorg-server-1.9.0-r2 and the not working xorg-server-1.9.0.90x except for these lines missing in 1.9.0.90x:
Code:
 (II) Power Button: Close
 (II) UnloadModule: "evdev"
 (II) Power Button: Close
 (II) UnloadModule: "evdev"
 (II) Logitech Logitech USB Keyboard: Close
 (II) UnloadModule: "evdev"
 (II) Logitech Logitech USB Keyboard: Close
 (II) UnloadModule: "evdev"
 (II) Logitech USB Mouse: Close
 (II) UnloadModule: "evdev"
Back to top
View user's profile Send private message
Mighty_Max
n00b
n00b


Joined: 19 Sep 2008
Posts: 55
Location: Thessaloniki, Greece

PostPosted: Sun Oct 17, 2010 12:21 pm    Post subject: Reply with quote

I had the same issue in .901 and .902 xorg-servers, and I was messing around with it for about a day. As it seems the gnome-keyboard-properties doesn't do much for keyboard layouts. Altouth tweaking the /usr/share/X11/xorg.conf.d/10-evdev.conf like TequilaTR said does the job:

Code:

Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
   Option "xkb_layout" "us,el"
   Option "XkbOptions"   "grp:alt_shift_toggle,grp_led:scroll"
Back to top
View user's profile Send private message
KrossFIN
n00b
n00b


Joined: 08 May 2010
Posts: 63
Location: Finland, Oulu

PostPosted: Sun Oct 17, 2010 4:41 pm    Post subject: Reply with quote

Yep, it works. Thank you for your help.
EDIT: the file removes your settings when updating xorg!
_________________
Gentoo Linux user
~amd64 user
no-multilib user
KDE user
Back to top
View user's profile Send private message
Mikkl
n00b
n00b


Joined: 12 Jan 2006
Posts: 60

PostPosted: Tue Oct 19, 2010 3:21 pm    Post subject: Reply with quote

Ahh, thanks, it works for me, too, and an addition made my x-server zap work again:
Code:

   Option "xkb_layout" "us, de"
   Option "XkbOptions" "grp:alt_shift_toggle, terminate:ctrl_alt_bksp"
Back to top
View user's profile Send private message
TequilaTR
n00b
n00b


Joined: 01 Feb 2005
Posts: 58

PostPosted: Wed Oct 20, 2010 4:57 am    Post subject: Reply with quote

KrossFIN wrote:
Yep, it works. Thank you for your help.
EDIT: the file removes your settings when updating xorg!


Hi,

indeed it is removed. However you can just simply copy the whole folder
/usr/share/X11/xorg.conf.d to /etc/X11 and have the file
modified there. Then it should not get overwritten
on update. /usr/share/X11 files seem to be some sort of template for
the default configuration.
Back to top
View user's profile Send private message
blutregens
n00b
n00b


Joined: 29 Dec 2007
Posts: 14

PostPosted: Tue Oct 26, 2010 3:29 am    Post subject: Reply with quote

Any tips as to why the policy files on /etc/hal/fdi/policy are being ignored? I used to configure my keyboard with a fdi file and it doesn't work anymore. Changing the /etc/X11/xorg.conf.d/10-evdev.conf file worked, though.

My policy file:
Code:

<deviceinfo version="0.2">
<device>
   <match key="info.capabilities" contains="input.keyboard">[/quote]
      <merge key="input.x11_options.AutoRepeat" type="string">500 300</merge>
      <merge key="input.x11_options.XkbRules" type="string">xorg</merge>
      <merge key="input.x11_options.XkbModel" type="string">abnt2</merge>
      <merge key="input.x11_options.XkbLayout" type="string">br</merge>
      <merge key="input.x11_options.XkbOptions" type="string">terminate:ctrl_alt_bksp</merge>
   </match>
   </device>
</deviceinfo>
Back to top
View user's profile Send private message
TequilaTR
n00b
n00b


Joined: 01 Feb 2005
Posts: 58

PostPosted: Tue Oct 26, 2010 7:12 am    Post subject: Reply with quote

I think the idea is to discontinue hal. Evdev does not seem to use it anymore.
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 336
Location: Stockholm, Sweden

PostPosted: Sat Nov 06, 2010 2:03 pm    Post subject: Reply with quote

TequilaTR wrote:
I think the idea is to discontinue hal. Evdev does not seem to use it anymore.


Yep, everybody hates HAL =)
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
CodAv
Apprentice
Apprentice


Joined: 09 May 2004
Posts: 164
Location: Wuppertal, Germany

PostPosted: Sun Nov 21, 2010 9:34 pm    Post subject: Reply with quote

Instead of editing files in /usr/share/X11/xorg.conf.d, use the proper method, and create a folder /etc/X11/xorg.conf.d and place your edited files there. To switch to a german keyboard layout for example, put a file "10-keymap.conf" there with the following contents:

Code:
Section "InputClass"
    Identifier "German Keyboard"
    MatchIsKeyboard "on"
    Option "XkbModel" "evdev"
    Option "XkbLayout" "de"
EndSection


After restarting XOrg, you should have your german layout working, and it doesn't get erased after the next XOrg upgrade.
_________________
Debian is available in three different versions: rusty, stale and broken.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum