Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mouse double clicks when I single click!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
PanzerKanzler
Guru
Guru


Joined: 04 Dec 2005
Posts: 371
Location: Belgravia, London

PostPosted: Tue Oct 12, 2010 8:14 pm    Post subject: Mouse double clicks when I single click! Reply with quote

Yesterday my mouse started registering things twice (not always, but often). When I single click something it acts just like if I had double clicked it. When scrolling with the wheel, it takes twice as big leaps as it used to. I noticed in my Xorg.0.log that Xorg is under the impression that I have two mice.
Code:
[    20.252] (II) config/udev: Adding input device Logitech Optical USB Mouse (/dev/input/event2)
[    20.252] (**) Logitech Optical USB Mouse: Applying InputClass "evdev pointer catchall"
[    20.252] (**) Logitech Optical USB Mouse: always reports core events
[    20.252] (**) Logitech Optical USB Mouse: Device: "/dev/input/event2"
[    20.255] (II) Logitech Optical USB Mouse: Found 3 mouse buttons
[    20.255] (II) Logitech Optical USB Mouse: Found scroll wheel(s)
[    20.255] (II) Logitech Optical USB Mouse: Found relative axes
[    20.255] (II) Logitech Optical USB Mouse: Found x and y relative axes
[    20.255] (II) Logitech Optical USB Mouse: Configuring as mouse
[    20.255] (**) Logitech Optical USB Mouse: YAxisMapping: buttons 4 and 5
[    20.255] (**) Logitech Optical USB Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    20.255] (II) XINPUT: Adding extended input device "Logitech Optical USB Mouse" (type: MOUSE)
[    20.255] (**) Logitech Optical USB Mouse: (accel) keeping acceleration scheme 1
[    20.255] (**) Logitech Optical USB Mouse: (accel) acceleration profile 0
[    20.255] (**) Logitech Optical USB Mouse: (accel) acceleration factor: 2.000
[    20.255] (**) Logitech Optical USB Mouse: (accel) acceleration threshold: 4
[    20.255] (II) Logitech Optical USB Mouse: initialized for relative axes.
[    20.255] (II) config/udev: Adding input device Logitech Optical USB Mouse (/dev/input/mouse0)

What is the recommended way to remove one of them? Thanks in advance!
_________________
If you've got nothing nice to say, you're probably not alone...
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3874
Location: USA

PostPosted: Tue Oct 12, 2010 9:23 pm    Post subject: Reply with quote

I had something like this happen when my Xorg.conf had the "old" style mouse configuration in it along with the new evdev style configuration... the mouse ended up getting one event through both places, resulting in inadvertent double clicks...

Check your Xorg.conf and remove any /dev/input/mice entries... should be using HAL and evdev in the kernel. (Or disable HAL/evdev and use the legacy mouse driver...)
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
PanzerKanzler
Guru
Guru


Joined: 04 Dec 2005
Posts: 371
Location: Belgravia, London

PostPosted: Tue Oct 12, 2010 9:40 pm    Post subject: Reply with quote

I forgot to say I am using Xorg 1.8, so the mouse goes via udev and not hal. My xorg.conf is just ten lines, and only contains the nvidia driver and keyboard layout, nothing else.

I fancy that I may have to add some section to xorg.conf that filters away one of the mice, but I cannot find out how :?
_________________
If you've got nothing nice to say, you're probably not alone...
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3874
Location: USA

PostPosted: Wed Oct 13, 2010 12:40 am    Post subject: Reply with quote

Seems it might be a udev issue or somehow X11 decides to pick up more than one mouse device...

I'm not an expert in udev, perhaps there's a way to stop udev from allocating /dev/input/mouse0 too...

(finally starting to figure out udev myself, after switching from legacy ide to libata, and how it mixes up fixed drives with the removable storage...)
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
PanzerKanzler
Guru
Guru


Joined: 04 Dec 2005
Posts: 371
Location: Belgravia, London

PostPosted: Wed Oct 13, 2010 4:15 pm    Post subject: Reply with quote

I have tried adding
Code:
Section "InputClass"
        Identifier "mouse-all"
        Driver "evdev"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
EndSection
to xorg.conf, but it does not seem to care.
_________________
If you've got nothing nice to say, you're probably not alone...
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2452
Location: Austria

PostPosted: Wed Oct 13, 2010 4:30 pm    Post subject: Reply with quote

Try latest xf86-input-evdev!
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
PanzerKanzler
Guru
Guru


Joined: 04 Dec 2005
Posts: 371
Location: Belgravia, London

PostPosted: Wed Oct 13, 2010 4:53 pm    Post subject: Reply with quote

genstorm wrote:
Try latest xf86-input-evdev!

Good idea, but alas, it did not help :(
_________________
If you've got nothing nice to say, you're probably not alone...
Back to top
View user's profile Send private message
PanzerKanzler
Guru
Guru


Joined: 04 Dec 2005
Posts: 371
Location: Belgravia, London

PostPosted: Wed Oct 13, 2010 7:05 pm    Post subject: Reply with quote

I have tried various things like
Code:
Section "InputClass"
        Identifier "duplicate-mouse"
        MatchDevicePath "/dev/input/mouse0"
        Option "Ignore" "on"
EndSection
but with no success.

Cone on, surely someone must know how to get one and only one mouse device in Xorg 1.8? Or at least skip redundant devices?
I simply refuse going back to Xorg 1.7 and those cursed .fdi-files for hal.
_________________
If you've got nothing nice to say, you're probably not alone...
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3874
Location: USA

PostPosted: Wed Oct 13, 2010 7:24 pm    Post subject: Reply with quote

What happens if you simply delete /dev/input/mouse0 temporarily? (as in rm /dev/input/mouse0 (or move it to another directory... don't worry, if you're using a ramfs udev it will recreate it))
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
PanzerKanzler
Guru
Guru


Joined: 04 Dec 2005
Posts: 371
Location: Belgravia, London

PostPosted: Wed Oct 13, 2010 7:44 pm    Post subject: Reply with quote

Ah, what a relief! Removing /dev/input/mouse0 did the trick.
So, how do I make this change permanent?
_________________
If you've got nothing nice to say, you're probably not alone...
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2287
Location: Canada

PostPosted: Wed Oct 13, 2010 9:52 pm    Post subject: Reply with quote

PanzerKanzler wrote:
Ah, what a relief! Removing /dev/input/mouse0 did the trick.
So, how do I make this change permanent?


Unmerge xf86-input-mouse ?
Back to top
View user's profile Send private message
PanzerKanzler
Guru
Guru


Joined: 04 Dec 2005
Posts: 371
Location: Belgravia, London

PostPosted: Thu Oct 14, 2010 4:13 pm    Post subject: Reply with quote

dmpogo wrote:
Unmerge xf86-input-mouse ?


And if there is no such package installed?
_________________
If you've got nothing nice to say, you're probably not alone...
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2287
Location: Canada

PostPosted: Fri Oct 15, 2010 12:51 am    Post subject: Reply with quote

PanzerKanzler wrote:
dmpogo wrote:
Unmerge xf86-input-mouse ?


And if there is no such package installed?


compile ps/2 mouse in kernel as a module but do not load it. Keep it as module just in case, but blacklist it so
it is not loaded automatically.

The module is called psmouse, you can see 'cat /proc/modules' if such module exists, if you you can unload it 'rmmod psmouse'
to see if this helps. And then blacklist it.
Back to top
View user's profile Send private message
Mad Merlin
Veteran
Veteran


Joined: 09 May 2005
Posts: 1143

PostPosted: Fri Oct 15, 2010 2:50 am    Post subject: Reply with quote

dmpogo wrote:
PanzerKanzler wrote:
Ah, what a relief! Removing /dev/input/mouse0 did the trick.
So, how do I make this change permanent?


Unmerge xf86-input-mouse ?


On my laptop, which actually has three mice (an external mouse, the trackpad and the nipple), I manually specify synaptics and mouse for the drivers for the mice in xorg.conf, and don't let evdev get merged. This works for me. Once I accidentally merged evdev and then all my mouse actions were automagically doubled (including movements).
_________________
Game! - Where the stick is mightier than the sword!
Back to top
View user's profile Send private message
PanzerKanzler
Guru
Guru


Joined: 04 Dec 2005
Posts: 371
Location: Belgravia, London

PostPosted: Fri Oct 15, 2010 4:39 am    Post subject: Reply with quote

Maybe I should try the legacy drivers again then..
_________________
If you've got nothing nice to say, you're probably not alone...
Back to top
View user's profile Send private message
lefsha
Veteran
Veteran


Joined: 30 Aug 2004
Posts: 1012
Location: Sankt-Petersburg, Russia

PostPosted: Tue Sep 03, 2013 8:23 pm    Post subject: Solution Reply with quote

Disabling in kernel mouse support completely has solved that problem for me.
Now only evdev is responsible for all input devices. Thinking to disable keyboard too,
but not sure yet, whether I have to, cause keyboard works well.

P.S. I was almost convinced, that my mouse is broken. It is not. Something went wrong in last linux
kernels, which made interference between evdev and mouse devices. Terrible.
_________________
Lefsha
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum