Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Blocked Packages, gentoolkit and portpeek
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
BakaO
n00b
n00b


Joined: 27 Sep 2003
Posts: 69

PostPosted: Sat Sep 11, 2010 12:13 pm    Post subject: [SOLVED] Blocked Packages, gentoolkit and portpeek Reply with quote

Hello,

I am really sorry to bother you all, but I have an emerge blocking problem :


Quote:
....
[blocks B ] >app-portage/gentoolkit-0.2.4.6.1-r1 (">app-portage/gentoolkit-0.2.4.6.1-r1" is blocking app-portage/portpeek-1.5.9.0-r1)

Total: 138 packages (130 upgrades, 3 new, 5 in new slots, 1 uninstall), Size of downloads: 553,913 kB
Conflict: 2 blocks (1 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(app-portage/gentoolkit-0.3.0_rc10-r1, installed) pulled in by
app-portage/gentoolkit required by @world

(app-portage/portpeek-1.5.9.0-r1, ebuild scheduled for merge) pulled in by
app-portage/portpeek required by @world



How can I solve this problem ?

Thanks.


Last edited by BakaO on Sat Sep 11, 2010 8:29 pm; edited 1 time in total
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5263

PostPosted: Sat Sep 11, 2010 1:40 pm    Post subject: Reply with quote

emerge -pv --nodeps portpeek

That's an odd block. Any of the maintainers want to tell us why it's there?

After emerging this, I get this error regardless of what I do:

Code:

Traceback (most recent call last):
  File "/usr/bin/portpeek", line 784, in <module>
    get_recursive_info(USER_CONFIG_PATH + "/package.keywords")
  File "/usr/bin/portpeek", line 287, in get_recursive_info
    get_recursive_info(filename+os.path.sep+file_name)
  File "/usr/bin/portpeek", line 289, in get_recursive_info
    get_info(filename)
  File "/usr/bin/portpeek", line 310, in get_info
    diffs_found = parse_line(line, filename)
  File "/usr/bin/portpeek", line 165, in parse_line
    pkgs = gentoolkit.helpers.find_packages(fields[0], True)
AttributeError: 'module' object has no attribute 'find_packages'

_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
BakaO
n00b
n00b


Joined: 27 Sep 2003
Posts: 69

PostPosted: Sat Sep 11, 2010 2:03 pm    Post subject: Reply with quote

Thanks ! everything solved now.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5263

PostPosted: Sat Sep 11, 2010 3:45 pm    Post subject: Reply with quote

Did you get portpeek to run?
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
BakaO
n00b
n00b


Joined: 27 Sep 2003
Posts: 69

PostPosted: Sat Sep 11, 2010 3:48 pm    Post subject: Reply with quote

Yes, I think.

Code:
# portpeek

Usage: portpeek command
       portpeek [ options ] command
       portpeek [-c] [akmu]
       portpeek [-r] [akmu]
       portpeek [-f] [akmu]
       portpeek [-F] [akmu]
 command  can be
 -a, --all            - show all matches
 -k, --keyword        - show matches from package.keyword only
 -m, --mask        - show matches from package.mask only
 -u, --unmask        - show matched from package.unmask only
 -f, --fix            - will remove the stabled packages without asking for confirmation
 -h, --help            - display this message
 -d, --debug            - display more verbose output for debugging
 -V, --version        - display version info
options are
 -c, --changes-only    - show all matches that have upgrade option, use with < k | u | m | a >
 -r, --removable-only    - show all matches that can be removed from package files, use with < k | u | m | a >

Back to top
View user's profile Send private message
BakaO
n00b
n00b


Joined: 27 Sep 2003
Posts: 69

PostPosted: Sat Sep 11, 2010 3:49 pm    Post subject: Reply with quote

Maybe not :

Code:
portpeek -a

package.keywords:

package.unmask:

package.mask:
Could not find file /etc/portage/package.mask
No ebuild options found.

package.use:
Traceback (most recent call last):
  File "/usr/bin/portpeek", line 820, in <module>
    get_recursive_info(USER_CONFIG_PATH + "/package.use")
  File "/usr/bin/portpeek", line 289, in get_recursive_info
    get_info(filename)
  File "/usr/bin/portpeek", line 313, in get_info
    diffs_found = parse_package_use(line,filename)
  File "/usr/bin/portpeek", line 354, in parse_package_use
    pkgs = gentoolkit.helpers.find_packages(check_pkg, True)
AttributeError: 'module' object has no attribute 'find_packages'
Back to top
View user's profile Send private message
skellr
l33t
l33t


Joined: 18 Jun 2005
Posts: 706
Location: The Village

PostPosted: Sat Sep 11, 2010 4:27 pm    Post subject: Reply with quote

gentoolkit underwent a rewrite so newer versions are different enough to cause some problems.

I'd try masking higher versions of gentoolkit to prevent it from updating and hope nothing else wants a higher version than what portpeek wants.(!>app-portage/gentoolkit-0.2.4.6.1-r1) I't looks like the masked versions of portpeek can use the newer gentoolkit but also want a masked version of portage.... :?
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1385
Location: Bardowick, Germany

PostPosted: Mon Sep 20, 2010 6:53 am    Post subject: Reply with quote

Even with the right version of gentoolkit I get the Traceback. And the Traceback was the reason for me to update portpeek in the first place. :(
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
mpagano
Developer
Developer


Joined: 27 Apr 2004
Posts: 167
Location: New Jersey

PostPosted: Tue Oct 05, 2010 4:18 pm    Post subject: Reply with quote

What version of portpeek and gentoolkit are you using (trying to use)?
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1385
Location: Bardowick, Germany

PostPosted: Tue Oct 05, 2010 4:46 pm    Post subject: Reply with quote

Code:
sed-notebook linux # eix -c -I "(gentoolkit|portpeek)"
[I] app-portage/gentoolkit (0.2.4.6.1-r1@15.09.2010): Collection of administration scripts for Gentoo
[I] app-portage/portpeek (1.5.9.3@15.09.2010): A helper program for maintaining the package.keyword and package.unmask files
So the latest stable version of gentoolkit, and the latest not-hard-masked version of portpeek.

As the error I get is different from the one above, I post the output here:
Code:
sed-notebook linux # portpeek -arf

package.keywords:
Traceback (most recent call last):
  File "/usr/bin/portpeek", line 847, in <module>
    get_recursive_info(USER_CONFIG_PATH + "/package.keywords")
  File "/usr/bin/portpeek", line 301, in get_recursive_info
    get_info(filename)
  File "/usr/bin/portpeek", line 322, in get_info
    diffs_found = parse_line(line, filename)
  File "/usr/bin/portpeek", line 201, in parse_line
    stable = check_for_stable_release(current_package)
  File "/usr/bin/portpeek", line 484, in check_for_stable_release
    if not is_pkg_package_masked(pkg.get_cpv()):
  File "/usr/bin/portpeek", line 452, in is_pkg_package_masked
    if settings.pmaskdict.has_key(mycp):
AttributeError: 'ExtendedAtomDict' object has no attribute 'has_key'
I must admit, that I haven't tried to mask the the current version of gentoolkit, thus using the previous one, yet.
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2540
Location: Richmond, BC, Canada

PostPosted: Tue Oct 05, 2010 9:06 pm    Post subject: Reply with quote

To me that error sounds like it is due to changes in portage. I don't know portpeek code, but that settings.pmaskdict... error sounds like a portage call.

What version of portage are you using? The latest versions of 2.8 are more portage-2.2 code based. Portage-2.1.9 series is completely portage-2.2 based with some things disabled.

The ebuilds may need updating to limit the portage versions they work with.
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1385
Location: Bardowick, Germany

PostPosted: Wed Oct 06, 2010 7:19 am    Post subject: Reply with quote

this might be the case, because it is portage-2.1.9.13

... I'll try something ...

Yes, that's it! Downgrading to portage-2.1.8.3 made it work again. Thanks a lot! :D
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2540
Location: Richmond, BC, Canada

PostPosted: Wed Oct 06, 2010 7:45 am    Post subject: Reply with quote

another option, although a little more difficult is to unmask one of the newer versions that are masked waiting for portage-2.2 to be unmasked. You will also have to edit the dependencies and change the version to include the 2.1.9 series, and put in your modified ebuild in your local overlay. That is until the ebuilds have been changed to reflect the new portage dep requirements.
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
mpagano
Developer
Developer


Joined: 27 Apr 2004
Posts: 167
Location: New Jersey

PostPosted: Wed Oct 06, 2010 12:56 pm    Post subject: Reply with quote

Always feel free to file a bug or email or hit me up on IRC. I am the author of portpeek and if you see an error, then someone else will also. :)


So, I have unmasked portpeek-1.9.48 and it can be safely used with portage 2.1.9.13. (Looks good from my testing).

You will also have to unmask the exact version of gentoolkit 0.3.0_rc9.

Portpeek deals with three things.

1. Python (2 very different versions)
2. portage (3 versions, 2.1.8.*, 2,1.9.* and 2.2.*) yes, different portpeek code for each version
3. gentoolkit (technically two versions, but there are differences between the 0.3.0_rcX versions that cause code breakage)


It's been a challenge figuring out all the combos that work, so I appreciate any bug reports.

Thanks for using portpeek.

Editing for grammar
Back to top
View user's profile Send private message
mpagano
Developer
Developer


Joined: 27 Apr 2004
Posts: 167
Location: New Jersey

PostPosted: Wed Oct 06, 2010 1:25 pm    Post subject: Reply with quote

It looks like you will still need to add portpeek-1.9.48 to package.unmask.

Portage thinks it's live because the sources comes from git. (Even though I tag the releases).

I will file a bug with portage.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5263

PostPosted: Wed Oct 06, 2010 1:45 pm    Post subject: Reply with quote

I just unmasked and emerged 2.0.7. 8)
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.org
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2540
Location: Richmond, BC, Canada

PostPosted: Wed Oct 06, 2010 2:00 pm    Post subject: Reply with quote

2.0.7 should work with portage-2.1.9 and portage-2.2, and of course you need the newest gentoolkit.
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum