Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] udev problem on alpha w/ kernel 2.6.35
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
dogshu
Apprentice
Apprentice


Joined: 22 Jun 2003
Posts: 168
Location: New Haven, CT, USA

PostPosted: Mon Sep 13, 2010 3:16 pm    Post subject: [SOLVED] udev problem on alpha w/ kernel 2.6.35 Reply with quote

Hi all,

I just upgraded my alphastation DS10 to sys-kernel/gentoo-sources-2.6.35-r5. When I rebooted, I got the following error when starting udev:

udevd[130]: inotify_init failed: Function not implemented
error initializing inotify
udevd[130]: error initializing inotify
No /sbin/udevd running; none killed.

After that fsck fails to find my root partition because /dev/ hasn't been populated.

I've checked and I do have all of the FSNOTIFY, DNOTIFY, and INOTIFY set to "y" in my kernel config. Any ideas what I'm doing wrong?


Last edited by dogshu on Wed Oct 13, 2010 8:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
richard.scott
Veteran
Veteran


Joined: 19 May 2003
Posts: 1496
Location: Oxfordshire, UK

PostPosted: Tue Sep 14, 2010 10:03 am    Post subject: Reply with quote

Perhaps you've not disabled CONFIG_SYSFS_DEPRECATED_V2?
Back to top
View user's profile Send private message
dogshu
Apprentice
Apprentice


Joined: 22 Jun 2003
Posts: 168
Location: New Haven, CT, USA

PostPosted: Tue Sep 14, 2010 3:55 pm    Post subject: Reply with quote

nope, CONFIG_SYSFS_DEPRECATED_V2 is not set. Are you running sys-kernel/gentoo-sources-2.6.35-r5 on alpha without problems?
Back to top
View user's profile Send private message
armin76
Developer
Developer


Joined: 24 Apr 2006
Posts: 174

PostPosted: Sun Oct 10, 2010 8:18 pm    Post subject: Reply with quote

Make sure you have =linux-headers-2.6.33 AND =glibc-2.11.2. If you have those, rebuild glibc. Should work after that.
Back to top
View user's profile Send private message
dogshu
Apprentice
Apprentice


Joined: 22 Jun 2003
Posts: 168
Location: New Haven, CT, USA

PostPosted: Wed Oct 13, 2010 8:08 pm    Post subject: Reply with quote

thanks, that fixed it!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum