Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 5)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 17, 18, 19, 20, 21  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
duryodhana
n00b
n00b


Joined: 13 Jan 2008
Posts: 65

PostPosted: Mon Jul 11, 2011 3:46 pm    Post subject: Reply with quote

Herring42 wrote:
lmarcini wrote:
EDIT : tarballs are available now!


Yay!

Compiling now :-)

EDIT: All done :-D


Are kde-pim tarballs available?
Back to top
View user's profile Send private message
Herring42
Guru
Guru


Joined: 10 Mar 2004
Posts: 372
Location: Buckinghamshire

PostPosted: Mon Jul 11, 2011 3:54 pm    Post subject: Reply with quote

duryodhana wrote:
Are kde-pim tarballs available?


Yes.

Running Kmail 2.1.96
_________________
"The problem with quotes on the internet is that it is difficult
to determine whether or not they are genuine." -- Abraham Lincoln
Back to top
View user's profile Send private message
duryodhana
n00b
n00b


Joined: 13 Jan 2008
Posts: 65

PostPosted: Mon Jul 11, 2011 4:09 pm    Post subject: Reply with quote

Herring42 wrote:
duryodhana wrote:
Are kde-pim tarballs available?


Yes.

Running Kmail 2.1.96



Did you mean kmail-4.6.95 ?
Back to top
View user's profile Send private message
Herring42
Guru
Guru


Joined: 10 Mar 2004
Posts: 372
Location: Buckinghamshire

PostPosted: Mon Jul 11, 2011 4:55 pm    Post subject: Reply with quote

duryodhana wrote:
Herring42 wrote:
duryodhana wrote:
Are kde-pim tarballs available?


Yes.

Running Kmail 2.1.96



Did you mean kmail-4.6.95 ?


Sort of. KDEPIM has its own versioning that is not in step with KDE, the tar files are indeed as follows:
Code:

path :: ~ %% ls /usr/portage/distfiles/kdepim*95* -l
-rw-rw-r-- 1 portage portage 15590443 Jul 11 11:21 /usr/portage/distfiles/kdepim-4.6.95.tar.bz2
-rw-rw-r-- 1 portage portage  3209123 Jul 11 11:21 /usr/portage/distfiles/kdepimlibs-4.6.95.tar.bz2
-rw-rw-r-- 1 portage portage  1199085 Jul 11 11:21 /usr/portage/distfiles/kdepim-runtime-4.6.95.tar.bz2

_________________
"The problem with quotes on the internet is that it is difficult
to determine whether or not they are genuine." -- Abraham Lincoln
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2467
Location: Austria

PostPosted: Sun Jul 24, 2011 3:12 pm    Post subject: Reply with quote

[annoyed]

So I updated kde-4.7.49.9999 once more yesterday.

Am I the only one noticing the same bug ever since 4.1, where the dynamic-length system tray breaks panel size? Trailing widgets get pushed out of the panel even though there would be plenty of maximum panel length available.

[/annoyed]

Best visible when the task manager resides on a different panel, with the system tray placed between several other widgets/icons on a centered panel.

Funnily, it seems the panel length even goes below the minimum size set when locked. Unlocking widgets resizes the centered panel to the size it should have in the first place, re-locking cuts widgets off again.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2467
Location: Austria

PostPosted: Sun Jul 31, 2011 8:34 am    Post subject: Reply with quote

Ok, so apparently I am the only one there. ;)

Another issue is kmail for some weeks now. It simply won't build, failing with

Code:
[ 93%] Building CXX object kmail/CMakeFiles/kmailprivate.dir/kmmainwidget.o                                       
[ 93%] Building CXX object kmail/CMakeFiles/kmailprivate.dir/aboutdata.o                                         
[ 93%] Building CXX object kmail/CMakeFiles/kmailprivate.dir/mailserviceimpl.o                                   
[ 93%] Building CXX object kmail/CMakeFiles/kmailprivate.dir/kmcomposereditor.o                                   
/var/tmp/portage/kde-base/kmail-4.7.49.9999/work/kmail-4.7.49.9999/kmail/kmmainwidget.cpp: In member function ‘virtual void KMMainWidget::readConfig()’:
/var/tmp/portage/kde-base/kmail-4.7.49.9999/work/kmail-4.7.49.9999/kmail/kmmainwidget.cpp:836:35: error: ‘class Akonadi::EntityListView’ has no member named ‘setDropActionMenuEnabled’
/var/tmp/portage/kde-base/kmail-4.7.49.9999/work/kmail-4.7.49.9999/kmail/kmmainwidget.cpp: In member function ‘void KMMainWidget::createWidgets()’:
/var/tmp/portage/kde-base/kmail-4.7.49.9999/work/kmail-4.7.49.9999/kmail/kmmainwidget.cpp:1043:31: error: ‘class Akonadi::EntityListView’ has no member named ‘setDropActionMenuEnabled’
[ 93%] Building CXX object kmail/CMakeFiles/kmailprivate.dir/composer.o
make[2]: *** [kmail/CMakeFiles/kmailprivate.dir/kmmainwidget.o] Error 1                                           
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [kmail/CMakeFiles/kmailprivate.dir/all] Error 2
make: *** [all] Error 2

Regardless of akonadi-server-9999 or 1.6.0, or what earlier versions am I supposed to choose?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Lustmored
Apprentice
Apprentice


Joined: 28 May 2010
Posts: 204
Location: Poland

PostPosted: Sun Jul 31, 2011 10:02 am    Post subject: Reply with quote

For me rocs-4.7.0 keeps failing:

Code:
[ 81%] Building CXX object src/CMakeFiles/rocs.dir/Interface/GraphVisualEditor.o                                         
In file included from /usr/include/boost/numeric/conversion/converter.hpp:14:0,                                         
                 from /usr/include/boost/numeric/conversion/cast.hpp:32,
                 from /usr/include/boost/lexical_cast.hpp:31,
                 from /usr/include/boost/math/constants/constants.hpp:15,
[ 83%] Building CXX object src/CMakeFiles/rocs.dir/Interface/GraphPropertiesWidget.o
[ 84%] Building CXX object src/CMakeFiles/rocs.dir/Interface/GraphLayers.o                                               
                 from /usr/include/boost/graph/topology.hpp:17,                                                         
                 from /var/tmp/paludis/kde-base-rocs-4.7.0/work/rocs-4.7.0/src/Plugins/GenerateGraph/generategraphwidget.h:25,                                                                                                                   
                 from /var/tmp/paludis/kde-base-rocs-4.7.0/work/rocs-4.7.0/src/Plugins/GenerateGraph/generategraphtoolsplugin.cpp:20:                                                                                                             
/usr/include/boost/numeric/conversion/converter_policies.hpp: In member function 'void boost::numeric::def_overflow_handler::operator()(boost::numeric::range_check_result)':                                                                     
/usr/include/boost/numeric/conversion/converter_policies.hpp:162:31: error: exception handling disabled, use -fexceptions to enable                                                                                                               
make[2]: *** [src/Plugins/GenerateGraph/CMakeFiles/rocs_generategraphplugin.dir/generategraphtoolsplugin.o] Error 1     
make[1]: *** [src/Plugins/GenerateGraph/CMakeFiles/rocs_generategraphplugin.dir/all] Error 2                             
make[1]: *** Waiting for unfinished jobs....                                                                             
[ 85%] Building CXX object src/CMakeFiles/rocs.dir/Interface/TabWidget.o                                                 
[ 86%] Building CXX object src/CMakeFiles/rocs.dir/Interface/CodeEditor.o                                               
[ 87%] Building CXX object src/CMakeFiles/rocs.dir/Interface/NodePropertiesWidget.o                                     
[ 89%] Building CXX object src/Plugins/TransformEdges/CMakeFiles/rocs_transformedgesplugin.dir/transformedgeswidget.o   
[ 90%] Building CXX object src/CMakeFiles/rocs.dir/Interface/edgepropertieswidget.o                                     
[ 91%] Building CXX object src/CMakeFiles/rocs.dir/Interface/ConfigureDefaultProperties.o                               
[ 92%] Building CXX object src/CMakeFiles/rocs.dir/Models/model_GraphDocument.o                                         
[ 93%] Building CXX object src/CMakeFiles/rocs.dir/Models/model_GraphLayers.o                                           
[ 95%] Building CXX object src/CMakeFiles/rocs.dir/Models/model_GraphProperties.o                                       
[ 96%] Building CXX object src/CMakeFiles/rocs.dir/Interface/PossibleIncludes.o                                         
[ 97%] Building CXX object src/CMakeFiles/rocs.dir/Scripts/IncludeManager.o                                             
[ 98%] Building CXX object src/CMakeFiles/rocs.dir/settings.o                                                           
Linking CXX executable rocs                                                                                             
In file included from /usr/include/boost/numeric/conversion/converter.hpp:14:0,                                         
                 from /usr/include/boost/numeric/conversion/cast.hpp:32,                                                 
                 from /usr/include/boost/lexical_cast.hpp:31,                                                           
                 from /usr/include/boost/math/constants/constants.hpp:15,                                               
                 from /usr/include/boost/graph/topology.hpp:17,                                                         
                 from /var/tmp/paludis/kde-base-rocs-4.7.0/work/rocs-4.7.0/src/Plugins/AssignValues/assignvalueswidget.h:25,                                                                                                                     
                 from /var/tmp/paludis/kde-base-rocs-4.7.0/work/rocs-4.7.0/src/Plugins/AssignValues/assignvalueswidget.cpp:19:                                                                                                                   
/usr/include/boost/numeric/conversion/converter_policies.hpp: In member function 'void boost::numeric::def_overflow_handler::operator()(boost::numeric::range_check_result)':                                                                     
/usr/include/boost/numeric/conversion/converter_policies.hpp:162:31: error: exception handling disabled, use -fexceptions to enable                                                                                                               
make[2]: *** [src/Plugins/AssignValues/CMakeFiles/rocs_assignvaluesplugin.dir/assignvalueswidget.o] Error 1             
make[2]: *** Waiting for unfinished jobs....                                                                             
In file included from /usr/include/boost/numeric/conversion/converter.hpp:14:0,                                         
                 from /usr/include/boost/numeric/conversion/cast.hpp:32,                                                 
                 from /usr/include/boost/lexical_cast.hpp:31,                                                           
                 from /usr/include/boost/math/constants/constants.hpp:15,                                               
                 from /usr/include/boost/graph/topology.hpp:17,                                                         
                 from /var/tmp/paludis/kde-base-rocs-4.7.0/work/rocs-4.7.0/src/Plugins/AssignValues/assignvalueswidget.h:25,                                                                                                                     
                 from /var/tmp/paludis/kde-base-rocs-4.7.0/work/rocs-4.7.0/src/Plugins/AssignValues/assignvaluestoolsplugin.cpp:20:                                                                                                               
/usr/include/boost/numeric/conversion/converter_policies.hpp: In member function 'void boost::numeric::def_overflow_handler::operator()(boost::numeric::range_check_result)':                                                                     
/usr/include/boost/numeric/conversion/converter_policies.hpp:162:31: error: exception handling disabled, use -fexceptions to enable                                                                                                               
make[2]: *** [src/Plugins/AssignValues/CMakeFiles/rocs_assignvaluesplugin.dir/assignvaluestoolsplugin.o] Error 1         
make[1]: *** [src/Plugins/AssignValues/CMakeFiles/rocs_assignvaluesplugin.dir/all] Error 2                               
In file included from /usr/include/boost/numeric/conversion/converter.hpp:14:0,                                         
                 from /usr/include/boost/numeric/conversion/cast.hpp:32,                                                 
                 from /usr/include/boost/lexical_cast.hpp:31,                                                           
                 from /usr/include/boost/math/constants/constants.hpp:15,                                               
                 from /usr/include/boost/graph/topology.hpp:17,                                                         
                 from /var/tmp/paludis/kde-base-rocs-4.7.0/work/rocs-4.7.0/src/Plugins/TransformEdges/transformedgeswidget.h:25,                                                                                                                 
                 from /var/tmp/paludis/kde-base-rocs-4.7.0/work/rocs-4.7.0/src/Plugins/TransformEdges/transformedgestoolsplugin.cpp:20:                                                                                                           
/usr/include/boost/numeric/conversion/converter_policies.hpp: In member function 'void boost::numeric::def_overflow_handler::operator()(boost::numeric::range_check_result)':                                                                     
/usr/include/boost/numeric/conversion/converter_policies.hpp:162:31: error: exception handling disabled, use -fexceptions to enable                                                                                                               
make[2]: *** [src/Plugins/TransformEdges/CMakeFiles/rocs_transformedgesplugin.dir/transformedgestoolsplugin.o] Error 1   
make[2]: *** Waiting for unfinished jobs....                                                                             
[ 98%] Built target rocs                                                                                                 
In file included from /usr/include/boost/numeric/conversion/converter.hpp:14:0,
                 from /usr/include/boost/numeric/conversion/cast.hpp:32,
                 from /usr/include/boost/lexical_cast.hpp:31,
                 from /usr/include/boost/math/constants/constants.hpp:15,
                 from /usr/include/boost/graph/topology.hpp:17,
                 from /var/tmp/paludis/kde-base-rocs-4.7.0/work/rocs-4.7.0/src/Plugins/TransformEdges/transformedgeswidget.h:25,
                 from /var/tmp/paludis/kde-base-rocs-4.7.0/work/rocs-4.7.0/src/Plugins/TransformEdges/transformedgeswidget.cpp:19:
/usr/include/boost/numeric/conversion/converter_policies.hpp: In member function 'void boost::numeric::def_overflow_handler::operator()(boost::numeric::range_check_result)':
/usr/include/boost/numeric/conversion/converter_policies.hpp:162:31: error: exception handling disabled, use -fexceptions to enable
make[2]: *** [src/Plugins/TransformEdges/CMakeFiles/rocs_transformedgesplugin.dir/transformedgeswidget.o] Error 1
make[1]: *** [src/Plugins/TransformEdges/CMakeFiles/rocs_transformedgesplugin.dir/all] Error 2
make: *** [all] Error 2

!!! ERROR in kde-base/rocs-4.7.0::gentoo:
!!! In /usr/libexec/paludis/utils/emake at line 30
!!! emake returned error 2

!!! Call stack:
!!!    * paludis_die_or_error_func (/usr/libexec/paludis/die_functions.bash:67)
!!!    * main (/usr/libexec/paludis/utils/emake:30)
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2467
Location: Austria

PostPosted: Mon Aug 15, 2011 12:11 pm    Post subject: Reply with quote

Update:

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2467
Location: Austria

PostPosted: Sun Sep 18, 2011 8:04 am    Post subject: Reply with quote

Just got that minor issue, even though it continues:
Code:
>>> Emerging (1 of 15) kde-base/kdepim-icons-4.7.49.9999 from kde
>>> Unpacking source...
fatal: ambiguous argument 'KDE/4.7': unknown revision or path not in the working tree.
Use '--' to separate paths from revisions
remote: Counting objects: 220, done.


Btw interestingly, there won't be a kdelibs-4.8 according to http://git.overlays.gentoo.org/gitweb/?p=proj/kde.git;a=commitdiff;h=3437ea8cedc67c2c962ba7922a9c1176d6fdacde

Particularly notice:
Code:
+       # There will be no kdelibs 4.8+ (the next kdelibs will be a non-BC 5.0, apparently)

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
cruzki123
Apprentice
Apprentice


Joined: 16 May 2008
Posts: 233

PostPosted: Thu Nov 24, 2011 9:22 am    Post subject: Reply with quote

Have anyone managed to compile kde 4.7.80 that have been released yesterday?

After remanifest kdelibs I have compiled but it shows in helps/about kde as 4.7.3 WTF?!!!!!!!!!!!

More interesting, firs of all kdelibs fails because the manifest BUT portage continue compiling packages of kde-4.7.80 as kdepimlibs, kwrite and the like!!!!!!!!! O_O

Can be the tarballs complete broken or it is just a naming issue?

EDIT:

I can confirm is a naming issue (dolphin have the pretty cool new features ;) ).
On the other hand, have anyone managed to compile libtaskmanager? Here it was failing with file missing error:

/home/portage/portage/kde-base/libtaskmanager-4.7.80/work/libtaskmanager-4.7.80/libs/taskmanager/taskitem.cpp:35:45: error fatal: ksysguard/processcore/processes.h: Don't exist file or directory

any ideas?
Back to top
View user's profile Send private message
kinbot
n00b
n00b


Joined: 25 Nov 2011
Posts: 1

PostPosted: Fri Nov 25, 2011 10:31 am    Post subject: Reply with quote

cruzki123 wrote:

/home/portage/portage/kde-base/libtaskmanager-4.7.80/work/libtaskmanager-4.7.80/libs/taskmanager/taskitem.cpp:35:45: error fatal: ksysguard/processcore/processes.h: Don't exist file or directory

any ideas?


Code:
sudo ln -s /usr/include/ksysguard/ /usr/include/ksysguard/processcore
Back to top
View user's profile Send private message
Tarch
n00b
n00b


Joined: 27 Apr 2005
Posts: 42

PostPosted: Fri Nov 25, 2011 4:06 pm    Post subject: Reply with quote

cruzki123 wrote:

/home/portage/portage/kde-base/libtaskmanager-4.7.80/work/libtaskmanager-4.7.80/libs/taskmanager/taskitem.cpp:35:45: error fatal: ksysguard/processcore/processes.h: Don't exist file or directory

any ideas?

Alternatively you can drop this little patch:
Code:

diff -urN libtaskmanager-4.7.80/libs/taskmanager/taskitem.cpp libtaskmanager-4.7.80.ok/libs/taskmanager/taskitem.cpp
--- libtaskmanager-4.7.80/libs/taskmanager/taskitem.cpp 2011-11-22 21:54:07.000000000 +0100
+++ libtaskmanager-4.7.80.ok/libs/taskmanager/taskitem.cpp      2011-11-23 19:21:33.723630648 +0100
@@ -32,8 +32,8 @@
 #include <KService>
 #include <KServiceTypeTrader>
 #include <KStandardDirs>
-#include <ksysguard/processcore/processes.h>
-#include <ksysguard/processcore/process.h>
+#include <ksysguard/processes.h>
+#include <ksysguard/process.h>
 
 #include <QtCore/QFile>
 #include <QtCore/QTimer>


in
Code:
/etc/portage/patches/kde-base/libtaskmanager-4.7.80/libtaskmanager-processcore-include.patch

the actual name of the patch is not important (it probably needs to have the .patch extension).

Hope it helps.

Bye.
Tarch
Back to top
View user's profile Send private message
energyman76b
Advocate
Advocate


Joined: 26 Mar 2003
Posts: 2031
Location: Germany

PostPosted: Fri Nov 25, 2011 10:19 pm    Post subject: Reply with quote

did you guys get kmail, kwrite and plasma-addons to install - if yes why? and how?
_________________
AidanJT wrote:

Libertardian denial of reality is wholly unimpressive and unconvincing, and simply serves to demonstrate what a bunch of delusional fools they all are.

Satan's got perfectly toned abs and rocks a c-cup.
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2467
Location: Austria

PostPosted: Sun Dec 04, 2011 6:37 pm    Post subject: Reply with quote

Anyone having an idea why kdeplasma-addons-4.7.49.9999 fails here:
Code:
Linking CXX shared library ../../lib/libplasmaweather.so                                                                                     
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.2/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lKDE4Workspace__weather_ion                       
collect2: ld returned 1 exit status
make[2]: *** [lib/libplasmaweather.so.4.7.0] Error 1
make[1]: *** [libs/plasmaweather/CMakeFiles/plasmaweather.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....

?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Lustmored
Apprentice
Apprentice


Joined: 28 May 2010
Posts: 204
Location: Poland

PostPosted: Sun Dec 04, 2011 11:26 pm    Post subject: Reply with quote

kdeplasma-apps or something similar may be missing?
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2467
Location: Austria

PostPosted: Mon Dec 05, 2011 7:30 am    Post subject: Reply with quote

Nope, everything is there and was also rebuilt before. Hmmm
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Stefano Crocco
Apprentice
Apprentice


Joined: 28 Sep 2006
Posts: 151

PostPosted: Mon Dec 05, 2011 1:45 pm    Post subject: Reply with quote

Since I installed kmail 4.7.80, I'm getting a strange issue: multi-part messages aren't recognized as such, but are treated as plain text messages. Here's an example snippet of such a mail:
Code:

This is a multi-part message in MIME format.

------=_NextPart_000_0007_01CCB1EB.77349F30
Content-Type: multipart/alternative;
        boundary="----=_NextPart_001_0008_01CCB1EB.773625D0"


------=_NextPart_001_0008_01CCB1EB.773625D0
Content-Type: text/plain;
        charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

Ciao

Enabling the display of the message structure displays a single plain text message.

The same issue happens with attachments: they're included in the text of the mail, but there's no way to download or open them.

All of this only happens with messages downloaded with the beta version of kmail. Those downloaded with kmail 4.7.3 are still treated correctly.

Is anyone else experiencing this problem? Should I report it as a bug?
_________________
Stefano
Back to top
View user's profile Send private message
katfish
Tux's lil' helper
Tux's lil' helper


Joined: 14 Nov 2011
Posts: 108

PostPosted: Mon Dec 05, 2011 2:47 pm    Post subject: Reply with quote

Since Saturday, 4.90 is pulled in for each kde4 package here.
I checked my keywords and updated it to >=*-4.7.50 (was ~4.7.49* bevor) but that didn't changed anything.

The most of the 4.90 tarballs aren't on any mirror. Whats going wrong here?
Code:
[ebuild     U #] kde-base/kcolorchooser-4.7.90 [4.7.49.9999] USE="(-aqua) -debug (-kdeenablefinal)" 5 kB [1]
[ebuild     U #] kde-base/kmix-4.7.90 [4.7.49.9999] USE="alsa handbook pulseaudio (-aqua) -debug (-kdeenablefinal)" 0 kB [1]
[ebuild     U #] kde-base/kdenetwork-filesharing-4.7.90 [4.7.49.9999] USE="(-aqua) -debug (-kdeenablefinal)" 0 kB [1]
[ebuild     U #] kde-base/kdebase-cursors-4.7.90 [4.7.49.9999] USE="(-aqua) (-kdeenablefinal)" 0 kB [1]
[ebuild     U #] kde-base/smokekde-4.7.90 [4.7.49.9999] USE="kate okular semantic-desktop -akonadi (-aqua) -attica -debug (-kdeenablefinal)" 37 kB [1]                                                                                                                 
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1560
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Mon Dec 05, 2011 4:02 pm    Post subject: Reply with quote

katfish wrote:
Since Saturday, 4.90 is pulled in for each kde4 package here.
I checked my keywords and updated it to >=*-4.7.50 (was ~4.7.49* bevor) but that didn't changed anything.

If you don't want beta2 yet you'll have to add the 4.8 mask.
Code:

 ln -s /usr/local/portage/layman/kde/Documentation/package.mask/kde-4.8 /etc/portage/package.mask/

I poked around a little and wasn't sure what changed since beta1 that made beta2 unmasked, overlay updates and ebuilds seem the same so it's probably eclass related. i guess.

Also the schedule says beta 2 is out on the 7th so no public tarballs till then.
_________________
#gentoo-kde on freenode
Back to top
View user's profile Send private message
katfish
Tux's lil' helper
Tux's lil' helper


Joined: 14 Nov 2011
Posts: 108

PostPosted: Mon Dec 05, 2011 4:52 pm    Post subject: Reply with quote

I understand my issue now. Thx ;)

Going to link the package mask file now.
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2467
Location: Austria

PostPosted: Sun Dec 11, 2011 11:02 am    Post subject: Reply with quote

I decided to not having to care about kdeplasma-addons-4.7.49.9999 anymore by updating to Qt-4.8.9999 and KDE 4.7.90 (well, my own idea of useful packages). And what a sound upgrade that was! Everything built fine except qt-assistant (not so important, lucky me) and also runs well.

EDIT: There IS of course the occasional hiccup when trying to change wallpapers... an old tradition with new releases it seems :lol:
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2467
Location: Austria

PostPosted: Thu Dec 22, 2011 9:56 pm    Post subject: Reply with quote

4.8 RC1 released today and kde overlay already revbumped moments ago (only ksecrets-4.7.95 is currently missing but can be easily created using the 9999 ebuild).

EDIT: kwrite failed:
Code:
[  0%] Built target kdeinit_kwrite_automoc
warning: failed to load external entity "../kate/part.docbook"
index.docbook:98: parser error : Failure to process entity part-chapter
&part-chapter;
              ^
index.docbook:98: parser error : Entity 'part-chapter' not defined
&part-chapter;
              ^
make[2]: *** [doc/kwrite/index.cache.bz2] Error 1
make[1]: *** [doc/kwrite/CMakeFiles/kwrite-handbook.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....

...but builds with USE="-handbook"

EDIT2: All else built fine. This could turn out to be a pretty smooth release.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Lustmored
Apprentice
Apprentice


Joined: 28 May 2010
Posts: 204
Location: Poland

PostPosted: Fri Dec 23, 2011 2:52 pm    Post subject: Reply with quote

kwrite fails:

Code:
>>> Starting src_compile
>>> Working in BUILD_DIR: "/var/tmp/paludis/kde-base-kwrite-4.7.95/work/kwrite-4.7.95_build"
Scanning dependencies of target kdeinit_kwrite_automoc
Scanning dependencies of target kwrite-handbook                                                                                                               
Generating kwritemain.moc                                                                                                                                     
[  0%] Generating index.cache.bz2                                                                                                                             
make -j20                                                                                                                                                     
warning: failed to load external entity "../kate/part.docbook"                                                                                               
index.docbook:98: parser error : Failure to process entity part-chapter                                                                                       
&part-chapter;                                                                                                                                               
              ^                                                                                                                                               
index.docbook:98: parser error : Entity 'part-chapter' not defined                                                                                           
&part-chapter;                                                                                                                                               
              ^                                                                                                                                               
make[2]: *** [doc/kwrite/index.cache.bz2] Error 1                                                                                                             
make[1]: *** [doc/kwrite/CMakeFiles/kwrite-handbook.dir/all] Error 2                                                                                         
make[1]: *** Waiting for unfinished jobs....                                                                                                                 
Generating moc_kwriteapp.cpp                                                                                                                                 
[  0%] Built target kdeinit_kwrite_automoc                                                                                                                   
make: *** [all] Error 2

!!! ERROR in kde-base/kwrite-4.7.95::kde:
!!! In /usr/libexec/paludis/utils/emake at line 30
!!! emake returned error 2

!!! Call stack:
!!!    * paludis_die_or_error_func (/usr/libexec/paludis/die_functions.bash:67)
!!!    * main (/usr/libexec/paludis/utils/emake:30)

diefunc: making ebuild PID 15393 exit with error
die trap: exiting with error.

Error:
  * In program cave perform install --hooks --managed-output --output-exclusivity with-others =kde-base/kwrite-4.7.95:4::kde --destination installed --replacing =kde-base/kwrite-4.7.90:4::installed --x-of-y 1 of 3:
  * When installing 'kde-base/kwrite-4.7.95:4::kde' replacing { 'kde-base/kwrite-4.7.90:4::installed' }:
  * When running an ebuild command on 'kde-base/kwrite-4.7.95:4::kde':
  * Install failed for 'kde-base/kwrite-4.7.95:4::kde' (paludis::ActionFailedError)


Failed install to / for kde-base/kwrite-4.7.95:4::kde replacing 4.7.90:4::installed
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2467
Location: Austria

PostPosted: Fri Dec 23, 2011 3:48 pm    Post subject: Reply with quote

See post above :lol:
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
gerard82
Advocate
Advocate


Joined: 04 Jan 2004
Posts: 2228
Location: Netherlands

PostPosted: Fri Dec 23, 2011 7:05 pm    Post subject: Reply with quote

Well I just tried 4.7.95.
After solving the ksecrets problem of not being in the unmask file I now have kdepimlibs failing to compile.
I tried several things but none of them work.
What troubles me is that it conks out at different points in the linking process.
Gerard.
_________________
To install Gentoo I use sysrescuecd.Based on Gentoo,has firefox to browse Gentoo docs and mc to browse (and edit) files.
The same disk can be used for 32 and 64 bit installs.
You can follow the Handbook verbatim.
http://www.sysresccd.org/Download
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 17, 18, 19, 20, 21  Next
Page 18 of 21

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum