Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201009-01 ] wxGTK: User-assisted execution of arbitrary code
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1613

PostPosted: Thu Sep 02, 2010 10:26 pm    Post subject: [ GLSA 201009-01 ] wxGTK: User-assisted execution of arbitra Reply with quote

Gentoo Linux Security Advisory

Title: wxGTK: User-assisted execution of arbitrary code (GLSA 201009-01)
Severity: normal
Exploitable: remote
Date: September 02, 2010
Bug(s): #277722
ID: 201009-01

Synopsis


An integer overflow vulnerability in wxGTK might enable remote attackers to
cause the execution of arbitrary code.


Background


wxGTK is the GTK+ version of wxWidgets, a cross-platform C++ GUI
toolkit.


Affected Packages

Package: x11-libs/wxGTK
Vulnerable: < 2.8.10.1-r1
Unaffected: >= 2.6.4.0-r5 < 2.6.4.1
Unaffected: >= 2.8.10.1-r1
Architectures: All supported architectures


Description


wxGTK is prone to an integer overflow error in the wxImage::Create()
function in src/common/image.cpp, possibly leading to a heap-based
buffer overflow.


Impact


A remote attacker might entice a user to open a specially crafted JPEG
file using a program that uses wxGTK, possibly resulting in the remote
execution of arbitrary code with the privileges of the user running the
application.


Workaround


There is no known workaround at this time.


Resolution


All wxGTK 2.6 users should upgrade to an updated version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=x11-libs/wxGTK-2.6.4.0-r5"

All wxGTK 2.8 users should upgrade to an updated version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=x11-libs/wxGTK-2.8.10.1-r1"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since August 9, 2009. It is likely that your system is
already no longer affected by this issue.


References

CVE-2009-2369
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum