Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mesa and gallium
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2173
Location: $TERM

PostPosted: Tue Dec 28, 2010 5:48 am    Post subject: Reply with quote

Apparently, this deserves a call to Linus Trovalds.


Till them I'm stuck with the Debian kernel.
_________________
Buy from companies supporting opensource -- IBM, Dell, HP, Hitachi, Google etc...
Disfavor companies supporting only Win -- Logitech, Epson, Adobe, Autodesk, Pioneer, Kingston, WD, Yahoo, MSI, XFX
My blog


Last edited by dE_logics on Thu Dec 30, 2010 4:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2173
Location: $TERM

PostPosted: Tue Dec 28, 2010 11:38 am    Post subject: Reply with quote

GOT IT!! I didn't set the pcie drivers, only pci, so it was working at half the pace...
_________________
Buy from companies supporting opensource -- IBM, Dell, HP, Hitachi, Google etc...
Disfavor companies supporting only Win -- Logitech, Epson, Adobe, Autodesk, Pioneer, Kingston, WD, Yahoo, MSI, XFX
My blog
Back to top
View user's profile Send private message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2173
Location: $TERM

PostPosted: Wed Dec 29, 2010 3:44 pm    Post subject: Reply with quote

No actually pcie is just one part of the story. After setting it to a yes in my custom kernel config, the FPS did increase but it was not as much as the Debian kernel's config. So I enabled whatever I think will be _good_ (and left obvious stuff like hotplugging) in the processor, Buses (PCI) and ACPI section... that magically improved the FPS. Now I tried to figure out what was it.

So I restored each section (first the processor, then PCI then ACPI) and still there are no performance drops.

And I was configuring the Debian sources. So it's still a mystery.
_________________
Buy from companies supporting opensource -- IBM, Dell, HP, Hitachi, Google etc...
Disfavor companies supporting only Win -- Logitech, Epson, Adobe, Autodesk, Pioneer, Kingston, WD, Yahoo, MSI, XFX
My blog
Back to top
View user's profile Send private message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2173
Location: $TERM

PostPosted: Thu Dec 30, 2010 2:56 pm    Post subject: Reply with quote

SHIT

Another research.

Again, the FPS doubles using the Debian kernel but IF I use the classic mesa implementation, and still more mysteriously it happens ONLY IF kms is enabled.

Unfortunately none of this happens with my custom-made kernel config.
_________________
Buy from companies supporting opensource -- IBM, Dell, HP, Hitachi, Google etc...
Disfavor companies supporting only Win -- Logitech, Epson, Adobe, Autodesk, Pioneer, Kingston, WD, Yahoo, MSI, XFX
My blog
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum