Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mesa and gallium
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2175
Location: $TERM

PostPosted: Thu Sep 02, 2010 5:11 am    Post subject: mesa and gallium Reply with quote

Code:
[ebuild   R   ] media-libs/mesa-7.8.2  USE="nptl xcb -debug (-gallium) -motif -pic (-selinux)" VIDEO_CARDS="radeon -intel -mach64 -mga -none -nouveau -r128 -radeonhd -savage -sis -svga -tdfx -via" 0 kB


So I cant enable the gallium use. After that here, I've heard here that I need to eselect mesa to actually use the gallium drivers, but at the current state of time the module 'mesa' is missing.

Code:
Built-in modules:
  help                      Display a help message
  usage                     Display a usage message
  version                   Display version information

Extra modules:
  bashcomp                  Manage contributed bash-completion scripts
  binutils                  Manage installed versions of sys-devel/binutils
  boost                     Manage boost installations
  editor                    Manage the EDITOR environment variable
  env                       Manage environment variables set in /etc/env.d/
  fontconfig                Manage fontconfig /etc/fonts/conf.d/ symlinks
  java-nsplugin             Manage the Java plugin for Netscape-like Browsers
  java-vm                   Manage the Java system and user VM
  kernel                    Manage the /usr/src/linux symlink
  modules                   A module for querying modules. By default, it lists all available modules
  news                      Read Gentoo ("GLEP 42") news items
  opengl                    Manage the OpenGL implementation used by your system
  pager                     Manage the PAGER environment variable
  profile                   Manage the /etc/make.profile symlink
  python                    Manage Python symlinks
  rc                        Manage /etc/init.d scripts in runlevels
  visual                    Manage the VISUAL environment variable
  wxwidgets                 Manage the system default wxWidgets profile.

_________________
Buy from companies supporting opensource -- IBM, Dell, HP, Hitachi, Google etc...
Disfavor companies supporting only Win -- Logitech, Epson, Adobe, Autodesk, Pioneer, Kingston, WD, Yahoo, MSI, XFX
My blog
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Thu Sep 02, 2010 5:24 am    Post subject: Reply with quote

De_logics as you can se the gallium is (-gallium) .
you need the 9999 via overlay to get it .
Back to top
View user's profile Send private message
Letharion
Veteran
Veteran


Joined: 13 Jun 2005
Posts: 1259
Location: Sweden

PostPosted: Thu Sep 02, 2010 7:31 am    Post subject: Reply with quote

As hedmo pointed out, the gallium use flag is _hard masked_, the reason being that gallium isn't considered very stable.
You can remove the mask like this:
Code:
mkdir -p  /etc/portage/profile
echo "-gallium" >> /etc/portage/profile/use.mask

but remember that it's masked, probably for a good reason.

Edit: Mesa 7.9 is due out this month. I can't say if that's going to affect the masking, but if you're gonna experiment with gallium that might be interesting to you.
Edit 2: A little bit of more info here: http://en.gentoo-wiki.com/wiki/Nouveau
Back to top
View user's profile Send private message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2175
Location: $TERM

PostPosted: Thu Sep 02, 2010 3:37 pm    Post subject: Reply with quote

I'm using ATI.

I didn't know they can mask use. Can I get more info on this thing?
_________________
Buy from companies supporting opensource -- IBM, Dell, HP, Hitachi, Google etc...
Disfavor companies supporting only Win -- Logitech, Epson, Adobe, Autodesk, Pioneer, Kingston, WD, Yahoo, MSI, XFX
My blog
Back to top
View user's profile Send private message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2175
Location: $TERM

PostPosted: Thu Sep 02, 2010 4:12 pm    Post subject: Reply with quote

Lots of activity on the forum relating this... so how do you use this thing?
_________________
Buy from companies supporting opensource -- IBM, Dell, HP, Hitachi, Google etc...
Disfavor companies supporting only Win -- Logitech, Epson, Adobe, Autodesk, Pioneer, Kingston, WD, Yahoo, MSI, XFX
My blog
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4926

PostPosted: Thu Sep 02, 2010 4:21 pm    Post subject: Reply with quote

using r600g from svn and it it stable from the initial commit.
keep in mind that I don't play and I don't use desktop effect.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1085

PostPosted: Thu Sep 02, 2010 6:17 pm    Post subject: Reply with quote

dE_logics wrote:
Lots of activity on the forum relating this... so how do you use this thing?

Since you use ati, you need to add x11 overlay and use the eselect mesa module. Emerge the live mesa ebuild. Then you can switch between classic and gallium by eselect.
Nvidia cards don't have a choice between classic and gallium. Info taken from here
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Thu Sep 02, 2010 6:35 pm    Post subject: Reply with quote

dE_logics

i am on rv350 and as far as i know (can got it wrong) its almost good. but not for me.the windows,and effects
are really good and smooth bot the texture is to bad. if i use the terminal and type something i can not see
it on till i move it.that and games dont work for me but i think its just me so my advice GO FOR IT



my .unmask

>=media-libs/mesa-9999
>=x11-libs/libdrm-9999
>=x11-drivers/xf86-video-ati-9999

and if you have r600 and up i think you can get

x11-drivers/radeon-ucode
Back to top
View user's profile Send private message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2175
Location: $TERM

PostPosted: Fri Sep 03, 2010 12:04 am    Post subject: Reply with quote

Atleast I can select gl in mplayer if it works...
_________________
Buy from companies supporting opensource -- IBM, Dell, HP, Hitachi, Google etc...
Disfavor companies supporting only Win -- Logitech, Epson, Adobe, Autodesk, Pioneer, Kingston, WD, Yahoo, MSI, XFX
My blog
Back to top
View user's profile Send private message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2175
Location: $TERM

PostPosted: Fri Sep 03, 2010 12:58 am    Post subject: Reply with quote

Absolutely no difference with kms turned on or off.

Radeon x1270

eselect mesa list
i915 (Intel 915, 945)
i965 (Intel 965, G/Q3x, G/Q4x)
r300 (Radeon R300-R500)
classic *
r600 (Radeon R600-R700)
gallium *
sw (Software renderer)
classic
gallium *
_________________
Buy from companies supporting opensource -- IBM, Dell, HP, Hitachi, Google etc...
Disfavor companies supporting only Win -- Logitech, Epson, Adobe, Autodesk, Pioneer, Kingston, WD, Yahoo, MSI, XFX
My blog
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Fri Sep 03, 2010 5:15 am    Post subject: Reply with quote

jepp thats just like iv got but on the old
eselect-mesa i had r300gallium and that one is not in
x11 overlay any more . you need kms in your kernel to get it
to work better. the odd thing for me about gallium
more then text and games is glxgears and glxinfo.
glxgears drops from 1500 to 100 fps but stable
and glxinfo shows none or low on all.gallium is
realy good on the D.E .hd films 3D effects xinerama and stuff like
that works fine
Back to top
View user's profile Send private message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2175
Location: $TERM

PostPosted: Fri Sep 03, 2010 5:23 am    Post subject: Reply with quote

You mean support has degraded like it has always been.

What are your CFLAGS? With which USE flags have you compiled mesa?
_________________
Buy from companies supporting opensource -- IBM, Dell, HP, Hitachi, Google etc...
Disfavor companies supporting only Win -- Logitech, Epson, Adobe, Autodesk, Pioneer, Kingston, WD, Yahoo, MSI, XFX
My blog
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Sat Sep 04, 2010 7:12 am    Post subject: Reply with quote

CFLAGS="-march=k8 -O2 -pipe -fomit-frame-pointer"


hedmo@mybox ~ $ emerge -vp mesa eselect-mesa

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] app-admin/eselect-mesa-0.0.5 0 kB [1]
[ebuild R ] media-libs/mesa-9999 USE="classic gallium nptl xcb -debug -gles -llvm -motif -pic (-selinux)" VIDEO_CARDS="r300 radeon -i810 -i915 -i965 -intel -mach64 -mga -none -nouveau -r100 -r128 -r200 -r600 -radeonhd -savage -sis -tdfx -via -vmware" 0 kB [1]

Total: 2 packages (2 reinstalls), Size of downloads: 0 kB
Portage tree and overlays:
[0] /usr/portage
[1] /var/lib/layman/x11

* IMPORTANT: 4 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

hedmo@mybox ~ $
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Sat Sep 04, 2010 1:40 pm    Post subject: Reply with quote

Moved from Desktop Environments to Unsupported Software. Overlay ebuild support belongs in US.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2175
Location: $TERM

PostPosted: Sun Sep 05, 2010 5:30 am    Post subject: Reply with quote

hedmo wrote:
CFLAGS="-march=k8 -O2 -pipe -fomit-frame-pointer"


hedmo@mybox ~ $ emerge -vp mesa eselect-mesa

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] app-admin/eselect-mesa-0.0.5 0 kB [1]
[ebuild R ] media-libs/mesa-9999 USE="classic gallium nptl xcb -debug -gles -llvm -motif -pic (-selinux)" VIDEO_CARDS="r300 radeon -i810 -i915 -i965 -intel -mach64 -mga -none -nouveau -r100 -r128 -r200 -r600 -radeonhd -savage -sis -tdfx -via -vmware" 0 kB [1]

Total: 2 packages (2 reinstalls), Size of downloads: 0 kB
Portage tree and overlays:
[0] /usr/portage
[1] /var/lib/layman/x11

* IMPORTANT: 4 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

hedmo@mybox ~ $


x64?
_________________
Buy from companies supporting opensource -- IBM, Dell, HP, Hitachi, Google etc...
Disfavor companies supporting only Win -- Logitech, Epson, Adobe, Autodesk, Pioneer, Kingston, WD, Yahoo, MSI, XFX
My blog
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Sun Sep 05, 2010 6:24 am    Post subject: Reply with quote

yes
Back to top
View user's profile Send private message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2175
Location: $TERM

PostPosted: Sun Sep 05, 2010 1:55 pm    Post subject: Reply with quote

Can you make a binary package for mesa and eselect-mesa? and then upload?
_________________
Buy from companies supporting opensource -- IBM, Dell, HP, Hitachi, Google etc...
Disfavor companies supporting only Win -- Logitech, Epson, Adobe, Autodesk, Pioneer, Kingston, WD, Yahoo, MSI, XFX
My blog
Back to top
View user's profile Send private message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2175
Location: $TERM

PostPosted: Wed Sep 08, 2010 3:41 am    Post subject: Reply with quote

In sabayon however I get 400+ FPS.

It's a kernel issue. Any advices?
_________________
Buy from companies supporting opensource -- IBM, Dell, HP, Hitachi, Google etc...
Disfavor companies supporting only Win -- Logitech, Epson, Adobe, Autodesk, Pioneer, Kingston, WD, Yahoo, MSI, XFX
My blog
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Wed Sep 08, 2010 10:18 am    Post subject: Reply with quote

before i switched to kms i used mm-sources
and got 800fps but could not use r300 gallium but sw gallium
and only with xinerama on
Back to top
View user's profile Send private message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2175
Location: $TERM

PostPosted: Wed Sep 08, 2010 2:19 pm    Post subject: Reply with quote

But I'm using zen...

mm should be a subset of zen.
_________________
Buy from companies supporting opensource -- IBM, Dell, HP, Hitachi, Google etc...
Disfavor companies supporting only Win -- Logitech, Epson, Adobe, Autodesk, Pioneer, Kingston, WD, Yahoo, MSI, XFX
My blog
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Wed Sep 08, 2010 5:52 pm    Post subject: Reply with quote

dE_logics you have to give me some info about zen :lol: .i dont know about it i (just reading the info i can get from
mr google) and if you want to bleed go mm.zen is not in the gentoo kernel docs.mm is a old 2.6.28 kernel
so i like to know about the zen.by the way mm is the only kernel that dont work for fglrx other wice id bin
used it on my game box.for my r300 box i have bin used it from the start in the gentoo jungle .sad its not updating
Back to top
View user's profile Send private message
pingufunkybeat
l33t
l33t


Joined: 01 Dec 2004
Posts: 610

PostPosted: Wed Sep 08, 2010 10:28 pm    Post subject: Reply with quote

emerge -pv zen-sources
Back to top
View user's profile Send private message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2175
Location: $TERM

PostPosted: Thu Sep 09, 2010 3:21 am    Post subject: Reply with quote

It's not about zen... the thing that's missing in the kernel config is also in the standard kernel.
_________________
Buy from companies supporting opensource -- IBM, Dell, HP, Hitachi, Google etc...
Disfavor companies supporting only Win -- Logitech, Epson, Adobe, Autodesk, Pioneer, Kingston, WD, Yahoo, MSI, XFX
My blog
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Thu Sep 09, 2010 5:33 pm    Post subject: Reply with quote

mm is from andrew morton and zen is from Con Kolivas

as far as i know mm was (is) a kernel that andrew build against the ordenary kernel with some patches
of some kind.it was along time ago i read it.back to gallium and mesa.try an older kernlel like me
and se what you get.i did like gallium more with 2.6.28-mm1-rc2 then 2.6.35-gentoo because of games
compiz and the fps was as it where before.not compiz without gallium i could not start it i had to low fps
for that.
Back to top
View user's profile Send private message
dE_logics
Advocate
Advocate


Joined: 02 Jan 2009
Posts: 2175
Location: $TERM

PostPosted: Sat Sep 11, 2010 1:12 am    Post subject: Reply with quote

But using the Sabayon kernel (2.6.34) I get 400 FPS... so the missing recipe is not deprecated IMO. After I fix this issue, I'll try gallium and other things, since Sabayon also uses the stable mesa.
_________________
Buy from companies supporting opensource -- IBM, Dell, HP, Hitachi, Google etc...
Disfavor companies supporting only Win -- Logitech, Epson, Adobe, Autodesk, Pioneer, Kingston, WD, Yahoo, MSI, XFX
My blog
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum