Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Escrita (e só escrita) em disco muito lenta
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
edbch21
n00b
n00b


Joined: 16 Jun 2010
Posts: 17

PostPosted: Fri Aug 13, 2010 2:53 am    Post subject: Escrita (e só escrita) em disco muito lenta Reply with quote

Olá a todos,

estou com um pequeno mistério pra resolver.
Recentemente adquiri um novo disco Seagate Barracuda LT 2TB. De cara ele não teve um desempenho aceitável (250kB/s) e usei isto como desculpa para fazer uma nova instalação do gentoo para substituir a minha velha de alguns anos, com vários problemas acumulados não resolvidos.

O hd de 2TB eu formatei usando dm-crypt +luks, que com o cd de instalação tinha um desempenho de 20MB/s, usando rsync, onde o gargalo é o dm-crypt e o rsync. O disco do sistema, um outro sata Barracuda de 250GB, com ext4 puro apresenta uma transferência de 40MB/s, o que me deixou satisfeito. Os resultados do hdparm foram bons, mas eu não consigo atingi-los no uso real, então vou mostrá-los, mas não vou usá-los mais como referência:
Code:
gentoo_64 ~ # hdparm -tT /dev/sda

/dev/sda:
 Timing cached reads:   1262 MB in  2.00 seconds = 630.58 MB/sec
 Timing buffered disk reads:  230 MB in  3.01 seconds =  76.47 MB/sec
gentoo_64 ~ # hdparm -tT /dev/sdb

/dev/sdb:
 Timing cached reads:   1320 MB in  2.00 seconds = 660.05 MB/sec
 Timing buffered disk reads:  304 MB in  3.01 seconds = 101.10 MB/sec
gentoo_64 ~ #


onde o sda é 250GB e o sdb é o 2TB

Instalei o sistema, compilei o kernel, rebootei e refiz os teste e obtive o mesmo resultado que com o cd de instalação. Satisfeito prosegui com a instalação do ambiente gráfico. Fazendo um novo teste após a instalação da tranquerada, fiz um novo teste e a velocidade do de 2TB caio para 2.5MB/s!!!, mas apenas na escrita!??????, pois na leitura a performance permanece a mesma (20MB/s).
Bootei o cd de instalação pra verificar possível problema de hardware e obtive o mesmo resultado de antes, ou seja 20MB/s leitura e escrita.
Eu desabilitei alguns serviços que foram adicionados durante o boot (não todos porque ainda estou meio incerto de por onde concentrar minhas forças) mas o "defeito de escrita" continua.
O que noto é que para a escrita o wa do top, que diz quanto o sistema está esperando pela desocupação do hardware, fica alto durante a escrita, 70-80%, o que antes não acontecia.
Eu compilei um kernel com o config.gz do proc do kernel do cd de boot, mas o problema persiste.

Eu não sei mais por onde procurar. Alguma sugestão?

Minha máquina:AMD Athlon(tm) 64 Processor 3000+ com asus nforce3 + 1GB ram.
Kernel: gentoo_64 2.6.34-gentoo-r1

Qualquer sugestão é realmente bem vinda. Se quiser mais informações sobre o sistema ou a máquina, basta perguntar.

Obrigado desde já,
Eduardo.
Back to top
View user's profile Send private message
njsg
n00b
n00b


Joined: 17 Dec 2005
Posts: 54
Location: Finland

PostPosted: Fri Aug 20, 2010 10:49 pm    Post subject: Reply with quote

O dmesg tem algum erro? Para ficar mais lento no hdparm ou é coisa no kernel ou no hardware, o dm-crypt não pode influenciar isso. (Usar encriptação deve, isso sim, tornar mais lento escrever na partição encriptada.)
Back to top
View user's profile Send private message
edbch21
n00b
n00b


Joined: 16 Jun 2010
Posts: 17

PostPosted: Mon Aug 23, 2010 4:08 pm    Post subject: Reply with quote

Olá,

Obrigado por responder, mas creio que apenas tomei seu tempo, desculpe. Acabei por descobrir o problema sozinho à alguns dias. Deixei, por alguma razão que não lembro, o fstab configurado para montar a partição com a opção sync. Esse era o problema. Retirando esta opção da linha do fstab, o disco voltou a ter a mesma performance para leitura e escrita. Ainda acho que estou tendo desempenho aquém do que o disco pode dar, mas acredito que são limitações da minha placa mãe.
Note que isso não resolveu o problema que eu tinha antes de formatar o pc, e eu nem estava investigado isso.

Obrigado novamente.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum