Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to downgrade python
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
whywhy
n00b
n00b


Joined: 20 Jul 2010
Posts: 35

PostPosted: Thu Jul 22, 2010 11:20 pm    Post subject: How to downgrade python Reply with quote

I am thinking of downgrading python as I am facing some problem with portage.

What would be a good way to go about it ?

Do I just mask the version of python I have now and then run a "emerge -NDup world" ?

Is there any extra steps I should do ?

Just asking as emerge / portage need python to run so I want to be sure about how to do it.
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4732
Location: Saint Amant, Acadiana

PostPosted: Thu Jul 22, 2010 11:24 pm    Post subject: Reply with quote

Generally, you do not want to downgrade python. What versions you have in mind?
Back to top
View user's profile Send private message
whywhy
n00b
n00b


Joined: 20 Jul 2010
Posts: 35

PostPosted: Thu Jul 22, 2010 11:37 pm    Post subject: Reply with quote

The version installed in my system now are :

dev-lang/python-2.6.5-r2
dev-lang/python-3.1.2-r3

I would like to try dev-lang/python-2.6.4-r1 or even dev-lang/python-2.5.4-r4.
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4732
Location: Saint Amant, Acadiana

PostPosted: Thu Jul 22, 2010 11:42 pm    Post subject: Reply with quote

2.6.4-r1 may be an option. Forget 2.5 as system python, it's going to break your Gentoo.

Still, why you need this downgrade? Maybe there is a better solution?
Back to top
View user's profile Send private message
whywhy
n00b
n00b


Joined: 20 Jul 2010
Posts: 35

PostPosted: Thu Jul 22, 2010 11:47 pm    Post subject: Reply with quote

The problem I am facing is in this post

http://forums.gentoo.org/viewtopic-t-836773-highlight-.html

basically I am getting seg fault in emerge / portage, I have done "emerge -e libtool" but that did not help.

So I thought I will try another version of python.
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4732
Location: Saint Amant, Acadiana

PostPosted: Thu Jul 22, 2010 11:49 pm    Post subject: Reply with quote

Random segfaults point to hardware problems. Bad RAM, overheating, dusty cases, out of spec PSU, etc.
Back to top
View user's profile Send private message
whywhy
n00b
n00b


Joined: 20 Jul 2010
Posts: 35

PostPosted: Thu Jul 22, 2010 11:55 pm    Post subject: Reply with quote

I have already changed the CPU, motherboard , RAM and casing fan but still getting seg fault
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4732
Location: Saint Amant, Acadiana

PostPosted: Thu Jul 22, 2010 11:59 pm    Post subject: Reply with quote

Bad hard drive (or cable), out of spec PSU.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6709
Location: Goose Creek SC

PostPosted: Fri Jul 23, 2010 12:13 am    Post subject: Reply with quote

you have done python-updater and lafilefixer --justfixit?
Back to top
View user's profile Send private message
whywhy
n00b
n00b


Joined: 20 Jul 2010
Posts: 35

PostPosted: Fri Jul 23, 2010 7:17 am    Post subject: Reply with quote

Yes run python-updater and lafilefixer, I have also manage to do a "emerge -e libtool".

However when I try to run a "emerge -e system" it seg fault during the installation of libgmp and did not install the .so files and so kill my system, I have to go get the libgmp file from a stage3 tarball.

So is python one of those package that cannot be downgraded, like glibc ?

Perhaps the gentoo handbook can include a section about what packages cannot be downgraded, that way users will be more careful doing emerge -Du.

I actually think the problem might be with glibc but as that package cannot be downgraded, there is not much I can do with it.
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7881
Location: Somewhere over Atlanta, Georgia

PostPosted: Fri Jul 23, 2010 11:25 am    Post subject: Reply with quote

Build messages leading up to the segfault can be instructive (and tasty). Why don't you feed us some? :wink:

- John
_________________
I can confirm that I have received between 0 and 999 National Security Letters.
Back to top
View user's profile Send private message
whywhy
n00b
n00b


Joined: 20 Jul 2010
Posts: 35

PostPosted: Fri Jul 23, 2010 12:23 pm    Post subject: Reply with quote

There is not much log to go on, portage would sometime seg fault right from the start like so,

tux64 ~ # emerge -NDup world

These are the packages that would be merged, in order:

Calculating dependencies... Segmentation fault

And there will be a entry in the kernel log like this,

log-2010-07-23-05:07:16:Jul 22 21:43:35 [kernel] emerge[30243]: segfault at 10737675 ip 00007f721d7472a9 sp 00007fffbd985a10 error 4 in libpython2.6.so.1.0[7f721d6c8000+157000]
Back to top
View user's profile Send private message
idella4
Veteran
Veteran


Joined: 09 Jun 2006
Posts: 1587
Location: Australia, Perth

PostPosted: Fri Jul 23, 2010 1:34 pm    Post subject: Reply with quote

downgrading python goes against the grain of gentoo. emerge and portage tun on python.
Aside from python-updater, try
emerge -u python
or
emerge -e python
which amount to the same thing.

Code:

libpython2.6.so.1.0[7f721d6c8000+157000]


says there is a fault in python 2.6. Is there already a prior version installed? e.g.

Code:

idella@genny ~ $ sudo emerge -s Python
Searching...                         
[ Results for search key : Python ]   
[ Applications found : 117 ]         

*  app-admin/eselect-python
      Latest version available: 20100321
      Latest version installed: 20091230
      Size of files: 5 kB               
      Homepage:      http://www.gentoo.org
      Description:   Eselect module for management of multiple Python versions
      License:       GPL-2                                                   

*  app-admin/python-updater
      Latest version available: 0.8
      Latest version installed: 0.8
      Size of files: 7 kB         
      Homepage:      http://www.gentoo.org/proj/en/Python
      Description:   Script used to remerge python packages when changing Python version.
      License:       GPL-2                                                               

......................................
.......................................

*  dev-lang/python
      Latest version available: 3.1.2-r4
      Latest version installed: 3.1.2-r3
      Size of files: 10,747 kB         
      Homepage:      http://www.python.org/
      Description:   Python is an interpreted, interactive, object-oriented programming language.                                                                                       
      License:       PSF-2.2
idella@genny ~ $ sudo eselect python show
python2.6


In fact if you get the segfault calculating dependencies, can emerge actually emerge?
_________________
idella4@aus
Back to top
View user's profile Send private message
whywhy
n00b
n00b


Joined: 20 Jul 2010
Posts: 35

PostPosted: Fri Jul 23, 2010 2:26 pm    Post subject: Reply with quote

here the python that is on my system :

equery list python
[ Searching for package 'python' in all categories among: ]
* installed packages
[I--] [ ] app-admin/eselect-python-20100321 (0)
[I--] [ ] app-admin/python-updater-0.8 (0)
[I--] [ ] dev-lang/python-2.6.5-r2 (2.6)
[I--] [ ] dev-lang/python-3.1.2-r3 (3.1)
[I--] [ ] dev-python/notify-python-0.1.1-r1 (0)

emerge does not seg fault everytime I used it, it just happen kind of randomly. There is no pattern to the seg fault, it can happen right after a reboot, or after the system was up for a whole day, or at a time when there is high I/O, or even when the system is idle.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6709
Location: Goose Creek SC

PostPosted: Fri Jul 23, 2010 2:29 pm    Post subject: Reply with quote

Quote:
emerge does not seg fault everytime I used it, it just happen kind of randomly. There is no pattern to the seg fault, it can happen right after a reboot, or after the system was up for a whole day, or at a time when there is high I/O, or even when the system is idle.

sure sounds like hardware as jaglover said
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9013
Location: beyond the rim

PostPosted: Fri Jul 23, 2010 2:42 pm    Post subject: Reply with quote

Even if it's not hardware related it's very unlikely that a downgrade of python (which is of course possible) would solve your segmentation faults. Also note that current portage versions require at least python-2.6, so your downgrade options are somewhat limited.
But as others have said, non-reproducable segfaults in random locations definitely sound like hardware issues.
Back to top
View user's profile Send private message
whywhy
n00b
n00b


Joined: 20 Jul 2010
Posts: 35

PostPosted: Fri Jul 30, 2010 12:11 am    Post subject: Reply with quote

I finally track down the problem, it is a hardware issue.

The 3rd core on my brand new AMD x4 635 is faulty, it fails under high load. With the way that process are schedule in linux/unix, this mean jobs will seg fault randomly with no apparent reason like how hot the CPU is running. As long as the job is not running on the faulty core, it will run fine.

I found the problem using the package "cpuburn", more details about cpuburn are here :

http://www.gentoo.org/doc/en/articles/hardware-stability-p1.xml

I am now running with maxcpus=2 until I can get the rma done.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum