Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Creating an ebuild for spotify (create ebuild from a .deb)
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Goltia
n00b
n00b


Joined: 17 Jul 2010
Posts: 13

PostPosted: Sat Jul 17, 2010 10:19 am    Post subject: Creating an ebuild for spotify (create ebuild from a .deb) Reply with quote

Hi there,

I'm a gentoo user for a few years now and a Spotify user for a few months.

Recently, I was happy to learn that Spotify release a pre-version for Linux.
I checked their website and they only provide a debian package.

I managed to install spotify with the .deb and thought it would be nice to create an ebuild for those who want Spotify on gentoo like me.

My question is:
I always thought that ebuilds must contain only source files to be compiled when en emerge is done by gentoo users.

As the .deb contains compiled binary files, is it a good thing to create an ebuild that will just take the binary files and copy them at the right place ?
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4399

PostPosted: Sat Jul 17, 2010 10:28 am    Post subject: Reply with quote

http://gentoo-overlays.zugaina.org/sunrise/portage/media-sound/despotify/despotify-9999.ebuild

not spotify, but i prefer open-source anyway

for your source file vs binary in ebuild, just check firefox-bin openoffice-bin...
Back to top
View user's profile Send private message
Goltia
n00b
n00b


Joined: 17 Jul 2010
Posts: 13

PostPosted: Sat Jul 17, 2010 10:32 am    Post subject: Reply with quote

krinn wrote:
for your source file vs binary in ebuild, just check firefox-bin openoffice-bin...


Right, thank you. I forgot about those packages.
Back to top
View user's profile Send private message
Gunde
n00b
n00b


Joined: 24 Nov 2004
Posts: 4

PostPosted: Sat Jul 17, 2010 8:03 pm    Post subject: Re: Creating an ebuild for spotify (create ebuild from a .de Reply with quote

Goltia wrote:
I managed to install spotify with the .deb and thought it would be nice to create an ebuild for those who want Spotify on gentoo like me.

Here's one mentioned in the comments for their release announcement: http://github.com/dstien/dstien-portage/tree/master/media-sound/spotify/
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 354
Location: Stockholm, Sweden

PostPosted: Sun Aug 08, 2010 9:59 pm    Post subject: Reply with quote

Nice, thanks for both tips! I'll try them both ;)
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 354
Location: Stockholm, Sweden

PostPosted: Thu Jan 06, 2011 9:03 pm    Post subject: Reply with quote

Here's a new ebuild if somebody wants it: http://trunc.it/djg7g
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
McGruff
Tux's lil' helper
Tux's lil' helper


Joined: 28 Dec 2004
Posts: 147

PostPosted: Wed Jan 26, 2011 11:51 pm    Post subject: Reply with quote

Thanks for the ebuild.

Any idea why pulseaudio is needed? I'd rather keep that off my system if possible.
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 354
Location: Stockholm, Sweden

PostPosted: Thu Jan 27, 2011 1:04 pm    Post subject: Reply with quote

mcgruff wrote:
Thanks for the ebuild.

Any idea why pulseaudio is needed? I'd rather keep that off my system if possible.


Yeah, me too, but for some reason the Spotify guys have decided on using it. I guess it's because they're using Qt, and PulseAudio works across all Linux desktops (if you have it installed). But that's just a guess of course.

PulseAudio was definitely worse for me than "raw" alsa, now I can't control my headphone output explicitly anymore, but all my outputs are changed at the same time. That really sucks!
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
dnm
n00b
n00b


Joined: 07 Oct 2002
Posts: 54
Location: Stockholm/Sweden

PostPosted: Fri Jun 10, 2011 9:03 am    Post subject: Reply with quote

I usually change to
Code:
pulseaudio? ( media-sound/pulseaudio )

and add pulseaudio to IUSE in the ebuild.
Seems to work without pulseaudio.

I try very hard to stay away from pulseaudio which have caused me a lot of grief. Same with gstreamer (not directly related to spotify).
Back to top
View user's profile Send private message
KaZeR
Apprentice
Apprentice


Joined: 04 Feb 2004
Posts: 270
Location: Au fond, à droite.

PostPosted: Sun Jun 26, 2011 9:12 am    Post subject: Reply with quote

Hi,

I used to use the ebuild from sabayon overlay, but it seems it disapeared (it was outdated, only using 0.4.9, anyway).

I've updated the ebuild for 0.5.1, and posted it in bugzilla, so it will be easier to update it.

Here's the link : https://bugs.gentoo.org/show_bug.cgi?id=373093

Hope it will be useful for someone :)
_________________
Foo.
Back to top
View user's profile Send private message
TinheadNed
Guru
Guru


Joined: 05 Apr 2003
Posts: 339
Location: Farnborough, UK

PostPosted: Sun Jul 24, 2011 6:57 pm    Post subject: Reply with quote

FYI latest is now 0.5.2.84 (g6d797eb9). I can't remember whose ebuild I'm using any more, but it was for 0.4.8 or something, renaming worked fine. Just tried the Android syncing which was terrifyingly idiotproof.
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 354
Location: Stockholm, Sweden

PostPosted: Tue Oct 04, 2011 1:46 pm    Post subject: Reply with quote

Updated post with ebuild: http://volatileint.blogspot.com/2011/10/updated-spotify-ebuild-061309.html

Renaming doesn't work anymore since they haven't updated the gnome-client this time, but I just did an ugly workaround for it. The package should really be split into two parts, just like they have with their debian package.
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
TinheadNed
Guru
Guru


Joined: 05 Apr 2003
Posts: 339
Location: Farnborough, UK

PostPosted: Tue Oct 04, 2011 9:05 pm    Post subject: Reply with quote

Looks like the 64 bit binaries link to OpenSSL 0.9.8, I'm using 1.0.0d :(

Did the old ones not link to libssl and libcrypto directly?
Back to top
View user's profile Send private message
FranZ
Apprentice
Apprentice


Joined: 15 Feb 2004
Posts: 212
Location: Enschede, Holland

PostPosted: Tue Oct 04, 2011 9:09 pm    Post subject: Reply with quote

azp wrote:
Updated post with ebuild: http://volatileint.blogspot.com/2011/10/updated-spotify-ebuild-061309.html

Renaming doesn't work anymore since they haven't updated the gnome-client this time, but I just did an ugly workaround for it. The package should really be split into two parts, just like they have with their debian package.
Actually they deprecated the gnome client. Apparently it is severely broken. You can and probably should remove it from your ebuilds.
_________________
Horse sense is the thing that keeps horses from betting on people. --W.C. Fields

Ask Smart Questions
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 354
Location: Stockholm, Sweden

PostPosted: Wed Oct 05, 2011 12:39 pm    Post subject: Reply with quote

TinheadNed wrote:
Looks like the 64 bit binaries link to OpenSSL 0.9.8, I'm using 1.0.0d :(

Did the old ones not link to libssl and libcrypto directly?


Yes, you're right. I shouldn't have posted about it before actually testing it =)
It doesn't start because of the ssl-thing (thread here), hopefully we can sort it out somehow.

FranZ wrote:

azp wrote:

Updated post with ebuild: http://volatileint.blogspot.com/2011/10/updated-spotify-ebuild-061309.html

Renaming doesn't work anymore since they haven't updated the gnome-client this time, but I just did an ugly workaround for it. The package should really be split into two parts, just like they have with their debian package.

Actually they deprecated the gnome client. Apparently it is severely broken. You can and probably should remove it from your ebuilds.


Really? Where did you hear that?
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
FranZ
Apprentice
Apprentice


Joined: 15 Feb 2004
Posts: 212
Location: Enschede, Holland

PostPosted: Wed Oct 05, 2011 2:17 pm    Post subject: Reply with quote

azp wrote:

FranZ wrote:

Actually they deprecated the gnome client. Apparently it is severely broken. You can and probably should remove it from your ebuilds.


Really? Where did you hear that?

One of the spotify employees wrote it in a message on the spotify forums.
_________________
Horse sense is the thing that keeps horses from betting on people. --W.C. Fields

Ask Smart Questions
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 354
Location: Stockholm, Sweden

PostPosted: Wed Oct 05, 2011 2:54 pm    Post subject: Reply with quote

Cool, I'll remove it then!
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
TinheadNed
Guru
Guru


Joined: 05 Apr 2003
Posts: 339
Location: Farnborough, UK

PostPosted: Sun Oct 09, 2011 2:52 pm    Post subject: Reply with quote

I've installed openssl:0.9.8 and spotify now starts but crashes pretty much instantly.
Back to top
View user's profile Send private message
guinness.stout
Apprentice
Apprentice


Joined: 26 Aug 2006
Posts: 237
Location: Maryland

PostPosted: Thu Oct 20, 2011 2:27 am    Post subject: Reply with quote

Tired the ebuild but got the following error, any ideas?

Code:

ebuild spotify-0.6.1.309.ebuild digest
>>> Downloading 'http://repository.spotify.com/pool/non-free/s/spotify/spotify-client-qt_0.6.1.309.gb871a7d-1_i386.deb'
--2011-10-19 22:25:21--  http://repository.spotify.com/pool/non-free/s/spotify/spotify-client-qt_0.6.1.309.gb871a7d-1_i386.deb
Resolving repository.spotify.com... 78.31.8.20
Connecting to repository.spotify.com|78.31.8.20|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2011-10-19 22:25:21 ERROR 404: Not Found.

!!! Couldn't download 'spotify-client-qt_0.6.1.309.gb871a7d-1_i386.deb'. Aborting.
!!! Fetch failed for spotify-client-qt_0.6.1.309.gb871a7d-1_i386.deb, can't update Manifest


EDIT:

Got a littler farther, now I'm here. I got it to go to the latest version (0.6.2.291) with the ebuild when I ran it but when I try to emerge it wants the older version.

Code:

EMERGE_DEFAULT_OPTS="--autounmask=n" ACCEPT_KEWYWORDS="~amd64" emerge spotify

 * IMPORTANT: 12 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

!!! All ebuilds that could satisfy "spotify" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-sound/spotify-0.6.1.309::gentoo (masked by: ~amd64 keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


 * IMPORTANT: 12 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


EDIT 2:

Well I skipped the ebuild totally and got the deb's and converted them to tar.gz. I'm on amd64 so I saw that one was not working so I attempted to use 386. I get the login screen, attempt to login, it loads and then immeidately crashes. I then tried the amd64 which gets me much farther. I can login and it beings to load and then when it appears to start loading images it crashes. Here is what I get in the console.

386
Code:

/usr/bin/spotify
/usr/bin/spotify: /usr/lib32/libcrypto.so.0.9.8: no version information available (required by /usr/bin/spotify)
/usr/bin/spotify: /usr/lib32/libssl.so.0.9.8: no version information available (required by /usr/bin/spotify)
02:57:53.193 I [breakpad.cpp:36] Registered Breakpad for product: spotify

02:57:53.194 I [translate.cpp:121] Reloading all languages
02:57:53.194 I [fsevents:692] starting polling thread
02:57:53.216 I [breakpad.cpp:94] Searching for crashdumps: /home/user/.cache/spotify/*.dmp

02:57:56.999 I [breakpad.cpp:74] Uploading crash dump: /home/user/.cache/spotify/207d5a37-15ba-a88e-323304ae-7ae52272.dmp

02:57:57.001 I [local_rpc_service_manager.cpp:191] CSRF domain='*.facebook.com' csrf_hash='eb42bc0e55223226b8a01916ac13f5d7ad42306a'
02:57:59.793 I [breakpad.cpp:60] Crashdump upload complete: error: 0, result: 200

02:58:07.345 I [ap:1751] Connecting to AP B2.spotify.com:4070
02:58:07.473 I [ap:1209] Connected to AP: 193.182.8.75:4070
02:58:07.845 I [user_cache:138] UserCache::initiateGetUsers() will query for 1 users
QDBusArgument: write from a read-only object
02:58:07.918 I [upnp:517] 192.168.2.2: got external ip 0x0
02:58:07.919 I [upnp:517] 192.168.2.1: got external ip 0xC0A80102
02:58:07.934 I [upnp:465] 192.168.2.1: mapping add ok
02:58:07.938 I [upnp:465] 192.168.2.2: mapping add ok
02:58:07.939 I [upnp:491] 192.168.2.1: Port 33679 mapped OK
02:58:07.945 I [upnp:491] 192.168.2.2: Port 33679 mapped OK
02:58:08.201 I [user_cache:138] UserCache::initiateGetUsers() will query for 1 users
02:58:08.263 I [offline-mgr:2142] Storage has been cleaned
02:58:08.321 I [user_cache:138] UserCache::initiateGetUsers() will query for 2 users
02:58:08.354 I [ad:1051] Found ad (time = 1319079487, adclass = 'mpu', time left = 0, length = 30)
Segmentation fault


amd64
Code:

/usr/bin/spotify
/usr/bin/spotify: /usr/lib64/libcrypto.so.0.9.8: no version information available (required by /usr/bin/spotify)
/usr/bin/spotify: /usr/lib64/libssl.so.0.9.8: no version information available (required by /usr/bin/spotify)
03:03:16.496 I [breakpad.cpp:36] Registered Breakpad for product: spotify

03:03:16.497 I [translate.cpp:121] Reloading all languages
03:03:16.497 I [fsevents:692] starting polling thread
03:03:16.518 I [breakpad.cpp:94] Searching for crashdumps: /home/user/.cache/spotify/*.dmp

03:03:22.056 I [breakpad.cpp:74] Uploading crash dump: /home/user/.cache/spotify/686e198a-3226-7bcb-4372c8e5-222c6d98.dmp

03:03:22.058 I [local_rpc_service_manager.cpp:191] CSRF domain='*.facebook.com' csrf_hash='5fb331c54a0aa5e797a99423f4413f045c850bcc'
03:03:24.616 I [breakpad.cpp:60] Crashdump upload complete: error: 0, result: 200

03:03:34.647 I [ap:1751] Connecting to AP B2.spotify.com:4070
03:03:34.766 I [ap:1209] Connected to AP: 193.182.8.75:4070
03:03:35.149 I [user_cache:138] UserCache::initiateGetUsers() will query for 1 users
QDBusArgument: write from a read-only object
03:03:35.241 I [upnp:517] 192.168.2.2: got external ip 0x0
03:03:35.241 I [upnp:517] 192.168.2.1: got external ip 0xC0A80102
03:03:35.259 I [upnp:465] 192.168.2.1: mapping add ok
03:03:35.261 I [upnp:465] 192.168.2.2: mapping add ok
03:03:35.266 I [upnp:491] 192.168.2.1: Port 58368 mapped OK
03:03:35.269 I [upnp:491] 192.168.2.2: Port 58368 mapped OK
03:03:35.774 I [user_cache:138] UserCache::initiateGetUsers() will query for 1 users
03:03:35.917 I [user_cache:138] UserCache::initiateGetUsers() will query for 2 users
03:03:35.917 I [offline-mgr:2142] Storage has been cleaned
No bp log location saved, using default.
[000:009] Browser XEmbed support present: 1
[000:009] Browser toolkit is not Gtk2 (0).
[000:073] Using Xt toolkit
03:03:37.223 I [ad:1051] Found ad (time = 1319079817, adclass = 'mpu', time left = 0, length = 30)
03:03:37.354 I [http:833] Result 301 Moved Permanently
03:03:37.399 I [http:833] Result 301 Moved Permanently
03:03:37.408 I [http:833] Result 301 Moved Permanently
03:03:37.458 I [http:833] Result 301 Moved Permanently
03:03:37.461 I [http:833] Result 301 Moved Permanently
03:03:37.480 I [http:833] Result 301 Moved Permanently
03:03:37.584 I [http:833] Result 301 Moved Permanently
03:03:37.725 I [http:833] Result 302 Moved Temporarily
03:03:37.823 I [http:833] Result 301 Moved Permanently
03:03:37.918 I [http:833] Result 302 Moved Temporarily
03:03:38.217 I [http:833] Result 302 Moved Temporarily
03:03:38.218 I [http:833] Result 301 Moved Permanently
03:03:38.361 I [http:833] Result 301 Moved
03:03:38.563 I [http:833] Result 302 Moved Temporarily
03:03:38.603 I [http:833] Result 302 Moved Temporarily
03:03:39.027 I [http:833] Result 301 Moved Permanently
03:03:39.116 I [http:833] Result 301 Moved Permanently
03:03:40.049 I [http:1076] Error 103
03:03:40.255 E [ap:4345] ChannelError(1, 1, playlist)
Segmentation fault
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 354
Location: Stockholm, Sweden

PostPosted: Thu Oct 20, 2011 8:19 am    Post subject: Reply with quote

The newest build doesn't seem to work on Gentoo because of the issue with SSL.. I haven't dug any deeper into it than that since the old version still works.

On another note:
guinness.stout wrote:
* IMPORTANT: 12 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


You might want read those news items ;) They are usually quite important to having a stable and working system.
Do eselect news list to view them all, and then eselect news read # to read a specific item.
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
TinheadNed
Guru
Guru


Joined: 05 Apr 2003
Posts: 339
Location: Farnborough, UK

PostPosted: Thu Oct 20, 2011 8:53 pm    Post subject: Reply with quote

I've also updated to 0.6.2.291 and it does the same thing.
Code:

spotify: /usr/lib64/libcrypto.so.0.9.8: no version information available (required by spotify)
spotify: /usr/lib64/libssl.so.0.9.8: no version information available (required by spotify)
20:51:52.077 I [breakpad.cpp:36] Registered Breakpad for product: spotify

20:51:52.078 I [translate.cpp:121] Reloading all languages
20:51:52.078 I [fsevents:692] starting polling thread
20:51:52.102 I [breakpad.cpp:94] Searching for crashdumps: /home/widget/.cache/spotify/*.dmp

20:51:56.555 I [breakpad.cpp:74] Uploading crash dump: /home/widget/.cache/spotify/63653656-fca2-85f7-5d5662d7-73142673.dmp

20:51:56.566 I [local_rpc_service_manager.cpp:191] CSRF domain='*.facebook.com' csrf_hash='b74b0c430cb1c986c1e00abe27c6067c52ad910a'
20:51:56.847 I [offline_authorizer.cpp:288] Unable to login offline: no such user
20:51:57.286 I [ap:1751] Connecting to AP B5.spotify.com:4070
20:51:57.682 I [ap:1209] Connected to AP: 78.31.8.16:4070
QDBusArgument: write from a read-only object
20:51:58.667 I [user_cache:138] UserCache::initiateGetUsers() will query for 1 users
20:51:58.671 I [breakpad.cpp:60] Crashdump upload complete: error: 0, result: 200

20:51:58.806 I [user_cache:138] UserCache::initiateGetUsers() will query for 1 users
20:51:58.862 I [offline-mgr:2142] Storage has been cleaned
20:51:58.863 I [IntroFlowDataSource.cpp:581] LightboxFlowStepHulk::LightboxFlowStepHulk() initial state=8
Segmentation fault
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 354
Location: Stockholm, Sweden

PostPosted: Fri Oct 21, 2011 11:41 am    Post subject: Reply with quote

I think we (as in you ;)) should write a bug on their getsatisfaction site. Inform them that we have the issue (and crashes) with libssl 0.9.8 vs 1.0 etc
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
TinheadNed
Guru
Guru


Joined: 05 Apr 2003
Posts: 339
Location: Farnborough, UK

PostPosted: Fri Oct 21, 2011 8:33 pm    Post subject: Reply with quote

When I get bored I run the crash dump uploader a bunch of times, and upload the crashes. I'll put something on there if I get the chance, although if I have to reg for that site the likelihood will diminish considerably.
Back to top
View user's profile Send private message
TinheadNed
Guru
Guru


Joined: 05 Apr 2003
Posts: 339
Location: Farnborough, UK

PostPosted: Thu Nov 03, 2011 9:02 pm    Post subject: Reply with quote

I raised something on getsatisfaction as it doesn't bloody work in wine now either.

EDIT Link here. Like it or whatever.
Back to top
View user's profile Send private message
lukipuki
n00b
n00b


Joined: 02 Nov 2004
Posts: 21
Location: Stockholm, Sweden

PostPosted: Thu Dec 15, 2011 1:58 pm    Post subject: Reply with quote

TinheadNed wrote:
I raised something on getsatisfaction as it doesn't bloody work in wine now either.


I did
Code:
winetricks winhttp

and now Spotify runs under Wine (even the new preview version with apps). Winetricks is a package in portage but you can just download it, it's a simple bash script.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum