Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge não instala gnome / skype / vdpau
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
CMatomic
n00b
n00b


Joined: 23 Jun 2010
Posts: 15

PostPosted: Sat Jun 26, 2010 7:19 pm    Post subject: emerge não instala gnome / skype / vdpau Reply with quote

já muito tempo que andava a pensar instalar o gentoo ate que ganhei coragem e comecei a instalar,desde do domingo passado , que estou instalando o gentoo , instalei o anbiente trabalho LXDE , mas não gosto muito deste ambiente , queria agora instalar o gnome mas o emerge diz que falta uma dependência ou alguma coisa do make.conf

Code:
gentoo-pc ~ # emerge gnome

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=gnome-base/gvfs-1.4.3[gdu]".
!!! One of the following packages is required to complete your request:
- gnome-base/gvfs-1.4.3-r1 (Change USE: +gdu)
(dependency required by "gnome-base/gnome-2.28.2" [ebuild])
(dependency required by "gnome" [argument])


 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

gentoo-pc ~ #


e o meu make.conf

Quote:

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=nocona -O2 -pipe"
CXXFLAGS="-march=nocona -O2 -pipe"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are e USE flags that were used in addition to what is provided by the
# profile used for building.

ACCEPT_LICENSE="*"

MAKEOPTS="-j2"
# Linguagem em Português Portugal:

LINGUAS="pt_PT"

# Arrays e Use Flags. Modifique para seu hardware e pacotes
# instalados.

## USE ARRAYS ##
BAD="-kdeprefix -arts -qt3 -beagle -evo -mono -eds -apm -oss -branding -esd"
MEDIA="musicbrainz sdl wmf fame cdr dvi mp3rtp xine cddb alsa dvb dvd network dvdread ipod audiofile artswrappersuid dvdr jack dri cdda mjpeg mmx joystick xvmc cpudetection v4l v4l2"
CODECS="x264 gsm lame dv mp3 stream live openal theora ogg a52 win32codecs matroska xvid flac ffmpeg aac speex real dts musepack"
SYSTEM="cjk unicode gnutls nptl gcj hal symlink udev kerberos acl dbus bash-completion lzo rar policykit xcb bzip2 bidi wifi lm_sensors acpi usb pcmcia bluetooth irda ieee1394"
FILESYS="fat hfs jfs xfs ntfs reiserfs sysfs gvfs inotify"
PRINT="cups ppds foomatic-db gimpprint freetype xprint scanner"
XSYS="cairo X opengl png gif gtk -qt4 qt3support xpm tiff xinerama aiglx svg gphoto2 dga lcd openexr"
DESKTOP="kdehiddenvisibility kde gmp gnome libnotify rdesktop pda nls zeroconf kdeenablefinal visualization startup-notification accessibility"
BROWSER="nsplugin firefox mozdevelop xulrunner"
COMMS="jabber msn yahoo icq irc aim rss slp mail imap"


USE="${BAD} ${MEDIA} ${CODECS} ${SYSTEM} ${FILESYS} ${PRINT} ${XSYS} ${DESKTOP} ${BROWSER} ${COMMS} gnome-base "

## DEVICES ##
INPUT_DEVICES="evdev keyboard mouse void"
VIDEO_CARDS="fbdev vesa nv nvidia"
LIRC_DEVICES="audio audio_alsa serial"
ALSA_CARDS="emu10k1x darla20 darla24 emu10k1 gina20 gina24 hdsp hdspm ice1712 indigo indigoio layla20 layla24 mia mixart mona pcxhr rme32 rme96 sb16 sbawe sscape usbusx2y vx222 usb-usx2y"
CAMERAS="agfa_cl20 casio_qv dimagev dimera3500 kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 konica_qm150 panasonic_coolshot panasonic_dc1000 panasonic_dc1580 panasonic_l859 polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ricoh_g3 sipix_blink sipix_blink2 sipix_web2 sony_dscf1 sony_dscf55 toshiba_pdrm11 adc65 aox barbie canon clicksmart310 digigr8 digita directory enigma13 fuji gsmart300 hp215 iclick jamcam jd11 konica largan lg_gsm mars mustek pccam300 pccam600 ptp2 ricoh samsung sierra smal sonix soundvision spca50x sq905 stv0674 stv0680 sx330z template"




GENTOO_MIRRORS="http://cesium.di.uminho.pt/pub/gentoo/"

SYNC="rsync://rsync1.pt.gentoo.org/gentoo-portage"

APACHE2_MPMS="prefork"

# Icecream setup
#PREROOTPATH="/usr/lib/ccache/bin:/usr/lib/icecc/bin"


Mas também estou tendo problemas com as licenças de alguns programas pois como é o skype
Code:
gentoo-pc ~ # emerge skype

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

!!! All ebuilds that could satisfy "net-im/skype" have been masked.
!!! One of the following masked packages is required to complete your request:
- net-im/skype-2.1.0.81 (masked by: ~amd64 keyword)


For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Eu sei que existe muita documentação do gentoo mas tive a ler muita coisa e ate agora não consegui arranjar uma solução para os problemas que referi a cima
agradeço muito a quem me ajudar


reparei que não tenho a pasta portage na pasta etc será que é possível recuperar esta pasta ?
Back to top
View user's profile Send private message
njsg
n00b
n00b


Joined: 17 Dec 2005
Posts: 54
Location: Finland

PostPosted: Sun Jun 27, 2010 9:20 am    Post subject: Reply with quote

As soluções para os dois problemas implicam escrever em ficheiros na /etc/portage. Num tópico em inglês aqui nos fóruns, disseram que basta criar a pasta, que "é completamente opcional, se precisas dela, cria-a". Por isso, basta mesmo chamar mkdir /etc/portage (como root — duvido que consigas criá-la com outro utilizador).

Quanto ao primeiro erro:
Quote:
emerge: there are no ebuilds built with USE flags to satisfy ">=gnome-base/gvfs-1.4.3[gdu]".
!!! One of the following packages is required to complete your request:
- gnome-base/gvfs-1.4.3-r1 (Change USE: + )
(dependency required by "gnome-base/gnome-2.28.2" [ebuild])
(dependency required by "gnome" [argument])


O que se passa é que o gnome precisa que o gvfs esteja instalado com a USE flag gdu activada (as USE flags alteram, por exemplo, funcionalidades do programa). Ele diz que não encontra ">=gnome-base/gvfs-1.4.3[gdu]" e sugere "(Change USE: + )" (e diz ainda quem é que precisa disso).

Basta meter uma linha com
Code:
gnome-base/gvfs gdu

no /etc/portage/package.use (também podes adicionar à variável USE do make.conf, mas isso activa a flag para todos os pacotes).


Já o teu problema com o Skype não é a licença, mas sim a versão ser considerada instável,
Quote:

!!! All ebuilds that could satisfy "net-im/skype" have been masked.
!!! One of the following masked packages is required to complete your request:
- net-im/skype-2.1.0.81 (masked by: ~amd64 keyword)


Isto não depende do fabricante — é uma classificação própria do gentoo.

Para permitires a instalação do pacote, adicionas a linha
Code:

net-im/skype

ao /etc/portage/package.keywords

Já um problema com a licença iria envolver uma coisa semelhante, meter uma linha no /etc/portage/package.license, com o nome do pacote seguido do nome da licença.
Back to top
View user's profile Send private message
CMatomic
n00b
n00b


Joined: 23 Jun 2010
Posts: 15

PostPosted: Sun Jun 27, 2010 11:17 am    Post subject: Reply with quote

muito obrigado njsg .
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum