Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libxslt: "/usr/lib64/libxslt.a: file not recognized"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Jenk
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2006
Posts: 112

PostPosted: Wed Jun 30, 2010 3:00 pm    Post subject: libxslt: "/usr/lib64/libxslt.a: file not recognized&quo Reply with quote

Hi all,

I'm trying to re-emerge libxslt, and am getting the following error:

Code:
libtool: install: warning: relinking `libexslt.la'
libtool: install: (cd /var/tmp/portage/dev-libs/libxslt-1.1.26/work/libxslt-1.1.26/libexslt; /bin/sh /var/tmp/portage/dev-libs/libxslt-1.1.26/work/libxslt-1.1.26/libtool  --tag CC --mode=relink x86_64-pc-linux-gnu-gcc -march=nocona -O2 -pipe -Wall -version-info 8:15:8 -L/usr/lib64 -lgcrypt -lgpg-error -Wl,-O1 -o libexslt.la -rpath /usr/lib64 exslt.lo common.lo crypto.lo math.lo sets.lo functions.lo strings.lo date.lo saxon.lo dynamic.lo ../libxslt/libxslt.la -lxml2 -lz -lm -lm -inst-prefix-dir /var/tmp/portage/dev-libs/libxslt-1.1.26/image/)
libtool: relink: x86_64-pc-linux-gnu-gcc -shared  .libs/exslt.o .libs/common.o .libs/crypto.o .libs/math.o .libs/sets.o .libs/functions.o .libs/strings.o .libs/date.o .libs/saxon.o .libs/dynamic.o   -L/usr/lib64 -L/var/tmp/portage/dev-libs/libxslt-1.1.26/image//usr/lib64 -lgcrypt -lgpg-error -lxslt -lxml2 -ldl -lz -lm  -march=nocona -Wl,-O1   -Wl,-soname -Wl,libexslt.so.0 -o .libs/libexslt.so.0.8.15
/usr/lib64/libxslt.a: file not recognized: File format not recognized
collect2: ld returned 1 exit status


EDIT: apologies, prematurely hit "Submit".

I'm trying to update world at the moment, and it gets to emerging postgresql-server and complains that libxslt needs to be installed, hence why I'm trying to re-emerge. :)
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5621

PostPosted: Wed Jun 30, 2010 3:08 pm    Post subject: Reply with quote

Pastebin whole log.
Back to top
View user's profile Send private message
Jenk
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2006
Posts: 112

PostPosted: Wed Jun 30, 2010 3:27 pm    Post subject: Reply with quote

As requested.. http://pastebin.ca/1892551
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5621

PostPosted: Wed Jun 30, 2010 5:35 pm    Post subject: Reply with quote

There's something strange there:
Code:
/usr/bin/xsltproc: error while loading shared libraries: /usr/lib64/libxslt.so.1: invalid ELF header

On one hand, that shouldn't affect the build (except for maybe the docs), on the other, did you have i.e. a disk failure recently ?
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4296

PostPosted: Thu Jul 01, 2010 12:22 am    Post subject: Reply with quote

can't see it, the link for me to pastebin.ca doesn't work

but i see two strange things for me :
Code:
libtool: install: warning: relinking `libexslt.la'

run lafilefixer --justfixit from well, lafilefixer package

and
Code:
cd /var/tmp/portage/dev-libs/libxslt-1.1.26/work/libxslt-1.1.26

when the configure script set version to be
Code:
-version-info 8:15:8

and
Code:
.libs/libexslt.so.0.8.15


libxslt build itself an older 0.8.15 version in order to build the 1.1.26 one (possible, but still rare case and that's a big versions difference)
libxslt config script found an older 0.8.15 on the system and mistake with the one you're trying to build, you should check libexslt.so* presence on the system for that 0.8.15 version laying someone.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5621

PostPosted: Thu Jul 01, 2010 1:11 am    Post subject: Reply with quote

Code:
equery b /usr/lib/libexslt.so.0.8.15
[ Searching for file(s) /usr/lib/libexslt.so.0.8.15 in *... ]
dev-libs/libxslt-1.1.26 (/usr/lib/libexslt.so.0.8.15)

Thank you.

Also, lafilefixer has nothing to do with it. While this problem might be libtool related,
it's doesn't look la file related.
Back to top
View user's profile Send private message
Jenk
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2006
Posts: 112

PostPosted: Thu Jul 01, 2010 9:56 am    Post subject: Reply with quote

I'm quite certain I haven't had a disk failure. :)

I'm not sure what else to try, in all honesty. I'm not familiar with libtool. :)
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2132
Location: Finland

PostPosted: Thu Jul 01, 2010 10:22 am    Post subject: Reply with quote

http://bugs.gentoo.org/297008

^ related, perhaps?
Back to top
View user's profile Send private message
Jenk
Tux's lil' helper
Tux's lil' helper


Joined: 18 Sep 2006
Posts: 112

PostPosted: Thu Jul 01, 2010 12:01 pm    Post subject: Reply with quote

I'm assuming you're referring to the /usr/local portion of that bug report? Apologies if not. :) That isn't the issue on my machine.

However, out of frustration I finally tried
Code:
# mv /usr/lib64/libxslt.a /usr/lib64/libxslt.a
# emerge -av libxslt
and it has now emerged successfully!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum