Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
tdb, talloc, samba Collision...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
rkrenzis
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2004
Posts: 135
Location: USA

PostPosted: Fri Jul 06, 2012 2:07 pm    Post subject: tdb, talloc, samba Collision... Reply with quote

All,

I updated portage this morning and went to go check for available updates. I referenced this article: http://forums.gentoo.org/viewtopic-t-805011.html and basically removed tdb, talloc, and samba. I attemped to re-merge samba however, I am still greeted with the collision between tdb and talloc. Ideas?


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] app-arch/unzip-6.0-r1 USE="bzip2 unicode" 1,345 kB
[ebuild N ] app-text/sgml-common-0.6.3-r5 75 kB
[ebuild N ] app-text/docbook-xml-dtd-4.2-r2 77 kB
[ebuild R ] dev-lang/python-2.7.3-r2 USE="gdbm ipv6 ncurses readline ssl threads* (wide-unicode) xml -berkdb -build -doc -examples -sqlite -tk -wininst" 0 kB
[ebuild N ] sys-libs/tdb-1.2.9 USE="-python" 360 kB
[ebuild N ] sys-libs/talloc-2.0.7 USE="-compat -python" 363 kB
[ebuild N ] net-fs/samba-3.5.15 USE="acl ads aio client cups ldap netapi pam readline server smbclient swat -addns -avahi -caps -cluster -debug -doc -examples -fam -ldb -quota -smbsharemodes -smbtav2 -syslog -winbind" 0 kB
[blocks B ] dev-lang/python[-threads] ("dev-lang/python[-threads]" is blocking sys-libs/tdb-1.2.9, sys-libs/talloc-2.0.7)

Total: 7 packages (6 new, 1 reinstall), Size of downloads: 2,219 kB
Conflict: 1 block (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/python:2.7

(dev-lang/python-2.7.3-r2::gentoo, ebuild scheduled for merge) pulled in by
dev-lang/python:2.7[threads] required by (sys-libs/talloc-2.0.7::gentoo, ebuild scheduled for merge)

(dev-lang/python-2.7.3-r2::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)


!!! Enabling --newuse and --update might solve this conflict.
!!! If not, it might help emerge to give a more specific suggestion.


The following USE changes are necessary to proceed:
#required by sys-libs/talloc-2.0.7, required by net-fs/samba-3.5.15, required by samba (argument)
>=dev-lang/python-2.7.3-r2:2.7 threads

Thanks.
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2521
Location: Richmond, BC, Canada

PostPosted: Fri Jul 06, 2012 2:24 pm    Post subject: Reply with quote

It told what you need to do.
Quote:
The following USE changes are necessary to proceed:
#required by sys-libs/talloc-2.0.7, required by net-fs/samba-3.5.15, required by samba (argument)
>=dev-lang/python-2.7.3-r2:2.7 threads


And it is not a good idea for python to have -threads anyway. All python versions in the tree have +threads IUSE defaults.

So, reverse any -threads settings make.conf and/or package.use, then re-emerge python:2.7 and your good to go.
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
rkrenzis
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2004
Posts: 135
Location: USA

PostPosted: Sat Sep 22, 2012 6:37 pm    Post subject: [SOLVED] No more collisions! Reply with quote

DUH! Of course (facepalm!) ...thanks for pointing out the obvious. I must have been tired and not seen that.

In my /etc/make.conf I had -threads set in the USE flags. I have no idea why it was set there. It was promptly removed.
Then I performed a emerge -uDN world

Thanks so much for the push into the right direction. Looking at grnscrn for too long can cause temporary blindness!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum