Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[libpng] Attention au passage 1.2 -> 1.4
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 5714
Location: ~Brussels - Belgique

PostPosted: Mon May 10, 2010 2:49 pm    Post subject: [libpng] Attention au passage 1.2 -> 1.4 Reply with quote

http://forums.gentoo.org/viewtopic-t-827262-highlight-.html

Attention aux versions "testing" : la version 1.4 de libpng demande de faire des revdep-rebuild, car libpng 1.4 casse la compatibilité avec la 1.2.
Et libpng est utilisé par un grand nombre de paquets (dans mon cas 55 sur ma machine en ~amd64, j'attends le vedict pour le netbook).

A bon entendeur... salut !
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3560
Location: Belgium

PostPosted: Mon May 10, 2010 4:16 pm    Post subject: Reply with quote

Ouaip, j'ai eu quelques angoisses aussi hier, genre kde qui ne démarrait plus ! ;-)
Back to top
View user's profile Send private message
gregool
Guru
Guru


Joined: 26 Nov 2007
Posts: 336
Location: Lille

PostPosted: Mon May 10, 2010 4:27 pm    Post subject: Reply with quote

mince j'ai pas vu ce topic! je viens d'en ouvrir un! si un modo peut cloturer, je vais déplacer
Back to top
View user's profile Send private message
Kazuya
Apprentice
Apprentice


Joined: 09 Jul 2006
Posts: 256

PostPosted: Mon May 10, 2010 5:49 pm    Post subject: Reply with quote

Hello,
Bon ça ne dit pas si après le revdep-rebuild, tout rentre dans l'ordre, si ?
Moi je n'ai pas encore passé à libpng-1.4 car j'ai un petit chromium-bin qui demande la v1.2 et donc ça bloque :) finalement ça a du bon ce blocage ^^.
_________________
Hacker vaillant, rien d'impossible !!!
"Quand une vache boit de l'eau, cette eau devient du lait. Quand un serpent boit de l'eau, cette eau devient du poison."
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3560
Location: Belgium

PostPosted: Mon May 10, 2010 6:43 pm    Post subject: Reply with quote

gregool wrote:
mince j'ai pas vu ce topic! je viens d'en ouvrir un! si un modo peut cloturer, je vais déplacer

Tant que personne n'a répondu, tu peux le supprimer toi-même ! ;-)
Back to top
View user's profile Send private message
gregool
Guru
Guru


Joined: 26 Nov 2007
Posts: 336
Location: Lille

PostPosted: Mon May 10, 2010 6:58 pm    Post subject: Reply with quote

c'est vrai, donc :

suite a la MAJ libpng 1.2.43 vers 1.4.2 j'ai lancé un revdep-rebuild qui me signale 99 paquets cassés

Problème ça bloque sur le 1er paquet qui est libgnomecanvas-python-2.28.0

Code:
checking for GTK+ - version >= 2.6.0... no
 *** Could not run GTK+ test program, checking why...
 *** The test program compiled, but did not run. This usually means
 *** that the run-time linker is not finding GTK+ or finding the wrong
 *** version of GTK+. If it is not finding GTK+, you'll need to set your
> *** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
> *** to the installed location  Also, make sure you have run ldconfig if that
> *** is required on your system
> ***
> *** If you have an old version installed, it is best to remove it, although
> *** you may also be able to get things to work by modifying LD_LIBRARY_PATH
> configure: error: maybe you want the gtk-gnome-1-2 branch?
>
> !!! Please attach the following file when seeking support:
> !!! /var/tmp/portage/dev-python/libgnomecanvas-python-2.28.0/work/gnome-python-2.28.0/config.log
>  * ERROR: dev-python/libgnomecanvas-python-2.28.0 failed:
>  *   econf failed
>  *
>  * Call stack:
>  *     ebuild.sh, line   54:  Called src_compile
>  *   environment, line 5142:  Called gnome2_src_compile
>  *   environment, line 3103:  Called gnome2_src_configure
>  *   environment, line 3117:  Called econf '--disable-allbindings' '--enable-gnomecanvas'
>  *     ebuild.sh, line  544:  Called die


j'ai essayé de ré-emerger gtk+ mais ça se plante aussi cette fois en me réclamant libpng12

Je tourne un peu en rond pour le coup, en attendant, j'ai ré-installé libpng12 sur un autre slot de façon a pouvoir utiliser la station quand même, mais les paquets qui ont libpng en dépendance, en l'occurrence 99 chez moi ne peuvent plus être mis à jour tant que je ne les aurais pas reconstruit avec libpng14.

j'ai essayé de recompiler libglade et libtool mais la compilation échoue, même après avoir lancé un lafilefixer.

est-ce que quelqu'un aurait une idée?

Merci,
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3324
Location: Paris - France

PostPosted: Mon May 10, 2010 7:39 pm    Post subject: Reply with quote

recompiler cairo en premier. Mais revdep-rebuild devrait le mettre en premier... gnomecanvas ne devrait pas être le premier...

Sinon, emerge --sync et emerge libpng : un script pour fixer à la scrud les fichiers .la a été rajouté, ça devrait aider...

En tous cas chez moi, un revdep-rebuild plus tard, et tout tourne au poil
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 5714
Location: ~Brussels - Belgique

PostPosted: Tue May 11, 2010 6:00 am    Post subject: Reply with quote

Chez moi tout a bien fonctionné, 64 et 65 paquets à recompiler, et dans le bon ordre.
J'utilise portage 2.2, et aucun ebuild propriétaire, je tourne sous XFCE.

Si ça ne passe pas, faites "emerge --keep-going --resume", puis revdep-rebuild jusqu'au moment où tout est en ordre.
Ou s'il faut émerger un paquet, n'oubliez pas le "--oneshot" sinon vous polluerez votre "world".
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
gregool
Guru
Guru


Joined: 26 Nov 2007
Posts: 336
Location: Lille

PostPosted: Tue May 11, 2010 7:34 am    Post subject: Reply with quote

ayé !

c'était pas de la tarte mais tout est rentré dans l'ordre, la raison pour laquelle ça ne fonctionnait pas était l'ordre des paquets.

en faisant d'abord emerge cairo pango gtk+ atk libglade qt-gui puis un revdep-rebuild c'est passé comme une lettre à la poste.

le tout est d'arriver a déterminer l'ordre soit même.

donc à l'arrivée c'est pas trop 'méchant' la mise à jour, juste un peu lourd dans mon cas 99 paquets ça prends quand même un certain temps.
Back to top
View user's profile Send private message
RickyLoad
Tux's lil' helper
Tux's lil' helper


Joined: 29 Dec 2006
Posts: 148
Location: Rennes

PostPosted: Thu May 13, 2010 2:58 am    Post subject: Reply with quote

arf
Bon dans la douleur ,mais çà a l'air de passer !!
Je me suis pris un laconique ==> emerge: there are no ebuilds to satisfy "x11-libs/qt:3".
Etant sous kde 4 je comprenais pas trop.
Puis je suis tombé sur ce lien ==> http://forums.gentoo.org/viewtopic-t-823043-start-0.html
qui m'a fait faire un peu de ménage ( restait quelques trucs au niveau de qt3 )
Voilà si çà peut aider quelqu'un qui se retrouve dans la même "mouise" !!
Le revdep-rebuild est parti pour 22 paquets , mais avec ceux que j'ai fait à la mano je devais tourner aussi autour de 40.
Y'a plus qu'à ...............
Back to top
View user's profile Send private message
bivittatus
l33t
l33t


Joined: 31 Jan 2006
Posts: 687
Location: Roissy-en-Brie (France)

PostPosted: Thu May 13, 2010 12:42 pm    Post subject: Reply with quote

Pour ma part, il a fallu que j'utilise le script /usr/sbin/./libpng-1.4.x-update.sh

Ca ne passait pas pour gdm, thunar et xfcepanel...:evil:
_________________
Linus TORVALDS: "Je ne suis pas là pour détruire Microsoft. Ce sera juste un effet secondaire tout à fait involontaire."
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4688
Location: Theux (Belgium)

PostPosted: Sat May 15, 2010 8:19 am    Post subject: Reply with quote

Dans mon cas, ni le script ni revdep-rebuild n'ont assuré . J'attends le résultat de emerge -e world ...

EDIT: emerge -e world terminé ce dimanche matin. Commencé la mise à jour vendredi soir... Tout fonctionne maintenant. (Manquerait plus que ça, tiens!)
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”


Last edited by VinzC on Sun May 16, 2010 9:20 pm; edited 2 times in total
Back to top
View user's profile Send private message
razer
l33t
l33t


Joined: 08 Oct 2004
Posts: 893
Location: Paris - France

PostPosted: Sat May 15, 2010 11:57 am    Post subject: Reply with quote

Moi, j'ai été obligé de linker dynamiquement vers un /usr/lib/libpng-1.2.so, sinon des dépendances gnome ne passaient pas (flag -lpng12)
Back to top
View user's profile Send private message
Kazuya
Apprentice
Apprentice


Joined: 09 Jul 2006
Posts: 256

PostPosted: Sun May 16, 2010 8:42 pm    Post subject: Reply with quote

Hello,
Et ben moi c'est passé...
> Razer, j'ai eu le même soucis de dépendances avec certains paquets, mais après une petite recherche sur le forum, l’exécution de:
solution de flameeyes récupéré par NSaibot wrote:

fgrep -e '-lpng12' --include '*.la' /usr/lib64 -rl | qfile -Cq -f - | sort -u | sudo xargs emerge -1v

à résolu le problème :).
Du coup, ce fut une migration réussis :)
_________________
Hacker vaillant, rien d'impossible !!!
"Quand une vache boit de l'eau, cette eau devient du lait. Quand un serpent boit de l'eau, cette eau devient du poison."
Back to top
View user's profile Send private message
razer
l33t
l33t


Joined: 08 Oct 2004
Posts: 893
Location: Paris - France

PostPosted: Tue May 18, 2010 3:02 pm    Post subject: Reply with quote

Merci Kazuya, j'essaye çà à l'instant
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Thu May 20, 2010 10:57 am    Post subject: Reply with quote

Je dis Bonjour tout le monde!! :)
et je dis Post-it modo svp :) ça mérite au moins ça
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 5714
Location: ~Brussels - Belgique

PostPosted: Thu May 20, 2010 11:09 am    Post subject: Reply with quote

Hé cool, mon premier message "post-it"é :)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Leander256
l33t
l33t


Joined: 05 Jul 2003
Posts: 898
Location: Singapour

PostPosted: Sun May 23, 2010 3:25 pm    Post subject: Reply with quote

Pratiquement deux semaines après c'est toujours aussi galère...

Mon emerge world a foiré au milieu parce que les ./configure ne trouvaient plus gtk, le revdep-rebuild faisait les paquets dans le désordre, pareil pour la commande de kazuya, j'ai aussi lancé le script bourrin pour réparer les fichiers .la ... Ça m'aura pris une bonne partie de la nuit, à lancer un truc puis un autre. Et histoire de bien me pourrir la vie, le pilote de ma 4965 a planté et kacpid s'est mis à me bouffer 90% d'un core donc j'ai rebooté et plus rien ne fonctionnait (même pas slim, encore moins mplayer...).

Bien sûr on peut s'attendre à ce que des trucs cassent quand on est en ~arch, mais là c'est quand même abusé. Si ils ne mettent pas au point une méthode correcte pour l'upgrade, le passage en stable va faire très mal.
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4688
Location: Theux (Belgium)

PostPosted: Sun May 23, 2010 4:03 pm    Post subject: Reply with quote

Leander256 wrote:
Pratiquement deux semaines après c'est toujours aussi galère...

Mon emerge world a foiré au milieu parce que les ./configure ne trouvaient plus gtk, le revdep-rebuild faisait les paquets dans le désordre, pareil pour la commande de kazuya, j'ai aussi lancé le script bourrin pour réparer les fichiers .la ... Ça m'aura pris une bonne partie de la nuit, à lancer un truc puis un autre. Et histoire de bien me pourrir la vie, le pilote de ma 4965 a planté et kacpid s'est mis à me bouffer 90% d'un core donc j'ai rebooté et plus rien ne fonctionnait (même pas slim, encore moins mplayer...).

Bien sûr on peut s'attendre à ce que des trucs cassent quand on est en ~arch, mais là c'est quand même abusé. Si ils ne mettent pas au point une méthode correcte pour l'upgrade, le passage en stable va faire très mal.


C'est impossible d'y arriver. Il y aura toujours des casse-têtes de ce genre et il faudra bien les résoudre a mano. Dans ton cas, je préconiserais le emerge -e world et de surveiller la reconstruction en permanence car il n'y a pas de martingale dans ces cas-là. J'ai dû par exemple passer certains paquets de stable à testing car les liaisons qu'ils avaient avec la libpng ne compilaient pas avec la nouvelle. Heureusement, il n'y a eu que quelques cas, trois tout au plus. C'est chiant au possible mais ça a eu l'avantage de remettre toutes les pendules à l'heure, si je puis dire...

Bonne chance et bon courage :) .
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Sun May 23, 2010 10:54 pm    Post subject: Reply with quote

Pour ceux qui auraient encore des problèmes (après avoir tenté en revdep-rebuild), essayez ça :

Code:
# emerge -av1 libpng
# emerge -aC =libpng-1.2.43-r3  (si encore présent)
# /usr/sbin/libpng-1.4.x-update.sh
# revdep-rebuild


Le script libpng-1.4.x-update.sh devrait arranger les choses
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4688
Location: Theux (Belgium)

PostPosted: Mon May 24, 2010 12:17 am    Post subject: Reply with quote

kernelsensei wrote:
Le script libpng-1.4.x-update.sh devrait arranger les choses

Justement, non, pas toujours -- par expérience perso :) .
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
Kazuya
Apprentice
Apprentice


Joined: 09 Jul 2006
Posts: 256

PostPosted: Mon May 24, 2010 9:59 am    Post subject: Reply with quote

Hello,
C'est bizarre que vous ayez encore ce soucis, normalement il n'ya plus aucune raison:
Installer : libpng-1.4.2 et libpng-1.2.43-r3 (deux slot différents)
ensuite un petit coup de
Quote:

revdep-rebuild -i
lafilefixer --justfixit
fgrep -e '-lpng12' --include '*.la' /usr/lib64 -rl | qfile -Cq -f - | sort -u | xargs emerge -1v
revdep-rebuild -i

Et chez moi ça marche nickel comme ça... après déterminez les paquets qui déconnent et regardez sur le bugzilla si il n'ya pas un patch de disponible...
_________________
Hacker vaillant, rien d'impossible !!!
"Quand une vache boit de l'eau, cette eau devient du lait. Quand un serpent boit de l'eau, cette eau devient du poison."
Back to top
View user's profile Send private message
VinzC
Advocate
Advocate


Joined: 17 Apr 2004
Posts: 4688
Location: Theux (Belgium)

PostPosted: Mon May 24, 2010 10:58 am    Post subject: Reply with quote

Kazuya wrote:
Hello,
C'est bizarre que vous ayez encore ce soucis, normalement il n'ya plus aucune raison [...]

Pour ma part, les soucis sont du passé, bien sûr. Mais je n'avais pas fait de mise à jour sur la machine depuis... un certain temps. Et là, sans doute, vu le nombre...
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
GNU/Linux user #369763
“Wow! I feel root”
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 5714
Location: ~Brussels - Belgique

PostPosted: Mon May 24, 2010 11:35 am    Post subject: Reply with quote

Hello,

S'il le faut, je pourrais éditer mon message initial pour mette en évidence les solutions apportées ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Tue May 25, 2010 11:37 am    Post subject: Reply with quote

Pour ma part j'ai adopté la solution de gregool.
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum