Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Clavier] Trois touches mappées incorrectement
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Leander256
l33t
l33t


Joined: 05 Jul 2003
Posts: 896
Location: Singapour

PostPosted: Tue Apr 27, 2010 2:55 pm    Post subject: [Clavier] Trois touches mappées incorrectement Reply with quote

Salut,

J'ai un problème plutôt difficile à cerner alors je m'en remets aux grands gourous du matériel. J'ai un Acer Travelmate 6292 avec un clavier qwerty et jusqu'ici toutes les touches étaient reconnues correctement, j'avais d'ailleurs supprimé mon xorg.conf. J'ai un noyau 2.6.32.11 compilé au début du mois (2.6.32.11 #1 SMP Tue Apr 6 23:22:08), un Xorg 1.8 depuis plus d'une semaine et tout allait très bien jusqu'à ce que je mette à jour udev le week-end dernier. Je pointe udev du doigt parce que c'est le seul responsable potentiel.

Les symptômes:
- mes touches "Acer" (à côté de "Power On") et "P" (en-dessous de "Web" et "Email") ne fonctionnent plus du tout
- le combo "Fn" + "Droite" pour augmenter la luminosité fonctionne mais en plus il me renvoie le symbole ±

Pour les touches multimédia qui ont disparu j'ai le message suivant dans /var/log/messages:
Code:
Apr 27 16:42:15 RAWR kernel: atkbd.c: Use 'setkeycodes e074 <keycode>' to make it known.
Apr 27 16:42:15 RAWR kernel: atkbd.c: Unknown key released (translated set 2, code 0xf4 on isa0060/serio0).
Apr 27 16:42:15 RAWR kernel: atkbd.c: Use 'setkeycodes e074 <keycode>' to make it known.
Apr 27 16:42:16 RAWR kernel: atkbd.c: Unknown key pressed (translated set 2, code 0xf3 on isa0060/serio0).
Apr 27 16:42:16 RAWR kernel: atkbd.c: Use 'setkeycodes e073 <keycode>' to make it known.
Apr 27 16:42:16 RAWR kernel: atkbd.c: Unknown key released (translated set 2, code 0xf3 on isa0060/serio0).
Apr 27 16:42:16 RAWR kernel: atkbd.c: Use 'setkeycodes e073 <keycode>' to make it known.

J'ai donc rajouté setkeycodes pour tester, et si je fais un mapping sur KEY_PROG1 et KEY_PROG2 je retrouve le comportement antérieur (sachant que je les utilise sous les noms de XF86Launch1 et XF86Launch2 dans mon .xbindkeysrc).

Mais je ne comprends pas pourquoi d'un seul coup mon noyau n'est plus capable de reconnaître ces touches alors que je ne l'ai pas modifié et que je m'en sers depuis des semaines. J'ai tenté de repasser udev à sa version antérieure mais ça ne change rien (je suppose que c'est normal mais je ne comprends pas bien qui fait quoi sur ma machine pour gérer le clavier). Donc si une bonne âme passe par là et a une idée de ce qui ne tourne pas rond...
Back to top
View user's profile Send private message
brubru
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2008
Posts: 109
Location: France

PostPosted: Tue Apr 27, 2010 5:02 pm    Post subject: Reply with quote

Salut.

Peut-être en rapport : http://linuxfr.org/comments/1122903.html#1122903
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum