Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How can i config the kernel to get the snd-pcm-oss module ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
garo
Moderator
Moderator


Joined: 15 Jul 2002
Posts: 860
Location: Edegem,BELGIUM

PostPosted: Mon Jul 15, 2002 5:48 pm    Post subject: How can i config the kernel to get the snd-pcm-oss module ? Reply with quote

What do I have to specify in the kernel configuration to get the snd-pcm-oss module ?
Back to top
View user's profile Send private message
BonezTheGoon
Bodhisattva
Bodhisattva


Joined: 14 Jun 2002
Posts: 1375
Location: Albuquerque, NM -- birthplace of Microsoft and Gentoo

PostPosted: Mon Jul 15, 2002 7:20 pm    Post subject: Reply with quote

Not sure how to answer this question specifically but something that COULD be related. I was unable to modprobe snd-pcm-oss and here is a thread that describes what I needed to do before I could. You situation could be completely different of course. I think also that snd-pcm-oss is dependent on ALSA and will go away after each rebuild of the kernel. So if you have recompiled your kernel since you emerged ALSA you should try re-emerging ALSA first.

Hope some of this info helps, be sure to post your results so we can all learn from your work!!!

Regards,
BonezTheGoon

Oh yeah almost forgot, here is the other thread I mentioned ---> http://forums.gentoo.org/viewtopic.php?t=5453&highlight=

My post is currently the last post in the thread.

Good luck!!!
_________________
mcgruff wrote:
I can't promise to be civil.


pjp wrote:
The greater evil is voting for the "lesser evil."
Back to top
View user's profile Send private message
Chris W
l33t
l33t


Joined: 25 Jun 2002
Posts: 972
Location: Brisbane, Australia

PostPosted: Tue Jul 16, 2002 9:03 am    Post subject: Reply with quote

# qpkg -f /lib/modules/2.4.18/kernel/sound/acore/oss/snd-pcm-oss.o
media-sound/alsa-driver

You need to emerge alsa-driver if you haven't yet done so. If you rebuild the kernel then you need to re-emerge the alsa-driver ebuild. You should have none of the kernel card-specific sound modules enabled if you are going to use ALSA - just enable the main kernel sound support option.
_________________
Cheers,
Chris W
"Common sense: The collection of prejudices acquired by age 18." -- Einstein
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum