Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
there are no ebuilds to satisfy "=dev-libs/openssl-0.9.8*"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Milos9304
n00b
n00b


Joined: 20 Feb 2014
Posts: 12
Location: Slovakia

PostPosted: Sun Aug 24, 2014 9:08 pm    Post subject: there are no ebuilds to satisfy "=dev-libs/openssl-0.9 Reply with quote

Hi, i am a Portage newbie and I want to know what should I do if I get an error like this:
Code:

emerge --ask app-emulation/vmware-workstation

 * IMPORTANT: 8 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "=dev-libs/openssl-0.9.8*".
(dependency required by "app-emulation/vmware-workstation-10.0.2.1744117" [ebuild])
(dependency required by "app-emulation/vmware-workstation" [argument])

I cannot solve this problem, I do not want to install packages outside of Portage.
thx a lot
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2470
Location: Austria

PostPosted: Sun Aug 24, 2014 9:32 pm    Post subject: Reply with quote

First of all, read your news.

Second, let's see what's going on:

Code:
$ equery l -ip openssl

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Milos9304
n00b
n00b


Joined: 20 Feb 2014
Posts: 12
Location: Slovakia

PostPosted: Sun Aug 24, 2014 10:19 pm    Post subject: Reply with quote

Code:

equery l -ip openssl
 * Searching for openssl ...
[-P-] [  ] dev-libs/openssl-1.0.1i:0


Do I understand it well? openssl-1.011i is installed, but not marked to use
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2470
Location: Austria

PostPosted: Mon Aug 25, 2014 6:23 am    Post subject: Reply with quote

No, it is not installed.

In an up-to-date portage tree, your result must look like that:

Code:
 * Searching for openssl ...
[-P-] [  ] dev-libs/openssl-0.9.8y:0.9.8
[-P-] [ ~] dev-libs/openssl-0.9.8y-r1:0.9.8
[-P-] [  ] dev-libs/openssl-0.9.8z_p1-r1:0.9.8
[-P-] [  ] dev-libs/openssl-0.9.8z_p1-r2:0.9.8
[-P-] [  ] dev-libs/openssl-0.9.8z_p2:0.9.8
[-P-] [  ] dev-libs/openssl-1.0.0m:0
[-P-] [  ] dev-libs/openssl-1.0.1g:0
[-P-] [ ~] dev-libs/openssl-1.0.1g-r1:0
[-P-] [  ] dev-libs/openssl-1.0.1h-r1:0
[-P-] [  ] dev-libs/openssl-1.0.1h-r2:0
[-P-] [ ~] dev-libs/openssl-1.0.1h-r3:0
[IP-] [  ] dev-libs/openssl-1.0.1i:0
[-P-] [ -] dev-libs/openssl-1.0.2_beta2:0


The fact that these are missing tells us your tree is broken - i.e. have you recently performed a delete operation in the openssl directory? ;)

`emerge --sync` and try again.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Milos9304
n00b
n00b


Joined: 20 Feb 2014
Posts: 12
Location: Slovakia

PostPosted: Mon Aug 25, 2014 5:13 pm    Post subject: Reply with quote

The result is the same :( Portage tree is up-to-date. Is it possible that problem might be caused by using Funtoo instead of Gentoo? But many people say the Portage tree is very very similar.
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2470
Location: Austria

PostPosted: Mon Aug 25, 2014 5:59 pm    Post subject: Reply with quote

That would be a bug in Funtoo then.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Milos9304
n00b
n00b


Joined: 20 Feb 2014
Posts: 12
Location: Slovakia

PostPosted: Mon Aug 25, 2014 6:05 pm    Post subject: Reply with quote

Ok, thx, I will report a bug. Just to make sure I understand, openssl-0.9.8* is required to install vmware-workstation, but there is no reference in Portage tree to it. Am I right?
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2470
Location: Austria

PostPosted: Mon Aug 25, 2014 6:49 pm    Post subject: Reply with quote

The dependencies (namely openssl-0.9.8*) for vmware-workstation are not satisfied by the funtoo package tree.

Someone did not run repoman there.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 8004

PostPosted: Fri Aug 29, 2014 3:52 am    Post subject: Reply with quote

Milos9304 wrote:
The result is the same :( Portage tree is up-to-date. Is it possible that problem might be caused by using Funtoo instead of Gentoo? But many people say the Portage tree is very very similar.
Funtoo is... different.

Moved from Portage & Programming to Unsupported Software.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum