Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[geki-overlay] split build of boost.org libraries
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2116
Location: Germania

PostPosted: Sat Nov 06, 2010 11:28 pm    Post subject: Reply with quote

wazoo42
what says 'equery files dev-libs/boost-graph'?
I still wonder why is boost-graph found in my system then ( see post above ). :roll:
_________________
boost|trans-follow xcb|instruction set analyzer
___
the self obscures the truth. I am no one, and so my words alone come from the truth of this world. amen.
Back to top
View user's profile Send private message
wazoo42
Apprentice
Apprentice


Joined: 13 Apr 2004
Posts: 165

PostPosted: Sun Nov 07, 2010 12:31 am    Post subject: Reply with quote

Code:

localhost benjfitz # equery files dev-libs/boost-graph
 * Searching for boostgraph in dev-libs ...
 * Contents of dev-libs/boost-graph-1.44.0:
/usr
/usr/lib64
/usr/lib64/boost-1_44
/usr/lib64/boost-1_44/libboost_graph.so -> ../libboost_graph-1_44.so
/usr/lib64/libboost_graph-1_44.so -> libboost_graph-1_44.so.1.44.0
/usr/lib64/libboost_graph-1_44.so.1 -> libboost_graph-1_44.so.1.44.0
/usr/lib64/libboost_graph-1_44.so.1.44 -> libboost_graph-1_44.so.1.44.0
/usr/lib64/libboost_graph-1_44.so.1.44.0


For the record, I run into this problem with avogadro (boost_python) and hugin (boost_date_time) as well.
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2116
Location: Germania

PostPosted: Sun Nov 07, 2010 12:44 am    Post subject: Reply with quote

hmm, you may enable useflag[threads] to get the *-mt* libraries and retry :roll:
_________________
boost|trans-follow xcb|instruction set analyzer
___
the self obscures the truth. I am no one, and so my words alone come from the truth of this world. amen.
Back to top
View user's profile Send private message
wazoo42
Apprentice
Apprentice


Joined: 13 Apr 2004
Posts: 165

PostPosted: Sun Nov 07, 2010 1:20 am    Post subject: Reply with quote

You win Geki, all of the other packages compiled fine once I had recompiled the boost packages with USE=threads. Thanks for the help.
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2116
Location: Germania

PostPosted: Sun Nov 07, 2010 11:34 am    Post subject: Reply with quote

so, the question is, do they really need the mt libraries?
then, they should be more verbose. there is just no need to be more cryptic/silent than gcc errors. :o

otherweise, if they do not, they should not fail.

wazoo42
please check to what boost libraries kdepimlibs et al link to with ldd.
_________________
boost|trans-follow xcb|instruction set analyzer
___
the self obscures the truth. I am no one, and so my words alone come from the truth of this world. amen.
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2116
Location: Germania

PostPosted: Sun Nov 07, 2010 11:54 am    Post subject: Reply with quote

so, if you set the cmake define Boost_USE_MULTITHREADED to OFF it does not take the mt versions. let's see where to put this.

edit #1
updated wiki: http://code.google.com/p/gekis-playground/wiki/Boost#How_to_fix_packages_from_Gentoo_repository?
_________________
boost|trans-follow xcb|instruction set analyzer
___
the self obscures the truth. I am no one, and so my words alone come from the truth of this world. amen.
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2116
Location: Germania

PostPosted: Mon Nov 08, 2010 10:17 pm    Post subject: Reply with quote

another thing you may propagate to upstreams. :o

https://github.com/tsuna/boost.m4

https://github.com/tsuna/boost.m4/wiki/

it looks quite complete for autotooling.
and I guess better than self-hacked code.

( I have seen another boost.m4 somewhere else. though, do not remember where ... )


have fun! :twisted:
_________________
boost|trans-follow xcb|instruction set analyzer
___
the self obscures the truth. I am no one, and so my words alone come from the truth of this world. amen.
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2116
Location: Germania

PostPosted: Sat Nov 20, 2010 3:10 pm    Post subject: Reply with quote

painless 1.45.0 bump; at least for the few libraries I use :o
- simply like it should be ...
_________________
boost|trans-follow xcb|instruction set analyzer
___
the self obscures the truth. I am no one, and so my words alone come from the truth of this world. amen.
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1044

PostPosted: Tue Dec 07, 2010 1:13 pm    Post subject: Reply with quote

>>> Install boost-system-1.45.0 into /var/tmp/portage/dev-libs/boost-system-1.45.0/image/ category dev-libs
/var/tmp/portage/dev-libs/boost-system-1.45.0/work/boost_1_45_0/libs/system/build /var/tmp/portage/dev-libs/boost-system-1.45.0/work/boost_1_45_0
bjam-1_45 -q -d+2 gentoorelease --with-system pch=off --user-config="/var/tmp/portage/dev-libs/boost-system-1.45.0/work/boost_1_45_0/user-config.jam" --boost-build=/usr/share/boost-build-1_45 --prefix="/var/tmp/portage/dev-libs/boost-system-1.45.0/image//usr" --layout=versioned threading=single,multi link=shared runtime-link=shared --includedir="/var/tmp/portage/dev-libs/boost-system-1.45.0/image//usr/include" --libdir="/var/tmp/portage/dev-libs/boost-system-1.45.0/image//usr/lib" install
common.mkdir ../../../libs/system/build/"

mkdir -p "../../../libs/system/build/""

/bin/sh: -c: line 1: unexpected EOF while looking for matching `"'
/bin/sh: -c: line 3: syntax error: unexpected end of file
...failed updating 1 target...

for some reasons, i can't get past here.

any help?
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
ajani_mgo
n00b
n00b


Joined: 13 Dec 2010
Posts: 1

PostPosted: Mon Dec 13, 2010 5:01 pm    Post subject: error: No best alternative for ../../../libs/python/build/in Reply with quote

Alright, it's my 1st time posting for help on this forum... So hello, I have a problem while emerging boost-python.

Everything seems to be normal, compiling fine, until it's time for the install. I must say that I don't really know what it actually means. Google has really little results. I thought it was something about the compiler include and linker library paths, so I hardcoded it into the eclass initially via includedir and libdir (if I actually used the right variables), but same error still occurs, only with different includedirs and libdirs as referenced from below.

Quote:


The following directory should be added to compiler include paths:

/var/tmp/portage/dev-libs/boost-python-1.45.0/work/boost_1_45_0

The following directory should be added to linker library paths:

/var/tmp/portage/dev-libs/boost-python-1.45.0/work/boost_1_45_0/stage/lib

>>> Source compiled.

>>> Test phase [not enabled]: dev-libs/boost-python-1.45.0
>>> Install boost-python-1.45.0 into /var/tmp/portage/dev-libs/boost-python-1.45.0/image/ category dev-libs
* bjam-1_45 -q -d+2 gentoorelease threading=single,multi link=shared runtime-link=shared
* --includedir=/var/tmp/portage/dev-libs/boost-python-1.45.0/image//usr/include
* --libdir=/var/tmp/portage/dev-libs/boost-python-1.45.0/image//usr/lib pch=off
* --user-config=/var/tmp/portage/dev-libs/boost-python-1.45.0/work/boost_1_45_0/user-config.jam
* --prefix=/var/tmp/portage/dev-libs/boost-python-1.45.0/image//usr
* --boost-build=/usr/share/boost-build-1_45
* --layout=versioned
* --with-python install
error: No best alternative for ../../../libs/python/build/install
next alternative: required properties: (empty)
matched
next alternative: required properties: (empty)
matched
error: No best alternative for ../../../libs/python/build/install
next alternative: required properties: (empty)
matched
next alternative: required properties: (empty)
matched
/var/tmp/portage/dev-libs/boost-python-1.45.0/temp/environment: line 1144: cd: /var/tmp/portage/dev-libs/boost-python-1.45.0/image//usr/lib: No such file or directory
* ERROR: dev-libs/boost-python-1.45.0 failed:
* (no error message)
*
* Call stack:
* ebuild.sh, line 56: Called src_install
* environment, line 5404: Called boost_src_install
* environment, line 1144: Called die
* The specific snippet of code:
* cd "${D}/usr/$(get_libdir)" || die;
*
* If you need support, post the output of 'emerge --info =dev-libs/boost-python-1.45.0',
* the complete build log and the output of 'emerge -pqv =dev-libs/boost-python-1.45.0'.
* This ebuild used the following eclasses from overlays:
* /var/lib/layman/openoffice-geki/eclass/boost.eclass
* This ebuild is from an overlay named 'geki-overlay': '/var/lib/layman/openoffice-geki/'
* The complete build log is located at '/var/lib/portage/dev-libs:boost-python-1.45.0:20101213-164359.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-libs/boost-python-1.45.0/temp/environment'.
* S: '/var/tmp/portage/dev-libs/boost-python-1.45.0/work/boost_1_45_0'

>>> Failed to emerge dev-libs/boost-python-1.45.0, Log file:

>>> '/var/lib/portage/dev-libs:boost-python-1.45.0:20101213-164359.log'


emerge --info =dev-libs/boost-python-1.45.0
Quote:
Portage 2.2.0_alpha8 (default/linux/x86/10.0/desktop, gcc-4.4.5, glibc-2.12.1-r3, 2.6.36-zen1-ajani i686)
=================================================================
System Settings
=================================================================
System uname: Linux-2.6.36-zen1-ajani-i686-Genuine_Intel-R-_CPU_T2080_@_1.73GHz-with-gentoo-2.0.1
Timestamp of tree: Mon, 13 Dec 2010 16:30:01 +0000
ccache version 3.1.3 [enabled]
app-shells/bash: 4.1_p9
dev-java/java-config: 2.1.11-r2
dev-lang/python: 2.6.6-r1, 2.7.1, 3.1.3
dev-util/ccache: 3.1.3
dev-util/cmake: 2.8.1-r2
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc: 0.6.8
sys-apps/sandbox: 2.4
sys-devel/autoconf: 2.13, 2.68
sys-devel/automake: 1.8.5-r4, 1.9.6-r3, 1.10.2, 1.11.1
sys-devel/binutils: 2.21
sys-devel/gcc: 4.4.5, 4.5.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 2.4-r1
sys-devel/make: 3.82
virtual/os-headers: 2.6.36.1 (sys-kernel/linux-headers)
Repositories: gentoo sabayon sunrise kde oss-overlay geki-overlay Ajani
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/config/kdm /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/skel /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache collision-protect distlocks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1,--as-needed"
LINGUAS="en en_US en_GB zh zh_CN"
MAKEOPTS="-j2 -s "
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sabayon /var/lib/layman/sunrise /var/lib/layman/kde /var/lib/layman/oss-overlay /var/lib/layman/openoffice-geki /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac accessibility acl acpi aiglx aim artswrappersuid audiofile avahi bash-completion berkdb bidi bluetooth bzip2 cairo cdda cddb cdr cjk cli consolekit cpudetection cracklib crypt cups custom-cflags cxx dbus dga dri dts dv dvb dvd dvdr dvdread dvi emboss encode exif fam fame fat ffmpeg firefox flac foomatic-db fortran freetype gcj gdbm gif gimpprint gmp gnutls gphoto2 gpm gsm gtk hal hfs iconv icq ieee1394 imap inotify ipod ipv6 irc irda jabber jack jfs joystick jpeg kde kdehiddenvisibility kerberos lame lcd lcms ldap libnotify live lm_sensors lzo mad mail matroska mikmod mjpeg mmx mng modules mozdevelop mp3 mp3rtp mp4 mpeg msn mudflap musepack musicbrainz ncurses network nls nptl nptlonly nsplugin ntfs ogg openal openexr opengl openmp oss oss4 pam pango pcmcia pcre pda pdf perl png policykit ppds pppd python qt3support qt4 rar rdesktop readline reiserfs rss scanner sdl session slp speex spell sse sse2 sse3 ssl startup-notification stream svg sysfs tcpd theora tiff truetype udev unicode usb v4l v4l2 visualization vorbis wifi win32codecs wmf x264 x86 xcb xfs xine xml xorg xpm xprint xulrunner xv xvid xvmc yahoo zeroconf zlib" ALSA_CARDS="emu10k1x darla20 darla24 emu10k1 gina20 gina24 hdsp hdspm ice1712 indigo indigoio layla20 layla24 mia mixart mona pcxhr rme32 rme96 sb16 sbawe sscape usbusx2y vx222 usb-usx2y" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" CAMERAS="agfa_cl20 casio_qv dimagev dimera3500 kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 konica_qm150 panasonic_coolshot panasonic_dc1000 panasonic_dc1580 panasonic_l859 polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ricoh_g3 sipix_blink sipix_blink2 sipix_web2 sony_dscf1 sony_dscf55 toshiba_pdrm11 adc65 aox barbie canon clicksmart310 digigr8 digita directory enigma13 fuji gsmart300 hp215 iclick jamcam jd11 konica largan lg_gsm mars mustek pccam300 pccam600 ptp2 ricoh samsung sierra smal sonix soundvision spca50x sq905 stv0674 stv0680 sx330z template" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US en_GB zh zh_CN" LIRC_DEVICES="audio audio_alsa serial" PHP_TARGETS="php5-2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev vesa intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


emerge -pqv =dev-libs/boost-python-1.45.0
Quote:
[ebuild N ] dev-libs/boost-python-1.45.0 USE="threads -debug -doc -static -test"


Build log is at http://pastebin.ca/2018494 . Will I need any more information, or did I write too much? :) Thanks.

EDIT 14 Dec: Got it to work. Turns out that boost-python has problems compiling with Python 3.1. I eselected Python 2.6 and it now installs fine. Hurray! :)
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2116
Location: Germania

PostPosted: Mon Dec 20, 2010 3:49 pm    Post subject: Reply with quote

ajani_mgo
thanks for reporting! has been fixed with revision 87; the jamfile jammed for python3.
in this case the quote and notice about python3 would have been enough.
_________________
boost|trans-follow xcb|instruction set analyzer
___
the self obscures the truth. I am no one, and so my words alone come from the truth of this world. amen.
Back to top
View user's profile Send private message
jasn
Guru
Guru


Joined: 05 May 2005
Posts: 412
Location: Maryland, US

PostPosted: Sat Jan 15, 2011 3:05 pm    Post subject: Reply with quote

I was able to install split boost using geki's overlay, (openoffice-geki), and the instructions in this thread. I was also able to modify several of my installed packages' ebuilds, in order to support the split boost configuration. Specifically using the instructions from geki's playground here, I was successfully able to update the following packages' ebuilds in order to support my split boost installation;

media-video/mkvtoolnix (using geki's diff patch)
games-puzzle/pingus
games-strategy/wesnoth

However, I'm having problems getting

games-board/pokerth

to build successfully. I basically performed the same steps for the pokerth ebuild that I did for the pingus and wesnoth ebuilds. After copying the latest pokerth ebuild to my local overlay, I edited it by adding 'boost-utils' to 'inherit' at the top of the ebuild and adding 'add_boost_paths' in the 'src_configure' section of the ebuild right before the 'eqmake4' line. Finally, even though it appears that pokerth is only looking for the boost iostreams, program_options, regex, system, and thread libraries, I've also set every boost USE flag, (except test), with my boost installation, and I still am greeted with a compile fail that includes the following error message;
Code:
Project ERROR: Unable to find boost libraries in PREFIX=/usr

Here's my build log; here's my ebuild environment, and here's my ebuild emerge info.

Thanks for any guidance..
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2116
Location: Germania

PostPosted: Sat Jan 15, 2011 4:40 pm    Post subject: Reply with quote

jasn
next to the changes I recommend you may remove the hacks in the ebuild of games-board/pokerth.

see starting line 46:
http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/games-board/pokerth/pokerth-0.8.2.ebuild?revision=1.1&view=markup

if it still fails it seems to ignore LDFLAGS?! that would be annoying ... then pastebin your ebuild, please.
_________________
boost|trans-follow xcb|instruction set analyzer
___
the self obscures the truth. I am no one, and so my words alone come from the truth of this world. amen.
Back to top
View user's profile Send private message
jasn
Guru
Guru


Joined: 05 May 2005
Posts: 412
Location: Maryland, US

PostPosted: Sat Jan 15, 2011 10:07 pm    Post subject: Reply with quote

Thanks geki..

I thought I saw a similar boost hack in the current wesnoth ebuild, (at line 60), but simply editing it as per your instructions, resulting in this modified ebuild, compiled fine, once I emerged boost with the correct USE flags.

Anyway, here's the first modified PokerTH ebuild I tried, and here's the second one. Both fail with the same output regarding not finding the boost libraries, as before.

Thanks again..
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2116
Location: Germania

PostPosted: Sun Jan 16, 2011 1:24 am    Post subject: Reply with quote

maybe it helps to set this in configure:
Quote:
export QMAKE_LFLAGS="${LDFLAGS} -L$(get_boost_library_path)"

otherwise you also need to edit the *.pro files. add the proper boost library path to LIB_DIRS, see:
Quote:
# grep -n LIB_DIRS *.pro
pokerth_game.pro:367: LIB_DIRS = $${PREFIX}/lib \
pokerth_game.pro:383: for(dir, LIB_DIRS):exists($$dir) {
pokerth_server.pro:190: LIB_DIRS = $${PREFIX}/lib $${PREFIX}/lib64
pokerth_server.pro:204: for(dir, LIB_DIRS){
zlib_compress.pro:55: LIB_DIRS = $${PREFIX}/lib $${PREFIX}/lib64
zlib_compress.pro:59: for(dir, LIB_DIRS) {

o what fun with hardcoded default paths. :evil:
_________________
boost|trans-follow xcb|instruction set analyzer
___
the self obscures the truth. I am no one, and so my words alone come from the truth of this world. amen.
Back to top
View user's profile Send private message
pallaert
n00b
n00b


Joined: 29 Apr 2005
Posts: 18

PostPosted: Wed Jan 19, 2011 9:26 am    Post subject: Issue when recomping dev-db/mongo Reply with quote

After installing libreoffice which uses the boost split build I realized that I had to reemerge dev-db/mongo (revdep-rebuild).
Doing so fail while checking about boost libraries:

Code:
emerge =dev-db/mongodb-1.6.0
will fail with:
Code:
Checking whether the C++ compiler worksyes
Checking for C library stdc++... yes
Checking for C++ header file pcrecpp.h... yes
Checking for C++ header file boost/filesystem/operations.hpp... yes
Checking for C library boost_system-mt... no
Checking for C library boost_system... no
Checking for C library boost_thread-mt... no
Checking for C library boost_thread... no
can't find or link against library ['boost_thread-mt', 'boost_thread'] in []
see config.log for more information
 * ERROR: dev-db/mongodb-1.6.0 failed:
 *   Compile failed
 *
 * Call stack:
 *     ebuild.sh, line  56:  Called src_compile
 *   environment, line 2587:  Called die
 * The specific snippet of code:
 *       scons ${MAKEOPTS} all || die "Compile failed"

Thanks in advance for investigating!
_________________
Patrick ALLAERT
Open Source Web Developer
http://patrickallaert.blogspot.com/
Back to top
View user's profile Send private message
jasn
Guru
Guru


Joined: 05 May 2005
Posts: 412
Location: Maryland, US

PostPosted: Fri Jan 21, 2011 12:19 pm    Post subject: Reply with quote

pallaert,

It appears that you need to emerge boost with at least the, filesystem system and thread, USE flags.

Good Luck..
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2116
Location: Germania

PostPosted: Sun Feb 06, 2011 11:53 am    Post subject: Reply with quote

ported to EAPI 4.

python.eclass needs porting! you may ask the developers for a patch. :o
_________________
boost|trans-follow xcb|instruction set analyzer
___
the self obscures the truth. I am no one, and so my words alone come from the truth of this world. amen.
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2463
Location: Austria

PostPosted: Sun Feb 06, 2011 11:58 am    Post subject: Reply with quote

Fyi, after taking a break since 1.42, there's 1.45 inside portage. Actually for a month already, and I didn't notice. No split though.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2116
Location: Germania

PostPosted: Sun Feb 06, 2011 12:24 pm    Post subject: Reply with quote

yes, I saw it as soon as it entered.

I would not go for a split build in gentoo repository.

instead, I would still do an eclass to simplify but have one package with useflags.
you just need to tweak my eclasses a little little bit. :o

because that funny test build procedure failing for single libraries too easily.

well, and latest gentoo rule I know => no split but use-flagging, though some years old already. even that they do not follow, sadly. :?
bugreport: https://bugs.gentoo.org/show_bug.cgi?id=310207
_________________
boost|trans-follow xcb|instruction set analyzer
___
the self obscures the truth. I am no one, and so my words alone come from the truth of this world. amen.
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2463
Location: Austria

PostPosted: Sun Feb 06, 2011 12:51 pm    Post subject: Reply with quote

Yes, I've seen your bug, and I would also go for a USE flag split instead of multiple ebuilds - that has been making me edit your open-/libreoffice ebuilds (now eclass) all the time. What was the reason again for your split ebuilds attempt? :wink:

Well, there's been a change in Gentoo boost maintenance, so maybe there's a chance...
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Lustmored
Apprentice
Apprentice


Joined: 28 May 2010
Posts: 204
Location: Poland

PostPosted: Sun Feb 06, 2011 1:56 pm    Post subject: Reply with quote

Paludis warning wrote:
cave@1297000505: [WARNING e.ebuild.metadata.unusable] No usable metadata for 'dev-libs/boost-signals-1.45.0::geki-overlay'
Deciding: 395 steps, 7 metadata (7 geki-overlay) cave@1297000505: [WARNING e.ebuild.cache_failure] In thread ID '21750':
... In program cave resolve -c world:
... When resolving and adding dependencies recursively:
... When adding dependencies for 'dev-libs/boost:1.45::(install_to_slash)' with 'dev-libs/boost-1.45.0:1.45::installed':
... When handling dependency '~dev-libs/boost-thread-1.45.0':
... When finding slots for '~dev-libs/boost-thread-1.45.0':
... When finding best version of each package from packages matching ~dev-libs/boost-thread-1.45.0 (ignoring additional requirements) with filter all matches filtered through supports action install filtered through not masked filtered through all matches:
... When generating metadata for ID 'dev-libs/boost-thread-1.45.0::geki-overlay':
... When running an ebuild command on 'dev-libs/boost-thread-1.45.0::geki-overlay':
... Could not generate cache for 'dev-libs/boost-thread-1.45.0::geki-overlay', stdout says '' and stderr says '
!!! ERROR in dev-libs/boost-thread-1.45.0::geki-overlay:
!!! In source at line 15
!!! API of python.eclass in EAPI="4" not established

!!! Call stack:
!!! * source (/usr/portage/eclass/python.eclass:15)
!!! * inherit (/usr/libexec/paludis/0/eclass_functions.bash:64)
!!! * source (/var/db/paludis/repositories/geki-overlay/eclass/boost.eclass:12)
!!! * inherit (/usr/libexec/paludis/0/eclass_functions.bash:64)
!!! * source (/var/db/paludis/repositories/geki-overlay/dev-libs/boost-thread/boost-thread-1.45.0.ebuild:5)
!!! * ebuild_load_ebuild (/usr/libexec/paludis/ebuild.bash:378)
!!! * ebuild_main (/usr/libexec/paludis/ebuild.bash:623)
!!! * main (/usr/libexec/paludis/ebuild.bash:676)

diefunc: making ebuild PID 22008 exit with error
die trap: exiting with error.
'
cave@1297000505: [WARNING e.ebuild.metadata.unusable] No usable metadata for 'dev-libs/boost-thread-1.45.0::geki-overlay'


I don't understand any of this, but since move to EAPI=4 paludis tells me it cannot be installed :(
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2463
Location: Austria

PostPosted: Sun Feb 06, 2011 2:05 pm    Post subject: Reply with quote

I guess that's supposed to happen:
geki wrote:
python.eclass needs porting! you may ask the developers for a patch. :o

Code:
!!! In source at line 15
!!! API of python.eclass in EAPI="4" not established

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2116
Location: Germania

PostPosted: Sun Feb 06, 2011 2:07 pm    Post subject: Reply with quote

genstorm
the simple reason that most libraries are independent and to get a headers only package.
there are many packages that require only the boost headers distribution but no boost libraries.

a sane application nowadays should use boost headers distribution and optionally, with descending importance, boost thread, filesystem and program_options library. :evil:
well, just my pov. :lol:


Lustmored
see above ...
_________________
boost|trans-follow xcb|instruction set analyzer
___
the self obscures the truth. I am no one, and so my words alone come from the truth of this world. amen.
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2116
Location: Germania

PostPosted: Mon Feb 07, 2011 7:12 pm    Post subject: Reply with quote

commented out python code. dev-libs/boost-python may just fail for now.
so, at least, the rest builds hopefully.
_________________
boost|trans-follow xcb|instruction set analyzer
___
the self obscures the truth. I am no one, and so my words alone come from the truth of this world. amen.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next
Page 4 of 7

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum