Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GeCHI Weekly Report #1.3
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
oRDeX
Veteran
Veteran


Joined: 19 Oct 2003
Posts: 1303
Location: Italy: Trento || Mondo

PostPosted: Sun Oct 11, 2009 10:20 am    Post subject: GeCHI Weekly Report #1.3 Reply with quote

Terzo report settimanale dei GeCHI.

Come al solito, rinnovo l'invito a commentare il thread e ricordo che in fondo sono presenti le referenze per seguire i report tramite RSS.

Quote:

GeCHI Weekly Report #1.3

Benvenuti al terzo GeCHI Weekly Report, il quale fornisce sommari e notizie importanti relative allo sviluppo della distribuzione Gentoo riguardanti il seguente periodo: 03.10.2009 - 09.10.2009.

[1] sys-apps/openrc-0.5.1 (09.10)
Matthias Schwarzott ha aggiornato il pacchetto sys-apps/openrc all'ultima versione 0.5.1 la quale introduce, tra le altre novità, l'uso di un nuovo sistema di init script per le periferiche di rete. Sfortunatamente questi nuovi init script non sono documentati per cui la migrazione dei vecchi script vs il nuovo formato è fortemente scoraggia fino a quando la relativa guida non verrà aggiornata. Infine, in virtù di quanto appena detto, si sconsiglia in modo categorico l'installazione di OpenRC 0.5.1 con la USE oldnet disattivata, pena il mancato funzionamento delle periferiche eth* e ppp*.

[2] nuove USE_EXPAND per Python e Ruby (06.10)
In portage esistono pacchetti quali le RubyGem, i moduli Python e altri che quando vengono installati compilando i relativi moduli solo per la versione di Ruby/Python selezionata tramite eselect al momento dell'installazione, generando non pochi grattacapi nel caso di upgrade dei rispetti linguaggi di programmazione; per sopperire a questo limite, il Team di sviluppatori Gentoo ha proposto l'introduzione di nuove USE_EXPAND sia per Ruby che per Python, rispettivamente: RUBY_TARGETS e PYTHON_TARGET. In questo modo, quando si installerà un modulo Ruby o Python, Portage mostrerà il seguente output all'utente finale:

[ebuild U ] dev-ruby/actionpack-2.3.2-r1 [2.3.2] USE="-doc -test%" RUBY_TARGETS="ruby18* ruby19* -jruby%" 746 kB

Non solo questa soluzione fornirà all'utente finale un livello di flessibilità e controllo su Ruby/Python come nessun'altra distro prima d'ora, ma semplificherà di molto le operazioni di update dei suddetti linguaggi, rendendo, per esempio, molto meno invasivo l'aggiornamento di python tramite il tanto odiato python-updater.

[3] gnome-base/gnome 2.26 (stabilizzazione) (06.10)
E' stato ultimato il processo di stabilizzazione della versione 2.26 dei pacchetti gnome-base/gnome e gnome-base/gnome-light; tutti gli utilizzatori di tale desktop sono invitati a leggere l'apposita guida all'aggiornamento di gnome 2.26 per facilitare le operazioni di migrazione.

[4] Rimozione del profilo ~sparc-fbsd (04.10)
A causa di problemi legati alle nuove versioni di dev-lang/python che richiedono l'uso di una toolchain esterna (dev-libs/libffi) che non può essere testata su architettura sparc, il Team di sviluppatori Gentoo ha deciso di rimuovere l'arch ~sparc-fbsd dai profili della distro in virtù del fatto che senza python non si può avere Portage e senza Portage non si può avere Gentoo.

Se nella comunity italiana c'è qualche volenteroso e fiero possessore di hardware sparc che volesse aiutare il Team BSD di Gentoo nel testare dev-libs/libffi per l'architettura ~sparc-fbsd, è fortemente incoraggiato a contattare Roy Marples (roy [at] marples.name) e Diego Pettenò (flameeyes [at] gmail.com).

[5] AS NEEDED (03.10)
Siccome le nuove binutils permettono di forzare globalmente il supporto a as-needed tramite LD_AS_NEEDED="1", e considerando il fatto che i bug report inerenti i pacchetti che non compilano con -Wl,--as-needed sono prossimi allo zero, il Team di sviluppo Gentoo ha deciso di aggiungere il supporto as-needed come default a tutti i profili developer (default/linux/*/*/developer); questo vuol dire che as-needed è ritenuta dagli stessi sviluppatori Gentoo una feature matura e quindi, con molta probabilità, presto sarà un candidato ideale per i valori di default anche per i profili degli utenti Gentoo, con tutti i vantaggi che ne conseguono.

[last rites]
Il Gentoo Tree Cleaning Team segnala che i seguenti pacchetti verranno rimossi dal tree di portage entro 30 giorni:

# Gilles Dartiguelongue gentoo.org> (8 Oct 2009)
# Obsolete. Supported by in-kernel driver qspca_stv06xx.
# Masked for removal, see bug #286818.
media-video/qc-usb

chi fa uso di uno o più dei pacchetti sopra citati è fortemente incoraggiato a trovare alternative oppure a contribuire al loro mantenimento.

----

Puoi seguire i GeCHI Weekly Report tramite i seguenti canali:
- gechi.it RSS Feed;
- Twitter: GeCHI Group | GeCHI RSS Feeds;
- Identi.ca: GeCHI Group | GeCHI RSS Feeds;
- Facebook;

_________________
Drink more beer, save water
P u n X the system
and support http://freenetproject.org!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum