Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] libXtst and docbook-xml-dtd driving me crazy
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
GD
Tux's lil' helper
Tux's lil' helper


Joined: 11 May 2005
Posts: 125
Location: Greece

PostPosted: Tue Feb 23, 2010 5:13 pm    Post subject: [SOLVED] libXtst and docbook-xml-dtd driving me crazy Reply with quote

I'm aware of the libXtst issue not compiling because of some docbook-xml-dtd dependency. The problem is that the issue reappears as randomly as it is resolved.

I managed to get libXtst to compile by emerging docbook-xml-dtd:4.3 at some point (although I had tried a lot of stuff before that so I'm not sure that that's what fixed it). Anyway I'm getting failures again:

Code:
config.status: creating config.h
config.status: executing depfiles commands
config.status: executing libtool commands
>>> Source configured.
>>> Compiling source in /var/tmp/portage/x11-libs/libXtst-9999/work/libXtst-9999 ...
make -j3
make  all-recursive
make[1]: Entering directory `/var/tmp/portage/x11-libs/libXtst-9999/work/libXtst-9999'
Making all in src
make[2]: Entering directory `/var/tmp/portage/x11-libs/libXtst-9999/work/libXtst-9999/src'
/bin/sh ../libtool --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..    -I../include -I../include/X11/extensions  -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -Wbad-function-cast -Wformat=2 -Wold-style-definition -Wdeclaration-after-statement  -march=core2 -O2 -pipe -fomit-frame-pointer -MT XRecord.lo -MD -MP -MF .deps/XRecord.Tpo -c -o XRecord.lo XRecord.c
/bin/sh ../libtool --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..    -I../include -I../include/X11/extensions  -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -Wbad-function-cast -Wformat=2 -Wold-style-definition -Wdeclaration-after-statement  -march=core2 -O2 -pipe -fomit-frame-pointer -MT XTest.lo -MD -MP -MF .deps/XTest.Tpo -c -o XTest.lo XTest.c
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -I../include -I../include/X11/extensions -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -Wbad-function-cast -Wformat=2 -Wold-style-definition -Wdeclaration-after-statement -march=core2 -O2 -pipe -fomit-frame-pointer -MT XRecord.lo -MD -MP -MF .deps/XRecord.Tpo -c XRecord.c  -fPIC -DPIC -o .libs/XRecord.o
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -I../include -I../include/X11/extensions -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -Wbad-function-cast -Wformat=2 -Wold-style-definition -Wdeclaration-after-statement -march=core2 -O2 -pipe -fomit-frame-pointer -MT XTest.lo -MD -MP -MF .deps/XTest.Tpo -c XTest.c  -fPIC -DPIC -o .libs/XTest.o
mv -f .deps/XTest.Tpo .deps/XTest.Plo
mv -f .deps/XRecord.Tpo .deps/XRecord.Plo
/bin/sh ../libtool --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc -I../include -I../include/X11/extensions  -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -Wbad-function-cast -Wformat=2 -Wold-style-definition -Wdeclaration-after-statement  -march=core2 -O2 -pipe -fomit-frame-pointer -version-number 6:1:0 -no-undefined -Wl,-O1,--as-needed -o libXtst.la -rpath /usr/lib64 XRecord.lo XTest.lo -lX11 -lXext -lXi   
libtool: link: x86_64-pc-linux-gnu-gcc -shared  .libs/XRecord.o .libs/XTest.o   /usr/lib64/libXi.so -L/usr/lib64 /usr/lib64/libXext.so /usr/lib64/libX11.so /usr/lib64/libxcb.so /usr/lib64/libXau.so /usr/lib64/libXdmcp.so -ldl  -march=core2 -Wl,-O1 -Wl,--as-needed   -Wl,-soname -Wl,libXtst.so.6 -o .libs/libXtst.so.6.1.0
libtool: link: (cd ".libs" && rm -f "libXtst.so.6" && ln -s "libXtst.so.6.1.0" "libXtst.so.6")
libtool: link: (cd ".libs" && rm -f "libXtst.so" && ln -s "libXtst.so.6.1.0" "libXtst.so")
libtool: link: ( cd ".libs" && rm -f "libXtst.la" && ln -s "../libXtst.la" "libXtst.la" )
make[2]: Leaving directory `/var/tmp/portage/x11-libs/libXtst-9999/work/libXtst-9999/src'
Making all in man
make[2]: Entering directory `/var/tmp/portage/x11-libs/libXtst-9999/work/libXtst-9999/man'
/usr/bin/xmlto man XTest.xml
xmlto: /var/tmp/portage/x11-libs/libXtst-9999/work/libXtst-9999/man/XTest.xml does not validate (status 3)
xmlto: Fix document syntax or use --skip-validation option
I/O error : Attempt to load network entity http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd
/var/tmp/portage/x11-libs/libXtst-9999/work/libXtst-9999/man/XTest.xml:3: warning: failed to load external entity "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd"
                   "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd">
                                                                              ^
/var/tmp/portage/x11-libs/libXtst-9999/work/libXtst-9999/man/XTest.xml:223: parser error : Entity 'mdash' not defined
&mdash; <structname>GC</structname>s
       ^
/var/tmp/portage/x11-libs/libXtst-9999/work/libXtst-9999/man/XTest.xml:225: parser error : Entity 'mdash' not defined
<structname>Visual</structname>s &mdash;
                                        ^
I/O error : Attempt to load network entity http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd
warning: failed to load external entity "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd"
validity error : Could not load the external subset "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd"
Document /var/tmp/portage/x11-libs/libXtst-9999/work/libXtst-9999/man/XTest.xml does not validate
make[2]: *** [x.stamp] Error 13
make[2]: Leaving directory `/var/tmp/portage/x11-libs/libXtst-9999/work/libXtst-9999/man'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-libs/libXtst-9999/work/libXtst-9999'
make: *** [all] Error 2


and no matter how many times I uninstall and reinstall various versions of docbook-xml-dtd I can't get it to work again. I'm using libXtst-9999 from the x11 overlay.

Has anyone ever gotten to the bottom of this? Is there a reproducible solution to this problem? Here's a related bugzilla entry:
http://bugs.gentoo.org/292151


Last edited by GD on Wed Feb 24, 2010 5:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2000
Location: Finland

PostPosted: Tue Feb 23, 2010 5:40 pm    Post subject: Re: libXtst and docbook-xml-dtd driving me crazy Reply with quote

GD wrote:

xmlto: /var/tmp/portage/x11-libs/libXtst-9999/work/libXtst-9999/man/XTest.xml does not validate (status 3)
xmlto: Fix document syntax or use --skip-validation option
I/O error : Attempt to load network entity http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd
/var/tmp/portage/x11-libs/libXtst-9999/work/libXtst-9999/man/XTest.xml:3: warning: failed to load external entity "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd"
"http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd">


You might get it worked around by adding:

sed -i -e 's:$(XMLTO):$(XMLTO) --skip-validation:' man/Makefile.am

to src_prepare() function of the ebuild

or

emerge app-text/docbook-xml-dtd:4.1.2

Good luck
Back to top
View user's profile Send private message
GD
Tux's lil' helper
Tux's lil' helper


Joined: 11 May 2005
Posts: 125
Location: Greece

PostPosted: Wed Feb 24, 2010 1:26 pm    Post subject: Reply with quote

Works like a charm... I was pretty sure it was version 4.3 that fixed it last time but apparently I was wrong :-D
Back to top
View user's profile Send private message
hkmaly
n00b
n00b


Joined: 13 Jul 2006
Posts: 20

PostPosted: Sat Sep 28, 2013 9:10 pm    Post subject: Reply with quote

GD wrote:
Works like a charm... I was pretty sure it was version 4.3 that fixed it last time but apparently I was wrong :-D


Not necessary. I've just got similar error with version 4.5 and successfully fixed it by upgrading app-text/docbook-xml-dtd:4.5. Apparently multiple or possibly all versions of app-text/docbook-xml-dtd needs to be reinstalled from time to time. So, previously it could've been 4.3 with error message being I/O error : Attempt to load network entity http://www.oasis-open.org/docbook/xml/4.3/docbookx.dtd etc ...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum