Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kde-sunset support (KDE-3.5.x) thread.<my issue resolved>
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
pappy_mcfae
Watchman
Watchman


Joined: 27 Dec 2007
Posts: 5919
Location: Pomona, California.

PostPosted: Sun Feb 07, 2010 12:23 am    Post subject: kde-sunset support (KDE-3.5.x) thread.<my issue resolved& Reply with quote

Sometimes, one must take the proverbial bull by the horns. Since I feel there needs to be a kde-sunset support discussion thread, I throw this offering out to the ether hoping that there is an interest for it. Since I do note that there are changes in layman when syncing kde-sunset, I also have to assume that KDE-3.5.x is far from dead. Maybe it could go sticky with enough interest. |wink, wink, nudge, nudge, say no more|

Now, with that out of the way, I have an issue with kde-sunset and poppler-0.12.3-r3. When attempting to emerge, The source gets configured, then sandbox complains about an access violation, vis a vis:
Code:
VERSION 1.0
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: open_wr
S: deny
P: /usr/qt/3/etc/settings/.qtrc.lock
A: /usr/qt/3/etc/settings/.qtrc.lock
R: /usr/qt/3/etc/settings/.qtrc.lock
C: /usr/qt/3/bin/uic -version


The full emerge log:
Code:
>>> Emerging (1 of 1) app-text/poppler-0.12.3-r3 from kde-sunset
 * poppler-0.12.3.tar.gz RMD160 SHA1 SHA256 size ;-) ...                 [ ok ]
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]
 * CPV:  app-text/poppler-0.12.3-r3
 * REPO: kde-sunset
 * USE:  amd64 cairo elibc_glibc jpeg kernel_linux lcms multilib png qt3 userland_GNU utils xpdf-headers
>>> Unpacking source...
>>> Unpacking poppler-0.12.3.tar.gz to /var/tmp/portage/app-text/poppler-0.12.3-r3/work
>>> Source unpacked in /var/tmp/portage/app-text/poppler-0.12.3-r3/work
>>> Preparing source in /var/tmp/portage/app-text/poppler-0.12.3-r3/work/poppler-0.12.3 ...
 * Applying poppler-0.12.3-cmake-disable-tests.patch ...                  [ ok ]
 * Applying poppler-0.12.3-fix-headers-installation.patch ...             [ ok ]
 * Applying poppler-0.12.3-gdk.patch ...                                  [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/app-text/poppler-0.12.3-r3/work/poppler-0.12.3 ...
>>> Working in BUILD_DIR: "/var/tmp/portage/app-text/poppler-0.12.3-r3/work/poppler-0.12.3_build"
cmake -C /var/tmp/portage/app-text/poppler-0.12.3-r3/temp/gentoo_common_config.cmake -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_GTK_TESTS=OFF -DBUILD_QT4_TESTS=OFF -DWITH_qt3=ON -DWITH_QT3=ON -DWITH_Qt3=ON -DENABLE_SPLASH=ON -DENABLE_ZLIB=ON -DENABLE_abiword=OFF -DENABLE_ABIWORD=OFF -DENABLE_Abiword=OFF -DENABLE_lcms=ON -DENABLE_LCMS=ON -DENABLE_Lcms=ON -DENABLE_LIBOPENJPEG=OFF -DENABLE_utils=ON -DENABLE_UTILS=ON -DENABLE_Utils=ON -DENABLE_XPDF_HEADERS=ON -DWITH_cairo=ON -DWITH_CAIRO=ON -DWITH_Cairo=ON -DWITH_GTK=ON -DWITH_jpeg=ON -DWITH_JPEG=ON -DWITH_Jpeg=ON -DWITH_png=ON -DWITH_PNG=ON -DWITH_Png=ON -DWITH_qt4=OFF -DWITH_QT4=OFF -DWITH_Qt4=OFF -DUSE_EXCEPTIONS=OFF -DCMAKE_BUILD_TYPE=Gentoo -DCMAKE_INSTALL_DO_STRIP=OFF -DCMAKE_USER_MAKE_RULES_OVERRIDE=/var/tmp/portage/app-text/poppler-0.12.3-r3/temp/gentoo_rules.cmake /var/tmp/portage/app-text/poppler-0.12.3-r3/work/poppler-0.12.3
loading initial cache file /var/tmp/portage/app-text/poppler-0.12.3-r3/temp/gentoo_common_config.cmake
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Found Freetype: /usr/lib64/libfreetype.so
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found Fontconfig: /usr/lib64/libfontconfig.so
-- Found JPEG: /usr/lib64/libjpeg.so
-- Found ZLIB: /lib64/libz.so
-- Found PNG: /usr/lib64/libpng.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib64/libX11.so
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found GLib: -lglib-2.0
-- Found GDK: -lgdk-x11-2.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -lglib-2.0
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found GTK: -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lglib-2.0;-lgdk_pixbuf-2.0 -lgobject-2.0 -lgmodule-2.0 -lglib-2.0;-pthread -lgthread-2.0 -lrt -lglib-2.0
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found Cairo: -lcairo
-- checking for module 'lcms'
--   found lcms, version 1.19
-- Found lcms version 1.19, /usr/lib64/liblcms.so
-- Looking for include files HAVE_DLFCN_H
-- Looking for include files HAVE_DLFCN_H - found
-- Looking for include files HAVE_INTTYPES_H
-- Looking for include files HAVE_INTTYPES_H - found
-- Looking for include files HAVE_MEMORY_H
-- Looking for include files HAVE_MEMORY_H - found
-- Looking for include files HAVE_STDINT_H
-- Looking for include files HAVE_STDINT_H - found
-- Looking for include files HAVE_STDLIB_H
-- Looking for include files HAVE_STDLIB_H - found
-- Looking for include files HAVE_STRINGS_H
-- Looking for include files HAVE_STRINGS_H - found
-- Looking for include files HAVE_STRING_H
-- Looking for include files HAVE_STRING_H - found
-- Looking for include files HAVE_SYS_STAT_H
-- Looking for include files HAVE_SYS_STAT_H - found
-- Looking for include files HAVE_SYS_TYPES_H
-- Looking for include files HAVE_SYS_TYPES_H - found
-- Looking for include files HAVE_UNISTD_H
-- Looking for include files HAVE_UNISTD_H - found
-- Looking for fseek64
-- Looking for fseek64 - not found
-- Looking for fseeko
-- Looking for fseeko - found
-- Looking for ftell64
-- Looking for ftell64 - not found
-- Looking for gettimeofday
-- Looking for gettimeofday - found
-- Looking for popen
-- Looking for popen - found
-- Looking for mkstemp
-- Looking for mkstemp - found
-- Looking for mkstemps
-- Looking for mkstemps - found
-- Performing Test HAVE_DIRENT_H
-- Performing Test HAVE_DIRENT_H - Success
-- Performing Test HAVE_NDIR_H
-- Performing Test HAVE_NDIR_H - Failed
-- Performing Test HAVE_SYS_DIR_H
-- Performing Test HAVE_SYS_DIR_H - Success
-- Performing Test HAVE_SYS_NDIR_H
-- Performing Test HAVE_SYS_NDIR_H - Failed
Building Poppler with support for:
  splash output:        yes
  cairo output:         yes
  abiword output:       no
  qt wrapper:           yes
  qt4 wrapper:          no
  glib wrapper:         yes
  use libjpeg:          yes
  use libpng:           yes
  use zlib:             yes
  use libopenjpeg:      no
  use cms:              yes
  command line utils:   yes
-- <<< Gentoo configuration >>>
Build type: Gentoo
Install path: /usr

-- Configuring done
-- Generating done
-- Build files have been written to: /var/tmp/portage/app-text/poppler-0.12.3-r3/work/poppler-0.12.3_build
>>> Source configured.
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE "/var/log/sandbox/sandbox-25899.log"

VERSION 1.0
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: open_wr
S: deny
P: /usr/qt/3/etc/settings/.qtrc.lock
A: /usr/qt/3/etc/settings/.qtrc.lock
R: /usr/qt/3/etc/settings/.qtrc.lock
C: /usr/qt/3/bin/uic -version
--------------------------------------------------------------------------------

>>> Failed to emerge app-text/poppler-0.12.3-r3, Log file:

>>>  '/var/tmp/portage/app-text/poppler-0.12.3-r3/temp/build.log'
 *
 * The following package has failed to build or install:
 *
 *  ('ebuild', '/', 'app-text/poppler-0.12.3-r3', 'merge'), Log file:
 *   '/var/tmp/portage/app-text/poppler-0.12.3-r3/temp/build.log'
 *


The emerge --info:
Code:
emerge --info
Portage 2.2_rc62 (default/linux/amd64/10.0, gcc-4.3.2, glibc-2.11-r1, 2.6.30-zen11 x86_64)
=================================================================
System uname: Linux-2.6.30-zen11-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E6550_@_2.33GHz-with-gentoo-2.0.1
Timestamp of tree: Sat, 06 Feb 2010 23:00:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:     4.0_p37
dev-java/java-config: 1.3.7-r1, 2.1.10
dev-lang/python:     2.6.4-r1, 3.1.1-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.8.0-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.0-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20
sys-devel/gcc:       4.3.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=core2 -pipe"
DISTDIR="/mnt/seeds/storage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/portage/layman/kde-sunset"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 apache2 audiofile avi bash-completion berkdb bitmap-fonts bzip2 cairo cdr cli cracklib crypt css ctype cups cxx dbus dlloader dri drm dvd dvdr dvdread emboss encode fam ffmpeg fftw filter flac foomaticdb fortran gdbm gif glib gnutls gpm gsl gtk hal iconv jpeg kde kdgraphics ladspa lame ldap libsamplerate libwww live lm_sensors mad mikmod mmx modules mp3 mpeg mudflap multilib mysql nas ncurses nls nptl nptlonly objc ogg opengl openmp pam pcre pdcre pdf pdflib perl php png ppds pppd python qt3 qt3support quicktime readline reflection samba sdl session slang slp sndfile spell spl sqlite sse sse2 ssl ssse3 svg swat sysfs tcpd theora tiff truetype udev unicode v4l v4l2 vhosts vorbis wxwindows x264 xml xorg xscreensaver xv xvid zlib" ALSA_CARDS="ice1712" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia v4l"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Blessed be!
Pappy
_________________
This space left intentionally blank, except for these ASCII symbols.


Last edited by pappy_mcfae on Fri Feb 12, 2010 9:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
pappy_mcfae
Watchman
Watchman


Joined: 27 Dec 2007
Posts: 5919
Location: Pomona, California.

PostPosted: Mon Feb 08, 2010 12:13 am    Post subject: Reply with quote

BUMP!
_________________
This space left intentionally blank, except for these ASCII symbols.
Back to top
View user's profile Send private message
Dont Panic
Guru
Guru


Joined: 20 Jun 2007
Posts: 320
Location: SouthEast U.S.A.

PostPosted: Fri Feb 12, 2010 4:04 am    Post subject: Reply with quote

I wonder if this is an amd64/x86 issue. It's building fine for me.

About the only noteworthy differences I see (other than the major difference of being x86 on my box) is I'm building with +qt4, and I'm using sys-devel/gcc-4.4.2.

My sandbox version seems to be the same as your sandbox version (sys-apps/sandbox-2.2)
Back to top
View user's profile Send private message
pappy_mcfae
Watchman
Watchman


Joined: 27 Dec 2007
Posts: 5919
Location: Pomona, California.

PostPosted: Fri Feb 12, 2010 4:49 am    Post subject: Reply with quote

Considering it built fine on the x86 machines, yes, that is a fair assessment. The assessment doesn't fix the machine, but it does narrow the search field a bit...I hope.

BUMP!

BB!
P
_________________
This space left intentionally blank, except for these ASCII symbols.
Back to top
View user's profile Send private message
AlanR
n00b
n00b


Joined: 05 Mar 2004
Posts: 7

PostPosted: Fri Feb 12, 2010 8:33 am    Post subject: Reply with quote

I'm having the same compile error with poppler. I have two amd64 systems, one AMD the other Intel. Both are KDE 4.3.3, the Intel box has kde-sunset (for Quanta+) and is exhibiting this compile problem with poppler; the AMD without kde-sunset is not.
Back to top
View user's profile Send private message
pappy_mcfae
Watchman
Watchman


Joined: 27 Dec 2007
Posts: 5919
Location: Pomona, California.

PostPosted: Fri Feb 12, 2010 8:42 am    Post subject: Reply with quote

I'd write a bug report, but it would get rejected out of hand as it seems that kde-sunset is the cause of my issues. So, I keep hoping that someone will happen along who might know better what's going on. Considering all the updates that come to the kde-sunset, I'm sure that someone is out there.

Amazingly, if I compile without the qt3 USE flag, it compiles as expected. I've done so until the true issue is found.

BB!
P
_________________
This space left intentionally blank, except for these ASCII symbols.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5729
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Feb 12, 2010 9:30 am    Post subject: Reply with quote

pappy_mcfae wrote:
I'd write a bug report, but it would get rejected out of hand as it seems that kde-sunset is the cause of my issues. So, I keep hoping that someone will happen along who might know better what's going on. Considering all the updates that come to the kde-sunset, I'm sure that someone is out there.

Amazingly, if I compile without the qt3 USE flag, it compiles as expected. I've done so until the true issue is found.

BB!
P


just tag the bug-report as [kde-sunset] (prefixing it)

I did the same with the kde / kde-testing overlay and it worked out nicely


aren't the people maintaining it from the kde herd anyway ?
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.3.0-r2
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2132
Location: Finland

PostPosted: Fri Feb 12, 2010 9:37 am    Post subject: Reply with quote

kernelOfTruth wrote:
pappy_mcfae wrote:
I'd write a bug report, but it would get rejected out of hand as it seems that kde-sunset is the cause of my issues. So, I keep hoping that someone will happen along who might know better what's going on. Considering all the updates that come to the kde-sunset, I'm sure that someone is out there.

Amazingly, if I compile without the qt3 USE flag, it compiles as expected. I've done so until the true issue is found.

BB!
P


just tag the bug-report as [kde-sunset] (prefixing it)

I did the same with the kde / kde-testing overlay and it worked out nicely


aren't the people maintaining it from the kde herd anyway ?


nope, it's not maintained by any of gentoo developers, only users, so all bugs get a "resolved, invalid" tag

the poppler ebuild is likely missing "inherit qt3" for the sandbox failure

EDIT: http://git.overlays.gentoo.org/gitweb/?p=proj/kde-sunset.git;a=blob;f=Documentation/README
Back to top
View user's profile Send private message
Dont Panic
Guru
Guru


Joined: 20 Jun 2007
Posts: 320
Location: SouthEast U.S.A.

PostPosted: Fri Feb 12, 2010 2:25 pm    Post subject: Reply with quote

ssuominen is correct about the app-text/poppler-0.12.3-r3.ebuild lacking 'qt3' in the inherit line:
Code:
inherit cmake-utils

Running 'layman -i kde-sunset' gives the contact as the gentoo-desktop mailing list.

I wonder if it is acceptable to send bug reports there?
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2132
Location: Finland

PostPosted: Fri Feb 12, 2010 2:34 pm    Post subject: Reply with quote

Dont Panic wrote:
ssuominen is correct about the app-text/poppler-0.12.3-r3.ebuild lacking 'qt3' in the inherit line:
Code:
inherit cmake-utils

Running 'layman -i kde-sunset' gives the contact as the gentoo-desktop mailing list.

I wonder if it is acceptable to send bug reports there?


Yep, gentoo-desktop mailing list is correct place

EDIT: Also you can try some of the maintainers directly: http://git.overlays.gentoo.org/gitweb/?p=proj/kde-sunset.git;a=blob_plain;f=Documentation/commiters;hb=HEAD
Back to top
View user's profile Send private message
pappy_mcfae
Watchman
Watchman


Joined: 27 Dec 2007
Posts: 5919
Location: Pomona, California.

PostPosted: Fri Feb 12, 2010 9:54 pm    Post subject: Reply with quote

ssuominen wrote:
the poppler ebuild is likely missing "inherit qt3" for the sandbox failure


We have a winner! That was the issue. Thanks. Solved

Blessed be!
Pappy
_________________
This space left intentionally blank, except for these ASCII symbols.
Back to top
View user's profile Send private message
AlanR
n00b
n00b


Joined: 05 Mar 2004
Posts: 7

PostPosted: Sat Feb 13, 2010 3:54 am    Post subject: Reply with quote

ssuominen wrote:
the poppler ebuild is likely missing "inherit qt3" for the sandbox failure



Thanks for that, cleared it right up for me, too!
Back to top
View user's profile Send private message
BitJam
Advocate
Advocate


Joined: 12 Aug 2003
Posts: 2454
Location: Silver City, NM

PostPosted: Mon Mar 08, 2010 1:14 am    Post subject: Reply with quote

Emerging world is blocked by the poppler qt3 flag:
Code:
# emerge -av -uDN world   

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=app-text/poppler-0.12.3-r3[qt3]".
!!! One of the following packages is required to complete your request:
- app-text/poppler-0.12.3-r3 (Change USE: +qt3)
(dependency required by "kde-base/kpdf-3.5.10-r3" [ebuild])
(dependency required by "@world" [argument])


Code:
# emerge -pv poppler

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] app-text/poppler-0.12.3-r3  USE="abiword cairo jpeg lcms png qt4 utils xpdf-headers -cjk -debug -doc -exceptions -jpeg2k (-qt3)" 0 kB [1]

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /var/lib/layman/kde-sunset


Code:
# emerge --info
Portage 2.2_rc65 (default/linux/amd64/10.0/desktop, gcc-4.1.2, glibc-2.10.1-r1, 2.6.30-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.30-gentoo-r5-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5200+-with-gentoo-1.12.13
Timestamp of tree: Sun, 07 Mar 2010 23:30:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     4.0_p35
dev-java/java-config: 2.1.9-r2
dev-lang/python:     2.5.4-r3, 2.6.4
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.8.0-r1
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       4.1.2, 4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 PUEL"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.datapipe.net/gentoo     http://chi-10g-1-mirror.fastsoft.net/pub/linux/gentoo/gentoo-distfiles/     http://gentoo.netnitco.net http://gentoo.mirrors.hoobly.com/     ftp://mirror.iawnet.sandia.gov/pub/gentoo/"
LANG="en_US"
LC_ALL="C"
LDFLAGS="-Wl,-O1"
LINGUAS="en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/lightscribe /var/lib/layman/kde-sunset /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acpi alsa amarok amd64 bash-completion berkdb branding bzip2 cairo cddb cdparanoia cdr cli consolekit cracklib crypt cups cxx dbus djvu dri dts dvd dvdnav dvdr dvdread eds emboss emovix encode evo exif fam fbcon ffmpeg firefox flac fortran gdbm gif glitz gmp gpm gstreamer hal iconv id3 ieee1394 imagemagick java jpeg kde kdexdeltas kpathsea libnotify libwww lm_sensors logitech-mouse mad mikmod mmx mmxext mng modules mp3 mp4 mpeg mplayer mudflap multilib musicbrainz ncurses nls nptl nptlonly nsplugin objc ogg opengl openmp pam pcre pdf perl plotutils png ppds pppd python qt3support qt4 quicktime readline reflection ruby sdl semantic-desktop session sockets spell spl sse sse2 ssl startup-notification svg sysfs tcltk tcpd tetex thunar tidy tiff tk truetype unicode usb vdpau vim-pager vim-syntax vorbis x264 xcomposite xetex xine xinerama xml xorg xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm     authn_default authn_file authz_dbm authz_default authz_groupfile authz_host     authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache     env expires ext_filter file_cache filter headers ident imagemap include info     log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer     proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack     vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 8006

PostPosted: Mon Mar 08, 2010 5:51 am    Post subject: Reply with quote

BitJam wrote:
Emerging world is blocked by the poppler qt3 flag:
Code:
echo -qt3 >> /etc/portage/profile/use.mask
Note that attempting to override the masking of the flag in the base profile of an overlay does not work, though that was evidently the intended manner of avoiding the mask.
Back to top
View user's profile Send private message
BitJam
Advocate
Advocate


Joined: 12 Aug 2003
Posts: 2454
Location: Silver City, NM

PostPosted: Mon Mar 08, 2010 6:01 am    Post subject: Reply with quote

Thank you desultory! That got me around the problem and I'm emerging world now.
Back to top
View user's profile Send private message
Nil_Spaar
Apprentice
Apprentice


Joined: 10 Jul 2004
Posts: 179
Location: Berlin, Germany

PostPosted: Sun Mar 14, 2010 12:52 am    Post subject: Reply with quote

Thank you. I had the same problem as BitJam and no idea how to fix it.
But one trip to the good old forum and now I have the solution :)
Back to top
View user's profile Send private message
Kate Monster
Apprentice
Apprentice


Joined: 13 Jun 2006
Posts: 222
Location: Clarkston, Michigan

PostPosted: Wed Mar 31, 2010 1:09 pm    Post subject: Reply with quote

The topic read "kde-sunset support thread" so I hope noone minds I use it...

Since I updated world a few weeks ago and KDE 3.5 was re-merged with packages from kde-sunset, I've had some bugs and I wonder if it's just me.

When attempting to use my ipod(nano 1st gen) with Amarok I get a crash. Going under settings, devices then next to the ipod mass storage device changing the drop-down box to "Apple Ipod" and hitting apply causes an insta-crash, but unfortunately all I see printed is "Segmentation fault". I've never tried debugging before, do I need to emerge just KDE3 with USE=+debug or all of world?

Kmail also crashes, when trying to send email. I think that this issue is simpler though, it somehow seems to think there is a message in the outbox, when there isn't, and trying to delete or move that message causes an instant crash. I backed up my mail(not including outbox of course) and rm -r'ed the kmail maildir, but it still thinks there's a message there. Is there another directory somewhere I need to delete as well?
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2109
Location: Near Toronto

PostPosted: Thu May 06, 2010 12:40 am    Post subject: Reply with quote

Does anyone know why there is no ebuild of kbibtex in kde-sunset?
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
Dont Panic
Guru
Guru


Joined: 20 Jun 2007
Posts: 320
Location: SouthEast U.S.A.

PostPosted: Mon May 17, 2010 7:04 pm    Post subject: Reply with quote

I think qt:3 is incompatible with media-libs/libpng-1.4.2.

I've upgraded one of my installations that still had KDE-3 to libpng14, and qt:3 is one of the few remaining packages I have that is failing regularly.

Code:
kernel/qpngio.cpp:165: error: ‘struct png_info_struct’ has no member named ‘trans_values’


I checked another box that has media-libs/libpng-1.2.40 installed, and /usr/include/png.h does have a ‘trans_values’ member in ‘struct png_info_struct’, while the png.h with libpng14 no longer appears to have this member.
Back to top
View user's profile Send private message
BitJam
Advocate
Advocate


Joined: 12 Aug 2003
Posts: 2454
Location: Silver City, NM

PostPosted: Mon May 17, 2010 7:19 pm    Post subject: Reply with quote

After using KDE exclusively for > 10 years, I've started using Enlightenment e16 (not e17 which reminds me of KDE-4) instead. It took some work to customize but I've found it to be a good KDE-3 work-alike. In fact, I find e16 to be an improvement in many ways. YMMVG. When I get a round-tuit, I will write a KDE-3 => e16 howto.
Back to top
View user's profile Send private message
pappy_mcfae
Watchman
Watchman


Joined: 27 Dec 2007
Posts: 5919
Location: Pomona, California.

PostPosted: Mon May 17, 2010 7:26 pm    Post subject: Reply with quote

I'd be interested in reading that.

Cheers,
Pappy
_________________
This space left intentionally blank, except for these ASCII symbols.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5729
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue May 18, 2010 12:28 am    Post subject: Reply with quote

pappy_mcfae wrote:
I'd be interested in reading that.

Cheers,
Pappy


++

yes please :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.3.0-r2
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
BitJam
Advocate
Advocate


Joined: 12 Aug 2003
Posts: 2454
Location: Silver City, NM

PostPosted: Tue May 18, 2010 2:35 am    Post subject: Reply with quote

I expect to be very busy until the end of this week so I wrote up something quick and dirty to get you started. There is probably enough information there to get you into a week's worth of trouble/fun.

KDE-3 ==> e16 HOWTO
Back to top
View user's profile Send private message
pappy_mcfae
Watchman
Watchman


Joined: 27 Dec 2007
Posts: 5919
Location: Pomona, California.

PostPosted: Tue May 18, 2010 5:22 am    Post subject: Reply with quote

Interesting. I'll have to peruse it more a bit later.

Cheers,
Pappy
_________________
This space left intentionally blank, except for these ASCII symbols.
Back to top
View user's profile Send private message
Dont Panic
Guru
Guru


Joined: 20 Jun 2007
Posts: 320
Location: SouthEast U.S.A.

PostPosted: Fri May 21, 2010 2:14 pm    Post subject: Reply with quote

It took me a few days to get back to it, but I see where my issue with qt-3 and libpng-1.4 was solved in an updated commit to the kde-sunset overlay with a libpng-1.4 patch.

[kde-sunset] x11-libs/qt-3.3.8b fails to build with libpng-1.4 because a patch is not being applied

Thanks Ladislav for getting that into the overlay. :)

It's re-assuring to see some activity in patching issues as they come up.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum