Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] dev-texlive/texlive-basic-2010 fails to update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
c00l.wave
Apprentice
Apprentice


Joined: 24 Aug 2003
Posts: 219

PostPosted: Thu Sep 15, 2011 3:14 pm    Post subject: [SOLVED] dev-texlive/texlive-basic-2010 fails to update Reply with quote

On a world update I got the known errors of a missing file "dehypht-x-2009-06-19.tex" vaguely explained here and here while trying to build dev-texlive/texlive-basic-2010. I unmerged all dev-texlive/* packages as well as app-text/texlive-core, virtual/latex-base, virtual/tex-base, virtual/texi2dvi, app-text/texlive, app-text/texlive-core and deleted /etc/texmf and /usr/share/texmf*, so I should have had a clean start (according to the other thread, that's the only thing that solves the problem, although this is highly radical).

Now, if I try to emerge texlive I run into another strange error with dev-texlive/texlive-basic-2010 after app-text/texlive-core-2010-r4 and dev-texlive/texlive-documentation-base have been merged:
Code:
>>> Compiling source in /var/tmp/portage/dev-texlive/texlive-basic-2010/work ...
 * Appending to format.texlive-basic.cnf for   name=dviluatex engine=luatex patterns=language.def,language.dat.lua   options="dviluatex.ini"
 * Appending to format.texlive-basic.cnf for   name=luatex    engine=luatex patterns=language.def,language.dat.lua   options="luatex.ini"
 * Appending to format.texlive-basic.cnf for name=mf engine=mf-nowin options="-translate-file=cp227.tcx mf.ini"
 * Appending to format.texlive-basic.cnf for name=etex    engine=pdftex patterns=language.def                     options="-translate-file=cp227.tcx *etex.ini"
 * Appending to format.texlive-basic.cnf for name=pdfetex engine=pdftex patterns=language.def                     options="-translate-file=cp227.tcx *pdfetex.ini"
 * Appending to format.texlive-basic.cnf for name=pdftex  engine=pdftex patterns=language.def                     options="-translate-file=cp227.tcx *pdfetex.ini"
 * Appending to format.texlive-basic.cnf for name=tex engine=tex options="tex.ini"
 * Building format texmf/fmtutil/format.texlive-basic.cnf
fmtutil: format directory `/var/tmp/portage/dev-texlive/texlive-basic-2010/work/texmf-var/web2c' does not exist.
 * ERROR: dev-texlive/texlive-basic-2010 failed (compile phase):
 *   failed to build format texmf/fmtutil/format.texlive-basic.cnf
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 2378:  Called texlive-module_src_compile
 *   environment, line 2984:  Called die
 * The specific snippet of code:
 *               VARTEXFONTS="${T}/fonts" TEXMFHOME="${S}/texmf:${S}/texmf-dist:${S}/texmf-var" env -u TEXINPUTS fmtutil --cnffile "${i}" --fmtdir "${S}/texmf-var/web2c" --all || die "failed to build format ${i}";
 *
 * If you need support, post the output of 'emerge --info =dev-texlive/texlive-basic-2010',
 * the complete build log and the output of 'emerge -pqv =dev-texlive/texlive-basic-2010'.
 * The complete build log is located at '/var/tmp/portage/dev-texlive/texlive-basic-2010/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-texlive/texlive-basic-2010/temp/environment'.
 * S: '/var/tmp/portage/dev-texlive/texlive-basic-2010/work'


So, texlive-basic is missing its own files inside the work-dir? Assuming the ebuild is not broken, how is that possible then?
_________________
nohup nice -n -20 cp /dev/urandom /dev/null &


Last edited by c00l.wave on Tue Sep 27, 2011 2:46 pm; edited 1 time in total
Back to top
View user's profile Send private message
c00l.wave
Apprentice
Apprentice


Joined: 24 Aug 2003
Posts: 219

PostPosted: Tue Sep 27, 2011 2:46 pm    Post subject: Reply with quote

There are at least two bug reports I had not found when I posted my question: https://bugs.gentoo.org/show_bug.cgi?id=379261 and https://bugs.gentoo.org/show_bug.cgi?id=379223

Comment 3 of the latter describes what needs to be done to get it working:

Quote:

Henrik Grubbström 2011-08-19 20:58:43 UTC
[...]
1) equery b -f '/etc/texmf/.*'
2) Uninstalling all of the above reported ebuilds.
3) rm -rf /etc/texmf
4) emerge texlive


I missed to remove some packages before running step 1 (app-text/xdvik, dev-libs/kpathsea and dev-tex/xmltex) which resulted in /etc/texmf being regenerated with some broken configs after deleting it. I also deleted /var/lib/texmf/ this time; I'm unsure if that matters. After I followed all of the steps above, additional to emerge -C `qlist -I -C dev-texlive/*` I was able to emerge texlive again.
_________________
nohup nice -n -20 cp /dev/urandom /dev/null &
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum