Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cups usb - Waiting for printer to become available
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
carpman
Advocate
Advocate


Joined: 20 Jun 2002
Posts: 2202
Location: London - UK

PostPosted: Mon Feb 01, 2010 6:27 pm    Post subject: cups usb - Waiting for printer to become available Reply with quote

Hello since latest updates i am having issues with my printer server.

It has usb printer that worked fine but now no connection?

i have blacklisted usblp but still printer displays in cups web cp
Code:

status
Processing - "Waiting for printer to become available..."


log show

Code:

D [01/Feb/2010:18:39:20 +0000] [Job 3260] usb_find_busses=0
D [01/Feb/2010:18:39:20 +0000] [Job 3260] usb_find_devices=0
D [01/Feb/2010:18:39:20 +0000] [Job 3260] STATE: +connecting-to-device
D [01/Feb/2010:18:39:20 +0000] Discarding unused printer-state-changed event...
D [01/Feb/2010:18:39:20 +0000] [Job 3260] STATE: -connecting-to-device
D [01/Feb/2010:18:39:20 +0000] Discarding unused printer-state-changed event...
I [01/Feb/2010:18:39:20 +0000] [Job 3260] Waiting for printer to become available...
D [01/Feb/2010:18:39:20 +0000] Discarding unused printer-state-changed event...
D [01/Feb/2010:18:39:20 +0000] Discarding unused job-progress event...


any ideas?

cheers
_________________
Work Station - 64bit
Gigabyte GA X48-DQ6 Core2duo E8400
8GB GSkill DDR2-1066
SATA Areca 1210 Raid
BFG OC2 8800 GTS 640mb
--------------------------------
Notebook
Samsung Q45 7100 4gb
Back to top
View user's profile Send private message
carpman
Advocate
Advocate


Joined: 20 Jun 2002
Posts: 2202
Location: London - UK

PostPosted: Tue Feb 02, 2010 12:11 pm    Post subject: Reply with quote

bit more info

Code:

lsusb
Bus 002 Device 003: ID 04b8:0007 Seiko Epson Corp. Printer
Bus 002 Device 002: ID 0424:0140 Standard Microsystems Corp.
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
caxton ~ # ls -l /dev/bus/usb/002/
total 0
crw-rw-r-- 1 root usb 189, 128 2010-02-02 11:36 001
crw-rw-r-- 1 root usb 189, 129 2010-02-02 11:36 002
crw-rw-r-- 1 root lp  189, 130 2010-02-02 11:36 003


So printer is there fine just cups 1.4 can't see it?
_________________
Work Station - 64bit
Gigabyte GA X48-DQ6 Core2duo E8400
8GB GSkill DDR2-1066
SATA Areca 1210 Raid
BFG OC2 8800 GTS 640mb
--------------------------------
Notebook
Samsung Q45 7100 4gb
Back to top
View user's profile Send private message
carpman
Advocate
Advocate


Joined: 20 Jun 2002
Posts: 2202
Location: London - UK

PostPosted: Tue Feb 02, 2010 1:02 pm    Post subject: Reply with quote

Downgrade to 1.3 works ok, just 1.4 does not !
_________________
Work Station - 64bit
Gigabyte GA X48-DQ6 Core2duo E8400
8GB GSkill DDR2-1066
SATA Areca 1210 Raid
BFG OC2 8800 GTS 640mb
--------------------------------
Notebook
Samsung Q45 7100 4gb
Back to top
View user's profile Send private message
baaann
Guru
Guru


Joined: 23 Jan 2006
Posts: 499
Location: uk

PostPosted: Tue Feb 02, 2010 2:45 pm    Post subject: Reply with quote

This bug provides various workarounds

http://bugs.gentoo.org/show_bug.cgi?id=285166

I retained usblp and used comment #12 for my Canon IP4000 as I also use libinklevel
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum