Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] target python3_3 not installing on stable keyword
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
kai.scorpio
n00b
n00b


Joined: 01 Sep 2011
Posts: 46

PostPosted: Thu Nov 07, 2013 2:48 pm    Post subject: [SOLVED] target python3_3 not installing on stable keyword Reply with quote

Hi all, a few questions regarding python_targets and keywords (on paludis, but not sure if that's relevant):

I want to install dev-python/werkzeug stable (0.9.3), but with python_targets: python3_3. I've set the following:

/etc/paludis/use.conf:
Code:

*/* PYTHON_TARGETS: -* python2_7 python3_2
dev-python/werkzeug PYTHON_TARGETS: python3_3


/etc/paludis/keywords.conf:
Code:

dev-lang/python:3.3 ~amd64


Then I do:
Code:
cave resolve dev-python/werkzeug

and it proceeds to install the stable version of werkzeug but without the python3_3 target.

I need to add the following to keywords.conf:
Code:
dev-python/werkzeug ~amd64

and then cave installs the correct target (or tries to and complains about a whole bunch of dependencies like setuptools, etc).

But that obviously pulls in the unstable version. I could unmask specifically 0.9.3, but I would like to use just the newest stable. Is there any reason why paludis considers the python3_3 target to be unstable, and how to I change that?


Last edited by kai.scorpio on Fri Nov 08, 2013 1:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Thu Nov 07, 2013 3:20 pm    Post subject: Reply with quote

According to portage, python3_3 is in parenthesis, which means that package does not support 3.3 yet
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
kai.scorpio
n00b
n00b


Joined: 01 Sep 2011
Posts: 46

PostPosted: Thu Nov 07, 2013 4:13 pm    Post subject: Reply with quote

The ebuild says otherwise: PYTHON_COMPAT( python{2_6,2_7,3_3} )

The problem actually is this file: /usr/portage/profiles/eapi-files/use.stable.mask
Code:
python_targets_python3_3


As far as I know there's no way to override this in paludis.
Back to top
View user's profile Send private message
kai.scorpio
n00b
n00b


Joined: 01 Sep 2011
Posts: 46

PostPosted: Fri Nov 08, 2013 1:49 pm    Post subject: Reply with quote

Solved by creating a folder in /etc/paludis/profile, and appending that to my repositories/gentoo.conf

The folder contains:
package.stable.mask
Code:
-python_targets_python3_3


eapi
Code:
5
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum