Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Pro-Audio ebuild and source fixes
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5246

PostPosted: Tue Dec 14, 2010 7:17 pm    Post subject: Reply with quote

http://www.ardour.org/building

This page is not complete, at least as far as Gentoo is concerned. In addition to the requirements listed on this page, you may need aubio. You will definitely require Wine.

I may write a better ebuild for 2.9999, which is the latest official version in the 2.x series (2.8.11, revision n, as of this post).

After manually emerging the requirements as stated on the Ardour build instructions page, I get:

Code:

[ebuild  N    ] media-libs/lv2core-4.0  0 kB [0]
[ebuild  N    ] media-libs/libsoundtouch-1.5.0  USE="sse2" 0 kB [0]
[ebuild  N    ] media-libs/vamp-plugin-sdk-2.1  USE="-doc" 0 kB [0]
[ebuild  N    ] dev-cpp/libgnomecanvasmm-2.26.0  USE="-debug -doc -examples" 0 kB [0]
[ebuild  N    ] dev-libs/rasqal-0.9.19  USE="pcre -gmp -test -xml" 0 kB [0]
[ebuild  N    ] dev-libs/redland-1.0.10-r2  USE="berkdb ssl -iodbc -mysql -odbc -postgres -sqlite -static-libs -xml" 0 kB [0]
[ebuild  N    ] media-libs/slv2-0.6.6  USE="jack -doc" 0 kB [0]
[ebuild  N    ] media-sound/ardour-2.9999  USE="lv2 nls sse vst (-altivec) -debug -freesound -sys-libs" 0 kB [1]


I don't know if these packages are required to actually run Ardour (the build page does not list them), but I would prefer a more minimal ebuild with non-required packages passed as use flags.

Paul may have given up on Ardour on Gentoo, but I haven't.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1085

PostPosted: Tue Dec 14, 2010 9:38 pm    Post subject: Reply with quote

audiodef wrote:
JACK2, jack-audio-connection-kit, is up to 1.9.6 but this version isn't in the pro-audio overlay. Here's the ebuild for it: http://audiodef.com/gentoo/proaudio/ebuilds/jack/jack-audio-connection-kit-1.9.6.ebuild

Ups, I forget to update here. I have put jack-audio-connection-kit-1.9.6 in the pro-audio overlay fixing some bugs with it.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5246

PostPosted: Fri Feb 11, 2011 2:09 pm    Post subject: Reply with quote

I've updated my site design, because of which the Pro-Audio For Gentoo Workstations how-to has a new url: http://audiodef.com/projects.php?project_id=1.

Or go to http://www.audiodef.com and click on "Projects" to find it.

Pro-audio ebuild and source fixes I've made continue to be hosted in the same place, so pro-audio ebuilds Keenblade updated with my fixes should continue to work.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5246

PostPosted: Fri Feb 18, 2011 1:36 am    Post subject: Reply with quote

Zita Convolver, and a bunch of other stuff that was previously hosted by http://www.kokkinizita.net/linuxaudio/, is not at that URL. The site appears to be down, and I haven't heard anything about why or when things might be back.

So anyway, here's the ebuild for Zita Convolver, with the src hosted by me.

http://audiodef.com/gentoo/proaudio/ebuilds/zita-convolver/zita-convolver-2.0.0.ebuild
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5246

PostPosted: Fri Feb 18, 2011 3:27 pm    Post subject: Reply with quote

Similarly, the amb-plugins src link is broken. I found 0.1.0 at http://users.skynet.be/solaris/, so this ebuild uses that. If anyone finds 0.8.1, or has the tarball, please send it to me and I'll host it, with an updated, working ebuild.

http://audiodef.com/gentoo/proaudio/ebuilds/amb-plugins/amb-plugins-0.1.0.ebuild
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1085

PostPosted: Sat Feb 19, 2011 10:23 pm    Post subject: Reply with quote

audiodef wrote:
Similarly, the amb-plugins src link is broken. I found 0.1.0 at http://users.skynet.be/solaris/, so this ebuild uses that. If anyone finds 0.8.1, or has the tarball, please send it to me and I'll host it, with an updated, working ebuild.

http://audiodef.com/gentoo/proaudio/ebuilds/amb-plugins/amb-plugins-0.1.0.ebuild

It seems these two links have the src for ver 0.8.1:
http://cacing.vlsm.org/pool/main/a/amb-plugins/
http://mirror.aarnet.edu.au/debian/pool/main/a/amb-plugins/
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5246

PostPosted: Sun Feb 20, 2011 9:18 pm    Post subject: Reply with quote

Thanks! I'll submit updated ebuilds, as well as grab the src in case those disappear.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
darkbasic
Tux's lil' helper
Tux's lil' helper


Joined: 06 Sep 2006
Posts: 123

PostPosted: Mon Feb 21, 2011 11:19 pm    Post subject: Reply with quote

media-libs/libffado-9999 gives access violation. please see the other thread for more info.

P.S.
Thank you for your work.
_________________
Computers are like air conditioners:
they stop working properly when you open Windows...

Coltiva Linux, Windows si pianta da solo.


http://www.linuxsystems.it/
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5246

PostPosted: Tue Feb 22, 2011 4:48 pm    Post subject: Reply with quote

darkbasic wrote:


Thank you for your work.


De nada. Gentoo has been my favourite Linux distro for a long time, and there's no reason in the world for it not to be used for audio production, professional or otherwise. :wink:
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5246

PostPosted: Tue Mar 01, 2011 2:20 am    Post subject: Reply with quote

libclalsadrv-2.0.0 from the overlay, which is a dependency of japa, can't fetch because kokkinizita.net is defunct. The solution is easy, though. Since the same version is in portage, just copy the portage files to your local overlay.

Keenblade, this could simply be taken out of the overlay, since it's presence there is redundant.

japa itself was hosted at kokkinizita.net. I managed to find a 0.6.0 bzipped tarball src at launchpad.net and modified the ebuild. Get the updated ebuild here:

http://audiodef.com/gentoo/proaudio/ebuilds/japa/japa-0.6.0.ebuild

I have no idea what happened to the guy running kokkinizita.net. The site suddenly fell off the radar. I hope he's alright.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1085

PostPosted: Thu Mar 03, 2011 8:35 pm    Post subject: Reply with quote

audiodef wrote:
libclalsadrv-2.0.0 from the overlay, which is a dependency of japa, can't fetch because kokkinizita.net is defunct...
I have no idea what happened to the guy running kokkinizita.net. The site suddenly fell off the radar. I hope he's alright.

I found the post explaining what happened and what will be for the kokkinizita.net. You can read the explanation here. He is having uncorrectable issues with his hosting service. I guess his site will be available soon.
I updated the source uri for japa using your server, until his site recovered. Thx for hosting.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5246

PostPosted: Thu Mar 03, 2011 10:03 pm    Post subject: Reply with quote

I'm glad his site will be back. I'm happy to host whatever I can, temporarily or permanently.

Now that I think of it, I'll try to remember to contact him and ask him if he would like his site mirrored.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
darkbasic
Tux's lil' helper
Tux's lil' helper


Joined: 06 Sep 2006
Posts: 123

PostPosted: Sun Mar 06, 2011 1:09 am    Post subject: Reply with quote

Broken link for zita-convolver-2.0.0.tar.bz2
_________________
Computers are like air conditioners:
they stop working properly when you open Windows...

Coltiva Linux, Windows si pianta da solo.


http://www.linuxsystems.it/
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5246

PostPosted: Mon Mar 07, 2011 2:43 pm    Post subject: Reply with quote

darkbasic wrote:
Broken link for zita-convolver-2.0.0.tar.bz2


Scroll up.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5246

PostPosted: Mon Mar 07, 2011 3:17 pm    Post subject: Reply with quote

Fixed the (hopefully temporarily) broken link for zita-at1 and the dependency zita-resampler.

For zita-resampler, you'll have to put

Code:

=media-libs/zita-resampler-0.1.1-r1


in /etc/portage/package.mask because I could not find a source tarball for version r1. If you have one, send it to me and I'll host it.

zita-at1 ebuild

zita-resampler ebuild
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
darkbasic
Tux's lil' helper
Tux's lil' helper


Joined: 06 Sep 2006
Posts: 123

PostPosted: Sat Mar 19, 2011 11:39 pm    Post subject: Reply with quote

checking for FLUIDSYNTH_DEPS... no
configure: error: fluidsynth library not found

calf-9999 with dssi use missing dep
_________________
Computers are like air conditioners:
they stop working properly when you open Windows...

Coltiva Linux, Windows si pianta da solo.


http://www.linuxsystems.it/
Back to top
View user's profile Send private message
darkbasic
Tux's lil' helper
Tux's lil' helper


Joined: 06 Sep 2006
Posts: 123

PostPosted: Mon Mar 21, 2011 6:49 pm    Post subject: Reply with quote

emerge: there are no ebuilds to satisfy "x11-libs/fltk:1.1".
(dependency required by "media-sound/rakarrack-0.5.8" [ebuild])

in portage fltk slot changed from 1.1 to 1
_________________
Computers are like air conditioners:
they stop working properly when you open Windows...

Coltiva Linux, Windows si pianta da solo.


http://www.linuxsystems.it/
Back to top
View user's profile Send private message
darkbasic
Tux's lil' helper
Tux's lil' helper


Joined: 06 Sep 2006
Posts: 123

PostPosted: Fri Mar 25, 2011 11:41 am    Post subject: Reply with quote

Thank you for the fix, also:
Code:
laptop pro-audio # grep -r "fltk:1.1" ./
./media-sound/csound/csound-5.12.1-r1.ebuild:   csoundac? ( x11-libs/fltk:1.1[threads]
./media-sound/csound/csound-5.12.1-r1.ebuild:   editor? ( x11-libs/fltk:1.1[threads] )
./media-sound/csound/csound-5.12.1-r1.ebuild:   gui? ( x11-libs/fltk:1.1[threads] )
./media-sound/csound/.svn/text-base/csound-5.12.1-r1.ebuild.svn-base:   csoundac? ( x11-libs/fltk:1.1[threads]
./media-sound/csound/.svn/text-base/csound-5.12.1-r1.ebuild.svn-base:   editor? ( x11-libs/fltk:1.1[threads] )
./media-sound/csound/.svn/text-base/csound-5.12.1-r1.ebuild.svn-base:   gui? ( x11-libs/fltk:1.1[threads] )
./media-sound/rakarrack/rakarrack-9999.ebuild:RDEPEND="x11-libs/fltk:1.1
./media-sound/rakarrack/.svn/text-base/rakarrack-9999.ebuild.svn-base:RDEPEND="x11-libs/fltk:1.1

_________________
Computers are like air conditioners:
they stop working properly when you open Windows...

Coltiva Linux, Windows si pianta da solo.


http://www.linuxsystems.it/
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5246

PostPosted: Fri Mar 25, 2011 1:57 pm    Post subject: Reply with quote

I'm working on a database to keep track of my fixes. Once that's done, I'll look into these. 8)
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1085

PostPosted: Fri Mar 25, 2011 11:25 pm    Post subject: Reply with quote

darkbasic wrote:
Thank you for the fix, also:
Code:
laptop pro-audio # grep -r "fltk:1.1" ./
./media-sound/csound/csound-5.12.1-r1.ebuild:   csoundac? ( x11-libs/fltk:1.1[threads]
./media-sound/csound/csound-5.12.1-r1.ebuild:   editor? ( x11-libs/fltk:1.1[threads] )
./media-sound/csound/csound-5.12.1-r1.ebuild:   gui? ( x11-libs/fltk:1.1[threads] )
./media-sound/csound/.svn/text-base/csound-5.12.1-r1.ebuild.svn-base:   csoundac? ( x11-libs/fltk:1.1[threads]
./media-sound/csound/.svn/text-base/csound-5.12.1-r1.ebuild.svn-base:   editor? ( x11-libs/fltk:1.1[threads] )
./media-sound/csound/.svn/text-base/csound-5.12.1-r1.ebuild.svn-base:   gui? ( x11-libs/fltk:1.1[threads] )
./media-sound/rakarrack/rakarrack-9999.ebuild:RDEPEND="x11-libs/fltk:1.1
./media-sound/rakarrack/.svn/text-base/rakarrack-9999.ebuild.svn-base:RDEPEND="x11-libs/fltk:1.1

Done. Thanks for the report.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5246

PostPosted: Thu Mar 31, 2011 4:34 pm    Post subject: Reply with quote

I've started a page for the ebuild and source fixes I do. Link is in my sig.

Note that as of the date of this post, I'm just starting to populate it. I have to go through my fixes and post them.

I guess this is also the appropriate place to announce that I'm changing my hosting provider in April, so please pardon any temporary down time of this page, or my Pro-Audio for Gentoo how-to. I intend to switch over to Host Virtual from Godaddy.
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
darkbasic
Tux's lil' helper
Tux's lil' helper


Joined: 06 Sep 2006
Posts: 123

PostPosted: Thu Mar 31, 2011 9:27 pm    Post subject: Reply with quote

sandybridge ~ # eix-update
Reading Portage settings ..
Building database (/var/cache/eix) ..
[0] "gentoo" /usr/portage/ (cache: metadata-flat)
Reading category 154|154 (100%) Finished
[1] "kde" /var/lib/layman/kde (cache: parse|ebuild*#metadata-flat#assign)
Reading category 154|154 (100%) Finished
[2] "x11" /var/lib/layman/x11 (cache: parse|ebuild*#metadata-flat#assign)
Reading category 154|154 (100%) Finished
[3] "ladi" /var/lib/layman/ladi (cache: parse|ebuild*#metadata-flat#assign)
Reading category 154|154 (100%) Finished
[4] "proaudio" /var/lib/layman/pro-audio (cache: parse|ebuild*#metadata-flat#assign)
Reading category 86|154 ( 55%): media-sound .. * ERROR: media-sound/kguitar-0.6_pre1 failed (depend phase):
* EAPI=2 is not supported
*
* Call stack:
* ebuild.sh, line 1998: Called source '/var/lib/layman/pro-audio/media-sound/kguitar/kguitar-0.6_pre1.ebuild'
* kguitar-0.6_pre1.ebuild, line 7: Called inherit 'cmake-utils' 'eutils' 'kde4-base'
* ebuild.sh, line 1403: Called qa_source '/var/lib/layman/kde/eclass/kde4-base.eclass'
* ebuild.sh, line 43: Called source '/var/lib/layman/kde/eclass/kde4-base.eclass'
* kde4-base.eclass, line 23: Called inherit 'kde4-functions' 'fdo-mime' 'gnome2-utils' 'base' 'virtualx' 'versionator' 'eutils'
* ebuild.sh, line 1403: Called qa_source '/var/lib/layman/kde/eclass/kde4-functions.eclass'
* ebuild.sh, line 43: Called source '/var/lib/layman/kde/eclass/kde4-functions.eclass'
* kde4-functions.eclass, line 21: Called die
* The specific snippet of code:
* *) die "EAPI=${EAPI} is not supported" ;;
*
* If you need support, post the output of 'emerge --info =media-sound/kguitar-0.6_pre1',
* the complete build log and the output of 'emerge -pqv =media-sound/kguitar-0.6_pre1'.
* This ebuild is from an overlay: '/var/lib/layman/pro-audio/'
* S: '/kguitar-0.6_pre1'

Ebuild failed with status 1
Reading category 86|154 ( 55%): media-sound ..
Could not properly execute /var/lib/layman/pro-audio/media-sound/kguitar/kguitar-0.6_pre1.ebuild
Reading category 154|154 (100%) Finished
[5] "darkbasic" /usr/local/portage (cache: parse|ebuild*#metadata-flat#assign)
Reading category 154|154 (100%) Finished
Applying masks ..
Calculating hash tables ..
Writing database file /var/cache/eix ..
Database contains 14923 packages in 154 categories.
sandybridge ~ # emerge -pv portage

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R *] sys-apps/portage-2.2.0_alpha29 USE="(ipc) -build -doc -epydoc -python2 -python3 (-selinux)" LINGUAS="-pl" 0 kB
_________________
Computers are like air conditioners:
they stop working properly when you open Windows...

Coltiva Linux, Windows si pianta da solo.


http://www.linuxsystems.it/
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5246

PostPosted: Fri Apr 01, 2011 2:56 pm    Post subject: Reply with quote

darkbasic wrote:
sandybridge ~ # eix-update


That's WAY beyond the scope of this thread. :wink:
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5246

PostPosted: Tue Apr 05, 2011 1:19 am    Post subject: Reply with quote

The new ebuild fixes page is now underway. If something is broken or unavailable (for example, from the downed kokkinizita.net site), please mention it here. No promises, but I'll take a look.

http://audiodef.com/projects.php?project_id=8
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 5246

PostPosted: Tue Apr 05, 2011 4:36 pm    Post subject: Reply with quote

Added ebuild fixes for the following:

AMB Plugins
Ardour
Ecasound (Portage version is old)
Japa
Libclalsadrv
PlayOnLinux (Portage version is old)
RTSynth (compiled binaries might not run, they didn't for me)
Wah Plugins
Zita AT1
Zita Convolver
Zita Resampler
_________________
Gentoo Studio: http://gentoostudio.org
Facebook: http://www.facebook.com/gentoostudio
G+: https://plus.google.com/113947758237122861689/posts
Pappy's Kernel Seeds: http://kernel-seeds.gentoostudio.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 2 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum