Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
why is there dev-libs/poppler and app-text/poppler? [solved]
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Sun Jan 24, 2010 11:24 am    Post subject: why is there dev-libs/poppler and app-text/poppler? [solved] Reply with quote

Hi there

I really can't see the difference betwenn the two mentioned ebuilds. Why are there both in the tree? And some ebuilds (poppler-glib) depending on app-text/poppler and others (okular->virtual/poppler) depending on dev-libs/poppler? And the latter is blocking app-text/poppler...

Whats wrong here?

Stuck. -- desultory
Unstuck - tomk
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor


Last edited by Phlogiston on Sun Jan 24, 2010 1:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
Master of the Darkside
Tux's lil' helper
Tux's lil' helper


Joined: 02 Sep 2004
Posts: 94
Location: Iasi, Romania

PostPosted: Sun Jan 24, 2010 12:00 pm    Post subject: Reply with quote

I'm asking myself the same question here... what's up with those?
_________________
No weight nor mass nor beauty of execution can outweigh a grain or fragment of thought
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2467
Location: Austria

PostPosted: Sun Jan 24, 2010 12:04 pm    Post subject: Reply with quote

Maybe you synced in the middle of the portage commits.

It seems app-text/poppler-0.12.3 is the new (supposed by upstream) monolithic way, I simply unmerged all dev-libs/poppler* packages and had to manually edit one local ebuild to depend on app-text/poppler instead of dev-libs/poppler, works now.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Sun Jan 24, 2010 12:05 pm    Post subject: Reply with quote

genstorm wrote:
Maybe you synced in the middle of the portage commits.

It seems app-text/poppler-0.12.3 is the new (supposed by upstream) monolithic way, I simply unmerged all dev-libs/poppler* packages and had to manually edit one local ebuild to depend on app-text/poppler instead of dev-libs/poppler, works now.


Yes the virtual packages DEPEND changed on -r1 versions of all packages to app-text/poppler instead of dev-libs/poppler... I got a lot of issues so I masked those until its really ready...
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2701
Location: Hamburg/Germany

PostPosted: Sun Jan 24, 2010 12:57 pm    Post subject: Reply with quote

Maybe here's more information : http://ben.liveforge.org/2010/01/24/poppler-reunification
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Sun Jan 24, 2010 1:11 pm    Post subject: Reply with quote

toralf wrote:
Maybe here's more information : http://ben.liveforge.org/2010/01/24/poppler-reunification


Thanks!
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Sun Jan 24, 2010 6:55 pm    Post subject: Reply with quote

All ebuilds that need poppler should currently be depending on virtual/poppler{,-glib,-qt4,-utils}. the newest version of these virtuals (0.12.3-r1) depend on app-text/poppler (the new monolithic ebuild). There were a few minor problems, but they should be sorted now. Make sure to sync first. Portage should then be able to upgrade automatically.

>=app-text/poppler-0.12.3 replaces all dev-libs/poppler* packages as well as app-text/poppler-utils and the ancient app-text/poppler-bindings. The virtual/poppler* packages are still used, but will be removed at a later date, once all ebuilds are migrated to depend on app-text/poppler with correct use deps.

If there is anything else that needs clearing up, let me know.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1627

PostPosted: Mon Jan 25, 2010 5:00 pm    Post subject: Reply with quote

User: yngwin
Topic: why is there dev-libs/poppler and app-text/poppler? [solved]
Post: post 6146245
Reason:

Hello,

I get this on my Computer:

Code:
app-text/poppler-utils:0

  ('ebuild', '/', 'app-text/poppler-utils-0.12.3', 'merge') pulled in by
    =app-text/poppler-utils-0.12.3

  ('ebuild', '/', 'app-text/poppler-utils-0.10.7', 'merge') pulled in by
    ~app-text/poppler-utils-0.10.7[abiword] required by ('ebuild', '/', 'virtual/poppler-utils-0.10.7', 'merge')
    ~app-text/poppler-utils-0.10.7[abiword] required by ('ebuild', '/', 'net-print/cups-1.3.11-r1', 'merge')

dev-libs/poppler:0

  ('ebuild', '/', 'dev-libs/poppler-0.12.3', 'merge') pulled in by
    ~dev-libs/poppler-0.12.3[abiword] required by ('ebuild', '/', 'app-text/poppler-utils-0.12.3', 'merge')

  ('ebuild', '/', 'dev-libs/poppler-0.10.7', 'merge') pulled in by
    ~dev-libs/poppler-0.10.7 required by ('ebuild', '/', 'dev-tex/luatex-0.30.3', 'merge')
    ~dev-libs/poppler-0.10.7 required by ('ebuild', '/', 'virtual/poppler-0.10.7', 'merge')
    ~dev-libs/poppler-0.10.7[abiword] required by ('ebuild', '/', 'app-text/poppler-utils-0.10.7', 'merge')


R. R.
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1627

PostPosted: Mon Jan 25, 2010 5:01 pm    Post subject: Reply with quote

This will not solve my Problem...I get always the same Error.
I unmerged all package which depend on it but then there will be other packages depend on poppler packages.....and so on.

Please help.
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Mon Jan 25, 2010 6:14 pm    Post subject: Reply with quote

It's hard to help without specific information. I assume you are on testing and are using the desktop profile. If you are not, then you need to check your package.keywords and your useflags.

These are currently the latest packages that you should have installed:
app-text/poppler-0.12.3-r2
virtual/poppler-0.12.3-r1


And depending on what your installed packages need, also:
virtual/poppler-glib-0.12.3-r2 (this pulls in app-text/poppler with USE=cairo)
virtual/poppler-qt4-0.12.3-r1 (this pulls in app-text/poppler with USE=qt4)
virtual/poppler-utils-0.12.3-r1 (this pulls in app-text/poppler with USE=utils)

You should not have any dev-libs/poppler{,-glib,-qt3,-qt4,-utils} ebuilds installed. And no app-text/poppler-utils or app-text/poppler-bindings either. If any packages in portage depend directly on one of these packages, then that is a bug. Please let me know if you find any.

If you still have trouble, please post the complete output of emerge -ptuvD world as well as emerge --info on a pastebin and link them here.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1627

PostPosted: Mon Jan 25, 2010 8:15 pm    Post subject: Reply with quote

Hello,

thanks this will help a little bit.

There is:

Code:

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge      ] dev-python/gnome-python-desktop-2.28.0
[ebuild  N    ]  dev-python/evince-python-2.28.0  0 kB
[ebuild     UD] media-plugins/vdr-epgsearch-0.9.24-r2 [0.9.25_beta14] USE="pcre (-tre%)" 0 kB
[nomerge      ] gnome-base/gnome-2.28.1  USE="cdr cups dvdr ldap mono -accessibility -esd"
[ebuild  N    ]  app-text/evince-2.28.2  USE="dbus doc dvi gnome nautilus tiff -debug -djvu -gnome-keyring -t1lib" 0 kB
[ebuild     UD] app-misc/strigi-0.7.0 [0.7.1] USE="clucene dbus fam qt4 -debug -exif -hyperestraier -inotify (-log) -test" 0 kB
[ebuild     U ]  virtual/poppler-utils-0.12.3-r1 [0.10.7] USE="abiword png%*" 0 kB
[nomerge      ] mail-client/evolution-2.28.2  USE="crypt dbus exchange gstreamer hal ldap mono networkmanager nntp pda python ssl -kerberos -krb4 -profile"
[ebuild  N    ]  dev-lang/mono-2.4.2.3  USE="-minimal -moonlight -xen" 0 kB
[nomerge      ] dev-lang/php-5.2.12  USE="apache2 berkdb bzip2 cli crypt ctype curl doc gdbm iconv ipv6 ldap mysql ncurses nls pcre readline reflection session spell spl ssl threads truetype unicode xml zlib (-adabas) -bcmath (-birdstep) -calendar -cdb -cgi -cjk -concurrentmodphp -curlwrappers -db2 -dbase (-dbmaker) -debug -discard-path (-empress) (-empress-bcs) (-esoob) -exif -fastbuild (-fdftk) -filter (-firebird) -flatfile -force-cgi-redirect (-frontbase) -ftp -gd -gd-external -gmp -hash -imap -inifile -interbase -iodbc (-java-external) -json -kerberos -kolab -ldap-sasl -libedit -mcve -mhash -msql -mssql -mysqli -oci8 -oci8-instant-client -odbc -pcntl -pdo -pic -posix -postgres -qdbm -recode -sapdb -sharedext -sharedmem -simplexml -snmp -soap -sockets (-solid) -sqlite -suhosin (-sybase) (-sybase-ct) -sysvipc -tidy -tokenizer -wddx -xmlreader -xmlrpc -xmlwriter -xpm -xsl -yaz -zip"
[ebuild  N    ]  media-libs/t1lib-5.1.2  USE="X doc" 0 kB
[ebuild  N    ]   virtual/latex-base-1.0  0 kB
[ebuild  N    ]    dev-texlive/texlive-latexrecommended-2008-r2  USE="doc -source" 0 kB
[ebuild  N    ]     dev-texlive/texlive-latex-2008-r2  USE="doc -source" 0 kB
[ebuild  N    ]      dev-tex/luatex-0.30.3  USE="doc" 0 kB
[ebuild     UD]       virtual/poppler-0.10.7 [0.12.3-r1] USE="(-lcms%*)" 0 kB
[ebuild  N    ]        dev-libs/poppler-0.10.7  USE="abiword poppler-data" 0 kB
[ebuild  N    ]      dev-texlive/texlive-basic-2008-r1  USE="doc -source" 0 kB
[ebuild  N    ]       dev-texlive/texlive-documentation-base-2008  USE="-source" 0 kB
[nomerge      ] dev-texlive/texlive-latex-2008-r2  USE="doc -source"
[nomerge      ]  app-text/texlive-core-2008-r7 [2009] USE="X doc -source -tk"
[nomerge      ]   dev-tex/luatex-0.30.3  USE="doc"
[ebuild  N    ]    dev-tex/mplib-1.110  USE="lua" 0 kB
[ebuild     UD]     app-text/texlive-core-2008-r7 [2009] USE="X doc -source -tk" 0 kB
[nomerge      ] perl-core/Archive-Tar-1.54
[ebuild   R   ]  perl-core/IO-Compress-2.021  USE="(-test%)" 0 kB
[ebuild   R   ]   perl-core/Compress-Raw-Zlib-2.021  USE="(-test%)" 0 kB
[ebuild   R   ]   perl-core/Compress-Raw-Bzip2-2.021  USE="(-test%)" 0 kB
[blocks B     ] dev-libs/poppler ("dev-libs/poppler" is blocking app-text/poppler-0.12.3-r2)
[blocks B     ] app-text/poppler ("app-text/poppler" is blocking dev-libs/poppler-0.10.7)


Ithink it's a ebuild ...



Thanks R.

Edit:

it is evince with USE dvi

R. R.


Last edited by Tinitus on Mon Jan 25, 2010 8:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Mon Jan 25, 2010 8:44 pm    Post subject: Reply with quote

What happens if you try this:
Code:
emerge -1av dev-libs/poppler
emerge -uDNav world
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1627

PostPosted: Mon Jan 25, 2010 8:52 pm    Post subject: Reply with quote

Mike Hunt wrote:
What happens if you try this:
Code:
emerge -1av dev-libs/poppler
emerge -uDNav world


Hello,

Code:
emerge -1av dev-libs/poppler
--- Invalid atom in /etc/portage/package.keywords: =

 * IMPORTANT: 5 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] dev-libs/poppler-0.10.7  USE="abiword poppler-data" 0 kB
[blocks B     ] app-text/poppler ("app-text/poppler" is blocking dev-libs/poppler-0.10.7)
[blocks B     ] dev-libs/poppler ("dev-libs/poppler" is blocking app-text/poppler-0.12.3-r2)

Total: 1 package (1 new), Size of downloads: 0 kB
Conflict: 2 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'dev-libs/poppler-0.10.7', 'merge') pulled in by
    dev-libs/poppler

  ('installed', '/', 'app-text/poppler-0.12.3-r2', 'nomerge') pulled in by
    ~app-text/poppler-0.12.3[utils,abiword,png] required by ('installed', '/', 'app-misc/strigi-0.7.0', 'nomerge')
    ~app-text/poppler-0.12.3[utils,abiword,png] required by ('installed', '/', 'net-print/cups-1.4.2-r1', 'nomerge')
    ~app-text/poppler-0.12.3[utils,abiword,png] required by ('installed', '/', 'virtual/poppler-utils-0.12.3-r1', 'nomerge')
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1627

PostPosted: Mon Jan 25, 2010 9:39 pm    Post subject: Reply with quote

Hello,

the Package app-misc/strigi-0.7.0 USE="clucene dbus fam qt4 -debug -exif -hyperestraier -inotify (-log) -test"

will install:

[ebuild N ] virtual/poppler-utils-0.10.7 USE="abiword" 0 kB
[ebuild N ] app-text/poppler-utils-0.10.7 USE="abiword" 0 kB
[ebuild N ] dev-libs/poppler-0.10.7 USE="abiword poppler-data" 0 kB

R.R.
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Mon Jan 25, 2010 11:53 pm    Post subject: Reply with quote

That is because you are on stable, not testing, and your package.keywords are not in order.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7986

PostPosted: Tue Jan 26, 2010 2:33 am    Post subject: Reply with quote

Merged a post from the reports topic.
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1627

PostPosted: Tue Jan 26, 2010 4:46 am    Post subject: Reply with quote

yngwin wrote:
That is because you are on stable, not testing, and your package.keywords are not in order.


What does it mean? I don't understand...
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Tue Jan 26, 2010 4:53 am    Post subject: Reply with quote

It means that there are entries in your /etc/portage/package.keywords file that are causing some or all of these problems.

Please post the output of:
Code:
emerge --info
cat /etc/portage/package.keywords
cat /etc/portage/package.use
cat /etc/portage/package.unmask
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1627

PostPosted: Tue Jan 26, 2010 5:11 am    Post subject: Reply with quote

Mike Hunt wrote:
It means that there are entries in your /etc/portage/package.keywords file that are causing some or all of these problems.

Please post the output of:
Code:
emerge --info
cat /etc/portage/package.keywords
cat /etc/portage/package.use
cat /etc/portage/package.unmask


Code:


emerge --info
Portage 2.1.6.13 (default/linux/amd64/10.0/desktop, gcc-4.3.4, glibc-2.10.1-r1, 2.6.32-gentoo-r2 x86_64)
=================================================================
System uname: Linux-2.6.32-gentoo-r2-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9650_@_3.00GHz-with-gentoo-1.12.13
Timestamp of tree: Mon, 25 Jan 2010 17:30:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:     4.0_p35
dev-java/java-config: 2.1.9-r2
dev-lang/python:     2.6.4
dev-python/pycrypto: 2.1.0_beta1
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.20.51.0.1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="de_DE.UTF-8@euro"
LDFLAGS="-Wl,-O1"
LINGUAS="de"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/xwing /usr/local/portage/layman/vdr-xine /usr/local/portage/layman/vdr-testing /usr/local/portage/layman/sunrise /usr/local/portage/layman/lightscribe /usr/local/portage/layman/vdr-devel /usr/local/portage/layman/berkano /usr/local/portage/layman/otih /usr/portage/local/myoverlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="7zip X a52 aac aalib acl acpi alsa amd64 apache2 avi bash-completion beagle berkdb bluetooth branding bzip2 cairo cdparanoia cdr cli consolekit cracklib crypt css cups cxx dbus dga divx doc dri dts dv dvd dvdr dvdread eds emboss encode evo fam ffmpeg firefox flac fortran gdbm gif glitz gnome gpm gstreamer gtk hal i18n iconv ieee1394 ipv6 jack java jpeg kde lame ldap libnotify live mad mikmod mjpeg mmx mng modules mono mp3 mp4 mpeg mudflap multilib nautilus ncurses networkmanager nls nptl nptlonly ogg opengl openmp pam pcre pdf perl php png policykit ppds pppd python qt3 qt3support qt4 quicktime readline reflection samba screenshot sdl session spell spl sse sse2 ssl startup-notification svg sysfs tcpd threads thunar tiff truetype unicode usb v4l vcd vdpau vdr vorbis webdav x264 xinerama xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia intel i128 i810"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


cat /etc/portage/package.keywords
Code:

app-admin/testdisk
app-arch/file-roller
app-editors/bluefish
app-misc/mc
app-text/evince
dev-cpp/commoncpp2
dev-python/bug-buddy-python
dev-python/gconf-python
dev-python/gnome-desktop-python
dev-python/gnome-keyring-python
dev-python/gnome-python
dev-python/gnome-python-base
dev-python/gnome-python-desktop
dev-python/gnome-python-desktop-base
dev-python/gtksourceview-python
dev-python/libgnomeprint-python
dev-python/libgnome-python
dev-python/librsvg-python
dev-python/libwnck-python
dev-python/metacity-python
dev-python/nautilus-cd-burner-python
dev-python/totem-python
gnome-base/gconf
gnome-base/gnome
gnome-base/gnome-applets
gnome-base/gnome-control-center
gnome-base/gnome-keyring
gnome-base/gnome-menus
gnome-base/gnome-panel
gnome-base/gnome-vfs
gnome-base/gvfs
gnome-base/libbonobo
gnome-base/libbonoboui
gnome-base/libgnome
gnome-base/nautilus
gnome-extra/deskbar-applet
gnome-extra/evolution-data-server
gnome-extra/evolution-exchange
gnome-extra/gconf-editor
gnome-extra/gnome-power-manager
gnome-extra/gnome-system-monitor
gnome-extra/gnome-utils
gnome-extra/hamster-applet
gnome-extra/yelp
mail-client/evolution
media-libs/gegl
media-libs/libgphoto2
media-libs/xine-lib
media-tv/linuxtv-dvb-headers
media-tv/tvtime
media-video/nvidia-settings
media-video/projectx
media-video/totem
media-video/xine-ui
net-libs/gtk-vnc
net-libs/libsoup
net-libs/opal
net-libs/xulrunner
net-print/cups
sys-apps/dbus
sys-devel/binutils
sys-fs/ntfs3g
sys-kernel/linux-headers
www-client/mozilla-firefox
x11-drivers/nvidia-drivers
x11-libs/libvdpau
x11-libs/vte
dev-python/gnome-python-desktop-base
x11-misc/alacarte
x11-terms/gnome-terminal
dev-python/gnome-applets-python
dev-python/evolution-python
gnome-extra/gucharmap
x11-libs/libwnck
x11-libs/pango
x11-libs/gtk+
app-text/gnome-doc-utils
=dev-libs/glib-2.22.3
=sys-devel/binutils-2.20.51.0.1
=media-libs/xine-lib-1.2.9999_p286 **
=sys-devel/binutils-2.20.51.0.1 **
=virtual/poppler-glib-0.12.3-r2 ~amd64
=app-text/poppler-0.12.3-r2 ~amd64
=dev-texlive/texlive-latex-2009 ~amd64
=app-text/texlive-core-2009 ~amd64
=dev-texlive/texlive-basic-2009 ~amd64
=dev-tex/luatex-0.50.0 ~amd64
=dev-tex/luatex-0.47.0 ~amd64
=dev-tex/luatex-0.46.0 ~amd64
=dev-texlive/texlive-documentation-base-2009 ~amd64
=virtual/poppler-0.12.3-r1 ~amd64
=virtual/poppler-0.12.3 ~amd64
=virtual/poppler-0.12.1 ~amd64
=virtual/poppler-0.12.0 ~amd64
dev-texlive/texlive-latexrecommended
app-misc/tomboy
dev-libs/totem-pl-parser
dev-python/evince-python
dev-python/gnome-vfs-python
dev-python/libbonobo-python
gnome-base/libgnomeui
sys-apps/lm_sensors
gnome-base/gnome-desktop
sys-auth/consolekit
dev-python/libgnomecanvas-python
dev-python/gnome-python-base
dev-libs/atk
app-admin/eselect-opengl
x11-themes/gnome-icon-theme
media-libs/gst-plugins-base
media-libs/gstreamer
gnome-base/libgtop
dev-libs/nss
dev-tex/luatex
app-cdr/lightscribe-simplelabeler
app-text/pdfedit
gnome-extra/nautilus-sendto

Code:


cat /etc/portage/package.unmask




Code:
cat /etc/portage/package.use
###
#poppler block
virtual/poppler lcms
x11-misc/zim -latex
dev-tex/luatex -doc
####
media-libs/gegl -doc -debug -openexr -raw
##############################
#SSH Speed Up
net-misc/openssh hpn
###############################
#Gnucash
app-office/gnucash  chipcard hbci ofx quotes
net-libs/aqbanking chipcard  ofx
###########################
sys-fs/udev extras
app-text/enchant aspell
gnome-base/gdm  gnome-keyring remote
sys-apps/portage
app-portage/eix tools
dev-util/subversion apache2 svnserve extras emacs webdav
dev-lang/php mysql curl
x11-libs/cairo svg
gnome-base/gnome-applets
##################
###KDE
dev-util/kdevelop cvs debug  pascal sql subversion
kde-base/krdc rdesktop slp
x11-terms/xterm  toolbar
dev-lang/php  ctype pcre session unicode pcre xml
media-video/vdr jumpplay lircsettings livebuffer sortrecords setup
net-fs/samba readline cups pam
net-print/cups ppds

##################
#Subversion
dev-util/subversion svnserve bash-completion -dso
##################
#Virtualbox
#app-emulation/virtualbox-bin additions headless vboxwebsrv
###########
#Anjuta
dev-util/anjuta subversion sourceview
###########
##Redhat Artwork
x11-themes/redhat-artwork -kde audacious cursors gdm icons -kdm nautilus
################
###vdr
media-tv/linuxtv-dvb ttpci
media-libs/xine 
media-libs/xine-lib wavpack win32codecs vdr
media-tv/xawtv X aalib alsa nls dv mmx opengl quicktime xext xv
media-plugins/vdr-xineliboutput X  libextractor
media-plugins/vdr-softdevice xv  mmx mmxext
media-tv/gentoo-vdr-scripts nvram
####
#Videolan
media-video/vlc cdda cddb dc1394 dvb httpd -matroska modplug mpeg nsplugin tream x264 -xulrunner rtsp
#############
#Firefox
www-client/mozilla-firefox mozdevelop startup-notification xulrunner
#################
#app-admin/phpsyslogng
#app-admin/phpsyslogng mysql
app-admin/conky truetype -audacious -ipv6 hddtemp mpd nano-syntax rss
###############################
###Apache
www-servers/apache  APACHE2_MODULES="userdir dav dav_fs rewrite" APACHE2_MPMS="prefork"
######################################
####Latex
app-emacs/auctex preview-latex -X
app-text/texlive linguas_de png pstricks
kde-base/okular ebook
###############
###Mail
mail-mta/ssmtp mailwrapper
mail-mta/postfix ipv6 pam ssl -mailwrapper -mbox sasl
##################
####GCC
sys-devel/gcc gcj d objc objc++ objc-gc
########################
#Openoffice
app-office/openoffice  nsplugin templates

#############################
#kvm 210708
app-emulation/qemu-kvm -esd -gnutls havekernel -pulseaudio sdl
app-emulation/qemu-kvm alsa bluetooth modules ncurses sdl havekernel
##############
#Java Firefox 210708
dev-java/sun-jre-bin nsplugin
dev-java/sun-jdk examples jce nsplugin odbc
app-emulation/emul-linux-x86-java nsplugin
####
#kdenlive
media-libs/mlt sdl xml
media-video/ffmpeg sdl
###
#Quicktime Blocker
media-video/transcode -quicktime
####Splash
media-gfx/splashutils fbcondecor
#############
#Kopete
kde-base/kopete connectionstatus contactnotes highlight history irc statistics texteffect htmlhandbook  msn oscar otr winpopup
#sane
media-gfx/sane-backends gphoto2 usb
media-gfx/xsane gimp lcms tiff
media-gfx/gimp smp svg tiff wmf
media-gfx/iscan gimp
##############
#app-emulation/emul-linux-x86-xlibs
app-emulation/emul-linux-x86-xlibs -arts
####
#gnome-commander
gnome-apps/gnome-commander exif gsf id3
gnome-base/gvfs cdda  gnome-keyring gphoto2
#####
 
media-libs/fontconfig -doc
##################
#compiz
x11-libs/libX11 xcb
x11-wm/compiz
#############################
#vdrburn
media-plugins/vdr-burn projectx
###########
#java
dev-java/icedtea6-bin nsplugin
################
#Projectx for videoumwandlung
#media-video/projectx mmx java5
#################
#mmsv2
media-video/mmsv2 sdl lirc
media-video/mms cpudetection
###############
#vlc
media-video/vlc matroska remoteosd stream schroedinger sdl id3tag
######
#virtmanager
app-emulation/libvirt kvm lvm sasl
#################
#nvidia
x11-drivers/nvidia-drivers acpi
###################
#mplayer
media-video/mplayer dvb pvr mp2 mng ssse3 v4l2 x264 xvid xanim teletext
#####
## epiphany will immer Firefox 2
www-client/epiphany xulrunner
####################
#app-emulation/emul-linux-x86-soundlibs revdep-rebuild loops
app-emulation/emul-linux-x86-soundlibs -arts
###
#Arbeitstier
app-misc/workrave
###############
#Kopete
x11-libs/qt-sql mysql
####################
##########
mail-client/evolution nntp pda exchange
###############
# lmsensors
gnome-extra/sensors-applet hddtemp libnotify lm_sensors nvidia
sys-apps/lm_sensors sensord
###############
#Sound
media-sound/audacity id3tag jack soundtouch twolame vamp
media-sound/jack-audio-connection-kit netjack
media-plugins/alsa-plugins jack libsamplerate pulseaudio
##############
#vmware
dev-cpp/gtkmm accessibility
dev-lang/python sqlite ncurses
############
#
sys-apps/hal apm acpi laptop
sys-power/pm-utils ntp
###################
#USV
sys-power/apcupsd doc ncurses nls threads cgi snmp usb
net-analyzer/net-snmp lm_sensors  sendmail
####################
#VPN
net-dialup/ppp atm dhcp eap-tls
# mppe-mppc
net-misc/vpnc hybrid-auth resolvconf
net-dialup/pptpclient tk
##########
##update
media-libs/freetype kpathsea
app-text/lcdf-typetools kpathsea
x11-libs/qt qt3support
###############
#texlive
app-text/texlive png pstricks truetype context  detex extra graphics music omega publishers science tex4ht xetex
####################
dev-util/libconf xml
##############
#Handy
app-mobilephone/gnokii X nls bluetooth ical mysql sms usb
dev-libs/openobex bluetooth syslog usb
net-wireless/bluez-utils usb
##############
#Kernel
#sys-kernel/gentoo-sources symlink
########################
#nano
#app-editors/nano ncurses nls spell unicode debug justify minimal slang
############
#git
dev-util/git bash-completion doc gtk iconv perl threads webdav cgi cvs emacs subversion tk
#############
#pgp seahorse
app-crypt/seahorse libnotify applet epiphany gedit  nautilus
app-crypt/seahorse-plugins applet epiphany gedit libnotify nautilus
app-admin/testdisk jpeg ntfs reiserfs
app-misc/slimrat cli gtk
#########################
app-portage/layman subversion git
######################
#dev-db/sqlite tcl


media-libs/libgphoto2 canon
dev-python/jinja2  -doc 
dev-python/sphinx  -doc


=gnome-extra/evolution-data-server-2.26.3 kerberos ldap
=dev-lang/fpc-2.2.4-r2 source
x11-libs/qt-opengl qt3support
x11-libs/qt-core qt3support
x11-libs/qt-gui qt3support
x11-libs/qt-sql qt3support
sys-auth/pambase gnome-keyring consolekit
dev-lang/python tk
x11-libs/qt-qt3support kde
x11-libs/qt-webkit kde
=net-libs/opal-3.6.6 sip
=net-libs/ptlib-2.6.5 wav
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Tue Jan 26, 2010 5:34 am    Post subject: Reply with quote

Nope, that's not the problem. Very messy, but not the problem. :P

Then it must be in the world file.

Remove anything *-libs/<package> except sys-libs/gpm (if you have it), and
also anything poppler from /var/lib/portage/world
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1627

PostPosted: Tue Jan 26, 2010 9:20 am    Post subject: Reply with quote

Mike Hunt wrote:
Nope, that's not the problem. Very messy, but not the problem. :P

Then it must be in the world file.

Remove anything *-libs/<package> except sys-libs/gpm (if you have it), and
also anything poppler from /var/lib/portage/world


Hi thanks...it's always the same:

Code:
* Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'app-text/poppler-0.12.3-r2', 'merge') pulled in by
    ~app-text/poppler-0.12.3[cairo] required by ('ebuild', '/', 'app-text/evince-2.28.2', 'merge')
    ~app-text/poppler-0.12.3[cairo] required by ('ebuild', '/', 'virtual/poppler-glib-0.12.3-r2', 'merge')

  ('ebuild', '/', 'dev-libs/poppler-0.10.7', 'merge') pulled in by
    ~dev-libs/poppler-0.10.7 required by ('ebuild', '/', 'dev-tex/luatex-0.46.0', 'merge')
    ~dev-libs/poppler-0.10.7 required by ('ebuild', '/', 'virtual/poppler-0.10.7', 'merge')
    ~dev-libs/poppler-0.10.7 required by ('ebuild', '/', 'dev-tex/pdftex-1.40.9', 'merge')
    (and 1 more)

  ('ebuild', '/', 'app-text/poppler-utils-0.10.7', 'merge') pulled in by
    ~app-text/poppler-utils-0.10.7[abiword] required by ('ebuild', '/', 'virtual/poppler-utils-0.10.7', 'merge')
    ~app-text/poppler-utils-0.10.7[abiword] required by ('ebuild', '/', 'net-print/cups-1.3.11-r1', 'merge')
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2103
Location: Near Toronto

PostPosted: Tue Jan 26, 2010 1:07 pm    Post subject: Reply with quote

Quote:
Portage should then be able to upgrade automatically.


mod +1 funny

So does this all mean that if I have kde 4.3.4 (now package masked)
I should put all the poppler packages also in package.keywords?
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Tue Jan 26, 2010 2:04 pm    Post subject: Reply with quote

albright wrote:
Quote:
Portage should then be able to upgrade automatically.

mod +1 funny

There are only three reasons I can think of why portage would not be able to upgrade this smoothly, and they basically all come down to user error:

1) your useflags are not set correctly
The desktop profile plus the useflags that are enabled by default in app-text/poppler should let things work "out of the box". If you are not on the desktop profile, then double check if you have the useflags enabled that you need. Also double check if you are not overriding useflags by disabling them, while they are actually needed by packages you have installed. For example, if you have the cairo useflag disabled, and you have a package that depends on virtual/poppler-glib, you have a problem.

2) you have poppler packages in your world file
As poppler is a library, there is no need for it to be in your world file. Just let the applications that you use pull in the required dependencies. Run a grep poppler /var/lib/portage/world and just remove all those poppler entries.

3) you are on stable and your package.keywords is not in order
If you have any poppler related entries in your package.keywords file, double check that they cover the latest app-text/poppler and virtuals.

albright wrote:
So does this all mean that if I have kde 4.3.4 (now package masked)
I should put all the poppler packages also in package.keywords?

If you want the currently latest poppler, which is highly recommended, and your are not on testing (~arch), then you should have these entries in your package.keywords:
Code:
~app-text/poppler-0.12.3
~app-text/poppler-data-0.4.0
~virtual/poppler-0.12.3
~virtual/poppler-glib-0.12.3
~virtual/poppler-qt4-0.12.3
~virtual/poppler-utils-0.12.3


For convenience, you could add these packages to your package.mask:
Code:
app-text/poppler-bindings
app-text/poppler-utils
dev-libs/poppler
dev-libs/poppler-glib
dev-libs/poppler-qt3
dev-libs/poppler-qt4

_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Tue Jan 26, 2010 2:17 pm    Post subject: Reply with quote

Tinitus wrote:
Hi thanks...it's always the same:

Code:
 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.
[...]

If you have done everything I wrote above, and it's still not working, then try this:
Code:
emerge --sync && emerge -C app-text/poppler-bindings app-text/poppler-utils dev-libs/poppler \
dev-libs/poppler-glib dev-libs/poppler-qt3 dev-libs/poppler-qt4 && emerge -a1 "=app-text/poppler-0.12.3-r2"

_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Tue Jan 26, 2010 2:42 pm    Post subject: Reply with quote

Tinitus,

To emerge kde-meta without the blocks, these 2 are missing from package.keywords:
Code:
~virtual/poppler-qt4-0.12.3
~virtual/poppler-utils-0.12.3


Also you should remove the qt3 USE flag from /etc/make.conf


Last edited by Mike Hunt on Tue Jan 26, 2010 3:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum