Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
åäö i gnome
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
linc
n00b
n00b


Joined: 31 Aug 2003
Posts: 14
Location: Skåne, Sweden

PostPosted: Sat Sep 06, 2003 1:05 am    Post subject: åäö i gnome Reply with quote

Ännu en sån här tråd.. :oops:

Jag har sökt men har inte hittat någon som tar upp just det här, ber om ursäkt om jag har missat någon tidigare tråd.

Jag har gnome på engelska, och vill fortsätta ha det så, men min tangentbordslayout är också engelsk. Den är svensk i console, och jag har Option "XkbdLayout" "se" i XF86Config.

Tangentbordslayouten blir rätt om jag använder "Keyboard Layout Switcher"-grunkan och lägger den i panelen, men eftersom jag inte vill ha den där (vill helst inte köra programmet öht, jag vill ju inte växla mellan olika layouter) så undrar jag hur jag ska göra. Startar jag programmet och sen stänger av det blir layouten amerikansk igen.
_________________
http://counter.li.org/cgi-bin/runscript/display-person.cgi?user=126749
Back to top
View user's profile Send private message
Andersson
Guru
Guru


Joined: 12 Jul 2003
Posts: 525
Location: Göteborg, Sweden

PostPosted: Sun Sep 07, 2003 2:16 am    Post subject: Reply with quote

Om jag förstår dig rätt vill du ha gnome på engelska men svenskt tangentbord? Har du kollat dina inställningar i /etc/env.d/02locale? Sätter du dessa rätt kan du få svenskt tangentbord men engelskt språk. Det jobbiga är att de har olika prioritet och vissa skriver över andra... Detta funkar för mig:
Code:

#LC_ALL=sv_SE
#LANGUAGE=sv_SE
LANG="sv_SE"
#LC_TELEPHONE=sv_SE
#LC_CTYPE=sv_SE
#LC_NUMERIC=sv_SE
#LC_TIME=sv_SE
#LC_MONETARY=sv_SE
#LC_ADDRESS=sv_SE
#LC_COLLATE=sv_SE
#LC_NAME=sv_SE
#LC_PAPER=sv_SE
#LC_NUMERIC=sv_SE
SYSFONT="lat0-16"
#LC_MEASUREMENT=sv_SE
LC_MESSAGES="en_US"
#LC_IDENTIFICATION=sv_SE

Dvs, de flesta är kommenterade... Pröva och se!
Back to top
View user's profile Send private message
linc
n00b
n00b


Joined: 31 Aug 2003
Posts: 14
Location: Skåne, Sweden

PostPosted: Sun Sep 07, 2003 5:44 pm    Post subject: Reply with quote

Hmm, jag har inte filen /etc/env.d/02locale, ska jag skapa den bara? Och isf, med vilka filrättigheter?
_________________
http://counter.li.org/cgi-bin/runscript/display-person.cgi?user=126749
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4830
Location: Gothenburg, Sweden

PostPosted: Sun Sep 07, 2003 5:53 pm    Post subject: Reply with quote

Det är bara att skapa den. Jag har 644 på min.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
linc
n00b
n00b


Joined: 31 Aug 2003
Posts: 14
Location: Skåne, Sweden

PostPosted: Mon Sep 08, 2003 7:38 am    Post subject: Reply with quote

Tack för svaren!

Jag skapade /etc/env.d/02locale med 644 som filrättigheter, och följande innehåll:

Code:
LC_ALL=sv_SE
LANGUAGE=sv_SE
LANG="sv_SE"
#LC_TELEPHONE=sv_SE
#LC_CTYPE=sv_SE
#LC_NUMERIC=sv_SE
#LC_TIME=sv_SE
#LC_MONETARY=sv_SE
#LC_ADDRESS=sv_SE
#LC_COLLATE=sv_SE
#LC_NAME=sv_SE
#LC_PAPER=sv_SE
#LC_NUMERIC=sv_SE
SYSFONT="lat0-16"
#LC_MEASUREMENT=sv_SE
LC_MESSAGES="en_US"
#LC_IDENTIFICATION=sv_SE


Resultatet? Svensktalande gnome (och alla andra program som stöder det), men amerikanskt tangentbord. :cry:
_________________
http://counter.li.org/cgi-bin/runscript/display-person.cgi?user=126749
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4830
Location: Gothenburg, Sweden

PostPosted: Mon Sep 08, 2003 9:24 am    Post subject: Reply with quote

Jag har
Code:
LANG="C"
LC_CTYPE="sv_SE"
LC_NUMERIC="sv_SE"
LC_TIME="sv_SE"
LC_COLLATE="sv_SE"
LC_MONETARY="sv_SE"
LC_MESSAGES="C"

i min. Svenskt tangentbord, datum mm men i övrigt engelsktalande gnome. Att du fick svenskt gnome beror nog på LANG(UAGE). Välj även engelska när du loggar in med gdm om du använder det.

I rc.conf har jag
Code:
KEYMAP="se-latin1"

och i XF86Config
Code:
    Option "XkbRules"   "xfree86"
    Option "XkbModel"   "pc105"
    Option "XkbLayout"  "se"

Sen kan det vara värt att titta på inställningarna i gnome-terminal.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
linc
n00b
n00b


Joined: 31 Aug 2003
Posts: 14
Location: Skåne, Sweden

PostPosted: Mon Sep 08, 2003 11:03 am    Post subject: Reply with quote

kallamej wrote:
I rc.conf har jag
Code:
KEYMAP="se-latin1"


Jag hade det förut också, men efter en 'emerge world' för någon dag sen så började den klaga på att "se-latin1" inte existerade. Så jag gick till katalogen med keymaps i (/usr/share/keymaps/i386/qwerty) och såg att de hade döpt om den till "sv-latin1". ;) Så jag har "sv-latin1" i min rc.conf istället.

kallarmej wrote:
och i XF86Config
Code:
    Option "XkbRules"   "xfree86"
    Option "XkbModel"   "pc105"
    Option "XkbLayout"  "se"

Sen kan det vara värt att titta på inställningarna i gnome-terminal.


Ahhh, här hade vi nog felet. Jag hade "XkbdLayout" i min XF86Config. 8O

Jag har ändrat det så att det överrensstämmer med dina inställningar nu och det funkar kanon! Jag tackar så mycket. :D
_________________
http://counter.li.org/cgi-bin/runscript/display-person.cgi?user=126749
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum