Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]X wont start framebuffer issues
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ForMar
n00b
n00b


Joined: 06 Dec 2008
Posts: 57
Location: Cali

PostPosted: Mon Jan 04, 2010 8:55 am    Post subject: [SOLVED]X wont start framebuffer issues Reply with quote

Hello,
Ive googled and searched the fourms and though i see that alot of ppl have simular issues i still cant seem to resolve it. My expereince in linux as a user is decent. Though as an admin it is low to nill


I'm attemping to install X on a computer of mine but when I "startx" it tells me

EE failed to load i810 (modules does not exsists) but my gcard is working running i915
EE failed to load vesa(modules does not exisits) I could fix this but do I need the generic driver?

and finally

Fatal server error:
Cannot run in framebuffer mode: specify busID

then if I use the config file from Xorg --configure I only get one error...

FATAL: module fbcon not found. But from what I understand its no longer a modules.

Code:

00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
        Kernel driver in use: agpgart-intel
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
        Kernel driver in use: i915
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
        Kernel driver in use: HDA Intel
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
        Kernel driver in use: uhci_hcd
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
        Kernel driver in use: uhci_hcd
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
        Kernel driver in use: uhci_hcd
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
        Kernel driver in use: uhci_hcd
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
        Kernel driver in use: ehci_hcd
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
        Kernel driver in use: ata_piix
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
        Kernel driver in use: ata_piix
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
        Kernel driver in use: i801_smbus
01:0a.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306 Fire II IEEE 1394 OHCI Link Layer Controller (rev c0)
01:0b.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 13)
        Kernel driver in use: skge

thanks for any help you can provide and your tme!


Last edited by ForMar on Mon Jan 04, 2010 11:40 pm; edited 1 time in total
Back to top
View user's profile Send private message
francofallica
n00b
n00b


Joined: 17 Mar 2008
Posts: 33

PostPosted: Mon Jan 04, 2010 10:37 am    Post subject: Reply with quote

what version of xserver are you running? and can you please post your xorg.conf file
Back to top
View user's profile Send private message
cach0rr0
Moderator
Moderator


Joined: 13 Nov 2008
Posts: 4121
Location: Houston, Republic of Texas

PostPosted: Mon Jan 04, 2010 10:40 am    Post subject: Reply with quote

could you chunk your kernel .config up on pastebin.com and share the link?

that would be quite useful in addition to the other information requested. If you're having trouble figuring out how to post it, but your network is functional:

Code:
emerge wgetpaste


then

Code:
wgetpaste -s ca /path/to/.config
Back to top
View user's profile Send private message
ForMar
n00b
n00b


Joined: 06 Dec 2008
Posts: 57
Location: Cali

PostPosted: Mon Jan 04, 2010 5:39 pm    Post subject: Reply with quote

Thanks for the responce!
as i said my experience in the admin relm is nill so please excuse any mistakes or posting the wrong info.

francofallica wrote:
what version of xserver are you running?


my xserver version is : 1.6.5-r1

francofallica wrote:
can you please post your xorg.conf file


http://pastebin.ca/1737589

Quote:
could you chunk your kernel .config up on pastebin.com and share the link?


thanks you very much for telling me how to do that i probably would have spend quite some time attempting to figure out what the hell you where asking for much less how t o do it =P

http://pastebin.ca/1737594

again thanks for the responce and your time!
Back to top
View user's profile Send private message
cach0rr0
Moderator
Moderator


Joined: 13 Nov 2008
Posts: 4121
Location: Houston, Republic of Texas

PostPosted: Mon Jan 04, 2010 8:35 pm    Post subject: Reply with quote

okie doke

go ahead and untick this (rather, untick it in menuconfig - KMS with FB is a nono)

Code:

CONFIG_DRM_I915_KMS=y



Also select these, which are currently unticked:

Code:

CONFIG_FB_BOOT_VESA_SUPPORT=y
CONFIG_FB_VESA=y



then rebuild your kernel and install as you did before

to take advantage of the FB, might add a "vga=0x318" to your kernel line in grub.conf

Anyway, try making those changes and post back with your results. If you get stuck getting the kernel rebuilt, post back as well.
_________________
Lost configuring your system?
dump lspci -n here | see Pappy's guide | Link Stash
Back to top
View user's profile Send private message
ForMar
n00b
n00b


Joined: 06 Dec 2008
Posts: 57
Location: Cali

PostPosted: Mon Jan 04, 2010 9:53 pm    Post subject: Reply with quote

cach0rr0 wrote:
okie doke

go ahead and untick this (rather, untick it in menuconfig - KMS with FB is a nono)

Code:

CONFIG_DRM_I915_KMS=y


Im assuming you mean =n if you want me to untick it
cach0rr0 wrote:
okie doke
Also select these, which are currently unticked:

Code:

CONFIG_FB_BOOT_VESA_SUPPORT=y
CONFIG_FB_VESA=y


done

cach0rr0 wrote:
okie doke
then rebuild your kernel and install as you did before

to take advantage of the FB, might add a "vga=0x318" to your kernel line in grub.conf

Anyway, try making those changes and post back with your results. If you get stuck getting the kernel rebuilt, post back as well.


I have yet to use vga in the grub.conf but when I lspci -k there is no kernel attached under the video card. I attempted to reinstall xserver with VIDEO_CARD = vesa but I got no where

the new error:

(EE) Failed to load module "intel" (module does not exist, 0)
(EE) Failed to load module "i810" (module does not exist, 0)
(EE) open /dev/fb0: No such file or directory


as always thanks for the help and time!
Back to top
View user's profile Send private message
cach0rr0
Moderator
Moderator


Joined: 13 Nov 2008
Posts: 4121
Location: Houston, Republic of Texas

PostPosted: Mon Jan 04, 2010 11:05 pm    Post subject: Reply with quote

ForMar wrote:

I have yet to use vga in the grub.conf but when I lspci -k there is no kernel attached under the video card. I attempted to reinstall xserver with VIDEO_CARD = vesa but I got no where


yip, that's fine, we wouldn't expect i915 to show in lspci -k without KMS

ForMar wrote:

the new error:

(EE) Failed to load module "intel" (module does not exist, 0)
(EE) Failed to load module "i810" (module does not exist, 0)
(EE) open /dev/fb0: No such file or directory


as always thanks for the help and time!


Adding the vga statement to grub.conf should give you a /dev/fb0

I may edit this post in a sec, can't remember if you have an xorg.conf or not, if you have hal/dbus setup and running in the default runlevel or not.

EDIT: ok, I see no mention of hal or dbus. Do you have 'hal' and 'dbus' in your USE flags?

Would like you to post the output of the following:
Code:

emerge --info
equery hasuse hal
rc-update show |egrep '(hal|dbus)'


Note the 'equery' command is part of 'gentoolkit', which is a must-have package really. If you don't have it, 'emerge gentoolkit' and re-run that command, posting the output here.

I think that's all for now. Should be able to point you in the right direction from there (though may want to look at additional info)
_________________
Lost configuring your system?
dump lspci -n here | see Pappy's guide | Link Stash
Back to top
View user's profile Send private message
ForMar
n00b
n00b


Joined: 06 Dec 2008
Posts: 57
Location: Cali

PostPosted: Mon Jan 04, 2010 11:19 pm    Post subject: Reply with quote

[quote="cach0rr0"

Adding the vga statement to grub.conf should give you a /dev/fb0

I may edit this post in a sec, can't remember if you have an xorg.conf or not, if you have hal/dbus setup and running in the default runlevel or not.[/quote]

I'm am attempting to use which ever works, i do have a xorg.conf but only the one generated via Xorg -configure . I do have both hal and dbus in the default lvl and if i can help it id like to not use an xorg config.

Progress!

startx w/o a xorg produces....
Code:

(EE) Failed to load module "intel" (module does not exist, 0)
(EE) Failed to load module "i810" (module does not exist, 0)

Fatal server error:
Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices


Running xorg -config xorg.conf.new produces...

Code:

(EE) FBDEV(0): FBIOBLANK: Invalid argument                                                     
expected keysym, got XF86TouchpadToggle: line 122 of inet                                       
(EE) FBDEV(0): FBIOBLANK: Invalid argument     


and a locked blank screen with no curser, but the backlight is on.

EDIT:

this info you asked for
http://pastebin.ca/1738067
i put it all on one file if its a bit much let me know and ill sperate it!

as always thank you so much and youve been beyond helpful!
Back to top
View user's profile Send private message
cach0rr0
Moderator
Moderator


Joined: 13 Nov 2008
Posts: 4121
Location: Houston, Republic of Texas

PostPosted: Mon Jan 04, 2010 11:31 pm    Post subject: Reply with quote

you hit the same stumbling block I did

without an xorg.conf I got

Code:

Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices


if I add an xorg.conf, all goes well.

Just to make sure we're not in a situation where things are working, but LOOK like they're not working, try adding the -retro switch when you test your xorg.conf.new

If you get a mouse and that, then it should be suitable for moving over to /etc/X11/xorg.conf

Far as getting it to work without an xorg.conf, I've had no real luck myself. Am using

Code:
Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller


For reference, if it's of any use to you (or if you fancy trying similar out for yourself)

Code:

laptop02 ~ # lspci |head -n 3
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)
laptop02 ~ # lspci -n |head -n 3
00:00.0 0600: 8086:2a40 (rev 09)
00:02.0 0300: 8086:2a42 (rev 09)
00:02.1 0380: 8086:2a43 (rev 09)
laptop02 ~ # cd /usr/src/linux/drivers
laptop02 drivers # grep -ir x2a42 *
char/agp/intel-agp.c:#define PCI_DEVICE_ID_INTEL_GM45_IG         0x2A42
edac/amd64_edac.c:      {/*8*/  0, 0x15c1, 0x2a42, 0x3f83, 0xcef4, 0xdb35, 0xe4b6, 0xf177,
gpu/drm/i915/i915_drv.h:                       (dev)->pci_device == 0x2A42 || \
gpu/drm/i915/i915_drv.h:#define IS_GM45(dev) ((dev)->pci_device == 0x2A42)


(tells me I'm using GM45, which works with i915 driver)

Anyway, X has always been epic fail for me without xorg.conf - epic fail on xorg 1.6, epic fail on xorg 1.7, and I *know* I have everything else set up as it should be.
_________________
Lost configuring your system?
dump lspci -n here | see Pappy's guide | Link Stash
Back to top
View user's profile Send private message
cach0rr0
Moderator
Moderator


Joined: 13 Nov 2008
Posts: 4121
Location: Houston, Republic of Texas

PostPosted: Mon Jan 04, 2010 11:34 pm    Post subject: Reply with quote

ForMar wrote:

EDIT:

this info you asked for
http://pastebin.ca/1738067
i put it all on one file if its a bit much let me know and ill sperate it!

as always thank you so much and youve been beyond helpful!


ah right, just saw this.

so I see hald, but I don't see dbus - the two are intertwined, so

Code:

rc-update add dbus default
/etc/init.d/dbus start


Then try again

If that fails, see my previous post
_________________
Lost configuring your system?
dump lspci -n here | see Pappy's guide | Link Stash
Back to top
View user's profile Send private message
ForMar
n00b
n00b


Joined: 06 Dec 2008
Posts: 57
Location: Cali

PostPosted: Mon Jan 04, 2010 11:40 pm    Post subject: Reply with quote

cach0rr0 wrote:

Just to make sure we're not in a situation where things are working, but LOOK like they're not working, try adding the -retro switch when you test your xorg.conf.new



worked with the -retro option !!!

youve been unbelievably helpful. And maybe some day ill understand how you knew what to do =P

im going to go ahead and stamp this one as solved ! hopeing with any luck i can figure out the rest!
Back to top
View user's profile Send private message
cach0rr0
Moderator
Moderator


Joined: 13 Nov 2008
Posts: 4121
Location: Houston, Republic of Texas

PostPosted: Tue Jan 05, 2010 12:04 am    Post subject: Reply with quote

ForMar wrote:

worked with the -retro option !!!


Cool, basically means it was working, but didn't *look* like it was working (someone else can explain why - but apparently some of the base apps like twm and whatnot are no longer emerged by default, so while things may be fine you'll have trouble knowing)

NB: the -retro thing isn't obvious, and knowing where to look to even know it exists isn't obvious (I just learned about it earlier today). As a guess, i checked 'man Xserver', and sure enough:

Code:

 -retro  starts  the  stipple with the classic stipple and cursor visible.  The default is to
               start with a black root window, and to suppress display  of  the  cursor  until  the
               first  time  an  application  calls XDefineCursor().  For the Xorg server, this also
               sets the default for the DontZap option to FALSE.  For kdrive servers, this  implies
               -zap.


ForMar wrote:

youve been unbelievably helpful. And maybe some day ill understand how you knew what to do =P


I just happen to have ended up asking the same questions you did at an earlier date, when my own rig was broken :P
People helped me, I learned, and pass it on like some sort of weird hippie 'pay it forward' nonsense. Most of this is regurgitation of things people have told me, or that I've seen work for others.

X is easily the most painful thing I've had to configure under Gentoo (OpenLDAP a close second), especially as up until around late 2008 I'd only ever *really* run it for headless hardened servers.

Glad things are quasi-functional for you. Post back if you hit any slip-ups getting a window manager or desktop environment functional!
_________________
Lost configuring your system?
dump lspci -n here | see Pappy's guide | Link Stash
Back to top
View user's profile Send private message
ForMar
n00b
n00b


Joined: 06 Dec 2008
Posts: 57
Location: Cali

PostPosted: Tue Jan 05, 2010 7:06 pm    Post subject: Reply with quote

Hi again!
humm it seems im not quite out of the woods though it might be worth starting a new post,
now when I startx I get a black screen and then an error comes up
Code:
Wating for X server to shut down error setting MTRR Invalid argument


my xorg config:

http://pastebin.ca/1739122

the logs produces no errors though =/ Ill prob wait a few hours and create a new post if I dont hear back from you.

As always thank you very much for your time and help!
Back to top
View user's profile Send private message
cach0rr0
Moderator
Moderator


Joined: 13 Nov 2008
Posts: 4121
Location: Houston, Republic of Texas

PostPosted: Tue Jan 05, 2010 9:56 pm    Post subject: Reply with quote

what desktop environment/window manager are you using? KDE, Gnome, which?

From here all that may be left is getting things working such that your desktop environment of choice is launched when you `startx`
_________________
Lost configuring your system?
dump lspci -n here | see Pappy's guide | Link Stash
Back to top
View user's profile Send private message
ForMar
n00b
n00b


Joined: 06 Dec 2008
Posts: 57
Location: Cali

PostPosted: Tue Jan 05, 2010 10:43 pm    Post subject: Reply with quote

cach0rr0 wrote:
what desktop environment/window manager are you using? KDE, Gnome, which?


Havent installed all that yet just want to make sure x works so I at least know where the problem is coming from =/ before I deal with KDE. Would that be my problem?
Back to top
View user's profile Send private message
cach0rr0
Moderator
Moderator


Joined: 13 Nov 2008
Posts: 4121
Location: Houston, Republic of Texas

PostPosted: Tue Jan 05, 2010 10:50 pm    Post subject: Reply with quote

ForMar wrote:

Havent installed all that yet just want to make sure x works so I at least know where the problem is coming from =/ before I deal with KDE. Would that be my problem?


I believe so. You could emerge 'twm' and 'xterm' just to make sure - in fact do that, bring in those two, fire off a startx, and if twm works you're good to pull down your DE/WM of choice
_________________
Lost configuring your system?
dump lspci -n here | see Pappy's guide | Link Stash
Back to top
View user's profile Send private message
ForMar
n00b
n00b


Joined: 06 Dec 2008
Posts: 57
Location: Cali

PostPosted: Tue Jan 05, 2010 11:05 pm    Post subject: Reply with quote

It seems im just a bit im dense =/ sorry it works after installing the managers! alright off to my 8hour install of kde. again and as always youve been amazingly helpful !
Back to top
View user's profile Send private message
cach0rr0
Moderator
Moderator


Joined: 13 Nov 2008
Posts: 4121
Location: Houston, Republic of Texas

PostPosted: Wed Jan 06, 2010 12:02 am    Post subject: Reply with quote

no worries - this stuff is NOT particularly obvious or easy to find
I'm only aware of it because I sit on these forums entirely too much.

Am slowly beginning to understand how things piece together, but for the most part I just have a really good memory, and can regurgitate things I've heard from other people.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum