Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Alsa AC888 Recognized but no Playback
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
juanbobo
n00b
n00b


Joined: 22 Sep 2007
Posts: 39

PostPosted: Thu Dec 03, 2009 10:16 am    Post subject: Alsa AC888 Recognized but no Playback Reply with quote

I've got an AC888 audio chip (Nvidia) and for whatever reason somewhere on the upgrade path it stopped working. lspci shows the device and I am able to play audio at the console or in Amarok but nothing can be heard. I believe the problem is related to the disappearance of my asound.conf file, but if that is the case I don't know how to regenerate this file.
Back to top
View user's profile Send private message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2072

PostPosted: Thu Dec 03, 2009 1:29 pm    Post subject: Reply with quote

Just to be sure, you did try running `alsaconf` (again), /etc/init.d/alsasound is running and you unmuted the needed channels?
Back to top
View user's profile Send private message
haarp
Guru
Guru


Joined: 31 Oct 2007
Posts: 372

PostPosted: Thu Dec 03, 2009 1:39 pm    Post subject: Reply with quote

/var/lib/alsa/asound.conf? It is recreated when the alsa initscript stops. It just saves your mixer levels.

How are your speakers connected? Are you sure that everything is unmuted and not at 0%?
Back to top
View user's profile Send private message
juanbobo
n00b
n00b


Joined: 22 Sep 2007
Posts: 39

PostPosted: Thu Dec 03, 2009 1:45 pm    Post subject: Reply with quote

I did run alsaconf, alsasound is running, everything is unmuted, and I'm using headphones.
Back to top
View user's profile Send private message
haarp
Guru
Guru


Joined: 31 Oct 2007
Posts: 372

PostPosted: Thu Dec 03, 2009 1:52 pm    Post subject: Reply with quote

Are they connected to the front panel? Try playing around with the toggles in alsamixer. Specifically the "headphones" one, if it exists.
Back to top
View user's profile Send private message
juanbobo
n00b
n00b


Joined: 22 Sep 2007
Posts: 39

PostPosted: Thu Dec 03, 2009 4:38 pm    Post subject: Reply with quote

I've got the headphones plugged in the back, the headphone option is enabled, there's no volume knob or anything for the "headphones", it's just in the green jack. The Phonon sound system in KDE4 says the device is not working and defaulting to "." yet any program simulates playing music.
Back to top
View user's profile Send private message
haarp
Guru
Guru


Joined: 31 Oct 2007
Posts: 372

PostPosted: Thu Dec 03, 2009 8:37 pm    Post subject: Reply with quote

No idea then, sorry. But I recommend the 'speaker-test' tool from alsa-tools. It is a bit more verbose in case of errors.
Back to top
View user's profile Send private message
juanbobo
n00b
n00b


Joined: 22 Sep 2007
Posts: 39

PostPosted: Thu Dec 03, 2009 9:12 pm    Post subject: Reply with quote

Thanks for the replies, ran the speaker test, didn't report any errors, but I didn't hear anything.
Back to top
View user's profile Send private message
juanbobo
n00b
n00b


Joined: 22 Sep 2007
Posts: 39

PostPosted: Mon Dec 07, 2009 5:12 pm    Post subject: Reply with quote

I ran alsactl init 0, I suppose it restored the default settings for the card and it works now, but there is still an issue with phonon apparently as I can't play music in amarok 2.
Back to top
View user's profile Send private message
juanbobo
n00b
n00b


Joined: 22 Sep 2007
Posts: 39

PostPosted: Wed Dec 09, 2009 4:10 pm    Post subject: Reply with quote

Problem averted by switching the phonon backend from xine to gstreamer.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum