Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
compiz problem (blocks)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Sat Dec 05, 2009 11:59 am    Post subject: compiz problem (blocks) Reply with quote

hi i have bin trying to get a compiz update but getting this blocks

mybox / # emerge -avu compiz-fusion-plugins-extra

* IMPORTANT: 4 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] x11-plugins/compiz-fusion-plugins-main-0.6.0 USE="-jpeg" 767 kB
[ebuild N ] x11-plugins/compiz-fusion-plugins-extra-0.6.0 2,240 kB
[blocks B ] x11-plugins/compiz-fusion-plugins-extra ("x11-plugins/compiz-fusion-plugins-extra" is blocking x11-plugins/compiz-plugins-extra-0.8.4-r1)
[blocks B ] x11-plugins/compiz-fusion-plugins-main ("x11-plugins/compiz-fusion-plugins-main" is blocking x11-plugins/compiz-plugins-main-0.8.4)

Total: 2 packages (2 new), Size of downloads: 3,007 kB
Conflict: 2 blocks (2 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('installed', '/', 'x11-plugins/compiz-plugins-extra-0.8.4-r1', 'nomerge') pulled in by
x11-plugins/compiz-plugins-extra required by world

('installed', '/', 'x11-plugins/compiz-plugins-main-0.8.4', 'nomerge') pulled in by
x11-plugins/compiz-plugins-main required by world

('ebuild', '/', 'x11-plugins/compiz-fusion-plugins-extra-0.6.0', 'merge') pulled in by
compiz-fusion-plugins-extra


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


* IMPORTANT: 4 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

mybox / #

why?
Back to top
View user's profile Send private message
OnlyTux
Apprentice
Apprentice


Joined: 15 Mar 2007
Posts: 174

PostPosted: Sat Dec 05, 2009 1:42 pm    Post subject: Reply with quote

Hello,

you could try to unmerge the offending packages and retry emerging compiz-fusion.
The plugins are all dependencies and they must be properly unmasked in packages.keywords.
_________________
ANTONIO: How every fool can play upon the world! I think the best grace of wit will shortly turn into silence, and discourse grow commendable in none only but parrots...

Shakespeare, The Merchant of Venice
Back to top
View user's profile Send private message
hedmo
l33t
l33t


Joined: 29 Aug 2009
Posts: 839
Location: halmstad

PostPosted: Sat Dec 05, 2009 4:04 pm    Post subject: Reply with quote

mybox / # emerge --unmerge "x11-plugins/compiz-fusion-plugins-extra"

--- Couldn't find 'x11-plugins/compiz-fusion-plugins-extra' to unmerge.

>>> No packages selected for removal by unmerge

* IMPORTANT: 4 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.



mybox / # emerge --unmerge "x11-plugins/compiz-fusion-plugins-main"

--- Couldn't find 'x11-plugins/compiz-fusion-plugins-main' to unmerge.

>>> No packages selected for removal by unmerge

* IMPORTANT: 4 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

mybox / #
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum