Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Slim will not start fluxbox
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
jezaustin
Tux's lil' helper
Tux's lil' helper


Joined: 22 Sep 2006
Posts: 83
Location: england

PostPosted: Fri Nov 20, 2009 9:53 am    Post subject: [solved] Slim will not start fluxbox Reply with quote

Morning,
For some reason, my xdm (slim) will not start fluxbox, I instead get twm + a couple of xterms.

If I stop the xdm service, I can startx into fluxbox. I have ~/.xsession symlinked to ~/.xinitrc. ("exec startfluxbox")
Also, I can log in with slim, then run "killall twm; startfluxbox" and get going that way. What could be going wrong? Should .xsession set an XSESSION variable or something?

thanks,
Jez.


Last edited by jezaustin on Tue Nov 24, 2009 3:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
feiticeir0
Apprentice
Apprentice


Joined: 13 Jul 2005
Posts: 256
Location: Castelo Branco, Portugal

PostPosted: Fri Nov 20, 2009 9:15 pm    Post subject: Reply with quote

Hi.

I had slim working with fluxbox.

Did you put edit /etc/rc.conf and add fluxbox to the XSESSION variable ?
Code:

XSESSION="fluxbox"

_________________
Do It With Rhythm
Back to top
View user's profile Send private message
Nerevar
l33t
l33t


Joined: 31 May 2008
Posts: 712

PostPosted: Sat Nov 21, 2009 1:02 am    Post subject: Reply with quote

Make sure you have this in /etc/slim.conf:
Code:
login_cmd           exec /bin/bash -login ~/.xinitrc %session
Back to top
View user's profile Send private message
taipan67
l33t
l33t


Joined: 04 Dec 2004
Posts: 866
Location: England (i'm told...)

PostPosted: Sat Nov 21, 2009 2:39 pm    Post subject: Reply with quote

Another variable you could try setting in /etc/slim.conf is "sessions"...
Code:
# Available sessions (first one is the default).
# The current chosen session name is replaced in the login_cmd
# above, so your login command can handle different sessions.
# see the xinitrc.sample file shipped with slim sources
sessions            fluxbox,openbox,xfce4

This works for me (along with /etc/rc.conf's $XSESSION variable), and i don't use a ~/.xsession or ~/.xinitrc at all.

EDIT: The value passed to both of those variables should match the name of a corresponding script in /etc/X11/Sessions... :wink:
_________________
"Anyone who goes to see a psychiatrist should have their head examined!"
Back to top
View user's profile Send private message
jezaustin
Tux's lil' helper
Tux's lil' helper


Joined: 22 Sep 2006
Posts: 83
Location: england

PostPosted: Tue Nov 24, 2009 3:07 pm    Post subject: Reply with quote

Nerevar wrote:
Make sure you have this in /etc/slim.conf:
Code:
login_cmd           exec /bin/bash -login ~/.xinitrc %session


Thanks, just did a reboot and this sorted it for me.
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2444
Location: Austria

PostPosted: Tue Nov 24, 2009 3:59 pm    Post subject: Reply with quote

The default way to do this is to create this file with the according variable setting:
Code:
echo "XSESSION=fluxbox" > /etc/env.d/90xsession

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
jdratlif
n00b
n00b


Joined: 22 Aug 2005
Posts: 48
Location: in a small white padded room.

PostPosted: Thu Nov 26, 2009 7:30 pm    Post subject: Reply with quote

genstorm wrote:
The default way to do this is to create this file with the according variable setting:
Code:
echo "XSESSION=fluxbox" > /etc/env.d/90xsession


What happened to XSESSION in /etc/rc.conf? Is this a recent change? I didn't notice the message for xinit until you mentioned this about creating the 90xsession file.
_________________
CODEpendent blog - http://jdrrant.blogspot.com/
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2444
Location: Austria

PostPosted: Thu Nov 26, 2009 11:44 pm    Post subject: Reply with quote

That option has moved out of rc.conf with baselayout-2.0 and openrc together with several other things. As I understand it, the /etc/env.d/90xsession method has 'always' been working but was overridden by rc.conf until that change, which might be the reason to make xinit push it now.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
jezaustin
Tux's lil' helper
Tux's lil' helper


Joined: 22 Sep 2006
Posts: 83
Location: england

PostPosted: Tue Dec 01, 2009 12:40 pm    Post subject: Reply with quote

Is baselayout2 the reason for users' .xsessions being ignored by slim? My expectation has always been that xdm or replacement would honour users' preferences by default, and it baffled me a bit when that didn't happen.

J.
Back to top
View user's profile Send private message
tava
n00b
n00b


Joined: 15 Nov 2005
Posts: 13

PostPosted: Wed Dec 23, 2009 7:14 pm    Post subject: Reply with quote

Does not work for me:
Quote:

echo "XSESSION=fluxbox" > /etc/env.d/90xsession



I used:

Quote:
echo 'XSESSION="startfluxbox"' > /etc/env.d/90xsession


instead.
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2379
Location: Edmonton, AB

PostPosted: Wed Dec 23, 2009 8:57 pm    Post subject: Reply with quote

tava wrote:
Does not work for me:
Quote:

echo "XSESSION=fluxbox" > /etc/env.d/90xsession



I used:

Quote:
echo 'XSESSION="startfluxbox"' > /etc/env.d/90xsession


instead.


That worked for me as well.
Does it mean that /etc/rc.conf file is obsolete?
(somebody screw it up gain :-/)
_________________
#Joseph
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2444
Location: Austria

PostPosted: Wed Dec 23, 2009 9:06 pm    Post subject: Reply with quote

No it's not obsolete, it just doesn't handle XSESSION anymore. ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
OPelerin
Guru
Guru


Joined: 17 Jul 2004
Posts: 328
Location: Belgium

PostPosted: Wed Mar 03, 2010 12:14 pm    Post subject: Reply with quote

Thanks for the tip. I had the same issue!
_________________
Olivier PELERIN
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum