Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GeCHI Weekly Report #1.8
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano
View previous topic :: View next topic  
Author Message
!equilibrium
Bodhisattva
Bodhisattva


Joined: 06 Jun 2004
Posts: 2109
Location: MI/BG/LC

PostPosted: Wed Nov 18, 2009 12:42 pm    Post subject: Reply with quote

bandreabis wrote:
Ora sto sbattendo contro il bluetooth che non mi permette di esplorare il mio cell. Su kde3, kdebluetooth girava "nativamente", kbluetooth no.


... e guarda caso, entrambi non fanno parte della suite KDE4 ne tanto meno sono sotto il controllo di KDE eV :roll:
_________________
Arch Tester for Gentoo/FreeBSD
Equilibrium's Universe

all my contents are released under the Creative Commons Licence by-nc-nd 2.5
Back to top
View user's profile Send private message
devilheart
l33t
l33t


Joined: 17 Mar 2005
Posts: 777
Location: san leonardo del friuli

PostPosted: Wed Nov 18, 2009 6:36 pm    Post subject: Reply with quote

riverdragon wrote:
Io uso gentoo da tre anni e mezzo, ma sarei curioso di sapere a che versioni erano i principali software 4, 6 o otto anni fa! :D
intendevo, chi è quel matto che non aggiorna da più di 3 anni e pretende che l'aggiornamento funzioni sempre e comunque?
bandreabis wrote:
Non so cloc3, ma anche io sono molto incazz per la rimozione di kde3, kde4 è tutto fumo e arrosto molto poco! Mi scappa di paragonarlo a Vista nel mondo Microsoft. KDE4 non lo sopporto!
Ma lasciare Gentoo è un passo che non mi sognerei mai di fare. Per ora... :twisted:
beh, non puoi di certo restare su un sistema quando non sono più mantenuti né il sistema ne le librerie per farlo andare
!equilibrium wrote:
non avete capito una fava di quello che ho scritto, il mio esempio di 8 anni era solo un esempio e non era riferito al passato: la gentoo di oggi (2009) NON sarà retrocompatibile con le versioni del passato di portage (quelle rilasciate tra l'anno 1999 e il 2009), ma IN FUTURO, sarà possibile fare gli upgrade da una versione qualsiasi di portage successiva a quella in cui il progetto di retro-compatibilità è partito (quindi al massimo partendo da novembre 2009, o dalla data in cui partirà sto benedetto progetto) fino all'ultima versione stabile, il tutto tramite degli upgrade guidati e graduali; esempio: gentoo installata nel 2009, ma siamo nell'anno 2014 e vogliamo aggiornare all'ultima stabile = fai l'aggiornamento di portage all'ultima stabile (2014), ma siccome hai superato 2 volte i 2 anni previsti dal ciclo di rilascio di portage (2009 +2 = 2011 + 2 = 2013) sicuramente i file di configurazione di Gentoo e/o di portage possono essere cambiati (ma non è detto!), quindi vai sulla pagina web con le istruzioni passo passo per gli upgrade retro-compatibili che ho accennato nel GWR e modifichi quello che ti suggerirà tale guida (sempre che ci sia da modificare qualcosa), fine.
se è una questione di mettere delle guide per l'aggiornamento non vedo quale sia il problema di adottare bash4. se i vecchi bash non saranno utilizzabili con i nuovi ebuild la guida semplicemente riporterà il passaggio per aggiornare bash
Quote:
p.s.: le distro commerciali come redhat (non fedora!) e novell hanno la totale retrocompatibilità (tramite una GUI point&click che fa tutto il lavoro per voi), ma è un servizio che costa svariate migliaia di euro, all'anno; voi l'avreste, gratis e senza sforzo da parte dei devel Gentoo e vi lagnate pure; praticamente state sputando nel piatto in cui mangiate :lol: bravi!
ce lo possiamo permettere perché una retrocompatibilità del genere ci è inutile :P
cloc3 wrote:
xdarma wrote:
Certi che 'sti piagnoni di KDE3 sono proprio monotoni :-D

un software instabile viene imposto in sostituzione di uno stabile e collaudato, con danni precisi per gli utenti.
semmai incompleto ma assolutamente non instabile. kde 4.3.1 è stabile per gentoo, e se è stabile per gentoo...
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2094
Location: イタリアのロヂで

PostPosted: Wed Nov 18, 2009 7:36 pm    Post subject: Reply with quote

Va beh.
Attendiamo sviluppi di kde e dei programmi di contorno.
Per velocizzare il raggiungimento del mio obbiettivo, usiamo kde4 ~x86.
E viva Gentoo.
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
xdarma
Guru
Guru


Joined: 08 Dec 2003
Posts: 557
Location: tra veneto e friuli (Italy)

PostPosted: Wed Nov 18, 2009 8:38 pm    Post subject: Reply with quote

cloc3 wrote:
un software instabile viene imposto in sostituzione di uno stabile e collaudato, con danni precisi per gli utenti.

Imposto? Danni? Ma qualcuno ti obbliga a digitare "emerge --sync && emerge -uDN world"? Se non ti funziona ark (per dirne uno) fallisce la ditta?

cloc3 wrote:
a breve, installare kde3.* diventerà progressivamente più difficoltoso: le dipendenze risulteranno irresolubili e le incompatibilità con altre parti del sistema, giù giù fino al kernel, faranno il resto. ma proprio questo è il motivo per cui la decisione dei devel (mio malgrado) è corretta. il supporto a kde3 è rimosso upstream, per gentoo non c'è nulla da fare. possessori di macchine vecchie, acquistate nuova ram.

Ma tutto questo dopo la venuta dei 4 cavalieri dell'apocalisse ma prima che il mare incominci a bollire? :-P

cloc3 wrote:
ma lasciaci questa la libertà di lagnarci apertamente. :!:

Ti dovrebbero cambiare il level da "Veteran" a "Rex Piagnorum" :-D

E credo di sapere perchè sei tanto restio ad abbandonare KDE3: adesso con KDE4 devi cambiare nickname in cloc4 :-D

!equilibrium wrote:
...si avrà la possibilità di accellerare interamente le UI tramite OpenGL, senza gravare quindi sulla CPU.

Questo mi sembra molto interessante.

bandreabis wrote:
E viva Gentoo.

Sempre viva!
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1412
Location: <ud|me|ts> - Italy

PostPosted: Wed Nov 18, 2009 11:37 pm    Post subject: Reply with quote

xdarma wrote:

cloc3 wrote:
ma lasciaci questa la libertà di lagnarci apertamente. :!:

Ti dovrebbero cambiare il level da "Veteran" a "Rex Piagnorum" :-D

E credo di sapere perchè sei tanto restio ad abbandonare KDE3: adesso con KDE4 devi cambiare nickname in cloc4 :-D

ROTFL!!!


[ot]
qui urge un gpub udinese!
[/ot]
_________________
LP
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4533
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed Nov 18, 2009 11:49 pm    Post subject: Reply with quote

devilheart wrote:
semmai incompleto ma assolutamente non instabile.

in verità, sono troppo nubbio per distinguere tra un software incompleto e un software instabile.

oggi, per stampare con okular il pdf del mio compito in classe, ho pigiato 23 volte ctrl-p invio.
il pannello della userlist di kdm è così brutto che è stato rimosso dalla penultima versione del layout di default, e non compare neppure se imposti l'opzione UserList=true.
adoro l'editor integrato con supporto read-write del nuovo konqueror e non penso a kde4 come a un accrocchio informe, ma a uno splendido giocattolo.
solo non me la sento di farne un uso professionale, mentre kde3 è privo di supporto upstream e fuori portage.

chiamatemi pure re dei piagnoni, ma l'onestà intellettuale di dire quello che vedo non può venirmi meno per questo.

@lucapost
il gpub udinese sarebbe una splendida idea. ma sono un po' compresso.
facciamo a dicembre avanzato?
aprite i contatti via email o via messaggio privato.
ma sia chiaro, di invitare xdrama non se ne parla.
8)
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
!equilibrium
Bodhisattva
Bodhisattva


Joined: 06 Jun 2004
Posts: 2109
Location: MI/BG/LC

PostPosted: Thu Nov 19, 2009 10:59 am    Post subject: Reply with quote

devilheart wrote:
se è una questione di mettere delle guide per l'aggiornamento non vedo quale sia il problema di adottare bash4. se i vecchi bash non saranno utilizzabili con i nuovi ebuild la guida semplicemente riporterà il passaggio per aggiornare bash


non si può fare l'upgrade di bash alle versioni che si desiderano come se fosse una normale dipendenza, portage smette di funzionare, cosa non ti è chiaro di questa frase? esempio: siamo nel 2014 ma abbiamo un'installazione vecchia del 2009 e la vogliamo aggiornare, in locale c'è bash3 e facciamo "emerge --sync"; ora grazie a @devilheart tutti gli ebuild presenti in /usr/portage/* sono scritti in bash5 e se lanciamo "emerge -auDNv world" otteniamo un simpatico syntax error perchè il nostro bash3 locale non è in grado di leggere la nuova e fiammeggiante sintassi di bash5 (non puoi, non è retrocompatible). siccome per avere un portage funzionante bisogna aggiornare app-shells/bash alla versione 5, non possiamo perchè sys-apps/portage smette di funzionare perchè trova in locale app-shells/bash:3, creando un loop infinito da cui non si può uscire (in realtà un'uscita di emergenza ci sarebbe, ma non è utonto-proof). chiaro ora? o ti devo fare un disegnino :roll: ?

devilheart wrote:
ce lo possiamo permettere perché una retrocompatibilità del genere ci è inutile :P


lo è per te, non per gli altri, Gentoo non è solo tua.
rileggiti le motivazioni che ho spiegato in precedenza. io ho dei server Gentoo che non voglio aggiornare/mantenere perchè sennò finirei per amministrare per 12 ore al giorno i server anzichè lavorare; mi paghi tu le bollette poi? :lol:

(non è solo una questione di aggiornare portage e qualche manciata di pacchetti alla settimana e basta, la situazione è un pelo più complessa di come la state mettendo voi, quindi se dovete fare commenti, fateli almeno seri altrimenti sono inutili)
_________________
Arch Tester for Gentoo/FreeBSD
Equilibrium's Universe

all my contents are released under the Creative Commons Licence by-nc-nd 2.5
Back to top
View user's profile Send private message
devilheart
l33t
l33t


Joined: 17 Mar 2005
Posts: 777
Location: san leonardo del friuli

PostPosted: Thu Nov 19, 2009 8:52 pm    Post subject: Reply with quote

!equilibrium wrote:
non si può fare l'upgrade di bash alle versioni che si desiderano come se fosse una normale dipendenza, portage smette di funzionare, cosa non ti è chiaro di questa frase? esempio: siamo nel 2014 ma abbiamo un'installazione vecchia del 2009 e la vogliamo aggiornare, in locale c'è bash3 e facciamo "emerge --sync"; ora grazie a @devilheart tutti gli ebuild presenti in /usr/portage/* sono scritti in bash5 e se lanciamo "emerge -auDNv world" otteniamo un simpatico syntax error perchè il nostro bash3 locale non è in grado di leggere la nuova e fiammeggiante sintassi di bash5 (non puoi, non è retrocompatible). siccome per avere un portage funzionante bisogna aggiornare app-shells/bash alla versione 5, non possiamo perchè sys-apps/portage smette di funzionare perchè trova in locale app-shells/bash:3, creando un loop infinito da cui non si può uscire (in realtà un'uscita di emergenza ci sarebbe, ma non è utonto-proof). chiaro ora? o ti devo fare un disegnino :roll: ?
disegnino? il problema è sempre stato chiaro. quello che dicevo io è mettere nella guida un passo per aggiornare bash3 ad un qualsiasi bash successivo dopo aver fatto un sync con gli ebuild con la nuova sintassi. tipo uno scriptino che usando solo bash3 è in grado di aggiornare bash stesso all'ultima versione, magari usando una tarball di bash precompilata ed estraendola in / (avendo cura di rimuovere i rimasugli della vecchia bash non sovrascritti). poi si può ricompilare come di solito. può essere un dirty hack ma l'alternativa è ritrovarci tra 20 anni ancora con la sintassi di bash3. nessuno ci garantisce che bash5 supporterà ancora la sintassi di bash3

Quote:
lo è per te, non per gli altri, Gentoo non è solo tua.
chiaramente mi riferivo a tutti quelli che si lagnano
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Thu Nov 19, 2009 11:24 pm    Post subject: Reply with quote

Devilheart non ha tutti i torti: se ho capito bene, la retrocompatibilità che si vuole costruire da ora in poi andrà bene solo fino a quando bash sarà retrocompatibile con se stesso; quel giorno (qualora arrivasse, è bene ricordare che si parla molto in astratto) gentoo si troverebbe a decidere se bloccare la nuova versione di bash, se buttare alle ortiche gli anni di retrocompatibilità costruiti con pazienza o questa eventuale terza via.
Lo stesso python3 non è retrocompatibile, immagino che non fosse possibile ottenere dei miglioramenti senza modificare il funzionamento del linguaggio.

Penso che si potrebbe inoltrare la questione ai "piani alti", anche solo per chiedere un parere agli sviluppatori di bash.
Back to top
View user's profile Send private message
!equilibrium
Bodhisattva
Bodhisattva


Joined: 06 Jun 2004
Posts: 2109
Location: MI/BG/LC

PostPosted: Fri Nov 20, 2009 8:52 am    Post subject: Reply with quote

@Devilheart, @riverdragon: non è così semplice e le vostre idee sono già state discusse anni fa e rigettate (vedere i Gentoo Council di qualche tempo fa per le spiegazioni); la questione bash si risolve solo in un modo: garantendo la retrocompatibilità di bash a livello di global space, tutto il resto è superfluo.
_________________
Arch Tester for Gentoo/FreeBSD
Equilibrium's Universe

all my contents are released under the Creative Commons Licence by-nc-nd 2.5
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Fri Nov 20, 2009 11:07 am    Post subject: Reply with quote

!equilibrium wrote:
non è così semplice e le vostre idee sono già state discusse anni fa e rigettate (vedere i Gentoo Council di qualche tempo fa per le spiegazioni)
Ok, non sapevo.
Back to top
View user's profile Send private message
xdarma
Guru
Guru


Joined: 08 Dec 2003
Posts: 557
Location: tra veneto e friuli (Italy)

PostPosted: Fri Nov 20, 2009 9:59 pm    Post subject: Reply with quote

cloc3 wrote:
chiamatemi pure re dei piagnoni, ma l'onestà intellettuale di dire quello che vedo non può venirmi meno per questo.

A parte le battute: condivido parzialmente le critiche che fai e mi sembri corretto e coerente con quello che dici.

Solo che a forza di leggere di gente che si lamenta di KDE4 per tutto (o quasi) e che osanna KDE3 come fosse il paradiso perduto... mi sembra che la situazione scivoli verso il comico.
Manca solo quello che dice "quando c'era KDE3 i treni arrivavano in orario" :-D
Se ti va, continuiamo il discorso con una birra sul tavolo ;-)
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum