Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200909-14 ] Horde: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1567

PostPosted: Sat Sep 12, 2009 7:26 pm    Post subject: [ GLSA 200909-14 ] Horde: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Horde: Multiple vulnerabilities (GLSA 200909-14)
Severity: normal
Exploitable: remote
Date: September 12, 2009
Bug(s): #256125, #262976, #262978, #277294
ID: 200909-14

Synopsis


Multiple vulnerabilities have been discovered in Horde and two modules,
allowing for the execution of arbitrary code, information disclosure, or
Cross-Site Scripting.


Background


Horde is a web application framework written in PHP. Horde IMP, the
"Internet Messaging Program", is a Webmail module and Horde Passwd is a
password changing module for Horde.


Affected Packages

Package: www-apps/horde
Vulnerable: < 3.3.4
Unaffected: >= 3.3.4
Architectures: All supported architectures

Package: www-apps/horde-imp
Vulnerable: < 4.3.4
Unaffected: >= 4.3.4
Architectures: All supported architectures

Package: www-apps/horde-passwd
Vulnerable: < 3.1.1
Unaffected: >= 3.1.1
Architectures: All supported architectures


Description


Multiple vulnerabilities have been discovered in Horde:
  • Gunnar Wrobel reported an input sanitation and directory traversal
    flaw in framework/Image/Image.php, related to the "Horde_Image driver
    name" (CVE-2009-0932).
  • Gunnar Wrobel reported that data sent
    to horde/services/portal/cloud_search.php is not properly sanitized
    before used in the output (CVE-2009-0931).
  • It was reported
    that data sent to framework/Text_Filter/Filter/xss.php is not properly
    sanitized before used in the output (CVE-2008-5917).

Horde Passwd: David Wharton reported that data sent via the "backend"
parameter to passwd/main.php is not properly sanitized before used in
the output (CVE-2009-2360).

Horde IMP: Gunnar Wrobel reported that data sent to smime.php, pgp.php,
and message.php is not properly sanitized before used in the output
(CVE-2009-0930).


Impact


A remote authenticated attacker could exploit these vulnerabilities to
execute arbitrary PHP files on the server, or disclose the content of
arbitrary files, both only if the file is readable to the web server. A
remote authenticated attacker could conduct Cross-Site Scripting
attacks. NOTE: Some Cross-Site Scripting vectors are limited to the
usage of Microsoft Internet Explorer.


Workaround


There is no known workaround at this time.


Resolution


All Horde users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=www-apps/horde-3.3.4"

All Horde IMP users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=www-apps/horde-imp-4.3.4"

All Horde Passwd users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=www-apps/horde-passwd-3.1.1"


References

CVE-2008-5917
CVE-2009-0930
CVE-2009-0931
CVE-2009-0932
CVE-2009-2360


Last edited by GLSA on Mon Feb 21, 2011 4:28 am; edited 3 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum