Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kde 4.3.3 clock screw [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Wed Nov 11, 2009 2:17 pm    Post subject: Kde 4.3.3 clock screw [SOLVED] Reply with quote

Hi Everyone, I have a weird bug with Kde 4.3.3.

My system has the right time :
Code:

mer nov 11 09:13:03 UTC 2009


Also, if I check with Configuration --> System Configuration --> Date and Time

I see that the big clock has the right time and I see that I use Montreal.

So, why the clock plasmoïde give me 04:16 when it's actually 09:16 ?

Any idea on that one ?

Thanks
_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec


Last edited by d2_racing on Wed Nov 11, 2009 6:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1238
Location: Bardowick, Germany

PostPosted: Wed Nov 11, 2009 2:19 pm    Post subject: Reply with quote

The tray clock has it's own timezone setting. Maybe it is set to something different?
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4563
Location: Saint Amant, Acadiana

PostPosted: Wed Nov 11, 2009 2:25 pm    Post subject: Reply with quote

Trying NOT to rant, but why the heck KDE ignores system configuration? For instance, it ignores VertRefresh setting in my xorg.conf. :evil:
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1238
Location: Bardowick, Germany

PostPosted: Wed Nov 11, 2009 2:29 pm    Post subject: Reply with quote

Not trying to be a know-it-all, but KDE ignores xorg.conf VertRefresh setting in KDE3.5, too. At least on my other not-yet-updated box...

And if you refer to the clock, well, the tray applet has a setting for the time zone named "local". ;)
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Wed Nov 11, 2009 3:35 pm    Post subject: Reply with quote

So, is there any way to correct that bug or misconfiguration from the clock tray ?
_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec
Back to top
View user's profile Send private message
gami
Apprentice
Apprentice


Joined: 02 Jun 2006
Posts: 297

PostPosted: Wed Nov 11, 2009 4:10 pm    Post subject: Reply with quote

Right click on the tray clock, and choose "Digital Clock Settings". Then in the settings dialogue choose "Time Zones". Check that "Clock defaults to <Local>", if you want the tray clock to pick up your system settings, or set it to any other time zone you like.
Back to top
View user's profile Send private message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Wed Nov 11, 2009 5:04 pm    Post subject: Reply with quote

I'm already like that.

I will test some modification about /etc/conf.d/hwclock.

Maybe I screw up big time with that file.
_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Wed Nov 11, 2009 5:17 pm    Post subject: Reply with quote

Mine is like this:
Code:
# cat /etc/conf.d/hwclock
# Set CLOCK to "UTC" if your system clock is set to UTC (also known as
# Greenwich Mean Time).  If your clock is set to the local time, then
# set CLOCK to "local".  Note that if you dual boot with Windows, then
# you should set it to "local".
clock="UTC"

# If you want to set the Hardware Clock to the current System Time
# during shutdown, then say "YES" here.
# You normally don't need to do this if you run a ntp daemon.
clock_systohc="NO"

# If you wish to pass any other arguments to hwclock during bootup,
# you may do so here. Alpha users may wish to use --arc or --srm here.
clock_args=""


Try setting your date and reset your hardware clock. If you use ntpd, stop it temporarily and run this to set the exact time once
Code:
ntpd -gq
then restart ntpd, otherwise just use the date command
then in either case, run
Code:
hwclock --systohc
hwclock --show

mine shows localtime +5 because I use UTC time in /etc/conf.d/hwclock.
Back to top
View user's profile Send private message
gami
Apprentice
Apprentice


Joined: 02 Jun 2006
Posts: 297

PostPosted: Wed Nov 11, 2009 6:36 pm    Post subject: Re: Kde 4.3.3 clock screw Reply with quote

d2_racing wrote:

Code:

mer nov 11 09:13:03 UTC 2009


Also, if I check with Configuration --> System Configuration --> Date and Time

I see that the big clock has the right time and I see that I use Montreal.

So, why the clock plasmoïde give me 04:16 when it's actually 09:16 ?



09:16 UTC == 04:16 Montreal ;)

If the above is the output of the date command, your system uses UTC, which is then obviously picked up by KDE. What does your /etc/timezone say? You seem to have set your HW clock to your local time, rather than UTC, though.

Try copying /usr/share/zoneinfo/America/Montreal to /etc/localtime, and put "America/Montreal" into /etc/timezone.

After that make sure that your system stores UTC in the HW chip. (clock="UTC" in /etc/conf.d/hwclock, or equivalent on older baselayout)
Back to top
View user's profile Send private message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Wed Nov 11, 2009 6:44 pm    Post subject: Reply with quote

Ok, I found the problem.

For an unknown reason, the plasmoid was using an another time, so I switched to local instead of Montreal or something else and it's working right now.

My /etc/conf.d/hwclock is like yours Mike except that I use local.
_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Wed Nov 11, 2009 9:30 pm    Post subject: Reply with quote

Good. Glad to hear that. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum