Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[APCUPS] No me deja instalar (Solucionado)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
deovex
n00b
n00b


Joined: 27 Jun 2007
Posts: 74
Location: Buenos Aires, Argentina.

PostPosted: Thu May 30, 2013 11:55 pm    Post subject: [APCUPS] No me deja instalar (Solucionado) Reply with quote

Hace unos días que no encuentro como solucionar ese problema, al instalar apcupsd me tira error que no se encuentra Wall, no se que hacer:

Code:
checking for shutdown... /sbin/shutdown
checking for mail... /bin/mail
checking for wall... no
configure: error: Missing required tool; need any one of: wall

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sys-power/apcupsd-3.14.8-r1/work/apcupsd-3.14.8/config.log
 * ERROR: sys-power/apcupsd-3.14.8-r1 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   93:  Called src_configure
 *        environment, line 3094:  Called econf '--sbindir=/sbin' '--sysconfdir=/etc/apcupsd' '--with-pwrfail-dir=/etc/apcupsd' '--with-lock-dir=/var/lock' '--with-pid-dir=/var/run' '--with-log-dir=/var/log' '--with-nis-port=3551' '--enable-net' '--enable-pcnet' '--with-distname=gentoo' '--disable-net-snmp' '--disable-gapcmon' '--with-upstype=usb' '--with-upscable=usb' '--enable-usb' '--with-dev=' 'APCUPSD_MAIL=/bin/mail'
 *   phase-helpers.sh, line  521:  Called die
 * The specific snippet of code:
 *            die "econf failed"
 *
 * If you need support, post the output of `emerge --info '=sys-power/apcupsd-3.14.8-r1'`,
 * the complete build log and the output of `emerge -pqv '=sys-power/apcupsd-3.14.8-r1'`.
 * The complete build log is located at '/var/tmp/portage/sys-power/apcupsd-3.14.8-r1/temp/build.log'.
 * The ebuild environment fil* Working directory: '/var/tmp/portage/sys-power/apcupsd-3.14.8-r1/work/apcupsd-3.14.8'
 * S: '/var/tmp/portage/sys-power/apcupsd-3.14.8-r1/work/apcupsd-3.14.8'

>>> Failed to emerge sys-power/apcupsd-3.14.8-r1, Log file:

>>>  '/var/tmp/portage/sys-power/apcupsd-3.14.8-r1/temp/build.log'e is located at '/var/tmp/portage/sys-power/apcupsd-3.14.8-r1/temp/environment'.


Gracias!
Saludos!


Last edited by deovex on Wed Jun 05, 2013 2:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
opotonil
l33t
l33t


Joined: 17 Jun 2005
Posts: 791
Location: 127.0.0.1

PostPosted: Fri May 31, 2013 6:48 am    Post subject: Reply with quote

En Gentoo Bugzilla hay abierto un bug sobre el tema: https://bugs.gentoo.org/show_bug.cgi?id=468648

La solución sugerida por ahora es reinstalar "util-linux" con la USE "tty-helpers" activada. Pero por lo que veo en http://gpo.zugaina.org/sys-apps/util-linux la primera versión de "util-linux" que incorpora esta USE es la "util-linux-2.23" que por ahora esta masked.

Salu2.
_________________
Localnet
Films Localnet
Back to top
View user's profile Send private message
deovex
n00b
n00b


Joined: 27 Jun 2007
Posts: 74
Location: Buenos Aires, Argentina.

PostPosted: Wed Jun 05, 2013 2:31 pm    Post subject: Reply with quote

Gracias opotonil! Lo solucione reinstalando util-linux con la USE tty-helpers.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum