Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Πρόβλημα με uvesafb
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Greek
View previous topic :: View next topic  
Author Message
atmosx
n00b
n00b


Joined: 17 Jul 2009
Posts: 37
Location: Brno

PostPosted: Sun Jul 19, 2009 1:56 pm    Post subject: Πρόβλημα με uvesafb Reply with quote

Καλησπέρα,

είμαι καινούριος (σχετικά) στο forum. Θα ήθελα να βάλω Gentoo σε ένα παλιό AMD Amilo K7600 laptop με framebuffer support. Επέλεξα uvesafb γιατί διάβασα ότι είναι η τελευταία "έκδοση". Δεν ξέρω αν είναι και η καλύτερη. Η κάρτα γραφικών που έχει πάνω το laptop είναι η S3 Inc. VT8375 [ProSavage8 KM266/KL266]. Έχει build-in driver o kernel. Χρησιμοποιώ τον gentoo sources 2629-gentoo-r5.

Τα logs

Jul 19 04:23:55 amilo [ 1.732556] uvesafb: unrecognized option noblack
Jul 19 04:23:55 amilo [ 1.733367] uvesafb: S3 Garphics Incorporated., VBE 3.0, Rev 0.0, OEM: S3 Graphics ProSavage DDR Family BIOS, VBE v3.0
Jul 19 04:23:55 amilo [ 1.734857] uvesafb: protected mode interface info at c000:976d
Jul 19 04:23:55 amilo [ 1.734903] uvesafb: pmi: set display start = c00c97fb, set palette = c00c9844
Jul 19 04:23:55 amilo [ 1.736075] uvesafb: VBIOS/hardware doesn't support DDC transfers
Jul 19 04:23:55 amilo [ 1.736643] uvesafb: no monitor limits have been set, default refresh rate will be used
Jul 19 04:23:55 amilo [ 1.737390] uvesafb: scrolling: ywrap using protected mode interface, yres_virtual=3750
Jul 19 04:23:55 amilo [ 1.738067] uvesafb: cannot reserve video memory at 0x90000000
Jul 19 04:23:55 amilo [ 1.738759] uvesafb: probe of uvesafb.0 failed with error -5


Το πρόβλημα είναι το "cannot reserve video memory" με αποτέλεσμα να μην φορτώνει το background image. Εδώ είναικαι το grub.conf

default 0
timeout 30
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title Gentoo GNU/Linux
root (hd0,0)
kernel /boot/kernel ro root=/dev/sda3 splash=verbose,theme:gentoo video=uvesafb:mtrr:3,ywrap,1024x768-24@60,noblack CONSOLE=/dev/tty1
initrd /boot/fbsplash

Το splashimage το διαβάζει μια χαρά... από εκεί και κάτω τα options είμαι σχετικά μελετημένα αλλά πάλι τίποτα...
_________________
Never argue with an idiot.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Greek All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum