Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Tilde fungerar inte
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
nihilizt
n00b
n00b


Joined: 17 May 2003
Posts: 14

PostPosted: Sat May 17, 2003 7:29 pm    Post subject: Tilde fungerar inte Reply with quote

När jag använder svensk tangentbordslayout fungerar inte knappen som har prickar, upphöjt-till-tecken och tilde (den övre som sitter till vänster om Enter) alls. Eftersom jag kör KDE kan jag komma runt problemet genom att bara byta layout med Ctrl-Alt-K, men det är ju störande att knappen inte funkar. Den funkar i Windows, så det är inte knappen som är trasig på tangentbordet. Dessutom rapporterar xev rätt tecken när jag trycker på knappen, både direkt, med Shift och med Alt Gr. Jag har ett Natural Keyboard Pro, och det har jag ställt in i xf86config och i KDE:s egna variant av detta program. Argh!!
Back to top
View user's profile Send private message
ErikT
n00b
n00b


Joined: 01 Aug 2002
Posts: 11
Location: Stockholm, Sweden

PostPosted: Sun May 18, 2003 10:33 am    Post subject: Samma här. Reply with quote

Samma sak gäller för mig. Misstänker att det slutade fungera vid uppgraderingen till xfree-4.3.0-r2 härrom veckan. Någon som har någon lösning?


/Erik

--
<http://erik.tjernlund.net/webblogg/>
Back to top
View user's profile Send private message
frippz
Guru
Guru


Joined: 22 Aug 2002
Posts: 460
Location: Malmö, Sweden

PostPosted: Sun May 18, 2003 1:23 pm    Post subject: Reply with quote

Har ni uppdaterat era konfigurationsfiler efter uppgraderingen?
Kontrollera även xkb-settings i /etc/X11/XF86Config.
Back to top
View user's profile Send private message
Simpster
n00b
n00b


Joined: 27 Apr 2003
Posts: 6

PostPosted: Mon May 19, 2003 2:26 am    Post subject: Reply with quote

Japp, samma här! Hände efter uppgradering till 4.30... hitta lite att läsa om det och en patch:

http://www.mail-archive.com/i18n@xfree86.org/msg01306.html

inte för att jag fick den patchen att funka iofs... :(
den var ju för version 4.29 nånting.
Sen prövade jag att dra hem source till senaste X och kopiera in filerna under xkb/symbols därifrån, de hade ändrat i filen "se" men ack nej. inte fan funka det heller. lite less på det nu. Särskilt när man ska merga nåt masked...
Back to top
View user's profile Send private message
zeb
Tux's lil' helper
Tux's lil' helper


Joined: 19 Apr 2002
Posts: 79
Location: Finland

PostPosted: Mon May 19, 2003 6:39 pm    Post subject: Reply with quote

Jag hade samma problem men det fixade sig efter att jag ändrat språkinställningarna. Jag har en sån här fil som /etc/env.d/02locale:
Code:
LANGUAGE="en_US"
LANG="en_US"
LC_CTYPE="fi_FI@euro"
LC_NUMERIC="fi_FI@euro"
LC_TIME="C"
LC_COLLATE="fi_FI@euro"
LC_MONETARY="fi_FI@euro"
LC_MESSAGES="en_US"
LC_MEASUREMENT="fi_FI@euro"
LC_PAPER="fi_FI@euro"

Vad filen heter spelar ingen större roll, bara den finns i /etc/env.d
Byt ut fi_FI mot se_SE om ni känner för det :)
Kom också ihåg att köra env-update efter att ha modifierat/lagt till filen.
Innan hade jag ingen sån fil alls, och det funkade bra, men efter uppdateringen till Xfree 4.3 så gick inte dom 'döda' knapparna att använda förrän jag fixade till filen så som den ser ut ovan. Jag använder svensk tangentbordslayout, så det är inget fel på den.
Back to top
View user's profile Send private message
spiff
n00b
n00b


Joined: 04 Oct 2002
Posts: 37

PostPosted: Mon May 26, 2003 11:44 am    Post subject: Reply with quote

Ah, gött med ett svenskt forum.. trode det var jag som hade pajat ngt.
Började bli trist å bara göra ouch smileys >_< saknar ^_^;
Back to top
View user's profile Send private message
Agitator[RoX]
n00b
n00b


Joined: 10 Mar 2003
Posts: 27
Location: Kalmar/Sweden

PostPosted: Tue May 27, 2003 1:28 am    Post subject: Reply with quote

hums.. Hjälper så långt som att om jag öppnar Eterm, och öppnar en Eterm med den kan jag om jag dubbeltrycker på knappen få ut ett tecken.. Fruktansvärt omständigt. :(

Någon som kan hjälpa till med DET problemet?

Vid närmare undersökning funkar det i allt som öppnas genom Eterm, men inte i något annat. Ugh.
_________________
"Linux is metal"
Back to top
View user's profile Send private message
Dozer
n00b
n00b


Joined: 17 Jun 2003
Posts: 1

PostPosted: Tue Jun 17, 2003 6:02 am    Post subject: Reply with quote

Option "NoDeadKeys"

pleier å gjøre tingen når man har dette problemet

I XFree4.3.x ble dette en nødvendighet for å få spesialtegn, som nettopp ~
_________________
--
Dozer
Back to top
View user's profile Send private message
pocke
n00b
n00b


Joined: 14 Mar 2003
Posts: 26
Location: Kalmar, Sweden

PostPosted: Sun Jun 22, 2003 12:06 pm    Post subject: "NoDeadKeys" hjälpte inte Reply with quote

Nu har jag ändrat min XF86Config:
Code:
...
Section "InputDevice"
        Identifier "Keyboard1"
        Driver "Keyboard"
        Option "AutoRepeat" "250 30"
        Option "XkbVariant" "nodeadkeys"
        Option "XkbRules" "xfree86"
        Option "XkbModel" "pc102"
        Option "XkbLayout" "se"
        Option "NoDeadKeys"
EndSection
...


Min /etc/env.d/02locale ser ut som ovan. Men det hjälper inte.

Tilde fungerar i konsollen, men inte i X! :-(

När jag startar t ex xterm får jag följande meddelande:
Code:
>xterm
Warning: locale not supported by C library, locale unchanged
Kan det ha något med det hela att göra?

Hoppas nån har nån ide´.
/Patrik
Back to top
View user's profile Send private message
pocke
n00b
n00b


Joined: 14 Mar 2003
Posts: 26
Location: Kalmar, Sweden

PostPosted: Sun Jun 22, 2003 4:21 pm    Post subject: Alt-Gr slutade tydligen att fungera också Reply with quote

Och nu har Alt-Gr slutat fungera också :-(
Jag får väl ändra tillbaka igen då.
Back to top
View user's profile Send private message
pocke
n00b
n00b


Joined: 14 Mar 2003
Posts: 26
Location: Kalmar, Sweden

PostPosted: Sun Jun 22, 2003 4:26 pm    Post subject: Oups Reply with quote

Jag hade visst testat med "sv_SE" i XF86Config. Så ska det ju inte vara. Nu funkar allt utom tilde igen (även ^ och ¨)... Hjälp :o
Back to top
View user's profile Send private message
Chewie
n00b
n00b


Joined: 02 Apr 2003
Posts: 26
Location: Sweden, Boras

PostPosted: Sun Jun 22, 2003 7:16 pm    Post subject: Re: Oups Reply with quote

pocke wrote:
Jag hade visst testat med "sv_SE" i XF86Config. Så ska det ju inte vara. Nu funkar allt utom tilde igen (även ^ och ¨)... Hjälp :o


Testat med Option "XkbModel" "pc105"
Back to top
View user's profile Send private message
pocke
n00b
n00b


Joined: 14 Mar 2003
Posts: 26
Location: Kalmar, Sweden

PostPosted: Sun Jun 22, 2003 7:23 pm    Post subject: Re: Oups Reply with quote

Chewie wrote:
Testat med Option "XkbModel" "pc105"

Det gjorde tyvärr ingen skillnad.
Back to top
View user's profile Send private message
luugin
n00b
n00b


Joined: 10 May 2003
Posts: 69

PostPosted: Mon Jun 23, 2003 2:28 pm    Post subject: Reply with quote

Jag har ungefär samma problem. 'tilde' funkar fint i console men inte i X/KDE... När jag kör med följande inställningar så funkar 'flest' tangenter (alla utom den där förbannade knappen :) )

Code:

    Option "XkbRules"   "xfree86"
    Option "XkbModel"   "pc102"
    Option "XkbVariant" "nodeadkeys"
    Option "NoDeadKeys"
    Option "XkbLayout"  "se"


Det funkar inte heller med KDE's keyboard layout utility även om man testar 1000 olika varianter :E
Back to top
View user's profile Send private message
Guzz
n00b
n00b


Joined: 16 Apr 2002
Posts: 25
Location: Sweden

PostPosted: Wed Jun 25, 2003 12:58 pm    Post subject: Reply with quote

Funkar det om ni startar en term med
LC_CTYPE=sv_SE xterm
_________________
That's it Mr. Giraff, get all the marmalade.
Back to top
View user's profile Send private message
pocke
n00b
n00b


Joined: 14 Mar 2003
Posts: 26
Location: Kalmar, Sweden

PostPosted: Wed Jun 25, 2003 1:56 pm    Post subject: Verkar inte hjälpa... Reply with quote

Quote:
Funkar det om ni startar en term med
LC_CTYPE=sv_SE xterm

Code:
$ env
...
LC_CTYPE=sv_SE@euro
...
$ env LC_CTYPE=sv_SE xterm
Warning: locale not supported by C library, locale unchanged


xterm kommer upp och i det nya fönstret:
Code:
$ env
...
LC_CTYPE=sv_SE@euro
...

Det verkar ju inte slå igenom... Gör jag rätt?
Kan väl tilläggas att tilde fortfarande inte funkar i nån av terminalerna. ;-)
Back to top
View user's profile Send private message
pocke
n00b
n00b


Joined: 14 Mar 2003
Posts: 26
Location: Kalmar, Sweden

PostPosted: Wed Jun 25, 2003 3:54 pm    Post subject: LÖSTE PROBLEM :-) Reply with quote

Tjoho. Testa lite och har nnu löst "tilde-problemet". Ganska enkelt faktiskt. Jag fixade bara till /etc/env.d/02locale (eller vad man nu har kallat den). Nu ser min ut så här:
Code:
LANGUAGE="en_US"
LANG="en_US"
LC_CTYPE="sv_SE"
LC_NUMERIC="sv_SE"
LC_TIME="C"
LC_COLLATE="sv_SE"
LC_MONETARY="sv_SE"
LC_MESSAGES="en_US"
LC_MEASUREMENT="sv_SE"
LC_PAPER="sv_SE"
Hoppas detta hjälper nån där ute.
/Patrik
Back to top
View user's profile Send private message
Savve
n00b
n00b


Joined: 23 Aug 2003
Posts: 19

PostPosted: Thu Aug 28, 2003 8:51 pm    Post subject: Reply with quote

Fick samma problem tills jag ställt in vilket tangentbord jag använder i controlcenter, av någon anledning ville den inte köra med inställningen jag hade i XFree86config.
_________________
---------
I fell in love with the cow :/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum