Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
continuos errores en la compilación del kernel
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Lolete
Guest





PostPosted: Wed Aug 14, 2002 7:55 am    Post subject: continuos errores en la compilación del kernel Reply with quote

Hola. Antes de nada te doy las gracias por leer esta mensaje.
He llegado al paso en el que hay que compilar el kernel y he escogido el de Gentoo R7. Siempre me da error en algo. Cuando llega el momento de usar "kernel_stat.h" se paraba diciendo que no encontraba "smp_num_cpus", pero eso al menos lo he solucionado buscándolo y cambiandolo por "1". Ahora me da otro error de compilación, en PCMCIA, y no sé si es por alguna opción que haya puesto mal... y el caso es que el PCMCIA lo tengo desactivado porque es un sobremesa, así que no me explico porqué se corta ahí...
Mis optimizaciones soy muy básicas: K6III, sonido, red, puerto paralelo para la impresora, no tengo USB, ni BlueTooth ni evidentemente PCMCIA...
Quisiera saber el motivo de tanto fallo, pues ya he arreglado hasta 3 y me estoy desesperando. Dispongo de muy poco tiempo y este lo empleo en leer toda la documentación que cae en mis manos, pero este error... me tiene frito. Antes de preguntar siempre me informo, esta vez no ha sido menos, pero es que ya... me tiene loco!
¿Alguien sabe como evitar tanto quebradero de cabeza? ¿Algún kernel de los que propone la documentación está libre de fallos?
Gracias.
Back to top
xarki
Guest





PostPosted: Mon Aug 19, 2002 8:44 am    Post subject: Reply with quote

no se porque pero la r7 a mi tb me da fallos, asi que yo tengo la r5 y sin problema
Back to top
Tuxisuau
Apprentice
Apprentice


Joined: 04 May 2002
Posts: 213
Location: Catalunya (Europe)

PostPosted: Tue Aug 20, 2002 7:09 am    Post subject: Reply with quote

Quiza tenga relación con este hilo:

http://forums.gentoo.org/viewtopic.php?t=12336
_________________
IM me at tuxisuau@jabber.7a69ezine.org
Back to top
View user's profile Send private message
Ferdy
Retired Dev
Retired Dev


Joined: 04 May 2002
Posts: 483
Location: España

PostPosted: Tue Aug 20, 2002 12:33 pm    Post subject: Reply with quote

Es sencillo. Eso es problema de la configuración del kernel, es decir, del paso make menuconfig. Lo que hay que hacer es desactivar el SMP en ell kernel y añadir el MTTR.

Salu2.Ferdu
_________________
Paludis, the next generation in package mangling.
Back to top
View user's profile Send private message
Lolete
Guest





PostPosted: Tue Aug 20, 2002 9:32 pm    Post subject: Agradecimientos Reply with quote

Gracias a todos por vuestra ayuda. Al final, con muuucha paciencia he conseguido compilarlo correctamente. Creo que ha sido a la 5 vez...

Os cuento que pasaba. El SMP estaba activado, aunque yo lo desactivaba... no sé porque algo lo volvía a activar al igual que el PCMCIA. Quizás también influyó que me moví a otro directorio y no encontraba bien el fichero de configuración del kernel.

En fin, lo dicho, gracias a los 3.

Manolo.
Back to top
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum