Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved in overlay][x11 overlay]libX11 conflicts with itself
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Ormaaj
Guru
Guru


Joined: 28 Jan 2008
Posts: 316

PostPosted: Thu Sep 09, 2010 1:35 am    Post subject: [solved in overlay][x11 overlay]libX11 conflicts with itself Reply with quote

mesa-9999 requires >x11-libs/libX11-1.3.5 which is satisfied by either x11-libs/libX11-9999 or 1.3.99.901.

Code:
x11-libs/libX11:0

  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (x11-libs/libXrandr-1.3.0, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    >=x11-libs/libX11-1.3 required by (x11-libs/libXi-1.3.1, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (media-libs/giflib-4.1.6-r1, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (x11-libs/libXft-2.1.14, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (sys-auth/consolekit-0.4.2, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (app-emulation/emul-linux-x86-xlibs-20100611, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (x11-libs/libXfontcache-1.0.5, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (dev-haskell/glfw-0.3, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (x11-libs/libXcursor-1.1.10, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (x11-libs/libXpm-3.5.8, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (x11-apps/xset-1.2.0, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (x11-apps/xrdb-1.0.6, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (media-libs/aalib-1.4_rc5, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (x11-libs/libXinerama-1.1, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (dev-lang/tk-8.5.8-r1, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (x11-libs/libXv-1.0.5, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (x11-apps/xprop-1.1.0, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (x11-libs/libXmu-1.0.5, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (x11-libs/gtk+-2.20.1-r1, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (media-libs/netpbm-10.49.00, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (sys-apps/dbus-1.2.24, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (x11-apps/iceauth-1.0.3, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (x11-libs/libXvMC-1.0.6, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (media-libs/xine-lib-1.1.19, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    x11-libs/libX11 required by (x11-libs/libXtst-1.1.0, installed)
  (x11-libs/libX11-9999, ebuild scheduled for merge) conflicts with
    >=x11-libs/libX11-1.1.99.1 required by (x11-libs/libXext-1.1.2-r1, installed)


For example >=x11-libs/libX11-1.1.99.1 required by (x11-libs/libXext-1.1.2-r1, installed). 9999 satisfies that dependency so I'm confused at what the conflict is. Perhaps libX11 is a virtual which conflicts with the nonvirtual package libX11 which for some reason doesn't satisfy the virtual of the same name?

EDIT: In testing whether this has to do with the xcb useflag on mesa and libX11, media-video/vlc requires +xcb on libX11 for some reason even if -xcb is set for vlc. I'm not sure why this is forcing a downgrade of libX11 to a version not compatible with mesa-9999. For some reason portage wants mesa-9999 and libX11 downgraded while still showing all these weird self-conflicts. Can't determine whether it's related to the xcb useflag because VLC won't allow me to disable it regardless of it's setting.


Last edited by Ormaaj on Thu Sep 16, 2010 7:03 am; edited 1 time in total
Back to top
View user's profile Send private message
alexbuell
Guru
Guru


Joined: 18 Jul 2002
Posts: 474
Location: "Hemp"shire, UK

PostPosted: Thu Sep 09, 2010 9:24 am    Post subject: Reply with quote

It *is*xcb. For some reason libX11 forces off the xcb use flag. I'm still trying to force it back on without success.
_________________
Cheers,
Alex.

Linux - the best text adventure game ever.
Back to top
View user's profile Send private message
Lustmored
Apprentice
Apprentice


Joined: 28 May 2010
Posts: 204
Location: Poland

PostPosted: Thu Sep 09, 2010 10:29 am    Post subject: Reply with quote

It's from vlc[opengl] probably.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum