Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 4)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 35, 36, 37, 38  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Herring42
Guru
Guru


Joined: 10 Mar 2004
Posts: 366
Location: Buckinghamshire

PostPosted: Fri Sep 03, 2010 1:16 pm    Post subject: Reply with quote

devsk wrote:
Surprisingly, I did not run into issues compiling pykde4-4.5.1. I have no idea why. I never applied any patches. Upgraded kde 4.5.1 in one shot straight.


And for me too. AMD64
_________________
"The problem with quotes on the internet is that it is difficult
to determine whether or not they are genuine." -- Abraham Lincoln
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 2734
Location: Gainesville, Florida

PostPosted: Fri Sep 03, 2010 4:14 pm    Post subject: Reply with quote

Same here on my ~amd64 (no-multilib) box. It was only on the ~x86 box I had the pykde4 issue. Both boxes were current updated, 2.6.35.x kernels, tuned and revdep-rebuild consistent, long-time reliable make.conf settings, and ~Arch portage with overlay kde-4.5.0 before moving to 4.5.1. Are those running into this on ~x86, or ~amd64?

Maybe ~x86 is the common aspect, unless an ~amd64 user also has seen this problem? Or a random cflag, ldflag, USE flag, etc./etc.

Still :? and :roll:
_________________
Main box- Gigabyte GIGABYTE GA-990FXA-UD3 AM3+ rev.-4.0
Amd FX 8320, 3.5 GHz, 16GB GSkill DDR3 1866mhz
Samsung SATA 1000GB, Radeon HD 6570 2GB DDR3
Gentoo ~x86, ~amd64, glibc-2.19, gcc-4.8.2, kernel 3.14.0-gentoo (USE=experimental)
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2726
Location: Bay Area, CA

PostPosted: Fri Sep 03, 2010 6:04 pm    Post subject: Reply with quote

Yup. ~amd64 here. So, it looks like some x86 peculiarity!
Back to top
View user's profile Send private message
Gh0str1d3r
Guru
Guru


Joined: 27 May 2008
Posts: 315

PostPosted: Fri Sep 03, 2010 6:25 pm    Post subject: Reply with quote

devsk wrote:
Yup. ~amd64 here. So, it looks like some x86 peculiarity!


definitely not. I am on ~amd64 and had the problem with pykde4.
Back to top
View user's profile Send private message
MrEntropy
n00b
n00b


Joined: 03 Nov 2005
Posts: 74
Location: Austin

PostPosted: Fri Sep 03, 2010 8:00 pm    Post subject: Reply with quote

I was able to get pykde4-4.5.1 on with no problems or patches, but I can't go up to 4.5.1-r1 without it crashing.

And Dolphin keeps crashing for me.
Back to top
View user's profile Send private message
Gh0str1d3r
Guru
Guru


Joined: 27 May 2008
Posts: 315

PostPosted: Fri Sep 03, 2010 8:18 pm    Post subject: Reply with quote

dolphin is a mess in KDE 4.5. I already switched back to console to browse through files...
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2726
Location: Bay Area, CA

PostPosted: Fri Sep 03, 2010 9:27 pm    Post subject: Reply with quote

Gh0str1d3r wrote:
dolphin is a mess in KDE 4.5. I already switched back to console to browse through files...
agreed. Couple of weird crashes here.
Back to top
View user's profile Send private message
Kingoftherings
Guru
Guru


Joined: 04 May 2008
Posts: 328

PostPosted: Fri Sep 03, 2010 11:41 pm    Post subject: Reply with quote

Gh0str1d3r wrote:
devsk wrote:
Yup. ~amd64 here. So, it looks like some x86 peculiarity!


definitely not. I am on ~amd64 and had the problem with pykde4.


I use ~amd64 too. So it's not just a x86 issue. :P
Back to top
View user's profile Send private message
ssteinberg
Apprentice
Apprentice


Joined: 09 Jul 2010
Posts: 206
Location: Israel

PostPosted: Sat Sep 04, 2010 1:23 am    Post subject: Reply with quote

devsk wrote:
Gh0str1d3r wrote:
dolphin is a mess in KDE 4.5. I already switched back to console to browse through files...
agreed. Couple of weird crashes here.


I always used the console, but actually Dolphin has been a very pleasant experience so far. No problems what so ever.
pykde4 fails here as well on 4.5.1-r1, amd64. :?
Back to top
View user's profile Send private message
Shining Arcanine
Veteran
Veteran


Joined: 24 Sep 2009
Posts: 1110

PostPosted: Sat Sep 04, 2010 3:52 am    Post subject: Reply with quote

ssteinberg wrote:
devsk wrote:
Gh0str1d3r wrote:
dolphin is a mess in KDE 4.5. I already switched back to console to browse through files...
agreed. Couple of weird crashes here.


I always used the console, but actually Dolphin has been a very pleasant experience so far. No problems what so ever.
pykde4 fails here as well on 4.5.1-r1, amd64. :?


Could you post information describing the failure? Perhaps the build.log would be helpful.
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1710
Location: Mannheim, Germany

PostPosted: Sat Sep 04, 2010 9:01 am    Post subject: Reply with quote

Since 4.5.0 (and also with 4.5.1) dolphin and konqueror hang for me. I browse through files and it just lags a few seconds, then all is normal again. I disabled all akonadi/strigi crap. ~amd64 here. Anyone else having these problems?
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
carpenterguy
Tux's lil' helper
Tux's lil' helper


Joined: 12 Oct 2009
Posts: 132

PostPosted: Sat Sep 04, 2010 1:11 pm    Post subject: Reply with quote

Also having the pykde error

The following 10 packages have failed to build or install:
*
* (kde-base/pykde4-4.4.5, ebuild scheduled for merge), Log file:
* '/var/tmp/portage/kde-base/pykde4-4.4.5/temp/build.log'
* (kde-base/plasma-workspace-4.4.5, ebuild scheduled for merge)
* (kde-base/kdeutils-meta-4.4.5, ebuild scheduled for merge)
* (kde-base/kdebase-meta-4.4.5, ebuild scheduled for merge)
* (kde-base/kdeedu-meta-4.4.5, ebuild scheduled for merge)
* (kde-base/kde-meta-4.4.5, ebuild scheduled for merge)
* (kde-base/kdebase-startkde-4.4.5, ebuild scheduled for merge)
* (kde-base/kdeplasma-addons-4.4.5, ebuild scheduled for merge)
* (kde-base/marble-4.4.5, ebuild scheduled for merge)
* (kde-base/superkaramba-4.4.5, ebuild scheduled for merge)

emerge --info here http://paste.pocoo.org/show/258439/

Two things I find odd, I have 2 ~86 installs on the same machine. I updated 1 install with no errors.
should eliminate hardware issue.
I have no complaints with dolphin.
Looking at Gh0str1d3r instructions, download the patch, put it to /var/lib/layman/kde/kde-base/pykde4/files
I have no layman dir on either install? Here is /var/lib/ dir
(chroot) foreplay lib # dir
DeviceKit-power dbus hal misc polkit-1 syslog-ng.persist
NetworkManager dhcpcd htdig mlocate portage udisks
PolicyKit dhcpcd-eth0.info kde module-rebuild rarian virtuoso
PolicyKit-public games kdm mysql sabayon wicd
alsa gdm kdm-4.4 openldap-data samba xkb
bluetooth gentoo lock os-prober sasl2

Makes it hard to apply the patch.
Was I standing in the wrong line, when layman was being passed out?
Back to top
View user's profile Send private message
Shining Arcanine
Veteran
Veteran


Joined: 24 Sep 2009
Posts: 1110

PostPosted: Sat Sep 04, 2010 2:26 pm    Post subject: Reply with quote

carpenterguy wrote:
Also having the pykde error

The following 10 packages have failed to build or install:
*
* (kde-base/pykde4-4.4.5, ebuild scheduled for merge), Log file:
* '/var/tmp/portage/kde-base/pykde4-4.4.5/temp/build.log'
* (kde-base/plasma-workspace-4.4.5, ebuild scheduled for merge)
* (kde-base/kdeutils-meta-4.4.5, ebuild scheduled for merge)
* (kde-base/kdebase-meta-4.4.5, ebuild scheduled for merge)
* (kde-base/kdeedu-meta-4.4.5, ebuild scheduled for merge)
* (kde-base/kde-meta-4.4.5, ebuild scheduled for merge)
* (kde-base/kdebase-startkde-4.4.5, ebuild scheduled for merge)
* (kde-base/kdeplasma-addons-4.4.5, ebuild scheduled for merge)
* (kde-base/marble-4.4.5, ebuild scheduled for merge)
* (kde-base/superkaramba-4.4.5, ebuild scheduled for merge)

emerge --info here http://paste.pocoo.org/show/258439/

Two things I find odd, I have 2 ~86 installs on the same machine. I updated 1 install with no errors.
should eliminate hardware issue.
I have no complaints with dolphin.
Looking at Gh0str1d3r instructions, download the patch, put it to /var/lib/layman/kde/kde-base/pykde4/files
I have no layman dir on either install? Here is /var/lib/ dir
(chroot) foreplay lib # dir
DeviceKit-power dbus hal misc polkit-1 syslog-ng.persist
NetworkManager dhcpcd htdig mlocate portage udisks
PolicyKit dhcpcd-eth0.info kde module-rebuild rarian virtuoso
PolicyKit-public games kdm mysql sabayon wicd
alsa gdm kdm-4.4 openldap-data samba xkb
bluetooth gentoo lock os-prober sasl2

Makes it hard to apply the patch.
Was I standing in the wrong line, when layman was being passed out?


Emerge layman and follow the instructions at the following page:

http://en.gentoo-wiki.com/wiki/Overlay#Local_Overlays

Gentoo's official documentation on overlays is not clear on how to do this. I have filed a bug report regarding that:

http://bugs.gentoo.org/show_bug.cgi?id=335946


Last edited by Shining Arcanine on Sat Sep 04, 2010 2:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
thorbenk
n00b
n00b


Joined: 25 Jan 2005
Posts: 20

PostPosted: Sat Sep 04, 2010 2:27 pm    Post subject: Reply with quote

After updgrading to kde 4.5.1, but leaving kmail at 4.4.5, I suddenly cannot send any mails anymore,
nor can I receive them:

I get loads of notification popups with errors like:

Error while checking account "...." (both imap and pop accounts) for new mail:
The process for the imap://.... protocol died unexpectedly

Does anyone else have this problem? I have no clue how to debug this. I turned on full debug output
with kdebugdialog but it does not help lots:

kmail(7226)/kio (Scheduler) KIO::SchedulerPrivate::getConnectedSlave: KUrl("imap://tkroeger@xxx:143") KIO::Slave(0x2880460)
kmail(7226)/kio (Slave) KIO::Slave::gotInput: slave died pid = 18530

Any ideas?
Back to top
View user's profile Send private message
Shining Arcanine
Veteran
Veteran


Joined: 24 Sep 2009
Posts: 1110

PostPosted: Sat Sep 04, 2010 2:57 pm    Post subject: Reply with quote

Have you tried upgrading kmail?
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 2734
Location: Gainesville, Florida

PostPosted: Sat Sep 04, 2010 3:21 pm    Post subject: Reply with quote

On both ~amd64 abd ~x86 installations with kde-4.5.0 and 4.5.1 I had to rebuild both kmail and libkdepim-4.4.5. Also, IIRC, I had to figure out some blocks first with kdepimlibs, uninstalling kdepimlibs-4.5.1.
_________________
Main box- Gigabyte GIGABYTE GA-990FXA-UD3 AM3+ rev.-4.0
Amd FX 8320, 3.5 GHz, 16GB GSkill DDR3 1866mhz
Samsung SATA 1000GB, Radeon HD 6570 2GB DDR3
Gentoo ~x86, ~amd64, glibc-2.19, gcc-4.8.2, kernel 3.14.0-gentoo (USE=experimental)
Back to top
View user's profile Send private message
thorbenk
n00b
n00b


Joined: 25 Jan 2005
Posts: 20

PostPosted: Sat Sep 04, 2010 10:08 pm    Post subject: Reply with quote

Im running ~amd64 with the kde overlay. the new kmail2, 4.4.92 is still masked. I don't have any blockers, and revdep-rebuild turned up nothing.
I tried reinstalling kmail, libkdepim, kdepimlibs etc but that did not help.
Back to top
View user's profile Send private message
Shining Arcanine
Veteran
Veteran


Joined: 24 Sep 2009
Posts: 1110

PostPosted: Sun Sep 05, 2010 3:23 am    Post subject: Reply with quote

thorbenk wrote:
Im running ~amd64 with the kde overlay. the new kmail2, 4.4.92 is still masked. I don't have any blockers, and revdep-rebuild turned up nothing.
I tried reinstalling kmail, libkdepim, kdepimlibs etc but that did not help.


Have you tried unmasking kmail 4.4.92?
Back to top
View user's profile Send private message
thorbenk
n00b
n00b


Joined: 25 Jan 2005
Posts: 20

PostPosted: Sun Sep 05, 2010 7:26 am    Post subject: Reply with quote

I have tried 4.4.92 about two months ago, but it did not work at all... I'd rather avoid upgrading to the unstable version at the moment
if I can find any other solution...
Back to top
View user's profile Send private message
thorbenk
n00b
n00b


Joined: 25 Jan 2005
Posts: 20

PostPosted: Sun Sep 05, 2010 8:42 am    Post subject: Reply with quote

OK, so I have tried 4.4.92 just now (used the kdepim-4.5 unmask file from the overlay)
and of course, the kmail migrator _still_ does not work, it complains about missing
UIDPLUS support for one of my IMAP email accounts... *sigh*
https://bugs.kde.org/show_bug.cgi?id=236109
and then it wants to run the migration again and again and I never even get to starting kmail2 :-(
Back to top
View user's profile Send private message
thorbenk
n00b
n00b


Joined: 25 Jan 2005
Posts: 20

PostPosted: Sun Sep 05, 2010 12:20 pm    Post subject: Reply with quote

I've now tried to upgrade to kmail-9999 which should include the bugfix for missing UIDPLUS,
as claimed in the bugreport. However, this means compiling a complete kde-live tree :-(

I cannot get past pykde4:

Code:

[  0%] Built target compile_python_files
[  1%] Building CXX object python/pykde4/CMakeFiles/python_module_PyKDE4_akonadi.dir/sip/akonadi/sipakonadipart6.o
In file included from /usr/include/python2.6/Python.h:8,                                                                                                                                                             
                 from /usr/include/python2.6/sip.h:32,
                 from /var/tmp/portage/kde-base/pykde4-9999/work/pykde4-9999_build/python/pykde4/sip/akonadi/sipAPIakonadi.h:11,
                 from /var/tmp/portage/kde-base/pykde4-9999/work/pykde4-9999_build/python/pykde4/sip/akonadi/sipakonadipart6.cpp:7:
/usr/include/python2.6/pyconfig.h:1079:1: warning: "_XOPEN_SOURCE" redefined
<command-line>: warning: this is the location of the previous definition
sipakonadipart6.cpp: In member function ‘virtual void sipAkonadi_CollectionComboBox::setContextMenuEnabled(bool)’:
sipakonadipart6.cpp:480: warning: ‘virtual void KComboBox::setContextMenuEnabled(bool)’ is deprecated (declared at /usr/include/kcombobox.h:291)
sipakonadipart6.cpp: In function ‘PyObject* meth_Akonadi_Collection_parent(PyObject*, PyObject*)’:
sipakonadipart6.cpp:4555: warning: ‘qint64 Akonadi::Collection::parent() const’ is deprecated (declared at /usr/include/akonadi/collection.h:166)
sipakonadipart6.cpp: In function ‘PyObject* meth_Akonadi_Collection_setParent(PyObject*, PyObject*)’:
sipakonadipart6.cpp:4581: warning: ‘void Akonadi::Collection::setParent(const Akonadi::Collection&)’ is deprecated (declared at /usr/include/akonadi/collection.h:178)
sipakonadipart6.cpp:4596: warning: ‘void Akonadi::Collection::setParent(qint64)’ is deprecated (declared at /usr/include/akonadi/collection.h:172)
sipakonadipart6.cpp: In function ‘PyObject* meth_Akonadi_Collection_parentRemoteId(PyObject*, PyObject*)’:
sipakonadipart6.cpp:4624: warning: ‘QString Akonadi::Collection::parentRemoteId() const’ is deprecated (declared at /usr/include/akonadi/collection.h:185)
sipakonadipart6.cpp: In function ‘PyObject* meth_Akonadi_Collection_setParentRemoteId(PyObject*, PyObject*)’:
sipakonadipart6.cpp:4651: warning: ‘void Akonadi::Collection::setParentRemoteId(const QString&)’ is deprecated (declared at /usr/include/akonadi/collection.h:191)
/usr/include/akonadi/entity.h: In function ‘void release_Akonadi_Entity(void*, int)’:
/usr/include/akonadi/entity.h:269: error: ‘Akonadi::Entity::~Entity()’ is protected
sipakonadipart6.cpp:5665: error: within this context
sipakonadipart6.cpp: In function ‘PyObject* meth_Akonadi_Monitor_itemsMonitored(PyObject*, PyObject*)’:
sipakonadipart6.cpp:7443: warning: ‘QList<long long int> Akonadi::Monitor::itemsMonitored() const’ is deprecated (declared at /usr/include/akonadi/monitor.h:241)
make[2]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_akonadi.dir/sip/akonadi/sipakonadipart6.o] Error 1
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_akonadi.dir/all] Error 2
make: *** [all] Error 2
Back to top
View user's profile Send private message
thorbenk
n00b
n00b


Joined: 25 Jan 2005
Posts: 20

PostPosted: Sun Sep 05, 2010 2:10 pm    Post subject: Reply with quote

So, if anyone hits the same pykde4 error, here is a workaround:

edit the file from which the error originates:
/usr/include/akonadi/entity.h:269: error: ‘Akonadi::Entity::~Entity()’ is protected

and make the destructor public.

I reported this error on #akonadi and they're going to look into it on monday...
Back to top
View user's profile Send private message
Shining Arcanine
Veteran
Veteran


Joined: 24 Sep 2009
Posts: 1110

PostPosted: Mon Sep 06, 2010 2:15 am    Post subject: Reply with quote

I upgraded to KDE 4.5.1 on my ~amd64 desktop. I had to uninstall webkit-kpart, which I had installed into a local overlay using an ebuild from bug #244519 before portage's dependency resolution would allow me to attempt an upgrade. I had some minor issues with build failures, but repeating the emerge fixed them. I filed a bug report about them:

http://bugs.gentoo.org/show_bug.cgi?id=336142

I also an issue where /etc/X11/xinit/xinitrc.d/11-xdg-menu-KDE-4 was not updated for kde 4.5, so I deleted it and re-emerged kde-base/kde-env-4.5.1, which fixed that. The result was that my kmenu was missing several things that it should have had.

Lastly, my computer failed to restart after installing KDE. Executing "shutdown" as root would print the usual jargon, but instead of doing the regular shut-down sequence, the console would simply hang. I had to force it to reboot via its reset button.

Supposedly, the issues involving KDE 4.5.x are only affecting open source drivers:

http://blog.martin-graesslin.com/blog/2010/09/driver-dilemma-in-kde-workspaces-4-5/

Since I use nvidia's proprietary driver, I am unaffected and aside from the initial installation troubles, I cannot seem to find any issues so far.
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2726
Location: Bay Area, CA

PostPosted: Mon Sep 06, 2010 10:36 pm    Post subject: Reply with quote

Looks like kde-4.5.1 is making its way into portage slowly today. YAY! I hate overlays!
Back to top
View user's profile Send private message
Shining Arcanine
Veteran
Veteran


Joined: 24 Sep 2009
Posts: 1110

PostPosted: Tue Sep 07, 2010 4:48 am    Post subject: Reply with quote

devsk wrote:
Looks like kde-4.5.1 is making its way into portage slowly today. YAY! I hate overlays!


The handbook use flag appears to have been removed. Switching back to the portage tree requires that all of the packages be recompiled. :/
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 35, 36, 37, 38  Next
Page 36 of 38

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum