Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 4)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, ... 36, 37, 38  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
KD-120RD
Tux's lil' helper
Tux's lil' helper


Joined: 07 Mar 2004
Posts: 149
Location: Hamburg

PostPosted: Wed Jul 01, 2009 2:20 pm    Post subject: Reply with quote

Seems like your not using kde-testing overlay.
kde-testing uses the default tar.bz2 files from kde.
_________________
(\ _/)
(O.o)
(>< ) This is Bunny. Copy Bunny into your signature to help him on his way to world domination.
Back to top
View user's profile Send private message
aTan
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2007
Posts: 134
Location: Czech Republic (Ukraine)

PostPosted: Wed Jul 01, 2009 3:30 pm    Post subject: Reply with quote

aTan wrote:
hi. how could i upgrade from 4.2 to 4.3 without kdeprefix? it won't upgrade but just shows blocks.


Don't say I have to uninstall KDE 4.2 to install KDE 4.3 if I don't have kdeprefix (it's masked by the way)?!
Back to top
View user's profile Send private message
boris64
Veteran
Veteran


Joined: 04 Oct 2003
Posts: 1770
Location: vechelde / peine

PostPosted: Wed Jul 01, 2009 3:48 pm    Post subject: Reply with quote

KD-120RD wrote:
Seems like your not using kde-testing overlay.
kde-testing uses the default tar.bz2 files from kde.

I'm using kde-testing provided by layman.

[EDIT]
Well, i had copied some ebuilds to my own overlay to avoid
these annoying blockers (kdeplasma-addons+keditfiletypes+oxygenicons)
and it looks like these 3 ebuilds need the eclasses from kde-testing
to link to the correct source files.
Btw. is there any other/better way to get around this?
I need some Kde-3.5 packages as deps for older programs like kaffeine
and amarok (still using the qt3-versions here).
[/EDIT]
_________________
boris64.net 200x / visit my desktop / try these tiny kernel patches ;)
Back to top
View user's profile Send private message
KD-120RD
Tux's lil' helper
Tux's lil' helper


Joined: 07 Mar 2004
Posts: 149
Location: Hamburg

PostPosted: Wed Jul 01, 2009 5:46 pm    Post subject: Reply with quote

i am having some trouble with older PyQt versions myself, but kaffeine and amarok work fine for me.
just emerge them and qt-3 and all debs should be pulled in automatically.
can you explain what you mean by annoying blockers (kdeplasma-addons+keditfiletypes+oxygenicons)?
i cant check right now, but as i recall at least oxygenicons compiled fine for me.
_________________
(\ _/)
(O.o)
(>< ) This is Bunny. Copy Bunny into your signature to help him on his way to world domination.
Back to top
View user's profile Send private message
ecroy
n00b
n00b


Joined: 08 Nov 2002
Posts: 59

PostPosted: Wed Jul 01, 2009 7:58 pm    Post subject: Reply with quote

For the reference: I just compiled kde-4.2.95 without problem (except for kalzium) using +kdeprefix. I had the betas with +kdeprefix installed before and now just masked the "-kdeprefix" use-flag as was mentioned before.
Everything seems to run very well and no dead kittens so far :)
Kudos to the devs!
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2467
Location: Austria

PostPosted: Wed Jul 01, 2009 7:59 pm    Post subject: Reply with quote

Confirmed, although with "-kdeprefix" and a rather reduced set of ~ 120 packages in my case. ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
boris64
Veteran
Veteran


Joined: 04 Oct 2003
Posts: 1770
Location: vechelde / peine

PostPosted: Wed Jul 01, 2009 8:05 pm    Post subject: Reply with quote

KD-120RD wrote:
...
can you explain what you mean by annoying blockers (kdeplasma-addons+keditfiletypes+oxygenicons)?
i cant check right now, but as i recall at least oxygenicons compiled fine for me.

Here we go...
Quote:
...
[blocks B ] <=kde-base/konqueror-4.2.67[-kdeprefix] ("<=kde-base/konqueror-4.2.67[-kdeprefix]" is blocking kde-base/keditfiletype-4.2.95)
[blocks B ] <kde-base/kdebase-data-4.2.88[-kdeprefix] ("<kde-base/kdebase-data-4.2.88[-kdeprefix]" is blocking kde-base/kdeplasma-addons-4.2.95)
[blocks B ] <kde-base/kdebase-data-4.2.67[-kdeprefix] ("<kde-base/kdebase-data-4.2.67[-kdeprefix]" is blocking kde-base/oxygen-icons-4.2.95)

Total: 235 packages (235 reinstalls), Size of downloads: 0 kB
Conflict: 3 blocks (3 unsatisfied)
Portage tree and overlays:
[0] /var/portage/portage
[1] /var/portage/overlays/kde-testing

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('ebuild', '/', 'kde-base/kdeplasma-addons-4.2.95', 'merge') pulled in by
kde-base/kdeplasma-addons:4.3 required by @kde-4.3
kde-base/kdeplasma-addons:4.3 required by @world

('installed', '/', 'kde-base/kdebase-data-3.5.10', 'nomerge') pulled in by
>=kde-base/kdebase-data-3.5.10:3.5 required by ('installed', '/', 'kde-base/kcontrol-3.5.10', 'nomerge')
>=kde-base/kdebase-data-3.5.10:3.5 required by ('installed', '/', 'kde-base/kicker-3.5.10-r1', 'nomerge')

('ebuild', '/', 'kde-base/oxygen-icons-4.2.95', 'merge') pulled in by
>=kde-base/oxygen-icons-4.2.95:4.3[-kdeprefix] required by ('ebuild', '/', 'kde-base/kdebase-data-4.2.95', 'merge')
kde-base/oxygen-icons:4.3 required by @world
kde-base/oxygen-icons:4.3 required by @kde-4.3

('installed', '/', 'kde-base/konqueror-3.5.10', 'nomerge') pulled in by
kde-base/konqueror:3.5 required by ('installed', '/', 'media-sound/amarok-1.4.10_p20090130-r2', 'nomerge')

('ebuild', '/', 'kde-base/keditfiletype-4.2.95', 'merge') pulled in by
kde-base/keditfiletype:4.3 required by @kde-4.3
kde-base/keditfiletype:4.3 required by @world
>=kde-base/keditfiletype-4.2.95:4.3[-kdeprefix] required by ('ebuild', '/', 'kde-base/kdebase-startkde-4.2.95', 'merge')
...

_________________
boris64.net 200x / visit my desktop / try these tiny kernel patches ;)
Back to top
View user's profile Send private message
rem5
n00b
n00b


Joined: 12 Oct 2005
Posts: 71
Location: Lille - France

PostPosted: Thu Jul 02, 2009 1:20 pm    Post subject: Reply with quote

I've just installer the RC1, and is this just me or new theme AIR make some icon in taskbar and systray nearly invisible like networkmanager-applet. It makes also text in lancelot launcher difficult to read ???

I can give a screenshot if needed...
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Thu Jul 02, 2009 1:42 pm    Post subject: Reply with quote

Regarding Lancelot and Air:
http://ivan.fomentgroup.org/blog/2009/06/24/kde-4-3-rc-lancelot-themes-a-bad-combo/
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
rem5
n00b
n00b


Joined: 12 Oct 2005
Posts: 71
Location: Lille - France

PostPosted: Thu Jul 02, 2009 1:45 pm    Post subject: Reply with quote

:D
Back to top
View user's profile Send private message
KD-120RD
Tux's lil' helper
Tux's lil' helper


Joined: 07 Mar 2004
Posts: 149
Location: Hamburg

PostPosted: Thu Jul 02, 2009 6:16 pm    Post subject: Reply with quote

boris64 wrote:

Here we go [... ]

looks like emerge can't update konqueror and kdebase-data for some reason. Maybe emerge is trying to install these from your local overlay. Could you post "emerge -pv konqueror kdebase" with full output. Also "emerge -s konqueror kdebase" could be helpful.

About kde-3.5: Did you mean its not working? Thats how i understood you last post-. But as I read emerges output it tells me all thoses 3.5 packages are installed.
_________________
(\ _/)
(O.o)
(>< ) This is Bunny. Copy Bunny into your signature to help him on his way to world domination.
Back to top
View user's profile Send private message
The Dealy Lama
n00b
n00b


Joined: 10 Jun 2003
Posts: 35
Location: Da'ath

PostPosted: Thu Jul 02, 2009 7:04 pm    Post subject: Reply with quote

@boris64:

I had the same conflict yesterday; had to uninstall amarok to resolve it.
_________________
"The shadows of this world are perceived by mortals, and they think they know the Truth, but the Reality which casts the shadows is hidden from them, and they do not perceive the Light." (Sayings 2:2)"
Back to top
View user's profile Send private message
boris64
Veteran
Veteran


Joined: 04 Oct 2003
Posts: 1770
Location: vechelde / peine

PostPosted: Sat Jul 04, 2009 6:08 pm    Post subject: Reply with quote

The Dealy Lama wrote:
@boris64:

I had the same conflict yesterday; had to uninstall amarok to resolve it.

Right, i just did that, too.
_________________
boris64.net 200x / visit my desktop / try these tiny kernel patches ;)
Back to top
View user's profile Send private message
bers
n00b
n00b


Joined: 28 Nov 2008
Posts: 49

PostPosted: Mon Jul 06, 2009 11:17 am    Post subject: Holidays in plasma-clock Reply with quote

What should I install that would see the holidays in plasma-clock?
Back to top
View user's profile Send private message
WilliamHeuts
n00b
n00b


Joined: 04 Dec 2003
Posts: 29

PostPosted: Mon Jul 06, 2009 6:47 pm    Post subject: Reply with quote

Guys, the kde-testing guide gives me a 403 Forbidden.
Back to top
View user's profile Send private message
Krog
Apprentice
Apprentice


Joined: 26 Jun 2007
Posts: 256
Location: Roma, Italy

PostPosted: Wed Jul 08, 2009 5:39 pm    Post subject: Reply with quote

in which package is AIR theme in 4.2.95?
it disappeared for me...
thanks

p.s. I tried x11-themes/playground-plasma-themes-9999 but fails in install (not compiling!!)

Code:
>>> Source compiled.                                                                                                                   
>>> Test phase [not enabled]: x11-themes/playground-plasma-themes-9999                                                                 

>>> Install playground-plasma-themes-9999 into /var/tmp/portage/x11-themes/playground-plasma-themes-9999/image/ category x11-themes
>>> Working in BUILD_DIR: "/var/tmp/portage/x11-themes/playground-plasma-themes-9999/work/playground-plasma-themes-9999_build"     
make -j3 install DESTDIR=/var/tmp/portage/x11-themes/playground-plasma-themes-9999/image/                                         
make: *** No rule to make target `install'.  Stop.                                                                                 
 *                                                                                                                                 
 * ERROR: x11-themes/playground-plasma-themes-9999 failed.                                                                         
 * Call stack:                                                                                                                     
 *               ebuild.sh, line   49:  Called src_install                                                                         
 *             environment, line 4028:  Called kde4-meta_src_install                                                               
 *             environment, line 3228:  Called kde4-base_src_install                                                               
 *             environment, line 2832:  Called cmake-utils_src_install                                                             
 *             environment, line 1095:  Called die                                                                                 
 * The specific snippet of code:                                                                                                   
 *       emake install DESTDIR="${D}" || die "Make install failed";                                                               
 *  The die message:                                                                                                               
 *   Make install failed   
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3932
Location: Irgendwo im Nirgendwo

PostPosted: Thu Jul 09, 2009 6:50 am    Post subject: Reply with quote

Amarok doesn't start anymore :/
Code:
amarok: symbol lookup error: /usr/lib64/qt4/plugins/script/libqtscript_network.so: undefined symbol: _ZN19QtScriptShell_QHttpC1EP7QObject

Code:
$ readelf -s /usr/lib64/qt4/plugins/script/libqtscript_network.so | grep NOTYPE
     0: 0000000000000000     0 NOTYPE  LOCAL  DEFAULT  UND
    11: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND _ZN25QtScriptShell_QHttpH
    33: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND _ZN26QtScriptShell_QIPv6A
    35: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND _ZN32QtScriptShell_QHttpR
    63: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND _ZN19QtScriptShell_QHttpC
    79: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND _ZN26QtScriptShell_QIPv6A
   102: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND _ZN24QtScriptShell_QUdpSo
   106: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND _ZN25QtScriptShell_QHttpH
   107: 0000000000000000     0 NOTYPE  WEAK   DEFAULT  UND __gmon_start__
   109: 0000000000000000     0 NOTYPE  WEAK   DEFAULT  UND _Jv_RegisterClasses
   126: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND _ZN31QtScriptShell_QNetwo
   128: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND _ZN26QtScriptShell_QLocal
   178: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND _ZN32QtScriptShell_QHttpR
   181: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND _ZN35QtScriptShell_QNetwo
   185: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND _ZN26QtScriptShell_QLocal
   191: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND _ZN34QtScriptShell_QNetwo
   194: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND _ZN22QtScriptShell_QUrlIn
   253: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND _ZN32QtScriptShell_QHttpR
   283: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND _ZN22QtScriptShell_QUrlIn
   296: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND _ZN19QtScriptShell_QHttpC
   339: 0000000000000000     0 NOTYPE  GLOBAL DEFAULT  UND _ZN18QtScriptShell_QFtpC1

[and so on]

Only the symbols concerning "QtScriptShell" are buggy.
There recently was a commit to qtscriptgenerator which caused the problem, as before this commit, everything went fine.
http://qt.gitorious.org/qt-labs/qtscriptgenerator/commit/04e49d162b15d7a32d4e5837e5f5ef284ea226ba

I hope somone can fix this (I can't, no clue yet how this scriptgenerator works...).

Thx!
Franz
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3932
Location: Irgendwo im Nirgendwo

PostPosted: Thu Jul 09, 2009 7:52 am    Post subject: Reply with quote

WOHOOO!!
The patch:
Code:
--- qtscriptgenerator_org/generator/shellimplgenerator.cpp   2009-07-09 09:39:22.000000000 +0200
+++ qtscriptgenerator/generator/shellimplgenerator.cpp   2009-07-09 09:40:48.000000000 +0200
@@ -52,9 +52,9 @@
     if (FileOut::license)
         writeQtScriptQtBindingsLicense(s);
 
-    QString pro_file_name = meta_class->package().replace(".", "_") + "/" + meta_class->package().replace(".", "_") + ".pri";
+    QString packName = meta_class->package().replace(".", "_");
 
-    priGenerator->addSource(pro_file_name, fileNameForClass(meta_class));
+    priGenerator->addSource(packName, fileNameForClass(meta_class));
 
     s << "#include \"qtscriptshell_" << meta_class->name() << ".h\"" << endl << endl;
 

Anything works fine again...
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
Krog
Apprentice
Apprentice


Joined: 26 Jun 2007
Posts: 256
Location: Roma, Italy

PostPosted: Thu Jul 09, 2009 5:55 pm    Post subject: Reply with quote

someone still uses air theme with 4.2.95?
pls... i LOVE that theme
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2467
Location: Austria

PostPosted: Thu Jul 09, 2009 6:04 pm    Post subject: Reply with quote

erm... it's the standard theme.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Krog
Apprentice
Apprentice


Joined: 26 Jun 2007
Posts: 256
Location: Roma, Italy

PostPosted: Thu Jul 09, 2009 6:26 pm    Post subject: Reply with quote

i haven't.
in which package is?
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2467
Location: Austria

PostPosted: Thu Jul 09, 2009 6:39 pm    Post subject: Reply with quote

Code:
equery belongs air
 * Searching for air ...
kde-base/kdeplasma-addons-4.2.95 (/usr/share/apps/desktoptheme/air)

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Krog
Apprentice
Apprentice


Joined: 26 Jun 2007
Posts: 256
Location: Roma, Italy

PostPosted: Thu Jul 09, 2009 8:28 pm    Post subject: Reply with quote

very strange, re-emerging solved!
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Fri Jul 10, 2009 8:40 am    Post subject: Reply with quote

Code:

googly rahul # emerge -avuDN --tree --with-bdeps\=y @system @world

These are the packages that would be merged, in reverse order:

Calculating dependencies - * Missing digest for '/usr/local/portage/layman/kde-testing/kde-base/kppp/kppp-4.2.96.ebuild'
 \ * Missing digest for '/usr/local/portage/layman/kde-testing/kde-base/kdenetwork-filesharing/kdenetwork-filesharing-4.2.96.ebuild'
 / * A file is not listed in the Manifest: '/usr/local/portage/layman/kde-testing/kde-base/krdc/krdc-4.2.96.ebuild'
 * Missing digest for '/usr/local/portage/layman/kde-testing/kde-base/krdc/krdc-4.2.96.ebuild'
 | * Missing digest for '/usr/local/portage/layman/kde-testing/kde-base/kget/kget-4.2.96.ebuild'
 / * Missing digest for '/usr/local/portage/layman/kde-testing/kde-base/kdnssd/kdnssd-4.2.96.ebuild'
 - * Missing digest for '/usr/local/portage/layman/kde-testing/kde-base/kopete/kopete-4.2.96.ebuild'
 \ * Missing digest for '/usr/local/portage/layman/kde-testing/kde-base/krfb/krfb-4.2.96.ebuild'
 / * A file is not listed in the Manifest: '/usr/local/portage/layman/kde-testing/kde-base/kdeplasma-addons/kdeplasma-addons-4.2.96.ebuild'
 * Missing digest for '/usr/local/portage/layman/kde-testing/kde-base/kdeplasma-addons/kdeplasma-addons-4.2.96.ebuild'
 \ * Missing digest for '/usr/local/portage/layman/kde-testing/kde-base/kdelibs/kdelibs-4.2.96.ebuild'
 - * Missing digest for '/usr/local/portage/layman/kde-testing/kde-base/kdepimlibs/kdepimlibs-4.2.96.ebuild'
... done!

!!! All ebuilds that could satisfy ">=kde-base/kdelibs-4.2.96[-kdeprefix]" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/kdelibs-9999 (masked by: corruption)
- kde-base/kdelibs-4.3.9999 (masked by: corruption)
- kde-base/kdelibs-4.2.96 (masked by: corruption)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "kde-base/ksystemlog-4.2.96" [ebuild])
(dependency required by "@world" [argument])

_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
surnu
n00b
n00b


Joined: 24 Jan 2007
Posts: 12

PostPosted: Fri Jul 10, 2009 11:17 am    Post subject: Reply with quote

emerge -pv amor

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild NS ] kde-base/amor-4.2.4 [4.2.95] USE="-debug -handbook (-kdeprefix)" 0 kB
[blocks B ] kde-base/amor:4.2[-kdeprefix] ("kde-base/amor:4.2[-kdeprefix]" is blocking kde-base/amor-4.2.95)
[blocks B ] kde-base/amor:4.3[-kdeprefix] ("kde-base/amor:4.3[-kdeprefix]" is blocking kde-base/amor-4.2.4)

merge =kde-base/amor-4.2.96
Calculating dependencies... done!

!!! All ebuilds that could satisfy "=kde-base/amor-4.2.96" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/amor-4.2.96 (masked by: missing keyword)

cat /usr/local/layman/kde-testing/kde-base/amor/amor-4.2.96.ebuild
KEYWORDS=""
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, ... 36, 37, 38  Next
Page 2 of 38

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum