Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GRUB on a 64-bit system
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
Shining Arcanine
Veteran
Veteran


Joined: 24 Sep 2009
Posts: 1110

PostPosted: Mon Mar 08, 2010 10:07 pm    Post subject: GRUB on a 64-bit system Reply with quote

What stops GRUB from working with a 64-bit system, specifically if IA-32 emulation support is disabled in the kernel?
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4690
Location: Saint Amant, Acadiana

PostPosted: Tue Mar 09, 2010 1:13 am    Post subject: Reply with quote

AFAIK nothing. It's not clear what you are asking. GRUB is not working on a newly installed pure 64-bit system or what? It doesn't boot? GRUB binary doesn't run?
Back to top
View user's profile Send private message
platojones
Veteran
Veteran


Joined: 23 Oct 2002
Posts: 1554
Location: Just over the horizon

PostPosted: Tue Mar 09, 2010 1:18 am    Post subject: Reply with quote

Agreed...lot's of AMD64 people here using grub...sounds like you have a grub problem of some sort, but it has nothing to do with running a 64 bit system.
Back to top
View user's profile Send private message
Etal
Veteran
Veteran


Joined: 15 Jul 2005
Posts: 1641

PostPosted: Tue Mar 09, 2010 1:54 am    Post subject: Reply with quote

I'm guessing he's talking about this:

Code:
$ emerge -qp grub

!!! All ebuilds that could satisfy "sys-boot/grub" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-boot/grub-9999 (masked by: package.mask, missing keyword)
/usr/portage/profiles/features/64bit-native/package.mask:
# AMD64 Team; <amd64@gentoo.org>
# grub is not available on no-multilib-profiles; use sys-boot/grub-static
Back to top
View user's profile Send private message
Shining Arcanine
Veteran
Veteran


Joined: 24 Sep 2009
Posts: 1110

PostPosted: Tue Mar 09, 2010 4:43 pm    Post subject: Reply with quote

The Gentoo Handbook says to use LILO instead of Grub:

Gentoo Handbook wrote:
Important: If you are using a non-multilib profile, you should not emerge grub, but instead you should emerge grub-static. If you plan to use a non-multilib profile and you have disabled IA-32 emulation in your kernel, then you should use lilo.


Does this mean that there is no technical issue that mandates the use of LILO?
Back to top
View user's profile Send private message
platojones
Veteran
Veteran


Joined: 23 Oct 2002
Posts: 1554
Location: Just over the horizon

PostPosted: Tue Mar 09, 2010 8:07 pm    Post subject: Reply with quote

I see it now...I'm using a multi-lib 64 bit system, so I never ran into this problem
Back to top
View user's profile Send private message
richard.scott
Veteran
Veteran


Joined: 19 May 2003
Posts: 1496
Location: Oxfordshire, UK

PostPosted: Thu Apr 01, 2010 1:38 pm    Post subject: Reply with quote

If your not using a multilib profile on your system then use sys-boot/grub-static :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum