Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge gnome IO-Socket-SSL error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
schorsche
Apprentice
Apprentice


Joined: 27 Jan 2005
Posts: 230

PostPosted: Thu Feb 03, 2005 10:35 pm    Post subject: emerge gnome IO-Socket-SSL error Reply with quote

When I emerged gnome it compiles fine until I get this message:
Code:
>>> emerge (2 of 7) dev-perl/IO-Socket-SSL-0.96 to /
>>> md5 src_uri ;-) IO-Socket-SSL-0.96.tar.gz
>>> Unpacking source...
>>> Unpacking IO-Socket-SSL-0.96.tar.gz to /var/tmp/portage/IO-Socket-SSL-0.96/work
>>> Source unpacked.
Checking if your kit is complete...
Looks good
Writing Makefile for IO::Socket::SSL
cp SSL.pm blib/lib/IO/Socket/SSL.pm
Manifying blib/man3/IO::Socket::SSL.3pm
PERL_DL_NONLAZY=1 /usr/bin/perl5.8.5 "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/01loadmodule.....ok
t/02settings.......FAILED--Further testing stopped: Setup of test IO::Socket::INET server failed: Cannot assign requested address.  All the rest of the tests in this suite will fail also unless you change the values in ssl_settings.req in the t/ directory.
make: *** [test_dynamic] Error 255

!!! ERROR: dev-perl/IO-Socket-SSL-0.96 failed.
!!! Function perl-module_src_compile, Line 69, Exitcode 2
!!! test failed
!!! If you need support, post the topmost build error, NOT this status message.



I'd be grateful for any ideas to address this problem

Cheerio

Georg
Back to top
View user's profile Send private message
hjnenc
Veteran
Veteran


Joined: 15 Aug 2004
Posts: 1599
Location: Vienna, Austria

PostPosted: Fri Feb 04, 2005 4:26 pm    Post subject: Reply with quote

Seems to be a similar problem as described here http://bugs.gentoo.org/show_bug.cgi?id=56541 (although the error message is slightly different)
Back to top
View user's profile Send private message
schorsche
Apprentice
Apprentice


Joined: 27 Jan 2005
Posts: 230

PostPosted: Sat Feb 05, 2005 1:38 am    Post subject: Reply with quote

II didn't quite understand what should be wrong with this
file.
/t/ssl_settings.req

Code:
#Change the following to a port and address that you can create a listening soc$
$SSL_SERVER_PORT  = 80;
$SSL_SERVER_PORT2 = 2001;
$SSL_SERVER_PORT3 = 2002;
$SSL_SERVER_ADDR = '127.0.0.1';
'True Value';


Any ideas?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum