Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200904-18 ] udev: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1547

PostPosted: Sat Apr 18, 2009 7:26 pm    Post subject: [ GLSA 200904-18 ] udev: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: udev: Multiple vulnerabilities (GLSA 200904-18)
Severity: high
Exploitable: local
Date: April 18, 2009
Bug(s): #266290
ID: 200904-18

Synopsis

Two errors in udev allow for a local root compromise and a Denial of Service.

Background

udev is the device manager used in the Linux 2.6 kernel series.

Affected Packages

Package: sys-fs/udev
Vulnerable: < 124-r2
Unaffected: >= 124-r2
Architectures: All supported architectures


Description

Sebastian Krahmer of SUSE discovered the following two vulnerabilities:
  • udev does not verify the origin of NETLINK messages properly (CVE-2009-1185).
  • A buffer overflow exists in the util_path_encode() function in lib/libudev-util.c (CVE-2009-1186).


Impact

A local attacker could gain root privileges by sending specially crafted NETLINK messages to udev or cause a Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All udev users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=sys-fs/udev-124-r2"


References

CVE-2009-1185
CVE-2009-1186
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum