Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200904-03 ] Gnumeric: Untrusted search path
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1540

PostPosted: Fri Apr 03, 2009 3:26 pm    Post subject: [ GLSA 200904-03 ] Gnumeric: Untrusted search path Reply with quote

Gentoo Linux Security Advisory

Title: Gnumeric: Untrusted search path (GLSA 200904-03)
Severity: normal
Exploitable: local
Date: April 03, 2009
Bug(s): #257012
ID: 200904-03

Synopsis

An untrusted search path vulnerability in Gnumeric might result in the execution of arbitrary code.

Background

The Gnumeric spreadsheet is a versatile application developed as part of the GNOME Office project.

Affected Packages

Package: app-office/gnumeric
Vulnerable: < 1.8.4-r1
Unaffected: >= 1.8.4-r1
Architectures: All supported architectures


Description

James Vega reported an untrusted search path vulnerability in the GObject Python interpreter wrapper in Gnumeric.

Impact

A local attacker could entice a user to run Gnumeric from a directory containing a specially crafted python module, resulting in the execution of arbitrary code with the privileges of the user running Gnumeric.

Workaround

Do not run "gnumeric" from untrusted working directories.

Resolution

All Gnumeric users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=app-office/gnumeric-1.8.4-r1"


References

CVE-2009-0318
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum